tripplesixer
Goto Top

SYSPREP allgemeine Frage (Windows 7)

Hi,

ich habe da mal eine allgemeine Frage zu Sysprep mit Windows 7

So mache ich Sysprep:

1. Windows 7 installieren
2. Software installieren & Settings machen
3. Sysprep -> Audit Mode (generalize) -> restart
4. Default User Settings
5. Sysprep -> OOBE (generalize) -> shutdown

6. Boot mit USB Stick -> imageX.exe, usw.

7. Ergebnis: WIM File, Release Candidate - fertig zum verteilen zB. MDT, usw.

Zu meiner Frage:

Kann es sein das ich nach dem ich eine Maschine verteilt habe und feststelle das ich noch ein paar Sachen einstellen möchte, mit Sysprep das System nicht mehr bearbeiten kann?

Gibt es da eine Sperre? Geht das nur 1x?

Mir ist hinter noch was eingefallen was ich in das Image haben will ... da dachte ich mir ok - nachinstallieren und nochmal "Sysprepen" ... ätsch ... ging aber nicht ... FATAL ERROR meldet Sysprep.

Habt ihr eine Idee?

Gruss Trip

Content-Key: 196941

Url: https://administrator.de/contentid/196941

Printed on: December 5, 2022 at 07:12 o'clock

Member: Der-Sash
Der-Sash Jan 14, 2013 at 14:13:25 (UTC)
Goto Top
Soweit ich weiss geht das nur 1 mal.


LG
Sascha
Member: tripplesixer
tripplesixer Jan 14, 2013 at 15:05:26 (UTC)
Goto Top
und kann man da den counter nicht zurückstellen?

ich habe da n bissi was gegoogelt ...
Member: Housemeister
Housemeister Jan 14, 2013 at 18:40:38 (UTC)
Goto Top
Der Counter ist nicht dein Problem, sondern ein Fehler wärend der generalize Phase.

Bitte überprüfe folgende Datei: Setuperr.log diese befindet sich im Ordner "\Windows\System32\Sysprep\Panther

Poste mal deren Inhalt, das Problem ist häufig der slmgr (Windows Aktivierung)

MfG Houser
Member: tripplesixer
tripplesixer Jan 15, 2013 at 15:03:32 (UTC)
Goto Top
Hier habe ich mal (sicherheitshalber) ein Screenshot von der Fehlermeldung:
6bd0262b743ae937a5bf59d56f60b94d


Hier der Text aus der SETUPERR.LOG:

2013-01-15 15:24:35, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\Program Files\Realtek\Audio\HDA\AERTSrv.exe!
2013-01-15 15:24:35, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\windows\system32\RTSndMgr.cpl!
2013-01-15 15:31:57, Error [0x0f0043] SYSPRP WinMain:The sysprep dialog box returned FALSE
2013-01-15 15:35:06, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\Program Files\Realtek\Audio\HDA\AERTSrv.exe!
2013-01-15 15:35:06, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\windows\system32\RTSndMgr.cpl!
2013-01-15 15:47:27, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\Program Files\Realtek\Audio\HDA\AERTSrv.exe!
2013-01-15 15:47:27, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\windows\system32\RTSndMgr.cpl!
2013-01-15 15:51:30, Error [0x0f0043] SYSPRP WinMain:The sysprep dialog box returned FALSE
2013-01-15 15:53:39, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\Program Files\Realtek\Audio\HDA\AERTSrv.exe!
2013-01-15 15:53:39, Error SYSPRP SPPNP: Error 0x2 setting SDDL on driver file C:\windows\system32\RTSndMgr.cpl!
2013-01-15 15:53:39, Error [0x0f0082] SYSPRP LaunchDll:Failure occurred while executing 'C:\Windows\System32\slc.dll,SLReArmWindows', returned error code -1073425657
2013-01-15 15:53:39, Error [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = -1073425657
2013-01-15 15:53:39, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0xc004d307
Member: Housemeister
Housemeister Jan 15, 2013 at 17:21:28 (UTC)
Goto Top
Das hilft doch schonmal weiter.

Bitte öffne die Console und gebe folgendes ein: slmgr.vbs /dlv
Zeigt die die Anzahl noch möglicher Aktivierungen an (vorletzte Zeile)
Bitte poste deinen Wert.
Sollte dieser "0" sein, dann öffne die registry und suche folgenden Schlüssel

HKEY_LOCAL_MACHINE\SYSTEM\Setup\Status\SysprepStatus
dort suchst du den Wert
GeneralizationState
und änderst diesen auf "7" ab!

Durchsuche folgende Verzeichnisse:
%WINDIR%\Panther\Unattend
%WINDIR%\Panther
%WINDIR%\System32\Sysprep

und lösche dort alle unattend.xml raus.

anschließend probierst du nochmal dein sysprep /generalize
Member: tripplesixer
tripplesixer Jan 15, 2013 at 19:24:37 (UTC)
Goto Top
Cool, probiere ich gleich morgen früh aus!
Danke vorab für die Mühe!!!
Member: tripplesixer
tripplesixer Jan 16, 2013 updated at 10:15:20 (UTC)
Goto Top
Ok, tatsächlich war in der vorletzten Zeile -0-.
Dann habe ich in der Regestry den Wert (3) abgeändert (in 7).

Die Verzeichnisse habe ich durchsucht, es gab nur eine unattend.xml.

Dann habe ich sysprep nochmal gestartet - fehlanzeige. Immernoch der Fehler.
Vielleicht erst noch ein reboot wegen der neuen einstellungen?

@Housemeister:
ist das überhaupt der richtige weg?

1. core erzeugen: win7 inkl. treibern, allgeimeiner software mit mdt installieren.
2. win7 starten, konfigurieren, updaten, usw.
3. sysprep audit modus, generalize, -reboot
4. default user settings, desktop ereignisse, usw.
5. sysprep oobe modus, generalize, -shutodwn
6. -> WIM erzeugen mit imagex
7. pc starten, oder mit mdt testmaschine erstellen und glücklich sein -> windows 7 core erstellt.

....

8. win7core erweitern um spezial software settings.
9. wieder sysprep ... audit modus, generalize, -reboot
10. default user settings, desktop ereignisse, usw.
11. sysprep oobe modus, generalize, -shutodwn ->>>>>>>>>>>>> ERROR vor dem shutdown.
Member: Housemeister
Housemeister Jan 16, 2013 updated at 17:11:10 (UTC)
Goto Top
Hast du die unattend.xml auch gelöscht?

Du hast einen Fehler bei Punkt 3.
Wenn du generalize machst, musst du shutdown wählen.
Anschließend bootest du den PC via USB Stick und WinPE und
erstellt mit ImageX deine WIM Datei.

Ich empfehle dir folgende Abarbeitung
1.) Install OS, Treiber, Software usw. auf den Client
2.) wenn du alles installiert hast öffnest die cmd und aktivierst den admin account
"net user administrator /active:yes"
3) Melde dich ab und logge dich mit dem eben aktivierten Administrator ein
4) Lösche den vorher verwendeten "admin" Account
5) Jetzt kommt der Trick: Wenn du nun deinen Desktop so anpasst, wie du Ihn für alle Images hättest, bleibt
dieser auch erhalten - also passe Ihn an
6) Jetzt führst du den sysprep /generalize /oobe mit Shutdown aus
7) Boot via USB - Wim erstellen - fertig!
Member: tripplesixer
tripplesixer Jan 16, 2013 at 17:04:50 (UTC)
Goto Top
Leider bin ich schon zuhause ... kann das scenario nicht mehr heute nachstellen. jo, unattend.xml hatte ich gelöscht.
Member: Housemeister
Housemeister Jan 16, 2013 at 17:05:46 (UTC)
Goto Top
Also ich bin immer froh, wenn ich denn zuhause sein darf^^
Member: Housemeister
Housemeister Jan 25, 2013 at 06:50:00 (UTC)
Goto Top
Wie ist der Stand, konnte ich dir helfen?

MfG Houser