W2K: RPC startet nicht richtig

afrika
Goto Top

PC fehlen dadurch Grundfunktionalitäten

Hallo,

mein Win2000 Rechner verhält sich plötzlich seltsam. Offenbar liegt es daran, dass der RPC-Dienst beim Starten hängt, d.h. er schafft es nicht ganz.

Symptome:
- drag & drop geht nicht
- kopieren/ einfügen auchnicht
- IE sehr langsam - Firefox schnell
- Downloads sind schnell
- drucken geht nicht
- Doppelklick auf Word-/ Exceldateien erfolglos

Ich kann den Dienst aber auch nicht beenden :o(

Was kann ich tun, ohne Neuinstallation?

Danke für Eure Hilfe!

Gruss

Afrika

Content-Key: 31275

Url: https://administrator.de/contentid/31275

Ausgedruckt am: 28.06.2022 um 22:06 Uhr

Mitglied: OneAdmin
OneAdmin 27.04.2006 um 13:22:16 Uhr
Goto Top
hat aber alles nix mit dem rpc-dienst zu tun. was sagt denn die ereignissanzeige?
und was steht in der Registry im Run-Key alles drinn???
Mitglied: Afrika
Afrika 27.04.2006 um 13:31:53 Uhr
Goto Top
Das eventlog ist voller Fehler, u.a. "...RPC hung during startup..." oder so ähnlich.
Und in der Services-Übersicht hat der RPC den Status "starting"...
Kann ihn deshalb nicht stoppen oder starten.
Mitglied: OneAdmin
OneAdmin 27.04.2006 um 13:36:02 Uhr
Goto Top
ok, aber steht auch ne Event-ID daebi. die wäre hilfreich.
den dienst kannst du im abgesichtern Modus auf manuell uder deaktiviert setzen.
Mitglied: Afrika
Afrika 27.04.2006 um 13:38:05 Uhr
Goto Top
Hab den PC grad nicht hier :( face-sad
Kann er anschliessend deaktiviert bleiben?
Ich habe den Eindruck, er ist irgendwie lebenswichtig...
Mitglied: OneAdmin
OneAdmin 27.04.2006 um 13:44:33 Uhr
Goto Top
Der Dienst ist schon wichtig und muss unbedingt zum laufen gebracht werden.
Vor allem... Der Fehler hat eine Ursache.. Virus? beschädigt Installation?
Du kannst ja mal versuchweise das SP4 neu installieren
Mitglied: chaparal
chaparal 21.09.2006 um 15:30:47 Uhr
Goto Top
Tach, zusammen,

gibt es zu diesem Thema etwas Neues???

Habe nämlich das gleiche Problem und das jetzt zum zweiten Mal auf dem gleichen PC.

Konfig W2k pro - SP4

Behebung beim ersten Mal, Installation einmal Neu,

aber das nervt auf Dauer.

Ein zweiter PC im Netz hat das Problem bisher nicht.

RPC-Dienst hängt, somit werden werden alle abhängigen Dienste auch nicht ausgeführt,

d.h. Speicherzuordnung klappt nicht, schließen des Dienstfensters nur über Taskmanager.

Fehleranzeige im Eventlog kann nicht geöffnet werden.

Eventuell Probleme mit Update des Adobereaders ???

Wer noch eine Idee zu dem Thema hat, her damit ;-) face-wink

mfg

Chaparal
Mitglied: chaparal
chaparal 28.10.2006 um 17:14:17 Uhr
Goto Top
Habe mein Problem ohne Neuinstallation behoben:

nach Deinstallation der IPX Protokolle konnte Windows wieder normal starten.

Die Auswertung der Fehler im Ereignisprotokoll "Hresult" brachte keine Lösung eher Verwirrung. Der Netware Dienst stand auf manuell d.h. nicht gestartet.