Win CE an Windows 10 Freigabe - Error 53

0xFFFF
Hallo zusammen,

..ein gesundes Neues!

Aktuell sitze ich vor einem kleinen Problem bei uns in der Firma.

Wir nutzen (leider) noch Windows CE 5 Maschinen die super gerne eine Windows 10 Freigabe gemappt haben möchten.

Der Übeltäter: Error 53.

Die Maschine hängt in einem eigenen VLAN und kann Clients anpingen. Sie ist kein Domänenmitglied.
DHCP Server liefert die IP, Gateway, DNS etc.

Die Namensauflösung von der Maschine funktioniert (aber irgendwie eigenartig).


Sobald ich aber ein Laufwerk mappen möchte
bekomme ich ständig ein Error 53. Auch bereits mit user/pw versucht, vergebens.

Freigabe auf ClientPC: Jeder - r/w
Auf der Maschine ist unter owner:
User, Domäne und Passwort hinterlegt.

Ich habe einige Pages durchgekaut, jedoch erfolglos.

Mir gehen langsam die Ideen aus und der Chef wirkt ebenso leicht genervt.
Von anderen Windows 10 PCs funktioniert das Mapping problemlos.

Ich habe gelesen, dass Windows CE nur maximal 16 Zeichen lange hostnamen aktzeptiert (client.domäne.tld ist bereits 24 Zeichen lang). Daher dachte ich mir, ich gebe die Domain nicht im DHCP mit was dazu führt, dass ich den Client nicht mehr wie üblich anpingen kann (ping clientpc geht nicht, ping clientpc.domäne.tld geht!)

NetBIOS habe ich an dem ClientPC temporär aktiviert, Firewall deaktiviert.

Hättet Ihr noch eine Idee?

Ich freue mich auf Eure Antworten - sollte ich etwas vergessen haben, lasst es mich wissen, das trage ich gerne nach :) face-smile

Schreib + Logikfehler sind beabsichtigt, weil sehr früh ;-) face-wink

Viele Grüße
65k

Edita: Ich habe vergessen zu erwähnen, dass ich bereits SMB1 aktiviert habe auf der Clientmöhre.

Content-Key: 1710813514

Url: https://administrator.de/contentid/1710813514

Ausgedruckt am: 23.01.2022 um 18:01 Uhr

Mitglied: rana-mp
rana-mp 11.01.2022 um 08:14:09 Uhr
Goto Top
Moin,

was mir auf die Schnelle einfiele, ohne mich jetzt konkret mit CE 5 auszukennen:
Der SMB Level. Windows 10 hat SMB 1 abgeschaltet, und das hat schon Probleme mit Systemen die deutlich aelter als CE 5 sind gefuehrt ;)

SMB 1 ist natuerlich sicherheitstechnisch ein No-Go, das gehoert sauber vom Rest des Netzwerkes abgetrennt damit du da kein Einfallstor oeffnest.

Gruss,

rana-mp
Mitglied: 0xFFFF
0xFFFF 11.01.2022 um 08:21:38 Uhr
Goto Top
Hallo rana-mp,

viele Dank für dein Feedback. Die Idee hatte ich auch schon, habe es nur vergessen zu erwähnen.

SMB1 ist aktiviert auf dem ClientPC (Features).

Der ClientPC + Maschinen haben kein Zugang ins Netz via ACL.

Danke für deinen Ansatz :) face-smile

Viele Grüße
Mitglied: TomTomBon
TomTomBon 11.01.2022 um 08:46:32 Uhr
Goto Top
Moin Moin

CE 5 ist Entwickelungs Stand etwa XP SP 0.
--> SMB v1

Wiki sagt dazu:
https://en.wikipedia.org/wiki/Windows_CE_5.0
On the x86 platform, Windows CE 5.0 competes against Microsoft's other embedded operating systems, Windows XP Embedded and its predecessor Windows NT Embedded.

Sprich steht sogar eher etwas vor XP.



Ich würde hier nicht über Win interne Tools gehen. Die Differenz ist einfach zu drastisch.
Auch und besonders bei SMB. Auch v.1 hat sich seit damals drastisch verändert.
Und Win 10 als Partner ist auch nicht gut.
Da verbastelt MS derzeit massiv viel.

Schon einmal über FTP nachgedacht?
Mitglied: TomTomBon
TomTomBon 11.01.2022 um 09:06:44 Uhr
Goto Top
Doof wenn man abgelenkt wird, passt zeitlich dann nicht mehr :-) face-smile
Und schnarchenlangsames Internet macht es nicht besser..


Das SMB 1 einlädt zum xxx sollte jeder IT affine wissen.
Tun es aber einige ITler nicht wie Ich aus Erfahrung weiß.
Bzw ist denen egal.

Aber wie Ich schon schrieb, Ich würde über Alternativen nachdenken.
SAMBA, ist NICHT SMB!, FTP
https://www.samba.org/
https://docs.microsoft.com/en-us/previous-versions/windows/embedded/ms90 ...
Mitglied: 0xFFFF
0xFFFF 11.01.2022 um 09:35:51 Uhr
Goto Top
Heyhu TomTomBon,

viele Dank für deine Ansätze :) face-smile

Schon einmal über FTP nachgedacht?
Ja - keine Chance. Wir arbeiten mit einem Tool, der die fertigen Daten direkt zur Maschine schubst.

Ich würde hier nicht über Win interne Tools gehen
Mir bleibt hier leider nicht sehr viel anderes übrig.

Das SMB 1 einlädt zum xxx sollte jeder IT affine wissen.
Absolut bekannt. Wenn Client + Maschine allerdings abgeschottet sind, mache ich mir da recht wenig Gedanken.

Danke mal. :) face-smile

Viele Grüße
Mitglied: 0xFFFF
0xFFFF 11.01.2022 um 10:11:03 Uhr
Goto Top
Nachtrag:

nun funktioniert auch die 2te Maschine nicht mehr (auch WinCE).

net use gibt mir ein Netzlaufwerk als Disconnected zurück.

Von Maschine an Client kann ich NUR pingen mit DNS Suffix (domäne.tld).
Ich vermute, hier liegt das Problem.

ping clientpc
-> BAD IP

ping clientpc.domäne.tld
-> ICMP antwortet

Von einem Windows 10 PC kann ich problemlos
ping clientpc (ohne dns suffix) abschießen und bekomme Antwort.

Habt Ihr eine Idee was ich da gekonnt zerbröselt haben könnte?

VG
Mitglied: em-pie
em-pie 11.01.2022 um 10:23:29 Uhr
Goto Top
Moin,

klingt womöglich nach einem DNS-Problem.
Ist dein Zielclient im DNS angelegt?
Kann dein WinCE aufs DNS sauber zugreifen?
Wird deinem WinCE der DNS-Suffix mitgeteilt?

Funktioniert fernab ein net use * \\client.domain.tld\share?

Gruß
em-pie
Mitglied: 0xFFFF
0xFFFF 11.01.2022 aktualisiert um 10:36:51 Uhr
Goto Top
Heyhu em-pie,

ja, das ist meine große Vermutung.
Ich kann mir allerdings nicht erklären, wie es zu diesem Zustand kommt. :( face-sad

Hintergrund: Wir haben ein neues Netzwerk aufgezogen. Ich vermute, da wurde auch was am DNS gefummelt (Routing übernehmen L3 switches mit DHCP und DNS Relay zum DC).

Ist dein Zielclient im DNS angelegt?
Yep, automatisch registriert

Kann dein WinCE aufs DNS sauber zugreifen?
Wie würde ich das am geschicktesten testen? Bin leider nicht sehr bewandert was WinCE angeht - viele hilfreiche Tools fehlen auch wie nslookup bspw.

Edit: ins Internet wird nicht geroutet, daher kann ich den DNS nicht vernünftig testen.

Wie gesagt, ping mit suffix geht durch, ohne nicht.

Wird deinem WinCE der DNS-Suffix mitgeteilt?
Wenn ich IP via DHCP bekomme ja, statisch habe ich keine Möglichkeit sowas zu setzen. IP/Maske/Gateway/DNS kann ich setzen und diese sind gesetzt.

Funktioniert fernab ein net use * \\client.domain.tld\share?
Leider nicht - ich vermute es liegt hier am, für NetBIOS, überlangen Hostnamen (client.domain.tld anstatt client).

Danke für deinen Hirnschmalz :) face-smile

VG
Mitglied: 0xFFFF
0xFFFF 11.01.2022 um 10:50:56 Uhr
Goto Top
Nagut. Ich packe mal die Maschinen ins Client vLAN und schaue mal, ob sich dadurch etwas ändert. Warum auch immer, aber man weiß ja nie..

Hoffentlich habt Ihr noch einen Ansatz.

Beste Grüße
Mitglied: em-pie
em-pie 11.01.2022 um 11:01:09 Uhr
Goto Top
Haben deine Clients, auf die du dich verbinden willst, eine fixe IP?

bevor ich hier nämlich ein Loch aufreißen würde, würde ich schlimmstenfalls den Weg über die IP gehen. Ggf. an den Zielclients schlicht eine Reservierung am DHCP-Server anlegen.
Mitglied: 0xFFFF
0xFFFF 11.01.2022 um 11:17:36 Uhr
Goto Top
Haben deine Clients, auf die du dich verbinden willst, eine fixe IP?
WinCE mag keine IPs :( face-sad

Das Ding kann nur mit DNS und WINS umgehen. Sonst hätte ich es mir auch deutlich einfacher gemacht :) face-smile

ABER: Im Client Netz klappt alles problemlos. Es muss also an der VLAN Konfig liegen. Wo genau, ist mir noch etwas schleierhaft aber mal schauen. Vielleicht blockt die ACL mir irgendetwas weg..

VG
Mitglied: Xerebus
Xerebus 11.01.2022 um 12:56:49 Uhr
Goto Top
Schon mal mit "net use Host \\clientPC.domain.tld\Freigabe" versucht?
Mitglied: TomTomBon
TomTomBon 11.01.2022 um 14:49:31 Uhr
Goto Top
Das war der Punkt, die Abschottung, den Ich meinte :-) face-smile

Wenn man SMB 1 nutzen muss, muss die Umgebung mehr kontrolliert werden als normal.
Mitglied: 0xFFFF
0xFFFF 19.01.2022 um 08:48:09 Uhr
Goto Top
Schon mal mit "net use Host \\clientPC.domain.tld\Freigabe" versucht?

Ja klar :) face-smile
Das Ding ist, soweit mir bekannt, kann net use maximal 16 Zeichen als Host nutzen, da war ich dann drüber.

Habe aber nun eine andere Lösung gefunden: Maschine kommt ins Clientnetz und wird via ACL zum schweigen gebracht.

Ich würde das Thread nun schließen.

Danke für eure Denkhilfen :) face-smile

VG + alles Gute euch.
Heiß diskutierte Beiträge
question
Alternative für MS TeamsBlackDevilVor 1 TagFrageVideo & Streaming5 Kommentare

Servus Zusammen, ich arbeite eigentlich grundsätzlich remote, was eben auch Kundengespräche und -beratung inkludiert. Bisher mache ich das über MS Teams, was im Grundsatz auch ...

question
Analog Telefonanschluss aufs Netzwerk bringenpeter91gVor 1 TagFrageISDN & Analoganschlüsse13 Kommentare

Hallo zusammen, ich habe aktuell ein Router von meinem Provider welcher im Bridge-Modus geschalten ist. Dadurch kann ich die Festnetztelefonie nur über den Analog-Anschluss am ...

question
Verständnisproblem SubnettingKarolaVor 1 TagFrageNetzwerkgrundlagen7 Kommentare

Hallo, möchte mal nerven weil ich keine Antwort finde Ein Netzwerk 172.16.0.0 /16 besteht aus einem alten Router als 4 Port Switch und 4 Clients. ...

question
Syntax zum Mappen einer Freigabe auf einem RDSH gelöst mtcmtcVor 1 TagFrageNetzwerke14 Kommentare

Hallo zusammen, ich starte normalerweise eine rdp-Datei um mich vom HomeOffice auf meinen RDSH-Client in der Firma zu verbinden. -> also kein Problem Auf diesem ...

question
Apps mit riesigen Datenbank verbindenBella21Vor 1 TagFrageEntwicklung4 Kommentare

Hallo alle zusammen, ich suche nach einer Lösung für einen APP. Der Datenbank ist riesig mehr als 10GB, da die komplette Datenbank nicht auf das ...

question
Umgestaltung HeimnetzwerkPaulePilsVor 1 TagFrageNetzwerke1 Kommentar

Hallo zusammen, ich bin seit heute neu im Forum, deshalb hoffe ich, dass meine Beitrag an der richtigen Stelle platziert ist :-) Ich würde mich ...

question
Ist diese Hardware sinnvoll für privaten Haushalt?stonevVor 12 StundenFrageRouter & Routing4 Kommentare

Hallo erstmal :) Meine alte Fritzbox 7490 spinnt seit gestern. Ich gehe von Alterschwäche aus, es wird also Ersatz fällig. Zufrieden war ich mit ihr ...

question
Hyper V Maschine (Windows 10 Pro) auf Server2022 langsam gelöst factxyVor 1 TagFrageHyper-V6 Kommentare

Hallo, ich habe einen neuen Server2022 augesetzt und dort von einem 2016er Server eine Windows10 HyperV erst exportiert dann am 2022er importiert. Soweit mit gleicher ...