Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 7 Embedded Schreibschutz entfernen

Mitglied: lordofremixes

lordofremixes (Level 2) - Jetzt verbinden

14.11.2017 um 13:33 Uhr, 3903 Aufrufe, 12 Kommentare, 1 Danke

Hallo zusammen,

ich arbeite seit gut zwei Tagen an einem Problem, das meine Haare mal wieder ergrauen lässt.
Wir haben diverse Windows Embedded Systeme im Einsatz, die an sich recht stabil laufen. Nur ein Gerät tanzt total aus der Reihe.
Unter anderem ist das Profil hinüber, Netzwerkverbindung baut sich nur sproadisch auf, Datum steht bei jedem Neustart auf 2012 etc etc.

Also zu einem funktionierenden Windows 7 Embedded Tablet hingegangen und ein sauberes Image mit Acronis 2016 gezogen, welches ich wiederum auf das defekte Gerät wieder aufspielen wollte.
Das Image erstellen hat und auf dem defekten einspielen hat auch wunderbar geklappt, und als ich den defekten Embedded Rechner nach dem Image einspielen hochfahren wollte, traute ich meinen Augen nicht:
Das Gerät zieht sich das komplette defekte Profil (woher auch immer) und das eben eingespielte Image wird ignoriert, als ob es nie eingespielt wurde.

Also erstmal recherchiert woher kommen die alten Daten. Es gibt nur 2 Partitionen (1x Boot, 1x System), es gibt kein Netzwerkboot, keine GPO, kein Startstript, Autostart oder was auch immer was.
Also Festplatte komplett mit Acronis Drive Cleaner formatiert, Rechner neugestartet und was passiert?
Er fährt wieder mit dem alten, defekten Profil hoch (Ich dachte, ich verliere den Glauben an die Menschheit).

Dann weiter recherchiert:
Windows Embedded Schreibschutz gegoogelt. Gibt wohl einen Enhanced Write Filter und einen File Based Write Filter für Embedded Systeme.
Ich dachte, Volltreffer, das muss es sein. Es gibt sicher eine versteckte Partition aus der die Daten wiederhergestellt werden!

Statusabfrage für EWF Filter gemacht:
cmd.exe --> ewfmgr -all

C:\windows\system32>ewfmgr -all
Protected Volume Configuration
Type RAM (REG)
State DISABLED
Boot Command NO_CMD
Param1 0
Param2 0
Volume ID 2A 59 F5 96 00 00 10 00 00 00 00 00 00 00 00 00
Volume Name "\\?\GLOBALROOT\Device\HarddiskVolume1"
Max Levels 1
Clump Size 512
Current Level N/A

Memory used for data 0 bytes
Memory used for mapping 0 bytes


Protected Volume Configuration
Type RAM (REG)
State DISABLED
Boot Command NO_CMD
Param1 0
Param2 0
Volume ID 2A 59 F5 96 00 00 50 06 00 00 00 00 00 00 00 00
Volume Name "\\?\GLOBALROOT\Device\HarddiskVolume2" [C:]
Max Levels 1
Clump Size 512
Current Level N/A

Memory used for data 0 bytes
Memory used for mapping 0 bytes

--> auch deaktiviert

und Status für den FBWF:

cmd.exe --> fbwfmgr

C:\windows\system32>fbwfmgr
File-based write filter configuration for the current session:
filter state: disabled.

File-based write filter configuration for the next session:
filter state: disabled.

--> auch deaktiviert


Was für einen ........ Schreibschutz kann das Ding noch haben, damit ich es endlich wieder neu installieren kann bzw. das Image aufspielen kann?`
Selbst wenn ich nur eine Verknüpfung vom Desktop lösche und einen Neustart mache oder irgendeine kleinste Änderung durchführe oder auch die Festplatte Sektor für Sektor mit 0en überschreiben lasse!, ist beim nächsten Neustart alles wieder beim Alten.

Hat vielleicht irgendjemand eine Idee, wo ich noch nachschauen kann?? (sonst hab ich bald keine Haare mehr auf dem Kopf bzw. nur graue)


Gruß
lordofremixes




Mitglied: Derbenzi
14.11.2017 um 14:10 Uhr
was ist das denn für ein Gerät? Es gibt auch manchmal herstellerbezogene eigene Schreibschutzfilter.
Bitte warten ..
Mitglied: lordofremixes
14.11.2017 um 14:23 Uhr
Es ist ein ads-tec VMT7012 Stapler-Terminal.
Beim Händler auch schon nachgefragt, er vermutet auch, dass es irgendwas mit dem EWF schreibschutz zu tun haben muss, mehr konnte er mir aber auch nicht sagen
Bitte warten ..
Mitglied: departure69
14.11.2017, aktualisiert um 14:44 Uhr
@lordofremixes:

Hallo.

Zu deinem Schreibschutzproblem kann ich leider nichts weiter sagen. Alles, was man dazu tun kann, daß dieser nicht mehr aktiv ist ("disabled"), hast Du bereits getan.

Vielleicht kannst Du das Problem rein hardwareseitig lösen? Ich kenne zwar Eure genaue HW nicht, aber Windows Embedded kenne ich beispielsweise auch von Thin Clients im Büro. Und die haben ihr System zumeist auf irgendwelchen Flash-Karten, früher auf CF, mittlerweile wahrscheinlich auf SD. Und Hersteller, die was auf sich halten, haben da früher fast immer Karten von Sandisk verwendet.

Ich würde das Gerät aufschrauben, nachsehen, was da für eine Karte drin ist, solch eine Karte normal im Handel kaufen, einbauen, und das Image eines funktionierenden Gerätes einspielen. Bei dieser Methode kann eigentlich kein Schreibschutz an jedweder Stelle aktiv sein (weil leere Karte). Und bei dem dabei entstehenden Lizenzproblem muß Dir dann einfach der Hersteller helfen, finde ich, denn der hat ja Deine Querelen dazu schon mitbekommen.

Viele Grüße

von

depaerture69
Bitte warten ..
Mitglied: Derbenzi
14.11.2017 um 14:52 Uhr
Hast du es schon mit dem Befehl:
ewfmgr c: -commitanddisable
versucht?
Dieser ist wohl extra für den Ram Modus, welchen dieser Client verwendet.
LG
Bitte warten ..
Mitglied: lordofremixes
14.11.2017 um 14:54 Uhr
Hallo.

Zu deinem Schreibschutzproblem kann ich leider nichts weiter sagen. Alles, was man dazu tun kann, daß dieser nicht mehr aktiv ist ("disabled"), hast Du bereits getan.

Vielleicht kannst Du das Problem rein hardwareseitig lösen? Ich kenne zwar Eure genaue HW nicht, aber Windows Embedded kenne ich beispielsweise auch von Thin Clients im Büro. Und die haben ihr System zumeist auf irgendwelchen Flash-Karten, früher auf CF, mittlerweile wahrscheinlich auf SD. Und Hersteller, die was auf sich halten, haben da früher fast immer Karten von Sandisk verwendet.

Ich würde das Gerät aufschrauben, nachsehen, was da für eine Karte drin ist, solch eine Karte normal im Handel kaufen, einbauen, und das Image eines funktionierenden Gerätes einspielen. Bei dieser Methode kann eigentlich kein Schreibschutz an jedweder Stelle aktiv sein (weil leere Karte). Und bei dem dabei entstehenden Lizenzproblem muß Dir dann einfach der Hersteller helfen, finde ich, denn der hat ja Deine Querelen dazu schon mitbekommen.

Viele Grüße

von

depaerture69



Hallo depaerture,

das Ding aufzuschrauben ist leider ein Ding der Unmöglichkeit, weil dann auch die Garantie erlöschen würde.
Was mich dennoch wundert:

Type RAM (REG)
State DISABLED
Boot Command NO_CMD

Dieser Type RAM (REG), da muss irgendwas aktiv sein.



Type RAM (REG)
State DISABLED
Boot Command NO_CMD
was mich dennoch wundert, warum bei
Bitte warten ..
Mitglied: lordofremixes
14.11.2017 um 14:55 Uhr
Mitglied: Derbenzi
Derbenzi (Level 1) - Jetzt verbinden
14.11.2017 um 14:52 Uhr
Hast du es schon mit dem Befehl:
ewfmgr c: -commitanddisable
versucht?
Dieser ist wohl extra für den Ram Modus, welchen dieser Client verwendet.
LG


Ja, ich probiere es gerade aber nochmal!
Bitte warten ..
Mitglied: lordofremixes
14.11.2017 um 15:10 Uhr
Leider ohne Veränderung
Bitte warten ..
Mitglied: departure69
14.11.2017 um 16:33 Uhr
das Ding aufzuschrauben ist leider ein Ding der Unmöglichkeit, weil dann auch die Garantie erlöschen würde.

Du hast noch Garantie?

Warum quälst Du Dich dann noch? Wieviele Stunden hast Du jetzt schon mit dem Problem verbra(u)cht?

Ab zum Hersteller damit!


Viele Grüße

von

departure69
Bitte warten ..
Mitglied: lordofremixes
14.11.2017 um 17:20 Uhr
Wird wohl so laufen müssen, obwohl es mich brennend interessiert hätte, was das ist!!

Gruß
lordofremixes
Bitte warten ..
Mitglied: brammer
14.11.2017 um 18:23 Uhr
Hallo,

Ein einfaches

hast du aber probiert?

Wird das ganze evtl. unter einem anderen User erwartet?
Irgendein Hersteller User oder Admin?


Brammer
Bitte warten ..
Mitglied: lordofremixes
17.11.2017 um 10:22 Uhr
Hallo Brammer,

habe das gerade erst noch gelesen, ja das habe ich probiert.
Sogar ein Werksimage, was lt. Hersteller alles überschreiben sollte, überschreibt nichts.

Naja das Geät wird jetzt zurückgesendet!

Danke dennoch für die Hilfe!

Gruß
Bitte warten ..
Ähnliche Inhalte
Windows Systemdateien

Windows Embedded Standard 7 CMD Shell als Admin starten

gelöst Frage von IngenieursWindows Systemdateien7 Kommentare

Hallo ich habe das Problem das die Command Prompt Shell in Windows Embedded Standard 7 sich beim booten ohne ...

Windows Installation

Von Windows embedded Standard POS Ready 7 zu Windows 10 Professional

Frage von Berto95Windows Installation12 Kommentare

Guten Abend Zusammen, ich habe das folgende Problem und ich hoffe, dass ihr mir helfen könntet. Ich habe 17 ...

Microsoft

Windows XP Embedded Partition verschwunden

Frage von TiloklomMicrosoft4 Kommentare

Hallo, Auf der Arbeit haben wir ein ganz großes Problem, welches mit Windows XP Embedded zusammen hängt. Ich hoffe ...

Outlook & Mail

EMails werden nach 3 Monaten entfern - Einstellung

Frage von staybbOutlook & Mail5 Kommentare

Hallo, ich habe bei einem Postfach das Problem, dass in Outlook alle Mails älter wie 3 Jahre verscheinden und ...

Neue Wissensbeiträge
Sicherheit
Alexa un Co. TU-Darmstadt entwickelt Anti-Spy Tool
Information von the-buccaneer vor 17 StundenSicherheit3 Kommentare

Moinsen! HR-Info hatte heute ein Feature in dem das "LeakyPick" der TH-Darmstadt vorgestellt wurde. Das Tool existiert bisher nur ...

Linux Tools
Rsync datenvolumen reduzieren mit -fuzzy
Anleitung von NetzwerkDude vor 3 TagenLinux Tools

Moin, aus der Kategorie "Häufig übersehene Parameter": Meistens benutzt kaum jemand den fuzzy Parameter von rsync, und er taucht ...

Sicherheit

Citrix ADC, Gateway u. SD-Wan: Schwachstellen patchen

Information von kgborn vor 5 TagenSicherheit

Keine Ahnung, wie viele Admins von Citrix-Applicances hier unterwegs sind und ob die Versorgung mit Advisories klappt. Aber im ...

Off Topic

Im Tel Raum von Hamburg (040) sind mal wieder viele Indische Microsoft Anrufer unterwegs

Information von TomTomBon vor 6 TagenOff Topic16 Kommentare

Moin Moin, Die sind so schlecht das sogar meine Frau sofort die erkannt hat was die sind. Und Ihr ...

Heiß diskutierte Inhalte
Windows 10
OneDrive: GUI lädt, move nicht
Frage von holliknolliWindows 1028 Kommentare

Hallo liebe alle, befindet sich jemand aus dem Kreise der MS-Developer, speziell Onedrive unter den Teilnehmern hier? Frage: warum ...

Windows Server
Anmelden via RDP bringt "Passwort fehlerhaft" - lokale Anmeldung möglich
Frage von it-froschWindows Server21 Kommentare

Hallo Kollegen, Windows Server 2012 Wir haben einen Server, an dem wir uns mit einem lokalen Account anmelden. Die ...

Router & Routing
Fritzbox Feste IP-Adresse Zugang
gelöst Frage von TobiTobiRouter & Routing19 Kommentare

Guten Tag liebes Forum, Ich habe ein Problem wo ich nicht weiterkomme! Situation: Netzwerk: DSL-Modem(daytrec)-OPNSense-Netzwerk Habe aktuell mein Anschluss ...

Festplatten, SSD, Raid
Backup einer an die FRITZBox angeschlossenen Festplatte
Frage von DJ-KeyFestplatten, SSD, Raid19 Kommentare

Habe eine Frstplatte, die mehrere Partitionen beherbergt. Die Festplatte die an der FRITZ!Box als NAS dient ist schon älter ...