kraww84
Goto Top

Windows auf andere Partition, nix geht mehr

Habe auf einer Festplatte c = Windows 98 und d= windows XP vorliegen. Habe die Windows 98 partition mit Partition Magic gelöscht, und die d partition auf die gesammte größe gelegt und in c unbenannt. damit ich die ganze platte für windows xp habe. nun startet nix mehr. auch nicht wenn ich mit der reperaturkonsole einen neuen mbr erstelle. Bitte um hilfe. Daten sind alle noch auf der platte von xp. startet aber nicht. kommt immer die fehlermeldung beim booten: ungültiges System.

Content-Key: 29471

Url: https://administrator.de/contentid/29471

Printed on: July 17, 2024 at 20:07 o'clock

Member: B0d0
B0d0 Apr 01, 2006 at 10:51:00 (UTC)
Goto Top
na ja mit Partition M. darüber zu bügeln ist auch nicht so die feine Art.
Wenn eine Partition gelöscht wurde, auf der och ein BS war, bezweifle ich, das du die Daten wiederbekommst.

Partition legt man eigentlich am Anfang an, beim Aufsetzen eines Systems und nicht mitten drin.

never touch a running system
Mitglied: 27119
27119 Apr 01, 2006 at 11:16:53 (UTC)
Goto Top
Es gibt in der Widerherstellungskonsole noch den Schalter

fixboot

Tja - "Zaubertools" wie Partition Magic können anscheinend alles, doch manchmal geht es halt auch schief. Ich vermeide den Einsatz so gut ich kann.
Member: KRAWW84
KRAWW84 Apr 01, 2006 at 11:22:42 (UTC)
Goto Top
fixboot hab ich auch schon probiert. bis jetzt klappte das immer mit fixmbr, aber diesmal nicht. *verdammt* hab schon öfters so partitionen verschoben oder umgebaut. mir ist es ein rätsel, wieso das jetzt nicht geht. noch irgendwelche Ideen?
Mitglied: 27119
27119 Apr 01, 2006 at 11:26:41 (UTC)
Goto Top
XP Reparatur Installation hätte ich noch in Petto.
An der Bootsequence im Bios hast du nicht zufällig gedreht?
face-wink
Member: Janni
Janni Apr 01, 2006 at 11:28:26 (UTC)
Goto Top
Dein Problem leigt darin, das Du die Partition gewechselt hast und jetzt in der Boot.ini die falsche drinnen steht.

Schnellste Weg ist per Knoppix, oder was auch immer auf die Platte zugreifen und in der Boot.ini den OS eintrag in:
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect  
ändern.
Als Alternative kannst Du auch die Wiederherstellungskonsole benutzen oder eine Reparaturinstallation.

MFG
Member: TobiasNYC
TobiasNYC Apr 01, 2006 at 11:40:22 (UTC)
Goto Top
Na ja stimmt nicht so ganz:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /fastdetect  

So sollte es aussehen
Member: Janni
Janni Apr 01, 2006 at 11:44:48 (UTC)
Goto Top
Wer lesen kann..... ich habe auch nur von der OS Zeile gesprochen ..... face-wink

MFG
Member: ITwissen
ITwissen Apr 01, 2006 at 13:40:56 (UTC)
Goto Top
Mach dir eine BartPE BootCD oder nimm eine Knoppix.

Dann kannst du erstmal deine Daten aufs Netzwerk oder auf eine externe Platte sichern.

Anschliessend kannst du rumbasteln und deine Daten sind wenigstes sicher.

Bei mir hats mal geholfen von Knoppix aus mittels fdisk der Partition das Bootflag zu setzen.
Mitglied: 16568
16568 Apr 01, 2006 at 14:34:52 (UTC)
Goto Top
Also, ich dachte immer, der Order "WINNT" sei ab Windows 2000 Professional abgeschafft worden, und heißt jetzt "WINDOWS"...


Lonesome Walker
Member: Janni
Janni Apr 01, 2006 at 15:03:38 (UTC)
Goto Top
Da hast Du recht, dann auch halt von mir einmal in Ganz:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /fastdetect /noexecute=optin  

Schönes Wochenende
Member: stpe
stpe Apr 01, 2006 at 18:00:26 (UTC)
Goto Top
Ich denke, Du hast leider keine Chance mehr, Dein XP an's laufen zu bekommen - selbst dann nicht, wenn Dein Bootloader wieder auf das richtige System zeigt. Denn auf einen Wechsel des Laufwerksbuchstaben reagiert Windows ziemlich allergisch.

Bei der Installation von Citrix auf einem Windows-Server gibt es zwar ein Tool, alle eingetragenen Systemlaufwerkszuweisungen auf ein anderes Laufwerk zu migrieren, aber selbst das läuft wirklich nur dann zuverlässig, wenn es direkt nach der Installation des OS benutzt wird.

Evtl. hilft es, das Systemlaufwerk wieder auf D:\ zu verschieben.

Gruss
Stefan
Member: KRAWW84
KRAWW84 Apr 01, 2006 at 18:52:31 (UTC)
Goto Top
habs hinbekommen. hab die repaeraturfunktion von xp genutzt. klappte einwandfrei.
Mitglied: 27119
27119 Apr 01, 2006 at 18:54:01 (UTC)
Goto Top
habs hinbekommen. hab die repaeraturfunktion
von xp genutzt. klappte einwandfrei.

Wie erwartet face-wink Muhahahahahaha.
Member: stpe
stpe Apr 01, 2006 at 19:51:57 (UTC)
Goto Top
habs hinbekommen. hab die repaeraturfunktion
von xp genutzt. klappte einwandfrei.

Und Dein XP läuft nun inkl. aller Anwendungen einwandfrei unter C:\ statt unter D:\??????

Gruss
Stefan
Member: KRAWW84
KRAWW84 Apr 01, 2006 at 22:38:41 (UTC)
Goto Top
Nein, die Anwendungen nicht. Hab dann die Partition wieder in D umgewandelt, und das ganze Spiel von vorne. Naja, hauptsache ich habe jetzt eine Partition für XP.