gelöst Zuweisung Netzwerkprofil nicht resetfest

Mitglied: altmetaller

altmetaller (Level 3) - Jetzt verbinden

20.10.2016 um 10:53 Uhr, 1164 Aufrufe, 7 Kommentare

Hallo,

ein Kollege hat auf einem Hyper-V-Host ein paar Netzwerkkarten an einen "leeren" Switch angeschlossen. Die Netzwerkschnittstellen haben eine IP-Adresse und eine Subnetzmaske, aber kein Gateway.

Die Netzwerkschnittstellen werden der Kategorie "Public" zugeordnet.

Also bin ich in die PowerShell, habe mir mit Get-NetConnectionProfile den InterfaceIndex von einer der Schnittstellen geholt und diesen via Set-NetconnectionProfile in die Kategorie "Private" geschubst. Interessanterweise sind daraufhin sämtliche Schnittstellen "umgeplöppt" (ich hätte gedacht, dass nur die umspringt, deren InterfaceIndex ich angebe).

Meine Theorien dazu:

"Der Server sieht über die anderen Schnittstellen, dass er bereits mit einer MAC auf dem Switch hängt, deren Schnittstelle der Kategorie Private zugeordnet ist - also betrachtet er den gesamten Switch und somit auch die anderen Schnittstellen auch als Private". Ist das korrekt? Falls nein - warum springen alle Schnittstellen gleichzeitig um, wenn ich explizit nur eine Schnittstelle umhänge?

Zusätzlich beobachten wir, dass die Zuordnung nicht resetfest ist. Dazu folgende Theorie: "Der Server muss auf dem Switch irgendeine MAC-Adresse finden. Diese merkt er sich und verwendet sie, um das Netzwerk zukünftig zu identifizieren. Da er dort nur eigene MAC-Adressen sieht, die ja grundsätzlich erst einmal nicht kategorisiert sind, kann er das Netzwerk nicht wiedererkennen und stuft es daher als Public ein". Ist das korrekt?

"Im Grunde genommen" dürfte sich das Problem spätestens dann erledigen, wenn an dem Switch zusätzlich ein weiteres Gerät mit einer MAC-Adresse angeschlossen wird - oder?

Gruß,
Jörg
Mitglied: altmetaller
20.10.2016 um 11:03 Uhr
Hallo,

Ergänzung - der Server wurde inzwischen in das Produktivnetz gehängt. Nach einem Neustart zeigt sich das gleiche Verhalten (Schnittstellen springen auf "Public" um).

Auf einem anderen Server, der laut Aussage meines Kollegen identisch konfiguriert ist, zeigt sich das Verhalten nicht. Dort haben die Schnittstellen ebenfalls kein Gateway, bleiben aber auf "Private" stehen wenn man die Mühle neu anschubst.

Gruß,
Jörg
Bitte warten ..
Mitglied: brammer
20.10.2016 um 11:24 Uhr
Hallo,

beidem "leeren" Switch hängen alle Teilnehmer im default VLAN 1
Ist das bei dem anderen Switch auch so? hängen die auch alle in einem VLAN?

brammer
Bitte warten ..
Mitglied: altmetaller
20.10.2016 um 11:58 Uhr
Hallo,

ja, die hängen alle gemeinsam in einem VLAN.

Gruß,
Jörg
Bitte warten ..
Mitglied: Pjordorf
LÖSUNG 20.10.2016, aktualisiert um 13:46 Uhr
Hallo,

Zitat von altmetaller:
Die Netzwerkschnittstellen haben eine IP-Adresse und eine Subnetzmaske, aber kein Gateway.
Die Netzwerkschnittstellen werden der Kategorie "Public" zugeordnet.
Und eben weil die kein Gateway finden können alle an diesen Switch angeschlossenen VMs eben nicht erkennen......
Dein Horst die Parent VM (Dein Host ist nachdem die Rolle Hyper-V installiert wurde ebenfalls dann eine VM) hängt auch da dran? Horst ist Workgroup oder DomainMember? LAN direkt per (lokal) GPedit.msc oder (Domäne) GPO in ein Privates LAN (Lokal) oder in dein Domänen-LAN (GPO) schubsen wenn der Horst mal neu starten sollte.

Kein Gateway erreichbar - keine Erkennung. Was tatsächlich das Gateway ist (z.B. ein PC) ist irrelevant.

netzwerkrichtlinie lokal gpedit - Klicke auf das Bild, um es zu vergrößern

Gruß,
Peter
Bitte warten ..
Mitglied: altmetaller
20.10.2016 um 15:04 Uhr
Hallo,

was mich wundert ist halt, dass der andere Server auch keine Gateways hat.

Das mit dem Domainmember lasse ich ihn mal überprüfen - danke für den Tipp! Zur Not machen wir 's halt über die Gruppenrichtlinie, allerdings ist das dann wohl eher die Brechstange...?!?

Gruß,
Jörg
Bitte warten ..
Mitglied: Pjordorf
LÖSUNG 20.10.2016 um 15:30 Uhr
Hallo,

Zitat von altmetaller:
allerdings ist das dann wohl eher die Brechstange...?!?
NÖ - warum sollte es? Wenn nunmal kein aktive reagierendes Gateyway zum Zietpunkt der Netzwerkschittstellenaktivierung existiert. Das Gateway selbst muss ja gar nicht als Gateway funktionieren, es muss nur antworten - nur Blöd wenn mann dann zum Arbeiten das Gateway doch wieder anfassen muss. Wenn dein Horst selbst eine eigene Hardwareschittstelle hat (kein V-Switch) ....

NLA und Gateway ist dein Freund Suchbegriff

Gruß,
Peter
Bitte warten ..
Mitglied: altmetaller
20.10.2016 um 21:44 Uhr
1000 Dank
Bitte warten ..
Heiß diskutierte Inhalte
Server-Hardware
Grobes Konzept Hyper-V Storage - Storage für Hyper-V
nachgefragtFrageServer-Hardware26 Kommentare

Hallo Administratoren. Um VHDX-Daten zentral zu halten freue ich mich auf Euren konstruktiven Input. Bisher liegen die VHDX-Daten jeweils ...

Router & Routing
Cisco RIPv1 RIPv2
MrLabelFrageRouter & Routing26 Kommentare

Hallo Zusammen, ich muss nochmal auf eine schon behandelte Frage eingehen. Bitte jemand, der auch den Cisco Paket Tracer ...

Schulung & Training
IT Ausbildung
gelöst IntershipFrageSchulung & Training18 Kommentare

Hallo Leute, ist diese Ausbildung etwas für den IT-Einstig? Willkommen bei der GFN! Arbeitsuchende Berufstätige Kostenträger Über uns Jobs ...

Windows Server
Terminal Server Hyper-V Grafik performance
ReneM1983FrageWindows Server17 Kommentare

Moin Kollegen, ich habe da mal ein Problem, ein Kunde hat einen Terminal Server auf einem Hyper-V laufen, wo ...

Verschlüsselung & Zertifikate
Elektronische Unterschrift
gelöst PeterzFrageVerschlüsselung & Zertifikate14 Kommentare

Hallo zusammen, könnt ihr mir vielleicht ein paar Hinweise geben, wie ihr eine elektronische Unterschrift unter Dokumente und E-Mails ...

Vmware
Probleme mit meinem VM-Server und keine Idee
worker2000FrageVmware13 Kommentare

Moin zusammen, ich brauche mal ein wenig Input weil mir langsam die Ideen ausgehen. Am Ende vermute ich dass ...

Ähnliche Inhalte
Windows 10
Zuweisung Netzwerkdrucker
oleg0815FrageWindows 103 Kommentare

Hallo zusammen, vielleicht weiß einer von euch einer Lösung zu meinem Problem, da ich seit 2 Tagen ratlos bin. ...

Windows Server

Problem mit Netzwerkprofil Windows Server 2019

gelöst vogtlaender212FrageWindows Server10 Kommentare

Hallo Gemeinde, ich bin gerade dabei, einen Windows Server 2019 Standard aufzusetzen - aktuelle Build 17763.475. Nach dem Domain ...

Netzwerkmanagement

Cisco port Zuweisung

131361FrageNetzwerkmanagement8 Kommentare

Hallo zusammen, such nach einer kurzen Syntax um mehrerer Ports eine Einstellung zuzuweisen. Aktuell mach ich dies wie folgt: ...

Windows Server

Windows Server 2012R2 Netzwerkprofil falsch nach KB4499151

gelöst anteNopeFrageWindows Server1 Kommentar

Mahlzeit zusammen, ich habe gestern Nacht das KB4499151 auf 4 Servern mit 2012R2 installiert. Hiervon sind 2 HyperV und ...

Drucker und Scanner

Drucker Zuweisung Medienquelle anhand Medientyp

gelöst MNAcc216FrageDrucker und Scanner3 Kommentare

Hallo Leute, ich habe hier ein Problem mit einem Kyocera P-3525 MFP. Konfiguration Einstellungen und Zuweisungen Quelle/Medientyp auf Druckgerät: ...

Switche und Hubs

Cisco SG250 VLAN-Zuweisung mit 802.1x

Tolot20FrageSwitche und Hubs3 Kommentare

Hallo, ich habe noch nie einen Switch konfiguriert, aktuell ist aber ein SG250 auf dem Weg zur Verwendung in ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT