Surface Pen funktioniert nicht nach Neuinstallation. Lösung inside

antenope
Goto Top
Hallo zusammen,
also nachdem Microsoft beim 20H2 Update verpeilt hatte die Geräte zu bereinigen, geht es nun in die zweite Rundes des "Was zum Geier soll der Mist?!?".

Ich habe hier gerade ein Surface Pro 4 liegen, mit TypeCover und Pen Modell 1776. Das Gerät wurde gerade frisch mit 20H2 vom USB-Stick installiert. Die Treiber werden von Windows Update geladen und installiert und alles sollte nach ein paar Neustarts funktionsfähig sein. Unzählige Male gemacht und nie Probleme damit gehabt.

Kurz noch den Stift via Bluetooth gekoppelt und ... er schreibt nicht??? 🤨
Batterie ist voll, Stift ist gekoppelt (auch wenn nicht notwendig), die entsprechenden Geräte sind installiert, der hinterer Kopf funktioniert, aber eben halt nur die Digitizer-Funktion möchte nicht. Seltsam ...

Nach über einer Stunde Suchen im Netz und Geräte aktivieren, deaktivieren, deinstallieren, UEFI hier und dort ..., bin ich schließlich selbst drauf gekommen. Hier die LÖSUNG:

  • Die Intel HD Graphics 520 hat keine Treiber installiert bekommen, sondern läuft mit dem "Microsoft Basic Display Adapter" ...
  • Stößt man manuell das Treiberupdate an, werden direkt die passenden Treiber geladen und installiert
  • Kurz darauf folgen weitere Geräte die plötzlich installiert werden (z.B. Intel AVStream Camera 2500)
  • Und die Digitizer Funktion des Pens funktioniert ...

Good Job ... 😐

p.s. nein, Windows Update war der Meinung das Gerät wäre auf dem aktuellsten Stand ... Also Augen auf bei der Verwendung von Windows 10 20H2 ...

Content-Key: 627109

Url: https://administrator.de/contentid/627109

Ausgedruckt am: 19.08.2022 um 07:08 Uhr

Mitglied: 146707
146707 01.12.2020 aktualisiert um 10:22:32 Uhr
Goto Top
p.s. nein, Windows Update war der Meinung das Gerät wäre auf dem aktuellsten Stand ... Also Augen auf bei der Verwendung von Windows 10 20H2 ...
Naja, das war ja schon immer so, wenn man sich auf die Treiberinstallation von Windows selbst verlässt. Dafür bist du ja der Admin des Geräts derjenige der die Installation und die korrekten Treiber bereitstellt face-wink. Wenn man meint das MS seine eigene Hardware besser supported als andere der träumt einen feuchten Traum face-smile.
Mitglied: anteNope
anteNope 01.12.2020 um 10:28:47 Uhr
Goto Top
Zitat von @146707:
Naja, das war ja schon immer so, wenn man sich auf die Treiberinstallation von Windows selbst verlässt. Dafür bist du ja der Admin des Geräts derjenige der die Installation und die korrekten Treiber bereitstellt face-wink

Scherzkeks, die Treiber kamen ja dann über Windows Update, man musste es nur über den Gerätemanager anstoßen. Das sollte eigentlich automatisch passieren.

Wenn man meint das MS seine eigene Hardware besser supported als andere der träumt einen feuchten Traum face-smile
Die supporten eigentlich jegliche Hardware sehr gut, es sei denn man hat da etwas exotisches. Bei B360M Boards brauchte es keinerlei Nacharbeit, beim B460M, braucht es nur Ethernet-Treiber und macht den Rest ebenfalls selbst 😋

Außerdem geht es hierbei eher um den Fakt, dass der Digitizer (und andere Geräte) nicht funktionieren wenn die Grafiktreiber fehlen ...
Mitglied: aqui
aqui 03.12.2020 um 14:50:16 Uhr
Goto Top
Dann fehlt ja eigentlich nur noch:
https://administrator.de/faq/32
Mitglied: anteNope
anteNope 03.12.2020 aktualisiert um 14:55:53 Uhr
Goto Top
Zitat von @aqui:

Dann fehlt ja eigentlich nur noch:
https://administrator.de/faq/32

Moin, das war ein Erfahrungsbericht, das fällt unter die Kategorie "Wissen". Den kann man nicht als gelöst markieren 😜

Siehe https://administrator.de/discover/?art=knowledge