gfritz74
Goto Top

AD Feld LandRegion wird nicht befüllt

Hallo zusammen,

Ich lege per Skript einen neuen User im AD an. Das klappt auch soweit wunderbar.
Das einzige was nicht klappt ist das das Land in dem Feld Land/Region angezeigt wird,
obwohl das Attribut gesetzt ist. Hier mal mein Code:

Hat vielleicht jemand ne Idee warum das nicht klappt und wie ich das lösen kann?

Viele Grüße
gfritz

Content-Key: 2849865079

Url: https://administrator.de/contentid/2849865079

Printed on: February 8, 2023 at 11:02 o'clock

Member: Dani
Dani May 20, 2022 at 10:39:11 (UTC)
Goto Top
Moin,
c = "CE"
co = "Deutschland"
countryCode = "276"
welcher Wert wird nicht gesetzt? Geht für mich nicht klar hervor.
Unabhängig davon vermute ich das es sich bei "CE" um einen Schreibfehler (=DE) handelt?


Gruß,
Dani
Member: MrCount
MrCount May 20, 2022 at 10:42:35 (UTC)
Goto Top
Servus,

das Attribut Country erledigt das auch und muss mit dem Code (hier DE) gefüllt werden.
https://www.alitajran.com/active-directory-country-code-list/

Mal davon abgesehen, dass in deinem Code in Zeile 13 vermutlich ein Typo ist...

c = "CE"
sollte vermitlich
c = "DE"
sein
Member: gfritz74
gfritz74 May 20, 2022 at 10:55:18 (UTC)
Goto Top
Ups da war wohl ein Tippfehler drin.
Hier das Feld welches ich meine.

unbenannt
Member: MrCount
Solution MrCount May 20, 2022 at 11:01:00 (UTC)
Goto Top
Ja, nimm als Attribut "Country" und fülle es mit "DE", dann ist das Feld ausgefüllt...

Bsp:
Member: gfritz74
gfritz74 May 20, 2022 at 11:12:53 (UTC)
Goto Top
Klappt danke Dir.