jojo0411
Goto Top

Autodiscover.xml generieren?

Hallo Leute,

Ich habe gerade meinen ersten Exchange 2016 installiert und soweit funktioniert das ganz gut. Ich habe ausserdem ein extern signiertes Zertifikat installiert.

Beim Autodiscover stehe ich noch etwas am Schlauch.... obwohl es tolle Anleitungen im Netz gibt wie zum Beispiel hier:

https://www.frankysweb.de/exchange-2016-umfangreiches-whitepaper-zu-auto ...

Ich habe jedoch das Problem das in meinem XML File am Server nur ein Einzeiler enthalten ist .... muss ich das selber befüllen oder wird das in irgendeinem Schritt der Konfiguration befüllt?

nice greetz jojo

Content-Key: 368212

Url: https://administrator.de/contentid/368212

Printed on: March 2, 2024 at 05:03 o'clock

Member: colinardo
colinardo Mar 15, 2018 updated at 12:59:05 (UTC)
Goto Top
Zitat von @jojo0411:
Ich habe jedoch das Problem das in meinem XML File am Server nur ein Einzeiler enthalten ist .... muss ich das selber befüllen oder wird das in irgendeinem Schritt der Konfiguration befüllt?
Nein, das wird durch die Dienste automatisch generiert!
https://technet.microsoft.com/en-us/library/bb124251(v=exchg.160).aspx
Du musst nur sicherstellen das alle Exchange Dienste laufen und du alle deine URLs richtig gesetzt hast
Powershell: Konfigurieren der internen und externen URLs von Exchange Server 2013, 2016

Grüße Uwe
Member: jojo0411
jojo0411 Mar 15, 2018 at 14:00:01 (UTC)
Goto Top
Ok, ich habe deinen 2. Link verwendet und das Script ausgeführt. Ausserdem den Server danach durchgestartet.

Autodiscover.xml ist immer noch ein Einzeiler und das verbinden über Autodiscover funktioniert nicht.

Was könnte ich noch tun damit das richtig konfiguriert wird?

nice greetz jojo
Member: colinardo
colinardo Mar 15, 2018 updated at 14:06:24 (UTC)
Goto Top
Zitat von @jojo0411:
Was könnte ich noch tun damit das richtig konfiguriert wird?
Den Exchange nach Vorschrift aufsetzen face-smile. Wenn du den neu aufgesetzt hast hast du einen Fehler gemacht.
Checken das alle EX Dienste laufen und die Logs konsultieren. Dir ist schon klar das die XML dynamisch generiert wird?!

Deine Beschreibungen strotzen ja nicht gerade vor Informationen... Meine Glaskugel ist in Wartung.
Member: jojo0411
jojo0411 Mar 15, 2018 at 14:52:26 (UTC)
Goto Top
Wenn die Glaskugel fertig ist schick mir die mal rüber.... ;)

Die Dienste laufen alle. Ich gebe gerne alle Infos weiter... wenn ich wüsste welche etwas helfen....

Ich habe den Exchange installiert und danach hat eigentlich alles funktioniert.

Dann habe ich das Zertifikat beantragt und seitdem lässt sich das Profil nicht mehr verbinden und Outlook bringt immer wieder die Authentifizierung.

Das mit dem Dynamisch generieren ist ein guter Hinweis. Das erklärt den Einzeiler. Das war etwas verwirrend weil die XML Dateien in den Anleitungen entsprechenden Inhalt haben.

Aber vielleicht ist meine Vermutung auch einfach falsch wie gesagt mein Problem ist das sich das Client Profil seit dem Zertifikat nicht mehr verbinden lässt weil er permanent die Authtentifizierung abfragt. Übrigens bei allen AD Usern mit denen ich es probiere. Welche Log Files könnten mir da weiterhelfen?

nice greetz jojo
Member: colinardo
colinardo Mar 15, 2018 updated at 15:34:21 (UTC)
Goto Top
Zitat von @jojo0411:
Ich habe den Exchange installiert und danach hat eigentlich alles funktioniert.
Oh ja das hilft mir jetzt ungemein ... face-big-smile.
Dann habe ich das Zertifikat beantragt und seitdem lässt sich das Profil nicht mehr verbinden und Outlook bringt immer wieder die Authentifizierung.
OK, also liegt hier zu 90% dein Hund begraben, dann verrate uns doch bitte mal wie du das Zertifikat exakt eingebunden hast. Ich hoffe nicht einfach nur im IIS hinterlegt, denn das ist absolut falsch. Nutze die ECP oder besser gleich Import-ExchangeCertificate in der Powershell.
Natürlich prüfen ob der Zertifikat alle URLs die du verwendest inkludiert hat sowohl im Common-Name als auch im SAN-Feld müssen unter anderen die FQDNs und autodiscover.domain.de vermerkt sein.
Im IIS prüfen ob die Zertifiikate dann in der Frontend und Backend Site korrekt angekommen sind.
Aber vielleicht ist meine Vermutung auch einfach falsch wie gesagt mein Problem ist das sich das Client Profil seit dem Zertifikat nicht mehr verbinden lässt weil er permanent die Authtentifizierung abfragt.
Wenn Änderungen an URLs vorgenommen werden oder sonstige Umbauarbeiten diesbezüglich, Profil löschen und neu anlegen. Outlook cached bestimmte Dinge.
Übrigens bei allen AD Usern mit denen ich es probiere. Welche Log Files könnten mir da weiterhelfen?
  • Zu allererst mal ein Check mit https://testconnectivity.microsoft.com/
  • Dann am Client den Auitodiscover-Test über das Taskleisten-Icon machen.
  • Am Exchange die Eventlogs und die Clientzugriffs-Logs im Exchange Programm-Verzeichnis
  • Eventlog des Clients
Member: jojo0411
jojo0411 Mar 16, 2018 at 08:45:02 (UTC)
Goto Top
Also ich habe jetzt das Autodiscover Test Utility vom Client ausgeführt und das hat keine Fehler anzeigt... das Testconnectivity Tool von Microsoft habe ich noch nicht ausgeführt weil ich den öffentlichen DNS Eintrag für Autodicovery.meinedomain.de noch nicht gesetzt habe. Ich denke das würde meine aktuelle Produktionsumgebung beeinflussen oder?

nice greetz jojo
Member: jojo0411
jojo0411 Mar 20, 2018 at 12:26:31 (UTC)
Goto Top
Hallo Leute,

Nicht ganz die Lösung aber zumindest funktioniert es:

Mit diesem Registry Key ist der Zugriff über die Profile möglich...

[HKEY_CURRENT_USER\Software\Microsoft\Exchange]
"MapiHttpDisabled"=dword:1

Es ist also ein MAPI over HTTP Problem.. das erst aufgetreten ist nachdem ich das Zertifikat erstellt habe.

Auch wenn das jetzt zu funktionieren scheint würde mich interessieren was das für ein Problem sein könnte.

nice greetz jojo
Member: colinardo
Solution colinardo Mar 20, 2018 updated at 13:00:18 (UTC)
Goto Top
Zitat von @jojo0411:

Hallo Leute,

Nicht ganz die Lösung aber zumindest funktioniert es:

Mit diesem Registry Key ist der Zugriff über die Profile möglich...

[HKEY_CURRENT_USER\Software\Microsoft\Exchange]
"MapiHttpDisabled"=dword:1
Das sollte man normalerweise nur über die Powershell machen.
Set-OrganizationConfig -MapiHttpEnabled $false
Es ist also ein MAPI over HTTP Problem.. das erst aufgetreten ist nachdem ich das Zertifikat erstellt habe.

Auch wenn das jetzt zu funktionieren scheint würde mich interessieren was das für ein Problem sein könnte.
Entweder falsch konfigurierte MAPIoHTTP URL oder die IISAuthentification Methode wird bei dir durch einen Proxy wie nginx geblockt.
Siehe https://www.windowspro.de/roland-eich/mapi-over-http-exchange-2013-2016- ...
Get-MapiVirtualDirectory | Set-MapiVirtualDirectory -InternalUrl "https://outlook.contoso.de/mapi" -ExternalUrl "https://outlook.contoso.de/mapi" -IISAuthenticationMethods Ntlm,OAuth,Negotiate  
Member: jojo0411
jojo0411 Mar 21, 2018 at 13:21:51 (UTC)
Goto Top
Danke für deine kompetente Hilfe.

Ich denke der Fehler für MAPI over HTTP war das ich bei der URL das "/mapi" vergessen hatte.

Jetzt funktioniert es bei allen Profilen so wie gewohnt mit MAPIoverHTTp.

nice greetz jojo
Member: colinardo
colinardo Mar 21, 2018 updated at 13:33:21 (UTC)
Goto Top
Zitat von @jojo0411:

Danke für deine kompetente Hilfe.

Ich denke der Fehler für MAPI over HTTP war das ich bei der URL das "/mapi" vergessen hatte.
Dann ist es klar. Öhm, wenn du mein Skript, wie du oben erwähnt angewendet hast, wäre die aber richtig gewesen face-smile. Hat du da gefummelt face-smile?
Jetzt funktioniert es bei allen Profilen so wie gewohnt mit MAPIoverHTTp.
So solls sein.

Viel Erfolg weiterhin.
Uwe