jaja99
Goto Top

AX2 interne Radio probleme

Hallo,
mal wieder ein Problem. Nachdem jetzt mein Cap AX und meine Basebox problemlos funktionieren, habe ich festgestellt, das das interne Wlan der AX2 nicht funktioniert. Das lief mal als erstes vor einigen Wochen, aber ich habe mir da wohl was zerschossen ... deshalb muß ich euch hier nochmal um Hilfe bitten. Hab erst mal screenshots gemacht. Es gibt keine Radios mehr. Vielleicht ist da der Fehler schon zu erkennen. Es handelt sich um wifi1-5g und wif2-2g. Erstaunlich finde ich, das wenn ich deren SSID ändere, kein Band mehr auswählen kann. Es stellt sich auf "unknown" Hoffe jemand hat eine Idee, Danke
clipboarder.2024.06.25-003
clipboarder.2024.06.25
clipboarder.2024.06.25-005
clipboarder.2024.06.25-004

Content-Key: 12541712024

Url: https://administrator.de/contentid/12541712024

Printed on: July 16, 2024 at 19:07 o'clock

Member: aqui
aqui Jun 26, 2024 at 08:19:58 (UTC)
Goto Top
Es gibt keine Radios mehr.
Wenn die physischen Radio Interfaces nicht mehr auftauchen ist das in der Regel ein sicheres Indiz dafür das du vergessen hast die plattformspezifische WiFi Firmware dafür aufzuspielen wie wifi-qcom-7.x.y.npk
Member: jaja99
jaja99 Jun 26, 2024 updated at 10:26:23 (UTC)
Goto Top
Danke,
damit hängt es wohl zusammen
screenshot 2024-06-26 122027
allerdings kann ich das Paket nur enablen, wenn ich ja das wireless Paket auch deaktiviere. Das nutze ich ja für die Mips-basestation. Meine gelesen zu haben das dies auch gleichzeitig geht.
Jetzt sind die Wifi Radios da ...
Hoffe ich muß mich nicht entscheiden ;)
screenshot 2024-06-26 122515
Member: aqui
aqui Jun 26, 2024 at 13:24:25 (UTC)
Goto Top
Normalerweise geht beides...
Enablen oder sowas muss man auch nix. Einfach den "Files" Button in der Winbox klicken und das .npk Paket dort per Drag and Drop abladen...rebooten...fertisch.
Unter System -> Routerboard kontrollieren ob auch der Bootloader korrekt zur FW passt und das wars.
Alles kein Hexenwerk.
Member: jaja99
jaja99 Jun 26, 2024 at 13:44:06 (UTC)
Goto Top
Genau so habe ich es gemacht !
eines der beiden Pakete ist immer grau hinterlegt. Wenn ich es enable und reboote schaltet sich das andere Package grau. Habe auch mal beide packages deinstalliert und gleichzeitig installiert . Gleiches Problem. Wifi-qcom gewinnt.
clipboarder.2024.06.26
screenshot 2024-06-26 154309
clipboarder.2024.06.26-006
Member: aqui
aqui Jun 26, 2024 at 14:18:17 (UTC)
Goto Top
Vielleicht hilft das noch:
Mikrotik Upgrade von OS7.12 auf OS7.13
Member: jaja99
jaja99 Jun 26, 2024 updated at 20:45:09 (UTC)
Goto Top
Ich fürchte die letzte Zeile trifft auf mich zu !!!
Bekomme echt die Krise.. Iwi ist bei MT nix kompatibel ...
oder ich erwische alle möglichen nicht kompatiblen Geräte ...
Gibt es einen Work around? Ich darf wohl definitiv das wireless package nicht auf dem AX installieren, wenn ich dort die lokalen radios nutzen möchte.
Also ich habe jetzt RB-AX2
Cap AX
Basebox2

Danke !
screenshot 2024-06-26 164357
Member: jaja99
jaja99 Jun 28, 2024 at 13:45:14 (UTC)
Goto Top
nachdem sicher ist, das ist nicht alle 3 Radios direkt auf dem AX2 managen kann, versuche ich gerade die Basebox als single gerät zu nutzen. Irgendwas stimmt aber nicht. Habe es versucht analog dem AX2 zu konfigurieren. geht so aber nicht wirklich. Nur Vlan1 wird über BB-Privat geroutet. Finde auch keinen Eintrag die Vlan am Master auf 100 zu ändern, wie das beim AX geht.
Hier der setup:
# 2024-06-28 10:56:52 by RouterOS 7.15.1
# software id = HY8A-AQ0S
#
# model = RB912UAG-2HPnD
# serial number = 7184065ECE9F
/interface bridge
add admin-mac=6C:xxxxxxxxx:4B auto-mac=no comment=defconf name=bridge
/interface vlan
add interface=bridge name=vlan1 vlan-id=1
add interface=bridge name=vlan10 vlan-id=10
add interface=bridge name=vlan20 vlan-id=20
add interface=bridge name=vlan100 vlan-id=100
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk mode=dynamic-keys name=Priv-sec \
    supplicant-identity="" wpa2-pre-shared-key=xxxxxxxxxx  
add authentication-types=wpa2-psk mode=dynamic-keys name=Iot-sec \
    supplicant-identity="" wpa2-pre-shared-key=yyyyyyyyyyy  
add authentication-types=wpa2-psk mode=dynamic-keys name=Gast-sec \
    supplicant-identity="" wpa2-pre-shared-key=zzzzzzzzzzzzz  
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=3 country=germany disabled=no \
    mac-address=6C:xxxxxxx:4D mode=ap-bridge name=BB-Privat \
    security-profile=Priv-sec ssid=P1 wps-mode=disabled
add disabled=no keepalive-frames=disabled mac-address=6E:xxxxxxxx:4E \
    master-interface=BB-Privat multicast-buffering=disabled name=BB-Gast \
    security-profile=Gast-sec ssid=guest vlan-id=10 vlan-mode=use-tag \
    wds-cost-range=0 wds-default-cost=1 wps-mode=disabled
add disabled=no keepalive-frames=disabled mac-address=6E:xxxxxxxx:4D \
    master-interface=BB-Privat multicast-buffering=disabled name=BB-IoT \
    security-profile=Iot-sec ssid=Iot vlan-id=20 vlan-mode=use-tag \
    wds-cost-range=0 wds-default-cost=1 wps-mode=disabled
/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge comment=defconf interface=BB-Privat
/interface bridge vlan
add bridge=bridge tagged=bridge,ether1 untagged=BB-Privat vlan-ids=1
add bridge=bridge tagged=bridge,ether1 untagged=BB-Gast vlan-ids=10
add bridge=bridge tagged=bridge,ether1 untagged=BB-IoT vlan-ids=20
add bridge=bridge tagged=bridge,ether1 untagged=BB-IoT vlan-ids=100
/interface wireless cap
set bridge=bridge certificate=request discovery-interfaces=ether1 interfaces=\
    BB-Privat lock-to-caps-man=yes
/ip dhcp-client
add comment=defconf interface=bridge
/system note
set show-at-login=no
Member: aqui
aqui Jun 28, 2024 updated at 17:49:47 (UTC)
Goto Top
Im Grunde ist das dann eine stinknormale standalone MSSID Konfig ohne CapsMan wie sie auch im Tutorial beschrieben ist. Guckst du hier.

Die groben ToDos:
  • CapsMan Konfig und Betrieb auf der Basebox vollständig deaktivieren!
  • VLAN Bridge einrichten
  • Einzig NUR das Management VLAN mit einem VLAN IP Interface versehen und auf dem IP Interface einen DHCP Client aktivieren, so zieht sich die Basebox eine IP aus dem Management Netz. Du kannst der später auch über die Mac Adresse eine feste IP zuweisen lassen.
  • Keine weiteren IP Interfaces sonst schaffst du dir einen Backdoor Router!! Die Basebox darf nur als AP mit Bridging arbeiten
  • Virtuelle WLAN Interfaces (MSSID APs) anlegen und VLAN Tags zuweisen und Mode auf Tag only setzen. Bei Dual Radio 2,4 und 5 GHz musst du das pro Band wiederholen.
Eigentlich kein Hexenwerk...
Member: jaja99
jaja99 Jun 29, 2024 at 06:04:51 (UTC)
Goto Top
Danke, so geht es ! Eine Kleinigkeit noch.
Ich mus wlan1 eine SSID vergeben. Ich kann dieser aber keine Vlan ID vergeben. Ich gehe davon aus. das auf wlan1 die Vlan ID1 liegt.
mit AX Radios, kann ich z.b. die Vlan100 auf den wlan1 legen.
Hier muss ich dazu einen client anlegen der wlan1 nutzt.
Irgendwie verstehe ich die Logik dahinter nicht. Vielleicht kannst du mir kurz den Denkfehler nennen.
Danke !
clipboarder.2024.06.29
Member: aqui
Solution aqui Jun 29, 2024 updated at 07:14:58 (UTC)
Goto Top
Ich gehe davon aus. das auf wlan1 die Vlan ID1 liegt.
Das solltest du besser nicht, denn die PVID bestimmt in welchem VLAN das physische WLAN Interface liegt!! Solltest du die PVID auf 1 gesetzt haben stimmt deine Annahme. Ansonsten ist sie falsch!
Die Logik ist eigentlich kein Hexenwerk und ähnlich einem tagged Port zu sehen.
Der WLAN Traffic einer SSID der über das physische Interface läuft wird ungetagged in das PVID VLAN dieses Ports geforwardet.
SSID bzw. MSSID Traffic der über virtuelle WLAN Interfaces auf diesem physischen Master Interface rennt muss entsprechend einen VLAN Tag zugeordnet bekommen, damit die VLAN Bridge diesen Traffic wieder in das richtige Netzwerk Segment forwarden kann.
Eigentlich doch ganz einfach zu verstehen... ­čĄö
Member: jaja99
jaja99 Jul 01, 2024 at 07:25:00 (UTC)
Goto Top
Ja verstehe ich auch so. Was mich nur wundert, ist das ich beim AX dem Wlan1 direkt zb. eine Vlan100 und ein Security eingeben kann und bei der Base Station ich dafür ein virtuelles Interface anlegen muß.
Member: aqui
aqui Jul 01, 2024 at 08:12:15 (UTC)
Goto Top
Kann eigentlich nicht sein, denn bei beiden rennt ja RouterOS und so sind die Konfig Schritte immer gleich.
Member: aqui
aqui Jul 08, 2024 at 07:45:55 (UTC)
Goto Top
Wenn es das denn nun war bitte dann auch nicht vergessen deinen Thread hier als erledigt zu schliessen!
How can I mark a post as solved?
Member: jaja99
jaja99 Jul 11, 2024 at 20:21:34 (UTC)
Goto Top
das am 1.7. genannte phänomen existiert weiterhin. Habe leider keine Zeit das näher zu untersuchen. Da aber das ganze auch so funktioniert mache ich das Thema zu. Danke für eure Hilfe !