jaja99
Goto Top

Verbindung Basebox2 (mipsbe) mit AX Router

Hallo, brauche mal wieder Hilfe !
Versuche gerade meine Basebox2 mit dem AX zu verbinden. Leider ist die Konfiguration ganz anders als bei CapAx, da ich bei dem Mips das wireless Package nehmen muß leider bekomme ich keine Verbindung zum Capsman auf dem AX. Danke für eure Tipps.
Es funktioniert mit der config. Allerdings ohne steuerung über capsman und ich hatte eigentlich die Hoffnung VLANS zu nutzen wie auf dem cAp-AX

Hier mal die aktuelle config:
# 2024-06-15 18:53:00 by RouterOS 7.15.1
# software id = HY8A-AQ0S
#
# model = RB912UAG-2HPnD
# serial number = 7184xxxx9F
/interface bridge
add admin-mac=6C:xx:xx:Xx:2F:4B auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    country=germany disabled=no frequency=auto mode=ap-bridge ssid=test \
    wireless-protocol=802.11
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \
    supplicant-identity=MikroTik wpa-pre-shared-key=iotpass# \
    wpa2-pre-shared-key=test123#
/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge interface=wlan1
/interface list member
add interface=ether1 list=WAN
add interface=wlan1 list=LAN
/interface wireless cap
set bridge=bridge caps-man-addresses=10.0.0.1 interfaces=wlan1
/ip address
add address=10.0.0.66/24 interface=wlan1 network=10.0.0.0
/ip dhcp-client
add comment=defconf disabled=yes interface=bridge
/ip dns
set servers=10.0.0.1,8.8.8.8
/system clock
set time-zone-name=Europe/Berlin
/system identity
set name="MikroTik BaseBox2"  
/system note
set show-at-login=no

Content-Key: 82469136868

Url: https://administrator.de/contentid/82469136868

Printed on: July 16, 2024 at 20:07 o'clock

Mitglied: 13034433319
13034433319 Jun 16, 2024 updated at 11:05:53 (UTC)
Goto Top
Wie im anderen Beitrag schon erwähnt, du musst dafür auf dem Router den alten CAPsMAN zusätzlich aktivieren (/caps-man), dort eine Configuration der Settings für den AP hinterlegen, ein Provisioning-Eintrag für den CAP erstellen und die VLANs in der Bridge auf dem Port zum AP taggen.
Der alte CAPsMan ist nämlich komplett separat zum neuen zu konfigurieren, denn ein alter CAP kann auch nur mit dem alten CAPsMAN kommunizieren!

add bridge=bridge interface=wlan1
Außerdem muss das Wifi-Interface hier nicht zur Bridge hinzugefügt werden da das vom CAPsMAN automatisch erledigt wird sobald der CAP provisioniert wurde!

/ip address add address=10.0.0.66/24 interface=wlan1 network=10.0.0.0
Des weiteren liegt die IP auf dem falschen Interface diese gehört auf beim CAP auf die Bridge gelegt sofern das MGMT Netz untagged ankommt.
/ip address add address=10.0.0.66/24 interface=bridge
Gruß
Member: aqui
aqui Jun 16, 2024 updated at 10:21:38 (UTC)
Goto Top
...diese gehört auf die Bridge gelegt.
Es sei denn der TO arbeitet mit VLANs! In dem Falle gehört sie auf das VLAN IP Interface. ­čśë
Natürlich nur das des AP Management (CapsMan) VLANs, denn die anderen dürfen keinesfalls mit IPs belegt werden da bekanntlich ein AP in der Regel ausschliesslich nur als L2 Bridge arbeitet!
Die üblichen Kardinalsfehler mit 40Mhz Bandbreite im 2,4 GHz Band und der Aktivierung des .11b Standards sind auch wieder gemacht worden! face-sad
Mitglied: 13034433319
13034433319 Jun 16, 2024 updated at 11:01:59 (UTC)
Goto Top
Zitat von @aqui:

...diese gehört auf die Bridge gelegt.
Es sei denn der TO arbeitet mit VLANs! In dem Falle gehört sie auf das VLAN IP Interface. ­čśë

Es ging mir hier nur um den CAP nicht um den Router. Wenn er das MGMT Netz natürlich zum CAP hin tagged, wovon ich erst mal nicht ausgehe muss er natürlich auch ein VLAN IF auf dem CAP in die Bridge legen und dort die IP setzen, logisch.
Member: jaja99
jaja99 Jun 16, 2024 at 12:00:44 (UTC)
Goto Top
Sorry muss nochmal nachhaken. Es ging mir nicht um ein CAp den ich anbinden möchte. Es geht um die BaseBox2 mit neuem Router OS.
Auf dem habe ich das Wifi package zusätzlich installiert nur so wird die Antenne erkannt.
Muss ich also auch auf dem AX2 dieses Package installieren?
DANKE
Mitglied: 13034433319
Solution 13034433319 Jun 16, 2024 updated at 12:55:22 (UTC)
Goto Top
Zitat von @jaja99:

Sorry muss nochmal nachhaken. Es ging mir nicht um ein CAp den ich anbinden möchte. Es geht um die BaseBox2 mit neuem Router OS.
Schon klar mit "CAP" meine ich hier nur die allgemeine Bezeichnung für einen AP der an den CAPsMan angebunden wird!

Auf dem habe ich das Wifi package zusätzlich installiert nur so wird die Antenne erkannt.
Mal wieder die falsche Bezeichnung benutzt! Es geht nur mit dem alten wireless package, das Wlan-Modul wird auf der Basebox2 von dem neueren Wifi nicht erkannt.

Muss ich also auch auf dem AX2 dieses Package installieren?
Um den alten CAPsMAN betreiben und nutzen zu können, ja klar. Wann liest du nun endlich mal die Doku? Wird langsam Zeit...
https://help.mikrotik.com/docs/display/RKB/7.13+new+wireless+packages

1000003644
Member: aqui
Solution aqui Jun 16, 2024 updated at 13:52:29 (UTC)
Goto Top
Es ging mir nicht um ein CAp den ich anbinden möchte.
Na ja, wenn du die Basebox einfach nur als Standalone AP ohne CapsMan anbinden willst brauchst du ja logischerweise auch kein Capsman dafür.

Dafür reicht es dort einfach das WLAN mit gleicher SSID und Passwort wie deine bestehenden WLANs lokal anzulegen und dann je nach Konfig mit dem Kupfer Uplink wie einen normalen Switch an deine Infrastruktur anbinden, fertisch.
Guckst du auch HIER.
Member: jaja99
jaja99 Jun 17, 2024 updated at 20:08:12 (UTC)
Goto Top
Danke für Tipps !
Sorry wenn ich weiter nerve. Versuche mein bestes und auch die Anleitungen zu verstehen. Dennoch hänge ich noch.
Die Verbindung zur Basebox funktioniert, das heist ich kann alles über den Wireless Capsman steuern ( sorry nochmal das ich die Namen vertauscht habe).
Dennoch bekomme ich mein Handy nicht an eine der 3 ssid (3 Vlans) verbunden.
Wo könnte der Fehler liegen ?
Danke für eure Mühen !

hoffe ich hab alle relevante im code
/caps-man interface
add channel.band=2ghz-b/g/n .control-channel-width=20mhz \
    configuration.country=germany .mode=ap .rx-chains=0,1 .ssid=P11 \
    .tx-chains=0,1 datapath.vlan-id=100 .vlan-mode=use-tag disabled=no l2mtu=\
    1600 mac-address=6C:XX:XX:XX:4C master-interface=none name=\
    BaseBox-Priv radio-mac=6C:XX:XX:XX:4C radio-name=6Cxxxxxxxxxxxx \
    security.authentication-types=wpa2-psk .encryption=aes-ccm \
    .group-encryption=aes-ccm .passphrase=12345678

/interface vlan
add interface=bridge1 name=vlan1 vlan-id=1
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
add interface=bridge1 name=vlan100 vlan-id=100
add interface=bridge1 name=vlan111 vlan-id=111

/caps-man interface
add channel.band=2ghz-b/g/n .control-channel-width=20mhz \
    configuration.country=germany .mode=ap .rx-chains=0,1 .ssid=G11 \
    .tx-chains=0,1 datapath.vlan-id=10 .vlan-mode=use-tag disabled=no l2mtu=\
    1600 mac-address=6C:XX:XX:XX:4C master-interface=BaseBox-Priv name=\
    BaseBox-Gast radio-mac=6C:XX:XX:XX:4C radio-name=6Cxxxxxxxxxxxx  \
    security.authentication-types=wpa2-psk .encryption=aes-ccm \
    .group-encryption=aes-ccm .passphrase=12345678
add channel.band=2ghz-b/g/n .control-channel-width=20mhz \
    configuration.country=germany .mode=ap .rx-chains=0,1 .ssid=IoT \
    .tx-chains=0,1 datapath.vlan-id=20 .vlan-mode=use-tag disabled=no l2mtu=\
    1600 mac-address=6C:XX:XX:XX:4C master-interface=BaseBox-Priv name=\
    BaseBox-IoT radio-mac=6C:XX:XX:XX:4C radio-name=6Cxxxxxxxxxxxx  \
    security.authentication-types=wpa2-psk .encryption=aes-ccm \
    .group-encryption=aes-ccm .passphrase=12345678
	
/interface bridge port
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=ether2
add bridge=bridge1 ingress-filtering=no interface=ether3
add bridge=bridge1 ingress-filtering=no interface=e4-to-cap
add bridge=bridge1 ingress-filtering=no interface=e5-to-switch
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi1-5g pvid=100
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi2-2g pvid=100
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi3-guest-2g pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi4-IoT pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi5-guest-5g pvid=10

/ip neighbor discovery-settings
set discover-interface-list=LAN

/interface bridge vlan
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=1
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=10
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=100
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=20
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch vlan-ids=111

/interface list member
add interface=bridge1 list=LAN
add interface=vlan1 list=LAN
add interface=vlan10 list=LAN
add interface=vlan20 list=LAN
add interface=pppoe-out1 list=WAN
add interface=e1-to-modem list=WAN
add interface=vlan100 list=LAN

/interface wifi cap
set discovery-interfaces=all enabled=yes

/interface wifi capsman
set ca-certificate=auto certificate=auto enabled=yes interfaces=vlan1 \
    package-path="" require-peer-certificate=no upgrade-policy=none  
Mitglied: 13034433319
Solution 13034433319 Jun 17, 2024 updated at 19:51:43 (UTC)
Goto Top
Du musst den Port in der Bridge zur Basebox2 mit allen VLANs taggen die du dort nutzen willst. Den Port kennst nur du.

Des weiteren solltest du ein local breakout auf dem CAP konfigurieren und zwar mit der Option
/caps-man interface add .............  datapath.local-forwarding=yes
Und zwar für alle deine configurations.
Sonst wird der Traffic auf den CAPsMAN getunnelt und das kostet viel Leistung, das macht man heutzutage deswegen nicht mehr.
Member: jaja99
jaja99 Jun 17, 2024 updated at 20:38:00 (UTC)
Goto Top
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi1-5g pvid=100
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi2-2g pvid=100
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi3-guest-2g pvid=10
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi4-IoT pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged \
    ingress-filtering=no interface=wifi5-guest-5g pvid=10

Die Einträge wifi1- wifi5 sind für den AX2 bzw. Cap-AX. Das hat auch so funktioniert.
die Änderung
/caps-man interface
add channel.band=2ghz-b/g/n .control-channel-width=20mhz \
    configuration.country=germany  .ssid=P11 \
    datapath.local-forwarding=yes .vlan-id=100 .vlan-mode=\
    use-tag disabled=no l2mtu=1600 mac-address=6C:XX:XX:XX:4C  \
    master-interface=none name=BaseBox-Priv radio-mac=6C:XX:XX:XX:4C  \
    radio-name=6Cxxxxxxx security.authentication-types=wpa2-psk \
    .encryption=aes-ccm .group-encryption=aes-ccm .passphrase=xxxxxxxxx
add channel.band=2ghz-b/g/n .control-channel-width=20mhz \
    configuration.country=germany .mode=ap .ssid=G11 \
    datapath.local-forwarding=yes .vlan-id=10 .vlan-mode=\
    use-tag disabled=no l2mtu=1600 mac-address=6C:XX:XX:XX:4C  \
    master-interface=BaseBox-Priv name=BaseBox-Gast radio-mac=\
    6C:XX:XX:XX:4C radio-name=6Cxxxxxxxxx security.authentication-types=\
    wpa2-psk .encryption=aes-ccm .group-encryption=aes-ccm .passphrase=\
    xxxxxxxxxx
add channel.band=2ghz-b/g/n .control-channel-width=20mhz \
    configuration.country=germany .mode=ap .ssid=IoT \
    datapath.local-forwarding=yes .vlan-id=20 .vlan-mode=\
    use-tag disabled=no l2mtu=1600 mac-address=6C:XX:XX:XX:4C  \
    master-interface=BaseBox-Priv name=BaseBox-IoT radio-mac=\
    6C:XX:XX:XX:4C  radio-name=6Cxxxxxxxxxx  security.authentication-types=\
    wpa2-psk .encryption=aes-ccm .group-encryption=aes-ccm .passphrase=\
    xxxxxxxx

habe ich gemacht. Brachte aber leider nicht der erhofften Erfolg.

Mir ist gerade aufgefallen, das am Caps noch die default ssid angezeigt wird.
screenshot 2024-06-17 223411

dementsprechend steht in der config noch:
# 2024-06-17 22:32:14 by RouterOS 7.15.1
# software id = HY8A-AQ0S
#
# model = RB912UAG-2HPnD
# serial number = xxxxxxxxxxx
/interface bridge
add admin-mac=6C:xxxxxxxxxxxxx auto-mac=no comment=defconf name=bridge
/interface wireless
# managed by CAPsMAN
# channel: 2412/20-Ce/gn(20dBm), SSID: P11, local forwarding
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    disabled=no frequency=auto installation=outdoor mode=ap-bridge ssid=\
    MikroTik-0A2F4C
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge comment=defconf interface=ether1
add bridge=bridge comment=defconf interface=wlan1
/interface wireless cap
# 
set certificate=request discovery-interfaces=ether1 enabled=yes interfaces=\
    wlan1 lock-to-caps-man=yes
/ip dhcp-client
add comment=defconf interface=bridge
/system clock
set time-zone-name=Europe/Berlin
/system note
set show-at-login=no

könnte das der Fehler sein ?

Danke!
Member: aqui
Solution aqui Jun 17, 2024 at 20:58:56 (UTC)
Goto Top
Sollte man natürlich löschen wenn man die nicht benutzt!
Außerdem hast du wieder den .11b Standard drin der die 2,4 GHz Performance in den Orkus reisst! face-sad
Mitglied: 13034433319
Solution 13034433319 Jun 17, 2024, updated at Jun 18, 2024 at 05:14:30 (UTC)
Goto Top
Brachte aber leider nicht der erhofften Erfolg.
Wie gesagt dir fehlt der Port zur Basebox2 in der Bridge mit getaggten VLANs und der Bridge auf dem CAPsman . Der fehlt in deiner Config oben.

Da du nicht sagst welcher das ist hier ein Beispiel für Port ether2 an dem es zur Basebox geht

/interface bridge port add bridge=bridge1 frame-types=admit-all interface=ether2 pvid=1
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch,ether2 vlan-ids=10
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch,ether2 vlan-ids=20
add bridge=bridge1 tagged=bridge1,e4-to-cap,e5-to-switch,ether2 vlan-ids=100

Außerdem ist in der Basebox2 Config wieder der selbe Fehler drin den ich oben schon angemahnt hatte
/interface bridge port add bridge=bridge comment=defconf interface=wlan1
Das Wifi Interface muss raus aus der Bridge ... das wird dynamisch hinzugefügt .

Des weiteren fehlt genau dafür hier das Bridge Interface in der CAP Config auf der Basebox, damit der CAP auch weiß zu welcher Bridge er die dynamisch erstellten Interfaces hinzufügen soll
/interface wireless cap set bridge=bridge 

So langsam solltest du das Prinzip des VLAN-taggings eigentlich kapiert haben ­čĄö.

Taggen tut man immer dort wo mehrere Netze auf dem gleichen Interface laufen, verständlich denn sonst gäbe es Chaos und eine gemixte Layer-2 Broadcast Domain zwischen den Netzen.
Wenn du also einen AP an einem Port hast muss darüber ja einerseits der MGMT Traffic zum AP laufen und (i.d.R. untagged in vlan1) und zusätzlich der Traffic der WLANs, die jeweils in separaten VLANs laufen die man dann auf dem Port tagged.
Member: jaja99
jaja99 Jun 17, 2024 at 22:21:25 (UTC)
Goto Top
Danke !
dis BaseBox hängt am Switch. Der hängt am "e5-to-switch" Denke ich mach morgen weiter ... Ausgeschlafen klappt bestimmt besser.
Member: jaja99
jaja99 Jun 18, 2024 at 06:04:34 (UTC)
Goto Top
Danke jetzt läuft es. Nach ein paar stunden Schlaf habe ich auch den letzten Fehler gefunden ... 2 Interfaces hatten die gleiche MAC-Adresse. Die SSD´s hatten dadurch einen zufallsgenerator eingebaut ;)
Nochmals Danke @13034433319 und @aqui