spartacus
Goto Top

Mikrotik Upgrade von OS7.12 auf OS7.13

Guten Morgen und Frohe Weihnachten,

eine Frage: Hat jemand schon von OS7.12 auf OS. 7.13 gewechselt? Ich nutze Capsman und bin mir unsicher ob das Upgrade auch automatisch das wireless package installiert.

Zur Zeit ist nur das routeros Basispaket installiert. Bin etwas unsicher, ob ich das ohne Probleme am Produktivsystem machen kann und dann am Ende nichts mehr geht!

Danke,
Spartacus

Content-Key: 83916071696

Url: https://administrator.de/contentid/83916071696

Printed on: May 28, 2024 at 06:05 o'clock

Mitglied: 10138557388
10138557388 Dec 25, 2023 updated at 10:01:28 (UTC)
Goto Top
Notice - Starting from RouterOS version 7.13, significant changes have been made to the RouterOS wireless packages. This is done due to a new product development which will require more disk space for hardware drivers so we had to split it in order to maintain old products alongside the new ones. More wireless packages are yet to come.

1. When upgrading by using "check-for-updates", all versions earlier than 7.12 will display 7.12 as the latest available version. Upgrade from v7.12 to v7.13 or later versions must be done through 7.12 in order to convert wireless packages automatically. Fresh installation with Netinstall or manual package installation works in the same manner as always.

2. Drivers for older wireless and 60GHz interfaces, as well as the wireless management system CAPsMAN, are now part of a separate "wireless" package instead of being a part of the bundle package. This package can be uninstalled if not needed.

3. The existing "wifiwave2" package has been divided into distinct packages: "wifi-qcom" and "wifi-qcom-ac", and the necessary utilities for WiFi management are now included in the RouterOS bundle. RouterOS and "wifi-qcom-ac" packages alongside each other now fit into 16MB flash memory.

Heißt also wenn du das neue "Wifi"-Package nutzt brauchst nichts tun weil das schon in das OS integriert ist , wenn du das alte "Wireless" Package nutzt (old CAPsMan) und das schon jetzt auch schon auf 7.12 läuft ebenfalls nicht, es wird nichts entfernt.
Nur wenn man das alte "Wireless" braucht und das noch nicht installiert ist dann muss man es nachinstallieren.

https://help.mikrotik.com/docs/display/RKB/7.13+new+wireless+packages

https://help.mikrotik.com/docs/display/ROS/Packages

Lesen und verstehen, dann ist das kein Hexenwerk.

PJ.
Member: Spirit-of-Eli
Spirit-of-Eli Dec 25, 2023 at 10:21:44 (UTC)
Goto Top
Moin,

wie in den Release Notes steht, solltest du je nach HW die entsprechenden Treiber installieren soweit du das neu wifiwave2 nutzt. Bei AC Geräte gibt es unter ExtraPackages die entsprechende Datei.

Gruß
Spirit
Member: Spartacus
Spartacus Dec 25, 2023 updated at 10:58:32 (UTC)
Goto Top
Moin zusammen,

sorry, das habe ich noch nicht verstanden! Es läuft aktuell Router OS 7.12, das habe ich vor einigen Wochen ganz frisch auf die neue HW RB5009 gepackt und eingerichtet. Capsman war im RouterOS schon enthalten und meine cAPs AP laufen damit sauber. Ich habe keine zus. Pakte in 7.12 installieren müssen

Muss ich jetzt nach dem Upgrade noch das Wireless Paket nachinstallieren, oder bleibt alles wie es ist?

Aktuell sieht das bei mir so aus:

routeros

und die Frage ist auch, was ich mit den cAPs AP mache? Die sind schon älter und auch da müsse ich dann ja auf 7.13 wechseln.
Member: Spirit-of-Eli
Spirit-of-Eli Dec 25, 2023 at 10:55:05 (UTC)
Goto Top
Nein, das bleibt so. Du verwendest gerade wohl das alte wifiwave1.
Mitglied: 10138557388
10138557388 Dec 25, 2023 updated at 11:04:05 (UTC)
Goto Top
Muss ich jetzt nach dem Upgrade noch das Wireless Paket nachinstallieren,
Nein, beim Upgrade auf 7.13 wird das alte CAPsMan dann nur umgewandelt in ein separates Package damit man es später unter Packages deinstallieren kann wenn man es nicht mehr braucht. Es wird also beim Upgrade sozusagen separiert.
Alte Devices (altes CAPsMan) = "Wireless"
Neue Devices (neues CAPsMan) = "Wifi"

"Wifi" ist ins OS integriert, "Wireless" ist das alte Package.
oder bleibt alles wie es ist?
Ja.
Member: Spartacus
Spartacus Dec 25, 2023 at 11:01:09 (UTC)
Goto Top
ok danke, dann einfach den Upgrade Button drücken und alles sollte dann funzen. Auch auf den cAP APs
Das sind diese teile hier:
cAP AP
Member: Spirit-of-Eli
Spirit-of-Eli Dec 25, 2023 at 11:03:40 (UTC)
Goto Top
RouterBoard Upgrade nicht vergessen!
Member: Spartacus
Spartacus Dec 25, 2023 updated at 16:37:12 (UTC)
Goto Top
Moin

danke für´s Feedback. Ich habe jetzt testweise den alten RB3011 mit OS 6.48 mal aus dem Schrank gekramt, weil mir das zu heikel war. Ich bin wie folgt vorgegangen:

  • Router auf Werkseinstellungen zurückgesetzt
  • Upgrade auf 7.12 gemacht
  • die gesamt Konfiguration vom RB5009 in diverse Skripte aufgeteilt und auf RB3011 angepasst (z.B. sfp1)
  • solange gespielt, bis alles fehlerfrei lief
  • Werkseinstellungen
  • Upgrade auf 7.13
  • die Konfiguration per Skript eingespielt

Es sieht so aus, als ist alles sauber konfiguriert worden. CapsMan findet man nun in der Winbox-Oberfläche unter "Wireless" und es gibt zus. noch den Punkt WiFi. gibt jetzt auch das Paket "wireless" auf dem Router.

Morgen werde ich dann man ein cAP an den RB3011 hängen und gucken was passiert, bevor ich die 5 anderen cAPs auf 7.13 bringe und das Produktivsystem auf dem RB5009 upgrade.

So ganz raffe ich noch nicht, was da jetzt umgestellt wird und ob ich hier ggf. auf ein anderes Paket umsteigen sollte um für die künftigen Updates gerüstet zu sein. Ist das mit dem wireless- Paket jetzt die beste Lösung für das RB5009 und meine cAP APs? Oder sollte man die auf Wifi umstellen?
Mitglied: 10138557388
10138557388 Dec 25, 2023 updated at 17:08:05 (UTC)
Goto Top
Zitat von @Spartacus:

Moin

danke für´s Feedback. Ich habe jetzt testweise den alten RB3011 mit OS 6.48 mal aus dem Schrank gekramt, weil mir das zu heikel war. Ich bin wie folgt vorgegangen:

Wozu gibt's Binary und Plaintext Backups? Im Fall der Fälle ist der vorherige Stand dann ja schnell wiederhergestellt. Aber nun gut wers umständlich mag ­čĄ¬.

So ganz raffe ich noch nicht, was da jetzt umgestellt wird
Habe ich oben doch geschrieben, das alte Wireless-Package wird aus RouterOS separiert so das es sich zukünftig deinstallieren lässt wenn gewünscht, das reduziert die Größe für Devices bei denen der Flash-Speicher knapp ist z.B. bei den diversen 16MB Geräten.

und ob ich hier ggf. auf ein anderes Paket umsteigen sollte um für die künftigen Updates gerüstet zu sein. Ist das mit dem wireless- Paket jetzt die beste Lösung für das RB5009 und meine cAP APs? Oder sollte man die auf Wifi umstellen?
Die Links überhaupt gelesen?! Das Wifi-Menü ist nur für neuere Gerätschaften die es auch supporten, bei den cAP AC mit ARM ist das der Fall.
https://help.mikrotik.com/docs/display/RKB/7.13+new+wireless+packages
Und ja, wenn du ausschließlich Geräte hast die über den neuen Treiber supported werden bringt das diverse Vorteile wie z.B. 802.1r/k/v und echtes seamless Roaming über die APs, oder auch WPA3.

Hast du einen Mix von alten und neuen Geräten kannst du aber auch beide CAPsMan Varianten betreiben über "Wireless" die alten und über "Wifi" die neuen.

Ach ja , vor Upgrades immer mal kurz ins Mikrotik Forum schauen ...
https://forum.mikrotik.com/viewtopic.php?t=202423
Member: Spartacus
Spartacus Dec 25, 2023 at 17:09:23 (UTC)
Goto Top
Hi,

ja, habe ich schon gelesen, aber nicht richtig verstanden. Ich habe nur die cAP ACs im Einsatz aber was ist mit "alt" gemeint? Die laufen hier schon seit 2018. Aber wenn ich es richtig verstanden habe, gibt es keine Unterschiede in der Hardware, oder?

               build-time: Nov/09/2023 07:45:06
         factory-software: 6.40.3
              free-memory: 183.6MiB
             total-memory: 256.0MiB
                      cpu: ARM
                cpu-count: 4
            cpu-frequency: 896MHz
                 cpu-load: 1%
           free-hdd-space: 1264.0KiB
          total-hdd-space: 15.2MiB
  write-sect-since-reboot: 45858
         write-sect-total: 756270
        architecture-name: arm
               board-name: cAP ac
                 platform: MikroTik

Hast Du da Erfahrungen mit dem neuen Capsman? Kann man die Konfiguration halbwegs vom alten CapsMan übernehmen oder ist das total anders! Das ist bei mir schon lange in Betrieb und da habe ich viel fummeln müssen bis das Ganze mit mit meinem externen Freeradius lief. Den will ich auf jeden Fall behalten und nicht über den Build-in ablösen.
Mitglied: 10138557388
10138557388 Dec 25, 2023 updated at 17:45:06 (UTC)
Goto Top
Zitat von @Spartacus:

Ich habe nur die cAP ACs im Einsatz aber was ist mit "alt" gemeint?
Da hatte ich mich verlesen was deine HW angeht kannst du ignorieren.
Hast Du da Erfahrungen mit dem neuen Capsman?
Ja.
Kann man die Konfiguration halbwegs vom alten CapsMan übernehmen oder ist das total anders!
Nein, musst du neu machen, ist aber wesentlich einfacher aufgebaut und das ganze läuft wesentlich stabiler und schneller als über den alten CAPsMan, vor allem das FastRoaming willst du nicht mehr missen wenn du einmal umgestiegen bist! Auch ist bei mir die Geschwindigkeit der APs mit den neuen Treibern um einiges gestiegen.
Config Beispiele mit dem neuen CAPsMan findest du auch hier im Forum oder wie immer in der Doku
https://help.mikrotik.com/docs/pages/viewpage.action?pageId=46759946
Oder auch
https://blog.meb-it.de/en/configuration-mikrotik-routeros-7-wifiwave2-an ...
Das ist bei mir schon lange in Betrieb und da habe ich viel fummeln müssen bis das Ganze mit mit meinem externen Freeradius lief. Den will ich auf jeden Fall behalten und nicht über den Build-in ablösen.
Das ist doch kein Hexenwerk, Radius anbinden unter "Radius", bleibt ja alles beim alten, viel mehr ist das ja nicht, der Rest findet ja auf dem Radius selbst statt.
Member: Spartacus
Spartacus Dec 25, 2023 at 17:45:10 (UTC)
Goto Top
ok, danke für die Info. Ich werde morgen erst mal das Produktivsystem auf 7.13 bringen. Und wenn ich Dich oben richtig verstanden habe, kann man "Wireless" und "Wifi" und damit den alten und den neuen CAPSMAN parallel betreiben. Dann könnte ich die 5 cAPs ja nach und nach umstellen....heute darf ich am Produktivsystem nix mehr machen sonst gibt es Ärger mit der Familie face-smile

Bis bald,
Spartacus
Member: Spirit-of-Eli
Spirit-of-Eli Dec 25, 2023 at 18:05:54 (UTC)
Goto Top
Welche CAPs hast du denn? Können die denn wifiwave2?
Member: Spartacus
Spartacus Dec 25, 2023 at 19:15:57 (UTC)
Goto Top
Hm! jetzt bin ich wieder verwirrt! Offenbar ist wifiwave2 schon wieder etwas anders als das hier!.

Also so ganz raffe ich es immer noch nicht! Ich habe die cAP ACs und pjumper schreibt weiter oben, dass die supportet werden, aber hiersteht wieder nichts davon!
Mitglied: 10138557388
10138557388 Dec 25, 2023 updated at 20:07:58 (UTC)
Goto Top
Zitat von @Spartacus:

Hm! jetzt bin ich wieder verwirrt! Offenbar ist wifiwave2 schon wieder etwas anders als das hier!.

Nein, nur der Name im Menü hat sich inzwischen auf "wifi" geändert. Vor 7.12 war es wifiwave2 jetzt ist heißt es "wifi".
Auf der Konsole werden aber aus Kompatibilitätsgründen noch beide Namensräume supportet.
Also so ganz raffe ich es immer noch nicht! Ich habe die cAP ACs und pjumper schreibt weiter oben, dass die supportet werden, aber hiersteht wieder nichts davon!
Sie werden mittlerweile supported! Die Seite ist nur noch nicht ganz up to date, es gilt mit 7.13 das hier
https://help.mikrotik.com/docs/display/RKB/7.13+new+wireless+packages

1000002773
Member: Spartacus
Spartacus Dec 26, 2023 at 09:47:51 (UTC)
Goto Top
Moin, Moin,

so, ich habe den RB5009 nun auf 7.13, die cAPs laufen noch auf 7.12.Soweit ist alles ok und ich würde dann jetzt mal versuchen, die alte Konfiguration in den Wifi-Bereich zu doppeln. sieht ja alles doch etwas anders aus, als vorher! Die Channel-Liste, Datapath, Configuration, Security und Provisioning kann man bestimmt übernehmen! Aber das hier habe ich in der alten Form noch nicht wirklich wiedergefunden:
aaa

Aktivieren tut man den CapsManager offenbar unter "Remote Cap"
ap

Ich frage mich nur, wie ich die capACs dem neuen Manager bekannt mache. Passiert das, wenn ich die auf 7.13 umgestellt habe? Der Plan ist ja, das ich die nach und nach umstelle, ich hoffe das geht auch so!
Mitglied: 10138557388
10138557388 Dec 26, 2023 updated at 10:06:00 (UTC)
Goto Top
Zitat von @Spartacus:

Aber das hier habe ich in der alten Form noch nicht wirklich wiedergefunden:
aaa

AAA Properties ...
https://help.mikrotik.com/docs/display/ROS/WiFi#WiFi-AAAproperties

Aktivieren tut man den CapsManager offenbar unter "Remote Cap"
ap

Ich frage mich nur, wie ich die capACs dem neuen Manager bekannt mache.
As usual ...über das neue "Wifi" Menü auf dem CAP, oder am besten gleich die Konsole nutzen.
/interface/wifi/cap set enabled=yes
/interface/wifi/set wifi1,wifi2 configuration.manager=capsman-or-local
CAPsMAN - CAP simple configuration example

Von selbst etwas probieren hast du wohl noch nie was gehört, da entgeht einem doch das Schönste an der Geschichte wenn man alles nur vorgebetet bekommt und stumpf nachtippt ­čĄ¬
Member: Spartacus
Spartacus Dec 26, 2023 at 10:09:55 (UTC)
Goto Top
pjumper, Du bist lustig! Probieren ist hier grad nicht viel! Ich habe nur ein System und da hängen gerade ca. 20 Leute dran. Wenn ich da anfange rumzuspielen und das WLAN für Stunden weg ist, ist das nicht so wirklich lustig! Da muss schon jeder Handgriff sitzen. Sorry, aber von daher frage ich lieber ein paar mehr Dinge, bevor ich mir den Ast absäge!
Mitglied: 10138557388
10138557388 Dec 26, 2023 updated at 11:28:20 (UTC)
Goto Top
Dann nimmt man sich halt einen der CAPs den man nicht zwingend braucht, schnappt sich die CHR VM von der Mikrotik Seite installiert die in einer VM und übt mit dem CAPsman in einer virtuellen Umgebung und überträgt das ganze dann Schritt für Schritt face-smile.
Du bist lustig!
Dito. Operierst du dich auch selbst wenn du es noch nie gemacht hast, dir aber jemand aus einem Forum eine Anleitung schreibt ?! face-big-smile
Member: Spartacus
Spartacus Dec 26, 2023 at 11:29:25 (UTC)
Goto Top
So, ich noch einmal.

Bevor ich nun den ersten cAP upgrade, hier einmal was ich konfiguriert habe. Vielleicht kannst Du noch mal drüber schauen, ob das so funktionieren kann:

CAPSMAN aktiviert:
/interface wifi capsman
set ca-certificate=auto certificate=auto enabled=yes package-path="" require-peer-certificate=no upgrade-policy=none  
und die Zeile verstehe ich nicht, ich nehme an, das ist für Router mit Wifi-Funktion, das hat der RB5009 nicht.
/interface/wifi/set wifi1,wifi2 configuration.manager=capsman-or-local
Security:
/interface wifi security
add authentication-types=wpa3-psk disable-pmkid=yes disabled=no encryption="" name=WLAN  

EAP Methode sollte defaultmäßig auf "passthrough" eingestellt sein, allerdings nutze ich aktuell dieGroup Encryprion auf aes ccm. Da bin ich mir unsicher, was ich da nun einstellen soll!

AAA:
das habe ich nur geraden, von daher muss ich das wohl wirklich probieren.
/interface wifi aaa
add disabled=no name=WLAN password-format=AA:AA:AA:AA:AA username-format=\
    AA:AA:AA:AA:AA
Im Vergleich zu vorher sah das so aus. Aber das kriege ich nicht auf das neue Format gemappt:
/caps-man aaa
set called-format=mac mac-mode=as-username-and-password

Datapath:
auch hier hat sich vieles verändert. Das Local Forwarding wird wohl automatisch gemacht.
/interface wifi datapath
add bridge=bridge client-isolation=no disabled=no name=WLAN
alte Konfiguration:
/caps-man datapath
add bridge=bridge client-to-client-forwarding=yes comment="mit MAC-Auth" local-forwarding=yes name=WLAN  
client-to-client forwarding habe ich auch nicht gefunden.

Configuration:
/interface wifi configuration
add aaa=WLAN country=Germany datapath=WLAN disabled=no mode=ap \
    multicast-enhance=enabled name=WLAN security=WLAN ssid=Test
Hier fehlt mir der multicast helper! Ist das über multicast-enhance abgefrühstückt?

Provisioning:
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no master-configuration=WLAN \
    supported-bands=2ghz-ax
was heissst hier "create-dynamic-enable" Heißt das er ordnet die cAPs, die er findet automatisch zu? Im alten Format musst ich hier die MAC Adresse des cAP-Kanals angeben.
Member: Spirit-of-Eli
Spirit-of-Eli Dec 26, 2023 updated at 11:48:30 (UTC)
Goto Top
Willst du mehrere SSIDs in unterschiedlichen Netzen nutzen? Dann kommt bei den AC Geräten noch was anderes zum tragen.
Member: Spartacus
Spartacus Dec 26, 2023 updated at 12:02:39 (UTC)
Goto Top
Hi,
nee, ich habe nur eine SSID und über MAC Auth. werden die dann vom Radius in das richtige VLAN geschubst. Das fehlte hier auf alle Fälle noch:
/interface wifi access-list
add action=query-radius allow-signal-out-of-range=10s disabled=no

Von daher ist die neue Konfiguration schon ziemlich anders als zuvor! Ivh weiß, ich komme nicht drumherum einen AP zu opfern und den umzustellen. Aber vorher sollte das so einigermaßen wasserdicht sein. deshalb die bitte, da noch mal drüber zu schauern. Besonders was die Authentifizierung angeht-

Auch noch mal die Frage:
Braucht der cAP jetzt auch eine Konfiguration, oder findet der neue CAPSMAN die nach dem Upgrade auf 7.13 automatisch?

Die Frage ist auch, ob der meinen radius findet? Hier gibt es als Service nur den alten Wireless-service
radius
Member: Spirit-of-Eli
Spirit-of-Eli Dec 26, 2023 at 12:09:19 (UTC)
Goto Top
Mac-Auth bei Wifiwave2 fände ich mal interessant. Sobald dafür allerdings eine "datapath" config mit Vlan ID nötig ist. So wird das nichts auf AC Geräten. Die supporten das schlicht nicht und jedes erstellte wifi Interface muss händisch der Bridge zugeordnet werden. Ich habe zu dem Thema einen Case bei Mikrotik offen.
Member: Spartacus
Spartacus Dec 26, 2023 at 12:17:24 (UTC)
Goto Top
Hm! Das heißt, ich kann das erst einmal vergessen mit dem Wifiwave2 und muss beim alten Capsman bleiben. Damit funktioniert MAC Auth nämlich einwandfrei!
Member: Spirit-of-Eli
Spirit-of-Eli Dec 26, 2023 at 12:25:35 (UTC)
Goto Top
Zitat von @Spartacus:

Hm! Das heißt, ich kann das erst einmal vergessen mit dem Wifiwave2 und muss beim alten Capsman bleiben. Damit funktioniert MAC Auth nämlich einwandfrei!

Ne, weiß ich nicht. Ich habe damit noch keine Erfahrung gemacht. Nur Datapath Vlan kann der AC Treiber nicht.
Member: Spartacus
Spartacus Dec 26, 2023 at 12:36:38 (UTC)
Goto Top
..das ist die alte Konfiguration und damit läuft es mit dem alten CAPSMAN
/caps-man datapath
add bridge=bridge client-to-client-forwarding=yes comment="mit MAC-Auth" local-forwarding=yes name=WLAN  

nur die Optionen client-to-client forwarding und local-forwarding gibt es beim Neuen nicht! Und von daher wird das wohl nichts.

Wenn ich einen der 5 cAP ACs nun umstelle, kriege ich den wieder auf 7.12 zurück? Ich weiß immer noch nicht, wie ein 7.13 cAP AC dann mit dem "alten" Capsman läuft, falls MAC-AUTH nicht funktionieren wird.
Member: mossox
mossox Mar 09, 2024 at 10:10:20 (UTC)
Goto Top
Mal eine Frage in die Runde hier:

Wer hat das neue Package bzw. die neuen Treiber installiert und wie sind die Erfahrungen?
WPA3 und "faster roaming" werden ja beworben.
Aber hat sich denn sonst was an der Performance (Reichweite, Durchsatz) etc. verbessert?