BGP Setup mit EOIP

Mitglied: Netgear24

Netgear24 (Level 1) - Jetzt verbinden

27.10.2016 um 13:20 Uhr, 1505 Aufrufe, 7 Kommentare

Hallo Zusammen

Ich habe mal eine kurze Frage an euch. Ich bin aktuell am Ausbau von meiner eigenen Infrastruktur.

Aktuell bin ich in einem Datacenter eingemietet, da mir das aber auf die dauer immer unflexibler wird, habe ich mich mit einem Kollegen dazu entschieden unseren eigenen Serverstandort hochzuziehen. Soweit klappt auch alles. RIPE Member ist beantragt und das /22 wurde beantragt. Fiber wird am 7.11.2016 gespleist. Da aber aktuell mein Provider über die Swisscom Wholesale Plattform geht, ist noch kein BGP direkt Verfügbar. Dies wird sich im Verlauf von 2017 aber ändern. Bis dahin würde ich aber beim Provider einen Mikrotik Router einstellen.

Transit Setup.

BGP Full Feed
Peering IP
100Mbps CDR mit 95% Regel burstable auf 1Gbps

Serverraum Setup

FTTO Anschluss
Aktuell 300/300 (3Q/2017, 1000/1000)
Feste IPv4 und IPv6 Adresse

Dazu habe ich mir folgendes Überlegt.

backbone scheme_grob - Klicke auf das Bild, um es zu vergrößern

Der Erste Router müsste nach meinem Gedanken das ganze BGP handeln. Auf den Router Verbindet sich der zweite Router mit einem EOIP Tunnel. Somit habe ich einen Transparenten Layer 2 Tunnel zum Provider.

Auf dem ersten Router Bridge ich den Tunnel mit dem Uplink Interface. Sommit habe ich den Transit auf dem Tunnel.

Auf dem Zweiten Router bridge ich den Tunnel mit einem Interface in die Installation. Sommit wird praktisch der zweite router unsichtbar für die Bevölkerung hinter dran.

Sehe ich das so richtig ? oder habe ich noch etwas entscheidendes Übersehen?

Als Router dachte ich an die Mikrotik CCR1009-8G-1S-1S+

Liebe Grüsse
Mitglied: Vision2015
27.10.2016 um 14:31 Uhr
tach...
aus dem Bauch sage ich dir, der Mikrotik CCR1009-8G-1S-1S+ wird wohl nicht reichen..
CPU Leistung und Speicher sind zu gering...
mit welcher last wirst du fahren ?

Frank
Bitte warten ..
Mitglied: Netgear24
27.10.2016 um 14:44 Uhr
tach wohl

Danke für deine antwort.
Konstant werde ich eine datenrate von ca 5 Mbps haben, dazu kommen noch Peaks durch den tag, sowie auch backups in der nacht die normalerweise gegen 90 Mbps gehen werden.

Würdest du eher richtung CCR1036-12G-4S gehen?

Gruss Rony
Bitte warten ..
Mitglied: Vision2015
27.10.2016 um 14:58 Uhr
hi..

hm.. ehrlich, ich traue MikroTik noch nicht bei deinen Anforderungen.
ich würde eher zu einem Cisco oder Juniper gehen.
Alleine wegen dem Support schon...


Frank
Bitte warten ..
Mitglied: Netgear24
27.10.2016 um 15:02 Uhr
hmm.

BGP und Cisco sind für mich kein Problem. Allerdings habe ich noch nie einen EOIP Tunnel eingerichtet, geht das überhaupt mit cisco? Ansonste wäre MPLS die alternative oder ?

Rony
Bitte warten ..
Mitglied: aqui
27.10.2016, aktualisiert um 15:11 Uhr
Full Feed Peering mit einem Mikrotik ?? Welche MT Hardware kann v4 plus v6 Full Table denn abbilden ??
Wohl eher ein frommer Wunschtraum...
Da ist wohl eher ein kleiner PC mit Quagga oder Bird das Mittel der Wahl. Entsprechend Speicher vorausgesetzt.
geht das überhaupt mit cisco?
GRE ist dein Freund hier !! Geht problemlos !
http://www.cisco.com/c/en/us/td/docs/ios/12_4/interface/configuration/g ...
Bitte warten ..
Mitglied: Netgear24
27.10.2016 um 15:49 Uhr
Okay, Danke für deinen Input. Quagga kenne ich bereits, ist ja sehr nahe an cisco. ausser dem bescheuerten bug. habe da soweit ich weiss noch eine kiste rumfliegen. Mal schauen was die nocht taugt.

Mit GRE habe ich bislang nur ganz wenig Erfahrung. Lese mich da aber mal ein.
Bitte warten ..
Mitglied: aqui
27.10.2016, aktualisiert um 15:54 Uhr
Du kanst als Alternative Bird nehmen. Ist etwas anspruchsvoller in der Konfig aber etwas weiter verbreitet im Profi Bereich, da stabiler:
http://bird.network.cz
Auf nem RasPi kann man wunderbar damit üben ;-) face-wink
https://www.administrator.de/wissen/netzwerk-management-server-raspberry ...
Ansonsten kann man das so lösen wie du es beschrieben hast. Ist etwas rumpelig aber für die Übergangszeit reicht das.
Bitte warten ..
Heiß diskutierte Inhalte
Firewall
PfSense direkt an Glasfasermodem der Telekom über PPPoE
snah0815Vor 1 TagFrageFirewall24 Kommentare

Hallo Zusammen, nachdem ich die pfSense nun eine Zeit lang in einer Kaskade mit einer Fritzbox 7590 betrieben habe, möchte ich nun gerne die ...

Netzwerkmanagement
TIA568A oder B - Leistungsunterschiede oder egal?
gelöst alboshiroVor 1 TagFrageNetzwerkmanagement15 Kommentare

Hallo Zusammen, ich bin aktuell im Hausbau und habe in jedem Zimmer ein RJ45 CAT7 Ethernetkabel für jeden Raum verlegt. Jetzt müsste ich die ...

Internet
Kein Internet nach Windows 2019 Server Installation
gelöst ZygmundVor 21 StundenFrageInternet24 Kommentare

Computer : HP ProLiant DL580 Gen7 , 4x CPU , 16 GB ECC Ram, 1 TB SAS Installation von - Windows 8 Server - ...

LAN, WAN, Wireless
WLAN-ACCESSPOINT welche soll ich mir kaufen?
samet22Vor 1 TagFrageLAN, WAN, Wireless11 Kommentare

Hallo :) Ich halte mich kurz: Ich möchte mir neue WLAN-Accesspoints für die Firma kaufen da die jetzigen fast 7 Jahre alt sind und ...

Webentwicklung
Wo legt Joomla den Content im Verzeichnis ab ?
MachelloVor 1 TagFrageWebentwicklung17 Kommentare

Hallo Zusammen, ich habe folgendes Problem: Ich benötige Daten aus einer alten Joomla Webseite. Von dieser Webseite habe ich nur das komplette Verzeichnis vom ...

Monitoring
PC Monitoring Software?
TRON06Vor 1 TagFrageMonitoring9 Kommentare

Gibt es eine Monitoring Software (ähnlich wie HWiNFO) mit der man mehrere Computer überwachen kann (CPU auslastung, Festplatte, Temperatur Sensoren) und wo die Daten ...

Netzwerke
DHCP-Probleme nach Switch-Wechsel
gelöst sausi77Vor 1 TagFrageNetzwerke7 Kommentare

Folgendes Problem: - hab meinen Switch gewechselt: vom Zyxel GS1900-24E auf einen Zyxel XGS1930 Seitdem haben mobile Clients (insbesondere auf iOS und Windows-Basis Probleme) ...

Windows 10
Vom Homeoffice auf lokale Dateien zugreifen
SayllesVor 23 StundenFrageWindows 106 Kommentare

Guten Morgen, meine Frau ist im Homeoffice, ihr Arbeitgeber stellt ihr einen Access der unter Server 2016 lauft zur Verfügung. Dieser Remote zugriff funktioniert ...