tire
Goto Top

bin irgendwie kein root (admin) nach installation glaub ich!

glaube, das ist ein ganz doofes problem!!!

Hi Admins,

Ich muss zu Anfang erstmal sagen, ich habe vor ein paar Tagen zum ERSTEN mal Linux-Kubuntu (also generell Linux) auf meinem Rechner installiert, weil ich das für die Arbeit brauche!
Bin also quasi blutiger Linux-Anfänger!

Also,
Ich habe eine Cd gefunden, wo ich Kubuntu quasi unter/in Windows installieren kann (ich kann nach der installation entweder linux oder windows wählen, also ganz normal eigendlich), weil ich mein windows nicht neuinstallieren wollte!
Hat auch eigendlich alles ganz gut geklappt!
so,
dann sollte ich einen User anlegen, und habe ganz normal einen user angelegt, weil man das musste (habe vielleicht nicht drauf geachtet, ob man da einstellen muss, ob der anzulegende user admin werden soll, oder nicht).
und dann melde ich mich ganz normal mit dem user an,

--> jetzt folgt das eigendliche problem!!!

jetzt wollte ich mit "chmod a+x" zugriffsrechte eines ordners verändern, und der gibt mir eine fehlermeldung, dass ich irgendwie keine zugriffsrechte vergeben kann.
jetzt glaube ich, ich habe meinen benutzer irgendwie nicht als administrator gemacht!
kann das sein?
und wenn ja, wie kann ich das ändern?

wäre gut wenn mir da jemand sagen kann, was ich falsch gemacht haben könnte, oder ob ich warscheinlich wirklich kein admin bin!
vielen dank schonmal

mfg

Dirck

Content-Key: 99659

Url: https://administrator.de/contentid/99659

Printed on: July 24, 2024 at 07:07 o'clock

Member: Tire
Tire Oct 19, 2008 at 13:33:11 (UTC)
Goto Top
vielleicht macht das die sache noch ein bisschen klarer:

ich wollte ndiswrapper installieren!
habe also folgendes gemacht:
tar "ndisrwrapper..."
cd "ordner-ndiswrapper" -->war dann also im ordner davon
make install
---> der installiert schön..., alles super!
so dann wollte ich:
cp utils/loadndisdriver /usr/bin

so ... geht nicht!
ich denk mir ok, ich hab keine zugriffsrechte dafür *schon komisch*
so will den ordner mit :
chmod a+x /usr/bin
zugriffsrechte geben!
geht aber nicht!
wieso!?!

das kann man warscheinlich nur als admin oder?!?!?!
Member: dog
dog Oct 19, 2008 at 13:34:24 (UTC)
Goto Top
Hallo,

stimmt du bist unter Linux normalerweise nie Root - aus Sicherheitsgründen.
Den "Superuser" benutzt man nur wenn man etwas am System ändern muss, sonst nie.
Um einen Befehl als root auszuführen kannst du darum einfach in die Kommandozeile eingeben:
sudo <befehl>

Du kannst aber auch ohne root die Berechtigungen bei Dateien ändern, aber dann musst du der
Eigentümer dieser Datei sein. (ls -lh zeigt das in der 3. spalte)
Member: Tire
Tire Oct 19, 2008 at 13:37:36 (UTC)
Goto Top
also,
muss ich also quasi der eigentümer des ordners /usr/bin sein?


(ich kann das jetzt nicht sofort gucken, weil ich dafür den rechner neustarten muss ..
ich hab ja noch kein inet unter linux, weil ich ja ndiswrapper (s.o.) nicht installieren kann ... wegen dem einen problem da oben!
Man ist das ein blöder rattenschwanz face-smile )
Member: dog
dog Oct 19, 2008 at 13:44:09 (UTC)
Goto Top
Prinzipiell müsstest du der Eigentümer sein, NUR:

/usr/bin ist ein Systemordner. Der MUSS aus Sicherheitsgründen root gehören.

Außerdem musst du aufpassen wie du chmod einsetzt:

a+x bedeutet (Alle ja Ausführen - Alle Benutzer dürfen Programme im Ordner ausführen)
Du wolltest aber in den Ordner schreiben, das wäre per
o+w (Andere ja Schreiben - Alle die nicht Besitzer oder in der Besitzergruppe sind dürfen auch schreiben)
gegangen.

ABER:

Wie gesagt, das ist ein Systemordner also musst du diesen Befehl benutzen:
sudo cp utils/loadndisdriver /usr/bin
Member: Tire
Tire Oct 19, 2008 at 13:49:12 (UTC)
Goto Top
ok!

das ergibt auch irgendwie für mich sinn!
also ich werde jetzt mal neustarten, dann teste ich mal, was der macht!

vielen dank bis dahin!
Member: Tire
Tire Oct 19, 2008 at 14:27:06 (UTC)
Goto Top
also,

es lag an "sudo"!

das hat jetzt funktioniert! danke

aber...
ich habe jetzt ein neues problem
so ich dachte damit wäre ndiswrapper installiert, is aber nicht so!
als ich "ndiswrapper .." eingab, hat der gesagt, das ist nicht installiert!
installiere mit :
"sudo apt-get install ndiswrapper-common"

ich geb das ein und dann kam:
->paketlisten werden gelesen... fertig
->abhängigkeitsbaum wird aufgebaut
->reading state information... fertig
->E: kontte packet ndiswrapper-common nicht finden

ich habe "apt-get install" warsceheinlich ein bisschen falsch benutzt, oder vergessen, etwas wichtiges dazuzuschreiben!?! aber was? (wie gesagt (Anfänger))

danke schonmal für "sudo"...

dirck
Member: Befanoid2
Befanoid2 Oct 19, 2008 at 14:57:28 (UTC)
Goto Top
versuchs mal mit :

"sudo aptitude" --> und such dein progi in der liste.
Member: Tire
Tire Oct 19, 2008 at 15:08:43 (UTC)
Goto Top
also muss ich vorher mit "cd" in den ordner wechseln, wo ndiswrapper drin ist?!?
weil da is glaub ich irgendwo die install drin.
Member: Tire
Tire Oct 19, 2008 at 16:40:13 (UTC)
Goto Top
also
so wie ich sehen kann, scheint das programm da nicht in der liste zu stehen!
was bedeutet das also für mich?
Member: dog
dog Oct 19, 2008 at 18:16:06 (UTC)
Goto Top
->E: kontte packet ndiswrapper-common nicht finden

Das kann zwei Gründe haben:

a) Deine Paketlite ist nicht aktuell. Die kannst du mit "sudo apt-get update" aktualisieren und dann neu installieren
b) das Paket wurde von Debian als non-free oder contrib eingestuft, die Paketlisten musst du in der Datei /etc/apt/sources.list erst hinzufügen.
Bei mir sieht die Datei z.B. so aus:
# Installations-CD nicht als Quelle benutzen
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb http://ftp.freenet.de/debian/ etch main contirb
deb-src http://ftp.freenet.de/debian/ etch main contrib
[...]
Member: Tire
Tire Oct 19, 2008 at 19:26:46 (UTC)
Goto Top
das bedeutet aber doch, dass ich entweder ...(internet brauche)
oder... (auch internet brauche)
...
ich habe aber nur internet unter meiner windows-installation, da ich wlan habe, und der router eine etage tiefer steht, ich also keine chance habe mit einem netzwerkkabel auf den router zuzugreifen!
unter kubuntu habe ich ja wie gesat noch keine wlan-karte installiert!
wie soll ich das jetzt machen?