Browsersuche und die eigene (lokale) Domäne

Mitglied: CyborgWeasel

CyborgWeasel (Level 1) - Jetzt verbinden

30.04.2021 um 10:12 Uhr, 460 Aufrufe, 7 Kommentare

Hallo Leute,

ich hoffe ich habe mir die richtige Kategorie ausgesucht, es ist ja eher ein Browserproblem:

Ich experimentiere gerade zu Hause mit einem eigenen DNS-Server (auf einer Synology DS918+). Dazu habe ich mir die Domäne/Zone zuhause.home angelegt und für den Server den Eintrag NAS.zuhause.home hinzugefügt. Funktioniert auch alles wie es soll, jedoch kommt mir beim Aufrufen dieser URL die Browsersuche in die Quere. Ich muss immer http(s) voransetzen oder den Port mit :80 o.ä. anhängen, damit der Browser den Begriff als URL behandelt und nicht als Suchbegriff für die Standardsuche. Sowohl Firefox (v. 88) als auch Chrome (v. 90) zeigen dieses Verhalten. Kann ich irgendwo dem Browser mitteilen, dass alles .home als URL behandelt werden soll, quasi die Liste der gültigen Domänendungen irgendwie erweitern?

Wie macht das denn AVM mit z.B. fritz.box? Soweit ich weiß ist .box noch keine gültige TLD, oder? Dann müsste .box ja auch irgendwie für alle Browser als "use as url" hinterlegt sein...

Gruß
CyborgWeasel
Mitglied: tomolpi
30.04.2021, aktualisiert um 11:00 Uhr
Zitat von @CyborgWeasel:

Hallo Leute,
Hi,
Wie macht das denn AVM mit z.B. fritz.box? Soweit ich weiß ist .box noch keine gültige TLD, oder? Dann müsste .box ja auch irgendwie für alle Browser als "use as url" hinterlegt sein...
Nein, die FritzBox ist dein erster DNS-Server, den dein Client standardmäßig per DHCP erhält. Ein DNS-Request geht also: Client -> Fritz!Box -> Provider-DNS -> weiter ins Internet
Die Fritz!Box kann die Domain fritz.box auflösen und dein Browser zeigt die Seite an.
Damit das bei dir läuft, musst du also deine Synology an deinem Client als DNS-Server eintragen (oder per DHCP verteilen lassen), und dazu noch eine Weiterleitung der Anfragen an die Fritz!Box (oder direkt an einen Public-DNS, z.B. quad9) einrichten. Sonst kommst du nicht mehr ins echte Internet ;-) face-wink.
Dein Request geht dann folgenden Weg: Client -> Synology -> Fritz!Box -> Provider-DNS -> weiter ins Internet
Dein NAS wird dann die Domäne .home auflösen können, und dein Browser die Seite zeigen können
Gruß
CyborgWeasel
tomolpi
Bitte warten ..
Mitglied: CyborgWeasel
30.04.2021 um 13:44 Uhr
Hi Tomolpi,

Nein, die FritzBox ist dein erster DNS-Server, den dein Client standardmäßig per DHCP erhält. Ein DNS-Request geht also: Client -> Fritz!Box -> Provider-DNS -> weiter ins Internet

Sorry, das ist aber nicht das Problem :-) face-smile Die DNS Auflösung funktioniert korrekt, DNS ist richtig eingetragen usw. Es geht darum, dass Firefox die Eingabe Nas.zuhause.home nicht als URL erkennt. Wenn ich das so in die Leiste des Browsers eingebe, dann kommt die Google-Suche nach Nas.Zuhause.home respektive die Antworten dazu. Wenn ich http://nas.zuhause.home eingebe, dann erkennt Firefox das ganze als URL und sucht nicht danach, sondern leitet mich so wie es sein soll auf die Seite des NAS. Firefox muss ja irgendwie unterscheiden, ob er das Eingegebene als URL betrachtet und den DNS Server anfragen soll, oder ob er es als Suche in eine "https://www.google.com/search?client=firefox-b-d&q=NAS.zuhause.home& ..." URL umwandeln soll. Un meine Idee/Vermutung war, dass er das vielleicht an bekannten TLDs festmacht und ich diese Liste nur um .home erweitern müsste... Hab dazu aber nichts gefunden bisher...

Der DNS ist nicht mein Problem :-) face-smile

Gruß
Bitte warten ..
Mitglied: jsysde
30.04.2021 um 21:50 Uhr
N'Abend.

Zitat von @CyborgWeasel:
[...]Der DNS ist nicht mein Problem :-) face-smile
Doch. ;-) face-wink

Cheers,
jsysde
Bitte warten ..
Mitglied: CyborgWeasel
01.05.2021 um 11:34 Uhr
Zitat von @CyborgWeasel:
[...]Der DNS ist nicht mein Problem :-) face-smile
Doch. ;-) face-wink

Ich lasse mich gerne belehren, kannst du das näher ausführen? meine URL lässt sich auflösen, was für ein Problem könnte es dann noch mit dem DNS sein?
Bitte warten ..
Mitglied: CyborgWeasel
01.05.2021 um 11:58 Uhr
Vielleicht kann ich das Problem nocheinmal wie folgt beschreiben:

Gegebenheiten:
Ich trenne alle Verbindungen meines Notebooks zu irgend einem Netzwerk.
Meine Testdomäne wird jetzt einmal eine, die definitiv nicht existiert: quakquak123.de
Die Standardsuche von Firefox ist Google

Wenn ich nun in der Suchleiste von Firefox eingebe:

quakquak123.d

dann ist vor diesem Begriff ein Google-Symbol angezeigt, was bedeutet dass Firefox nach diesem Begriff bei Google suchen wird, sobald ich ENTER drücke. Sobald ich jetzt noch das zusätzliche "e" eingebe, so dass in der Leiste steht

quakquak123.de

dann ändert sich das Google Symbol in eine Weltkugel, was mir anzeigt dass Firefox dies als URL behandeln wird und eben nicht bei Google als Suchbegriff benutzt.

Da ich gerade keine Verbindung zu einem DNS Server habe und die URL auch noch nie zuvor aufgerufen habe (ich hatte vorher mit meinem Smartphone geprüft ob die URL existiert ;-) face-wink ) kann dieses Verhalten auch nicht von einem DNS Server bzw. DNS cache kommen. Firefox muss irgendwie unterscheiden, ob er das Eingegebene als Suchbegriff verwendet oder als URL. Und ich vermute mal, dass das anhand des ".de" geschieht?! -> Hat Firefox die TLDs hinterlegt? Falls ja, könnte man die Liste um .home erweitern?

Gruß
Bitte warten ..
Mitglied: SunshineAdmin
01.05.2021 um 17:54 Uhr
Hi,

schau mal hier: https://wiki.mozilla.org/Public_Suffix_List/Uses">https://wiki.mozilla.org/Public_Suffix_List/Uses
und auch hier: https://publicsuffix.org/learn/">https://publicsuffix.org/learn/
Die Public Suffix List führt die bekannten toplevel domains.
Ich gehe davon aus, dass einige Browser diese Liste nutzen um domains zu "erkennen".
Und .home steht wohl nicht drauf.

VG
SunshineAdmin
Bitte warten ..
Mitglied: CyborgWeasel
03.05.2021 um 12:17 Uhr
Und .home steht wohl nicht drauf.

und du weißt nicht, wie und ob man dies lokal ändern kann?

Ich habe jetzt noch einen Workaround gefunden:
sobald ich hinter der URL einen Punkt eingebe, wird sie auch als URL behandelt, also

NAS.zuhause.home.

Gruß
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Unterschiedliche IP-Adressbereiche im Netzwerk
achkleinVor 1 TagFrageLAN, WAN, Wireless17 Kommentare

Hallo, ich stehe vor einem Problem mit der WLAN-Verbindung zum Router (Fritzbox Cable 6490). Das verbundene Notebook hat die Adresse 192.168.0.164, Gateway ist 192.168.0.149: ...

Off Topic
Microsoft und der (leidige) Datenschutz
Franz-Josef-IIVor 1 TagAllgemeinOff Topic18 Kommentare

Hello Ich möchte vorausschicken, daß ich rein prinzipiell nichts gegen Microsoft habe, eher gegen die US-amerikanische Politik 😊 Microsoft bietet die Datenverarbeitung in der ...

Off Topic
32 bit Problem
brammerVor 1 TagAllgemeinOff Topic9 Kommentare

Hallo, also das ist mal ein Problem das ich auch haben möchte eine Aktie ist mehr Wert als das die Börsensoftware darstellen kann. brammer

Hardware
Thin- oder Zero-Client für RDP und Dual-Monitor im LAN gesucht
FestplattenaufzieherVor 1 TagFrageHardware9 Kommentare

Hallo, Kurzfassung meiner Frage: Ich suche Thin/Zero-Clients (4 Stück) mit Dual-Monitor-Unterstützung für den RDP-Zugriff auf PCs in einem LAN - idealerweise lautlos und relativ ...

Windows Server
Lizenzen für Virtualisierungshost
TakworianVor 11 StundenFrageWindows Server15 Kommentare

Hallo, ich werde demnächst einen HA-Cluster aus 3 x HP DL580 in Betrieb nehmen. Der Cluster wird unter Proxmox betrieben und es sollen diverse ...

Windows 10
Windows 10 2021-04 end of life?
gelöst Paedi12Vor 1 TagFrageWindows 103 Kommentare

Hi Leute! Ich bin gerade auf der Suche, wie lange die Windows Version 2021-04 unterstützt wird. Kann aber nichts finden. Hat jemand eine Ahnung, ...

Switche und Hubs
Netgear Switch Problem bei VLAN Konfiguration
gelöst meltersVor 1 TagFrageSwitche und Hubs15 Kommentare

Hallo, ich habe einen Netgear XS716T Switch zum Testen in Betrieb genommen, komme aber mit der VLAN Konfiguration nicht so ganz klar. Bislang habe ...

Router & Routing
Suche Tipps für Selfmade-Load-Balancing-Router auf HP MicroServer Gen10+
gelöst MagicChris86Vor 1 TagFrageRouter & Routing7 Kommentare

Hi Leute, ich habe einen HP MicroServer Gen10+ Performance übrig, der bei einer Kundin rausgeflogen ist, weil sie mehr Power brauchte für Desktopvirtualisierung für ...