Case sensitive in NETLOGON und sonstigen Freigaben?! WinServer2k8 SE und Win10 Win7

Mitglied: KMUlife

KMUlife (Level 2) - Jetzt verbinden

20.04.2016, aktualisiert 17:12 Uhr, 1228 Aufrufe, 12 Kommentare

Hallo zusammen!

Ich bin letzte Woche über ein Problem gestolpert welches für mich 0 Sinn ergibt.
Grundsätzlich ist Ja Windows so ausgelegt, dass es nicht case sensitive ist.

Ich habe nun eine Server Freigabe, beispielsweise \\SERVER01\NETLOGON.

Auf dem Windows 7 rechner kann ich auf diese Freigabe mit \\xxx.xxx.xxx.xxx\netlogon oder \\server01\netlogon oder \\SERVER01\NETLOGON zugreifen.
Mit dem Windows 10 rechner kann ich nur mit \\SERVER01\NETLOGON darauf zugreifen. Über die anderen adressen kommt ne Passwortabfrage. (was ja kein Sinn macht bei "Jeder" leseberechtigung)

Kann mir das jemand erklären oder hat eine Idee?

Auf dem Server sind die Berechtigungen für die Netlogon-Freigabe so gesetzt, dass "Jeder" lesen kann und Administratoren "Vollzugriff" haben.

WinServer2k8 SE
Clients Win7 & Win10

Grüsse
KMUlife
Mitglied: Dani
20.04.2016 um 18:05 Uhr
Moin,
kontrolliere auf dem Windows 10 Client folgenden Registrywert:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\kernel -> obcaseinsensitive. Wert 1: Deaktviert, Wert 0: Aktiviert.

Über die anderen adressen kommt ne Passwortabfrage. (was ja kein Sinn macht bei "Jeder" leseberechtigung)
Was sind die "anderen Adressen"?

Wenn du einen Ping/Nslookup vom betroffenen Client auf die verschiedenen Adressen durchführst, ist die Ausgabe jedesmal richtig?


Gruß,
Dani
Bitte warten ..
Mitglied: KMUlife
21.04.2016, aktualisiert um 08:41 Uhr
Hallo Dani

Danke für deine Antwort!

obcaseinsensitve ist Wert 1 also Deaktiviert. Sollte also so stimmen?

Mit den "anderen Adressen" meine ich, den Zugriff auf das Netzlaufwerk NETLOGON über die "verschiedenen Pfade" bzw. Schreibweisen:

  • Alles gross geschrieben: \\SERVER01\NETLOGON - Funktioniert
  • Alles klein geschrieben: \\server01\netlogon - Es kommt ne pw. abfrage
  • ip + Kleinschreibung: \\X.X.X.X\netlogon - Kommt pw. abfrage
  • ip + Grossschreibung \\X.X.X.X\NETLOGON Kommt pw. abfrage
(mit einem win7-Client, gleicher User in der AD funktioniert es immer)

Das komische daran ist ja, dass es immer der gleiche Server ist. Der DNS löst das ganze auch korrekt auf (also ob über ip/name mit gross oder kleinschreibung) nslookup zeigt immer auf server01.domain.local

Gruss
KMUlife
Bitte warten ..
Mitglied: Dani
23.04.2016 um 18:21 Uhr
Moin,
hast du das Problem an allen Windows 10 Clients oder nur an dieser einen Maschine? Die Konfiguration der Netzwerkkarte bezüglich DNS, evtl. WINS, etc... ist korrekt. Manchmal schleicht sich ein Tippfehler ein. Ansonsten evtl. den Rechner aus und wieder in die Domäne aufnehmen.


Gruß,
Dani
Bitte warten ..
Mitglied: KMUlife
25.04.2016 um 11:06 Uhr
Auf allen Rechner mit Win10 das gleiche Problem. Interessant dabei ist, dass mit Win 7 mit VPN Zugriff laut Kollege das Problem auch besteht.

Ich kanns mir momentan echt nicht erklären. Grundsätzlich ist "Jeder" berechtigt zu lesen und es kommt trotzdem ne PW-Abfrage.
Als ob er die ip anders auflöst wie der Servername. Mit nslookup löst er sie aber richtig auf.

Naja, anscheinend müssen wir damit leben...

Grüsse
KMUlife
Bitte warten ..
Mitglied: Dani
25.04.2016 um 18:10 Uhr
Hey,
hast du evtl. noch WINS-Server im Einsatz bzw. bei den Clients hinterlegt? Ich würde die aus der Konfiguration löschen und nochmals probieren.


Gruß,
Dani
Bitte warten ..
Mitglied: KMUlife
27.04.2016, aktualisiert um 09:39 Uhr
Hallo Dani
Nein keiner Hinterlegt.

Ich begreife das echt nicht, auf dem Server habe ich die Freigabe \\Server\netlogon welche im Standartpfad: C:\Windows\sysvol\sysvol\domain.local\scripts liegt.

Freigabeberechtigungen:
Jeder = Lesen
Administratoren = Vollzugriff
NTFS Berechtigungen:
Ersteller Besitzer = Keine Berechtigungen
Authentifizierter Benutzer = Lesen, Ausführen, Ornderinhalt, Lesen
Noch admin/SYSTEM gruppen aber die sind ja nicht wichtig....

(Wurde nicht von mir so aufgesetzt, scheint mir aber ganz in Ordnung zu sein.)

--> Wenn ich mich nun an einem Computer mit Domänenaccount anmelde sollte ich doch eigentlich ein Authentifizierter Benuzter sein, also mindestens lesen können? (egal ob lokaler admin oder nicht?)

Oder seht ihr evt. irgendwo ein Fehler in der Konfig.?

Grüsse
KMUlife
Bitte warten ..
Mitglied: Dani
LÖSUNG 27.04.2016 um 09:47 Uhr
Moin KMUlife,
bitte prüfe, ob deine DCs und das Active Directory sauber laufen. Dazu lege ich dir folgende Tools ans Herz:
  • Active Directory Health Checks for Domain Controllers
  • Active Directory Replication Status Tool
  • dcdiag


Gruß,
Dani
Bitte warten ..
Mitglied: KMUlife
27.04.2016 um 11:00 Uhr
Hallo Dani

dcdiag /V bringt mir n schöner hinweis... denke das ist schon mal ne Katastrophe.

Starting test: NetLogons
Network Logons Privileges Check
Verified share \\BASEL\netlogon
Verified share \\BASEL\sysvol
[BASEL] Die Anmeldeinformationen berechtigen nicht zum Ausfhren
dieses Vorgangs.
Das fr diesen Test verwendete Konto muss fr die Dom„ne dieses
Computers ber Netwerkanmelderechte verfgen.
......................... BASEL hat den Test NetLogons nicht
bestanden.



Bin mit einem Netzwerkadmin eingeloggt...
Falls du dich jetzt fragst wie das überhaupt gehen kann.^^ Ich weiss es auch nicht, bin erst seit 2 Monaten in dieser Firma angestellt und vorher hat der Chef das halt so "über den Daumen" aufgebaut. (KMU halt :) face-smile)

Danke für die Tipps! - Jetzt muss ich "nur" noch herausfinden wieso dies so ist... aber dann haben wir wohl ein grundlegenderes Problem....
Bitte warten ..
Mitglied: Dani
27.04.2016, aktualisiert um 12:32 Uhr
Hast du den Test direkt auf dem DC durchgeführt?
Bist du mit dem DOMÄNE\Administrator angemeldet?

Was sagen die anderen Tools und die Ereignisprotokolle?
Bitte warten ..
Mitglied: KMUlife
27.04.2016 um 13:37 Uhr
Ciao Dani


Zitat von @Dani:

Hast du den Test direkt auf dem DC durchgeführt?
Bist du mit dem DOMÄNE\Administrator angemeldet?

- Direkt auf dem DC (über Remotedsktp)
- Jap DOMÄNE\Administrator (also eigens angelegter user aber in der Administrator-Gruppe des DC's(Builtin --> Administratoren))

Was sagen die anderen Tools und die Ereignisprotokolle?

Das Replication Status Tool ist wohl nicht allzu nützlich, da ich nichts repliziere. (Ist ein einziger DC Small Business 2008)
und mit Active Directory Health Checks for DC's meinste folgendes? --> http://blogs.msmvps.com/ad/blog/2008/06/04/active-directory-health-chec ...

Hab mal noch den BPA laufen lassen. Vlt. hilft das ja weiter. Das Zertifikat sollte ja nicht problematisch sein, wenn das schon seit 3 jahren nicht mehr zertifiziert ist?! Gilt ja nur für die Terminal-Server dienste oder?(welche nicht eingesetzt werden)
bpa - Klicke auf das Bild, um es zu vergrößern

Sorry bin halt noch nicht so der Pro im analysieren, alles noch am lernen.^^

Grüsse
KMUlife
Bitte warten ..
Mitglied: Dani
27.04.2016 um 19:49 Uhr
Moin,
puhh.. bei SBS bin ich raus. Noch nie solch ein Betriebssystem vor mir gehabt und kenn damit evtl. Eigenheiten nicht.
Die Eingabeaufforderung hast du aber über Rechtsklick -> Als Administrator ausführen gestartet?!

Das Replication Status Tool ist wohl nicht allzu nützlich, da ich nichts repliziere. (Ist ein einziger DC Small Business 2008)
Okay, war mir nicht klar. Was findest du an Fehlern in der Windows Ereignisanzeige?


Gruß,
Dani
Bitte warten ..
Mitglied: KMUlife
29.04.2016 um 09:36 Uhr
Hey Dani

Haha ich Holz hab glatt vergessen als admin zu starten... Jetzt funkts. (Problem liegt also anderswo)

Zur Ereignisanzeige, die ist voll mit Warnungen....
ABER
Ich darf vom Chef aus eine komplett neue Umgebung aufbauen. (Diese ist jetzt doch schon fünf Jahre alt und wurde nie richtig administriert.)
Hauptcerts. seit 3 Jahren abgelaufen usw. usw. (und eben die Ereignisanzeige voll von Fehlern).

Also kann von Grün auf neu beginnen....
Darum würde ich sagen investieren wir unsere Hirnzellen nicht mehr in Probleme mit der alten Umgebung!
Die muss jetzt einfach noch ein knappes halbes Jahr durchhalten bis die Migration soweit ist. (weiss zwar nicht wie ich das verantworten soll, aber der Chef weiss bescheid...) naja... er will nicht das ich noch mehr zeit investiere, irgendwodurch auch verständlich...

Danke viel mal für deine Mühe!
Ich stell sicher dann mal wieder ein paar Fragen zur neuen Umgebung ;-) face-wink.

Grüsse
KMUlife & danke nochmals! :) face-smile
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerke
Was passiert wenn ich zeitgleich PoE und Strom vom Netzteil an einen Access Point (Mikrotik) lege?
kartoffelesserVor 1 TagFrageNetzwerke3 Kommentare

Hallo Experten und Admins Ich habe einen Mikrotik wAP ac (RB-WAPG-5HACD2HND) an einem Laptopwagen im Einsatz. Leider ist die vorhandene Stromversorgung für den AP ...

Windows Server
Infrastruktur für Firma
brainwashVor 18 StundenFrageWindows Server7 Kommentare

Hallo zusammen, kurze Erklärung zu meinem Problem Wir sind eine kleine Firma mit zwei Standorten im Bereich Brandschutz. Zur Zeit nutzen wir für unsere ...

Netzwerkprotokolle
Proxy Zugang von Extern
gelöst Jannik2018Vor 1 TagFrageNetzwerkprotokolle17 Kommentare

Hallo zusammen, ich habe mir einen Squid Proxy auf einer Linux VM aufgesetzt und möchte das man aus allen netzen drauf zugreifen kann allerdings ...

Windows Server
Windows 10 VM auf Server 2019 Essentials
jhuedderVor 1 TagFrageWindows Server10 Kommentare

Hallo, einer meiner Kunden möchte aus Kostengründen einen Windows Server 2019 (direkt auf einer physikalischen Maschine installiert) erwerben und dort für einen Außendienstler mit ...

Server-Hardware
Verkaufe RX300 S7 Server von Fuijutsu
HolzBrettVor 19 StundenAllgemeinServer-Hardware9 Kommentare

Hi, Ich wohne in Aachen und habe die Server von der Firma umsonst erhalten. Ich habe sie bereits überprüft (es geht alles). Ich möchte ...

Windows Server
Veeam Endpoint Backup FREE zur Sicherung eines DCs
gelöst takvorianVor 1 TagFrageWindows Server7 Kommentare

Hallo zusammen, ich habe hier bei mir 1 Hypervisor mit 4 VMs (darunter 1 DC) welche ich mittels backupAssist alle wegsichere. Klappt soweit auch ...

LAN, WAN, Wireless
WLan-unterstütztes Telefonieren iOS, Unifi
VisuciusVor 1 TagFrageLAN, WAN, Wireless8 Kommentare

Hallo. Ich bins (wieder) ;-) Guten Morgen, ich beobachte seit einer Umstellung ein "komisches Verhalten" und kann mir das gerade nicht erklären. Und vielleicht ...

LAN, WAN, Wireless
Heimnetzwerk mit VLAN - getrennter Internetzugang
gelöst anyibkVor 1 TagFrageLAN, WAN, Wireless5 Kommentare

Hallo liebe Community! Ich bastle seit einiger Zeit an einem recht besonderen Heimnetzwerkproblem. Wir haben einen neuen Glasfaseranschluss ins Haus (3 Parteien) bekommen und ...