Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CF-Karte spiegeln

Mitglied: aufder

aufder (Level 1) - Jetzt verbinden

15.10.2004, aktualisiert 18.04.2006, 28585 Aufrufe, 22 Kommentare

Wie kann ich eine CF-Karte kopieren?

Hallo Admins!

Ich habe ein Windows Emedded OS auf einer CF-Karte gespeichert, von der ich auch boote. Gibt es ein Programm, mit dem man diese CF-Karte samt MBR kopieren/spiegeln kann, sodass ich auch von der Kopie booten kann?
Vielen Dank im Voraus!

MfG
Stefan
Mitglied: BartSimpson
15.10.2004 um 11:04 Uhr
Ich würde es mit Linux verusuchen und denn dort mit dem Befehl dd. Damit kannst komplette. Platten kopieren. Must nur etwas aufpassen mit den Parametern. Dann einfach mal testetn obs geht.
Bitte warten ..
Mitglied: linkit
15.10.2004 um 13:16 Uhr
Hallo du hast zwei Möglichkeiten,


1. wenn der CF-Slot über ein IDE Kabel angeschlossen wurde, dann wird das Ding als Festplatte erkannt, in diesem Fall kannst du wie Bart beschrieben hat vorgehen oder du lädst dir die Ultimate Boot CD herunter und dann cloneHD etc.

2. Du kopierst ganz normal die CF eins zu eins, inklusive aller Systemdateien etc. (also diese im Explorer mit anzeigen lassen, oder alternativ per xcopy mit entsprechenden Optionen kopieren)
Dann nimmst du eines der beiden folgenden Tools:

http://www.w-hermanns.desoftw1mbr.zip
http://www.dirkbilland.de/mbr.exe

und liest bzw. schreibst hiermit den MBR.
Bitte warten ..
Mitglied: BartSimpson
15.10.2004 um 15:04 Uhr
Linux geht auch prima wenn das teil nicht am IDE Port hängt.
Bitte warten ..
Mitglied: MasterEye
24.05.2005 um 10:18 Uhr
Ich glaub das geht auch ganz gut mir dem Programm Ghost von Symantec.
Kostet halt
Bitte warten ..
Mitglied: BartSimpson
24.05.2005 um 10:58 Uhr
Also mit ghost muste aufpassen. Denn ghost macht bei nicht Windows Dateisystem manchmal nur Mist.
Bitte warten ..
Mitglied: Cassiopeia
27.03.2006 um 17:52 Uhr
Hallo Bart,


habe dasselbe gemacht. (mit dd unter Linux).
Mein Problem ist, dass ich zwar eine bootfähige Kopie bekomme wenn ich eine gleichgrosse (2GB-CF-Karte) Kopie mache.
Wenn ich aber auf die 4GB Karte die 2GB rüberschreibe dann bootet der Rechner nicht (trotz gleichen Befehlen.....)
Habs auch schon versucht die 4GB-Karte zu 2*2GB partitionieren und die Kopie-Partition auf "aktiv" zu setzen, etc etc etc. Leider ohne Erfolg.

Übrigens dd von 2GB auf 4GB macht aus der 4GB-Karte eine 2GB-Version - zeigt im fdisk aber an dass sie eine 4GB ist und lässt aber keine Partition mehr hinzufügen!?!?!?

Hast Du dafür eine Lösung?


Danke!



Didi
Bitte warten ..
Mitglied: BartSimpson
27.03.2006 um 18:08 Uhr
Haste mal geschaut, ob dein System überhaupt von 4GB Karten starten kann?
Bitte warten ..
Mitglied: Cassiopeia
28.03.2006 um 09:56 Uhr
Ja, hab ich. Er kann auf Karten bis zu 8GB booten...
Übrigens: Habs auch mit Norton Ghost versucht (diverse Versionen) - leider auch ohne Erfolg!
Bitte warten ..
Mitglied: BartSimpson
28.03.2006 um 11:15 Uhr
Nagut dann liegt es nicht am dd
Ist es die XP Embedded SP2 Version oder noch die alte??
Es könnte auch an der Lizenz liegen, das das Systemimage irgenwie an die Karte gebunden ist, Und denn bei einer größeren Karte die Prüfsumme nicht meht stimmt.
Bitte warten ..
Mitglied: Cassiopeia
28.03.2006 um 14:12 Uhr
Uuups - da hab ich was übersehen - da läuft keine embedded Version drauf (gibts die???), sondern ein "normales" Windows XP Professional SP1a.
Das mit der Lizenz glaub ich nicht, da anno dazumals mein Kollege den Rechner stinknormal auf die 2GB-CF aufgesetzt hat....

Ich werd mal den Kunden fragen ob der Zugangsdaten zum Herstellerportal hat. Vielleicht gibts da nun BIOS-Updates oder dlg. um von 4GB-CF zu booten..... Ist ja ein Industrierechner mit non-Standard-Bauteilen - aber zum aufsetzen benötigte mein Kollege keine speziellen Treiber......

Vielleicht hängts ja auch mit der industrial-Version der 4GB-Karte zusammen - doch fdisk meint dass alles in Ordnung ist, der einzige Unterschied zwischen der 2 und der 4GB-Variante ist die Anzahl der Zylinder und halt der Speichergrösse:

Beispiel 2GB:
Platte /dev/hda: 2048MB, 2048901120 Byte
64 Köpfe, 63 Sektoren/Spuren, 992 Zylinder
Einheiten = Zylinder von 4032 * 512 = 2064384

Gerät /dev/hda1, boot. *, Anfang 1, Ende 991, Blöcke 1997824+, Id 7, Dateisystemtyp HPFS/NTFS

fdisk meckert bei der 4GB-CF halt am Anfang dass der Wert der Zylinder über 1024 ist und dass es Probleme beim Booten geben kann. Ich weiß dass ich genau diese Probleme habe - aber wie soll ich das ändern??? Ich hab ja die 1. Partition eh nur 992 Blöcke gross gemacht!?!?
Bitte warten ..
Mitglied: BartSimpson
28.03.2006 um 14:22 Uhr
Das BIOS ist das Probelm, was manchmal ein Problem hat, wenn die Startpartition über dem 1024. Zylinder liegt.
Bitte warten ..
Mitglied: Cassiopeia
28.03.2006 um 14:30 Uhr
Ja, das "alte" Problem kenn ich - das BIOS ist von vorigem Jahr - sollte also hoffentlich nicht mehr betroffen sein. Wie schon gesagt warte ich noch auf den Zugang zur Downloadseite des PC-Herstellers.....
Bitte warten ..
Mitglied: Cassiopeia
31.03.2006 um 15:45 Uhr
Hi nochmal,


hab nun Zugang zum Downloadbereich bekommen, das neueste BIOS installiert und TATAAAA - er bootet! (zumindest schon mal bis zur "Willkommen"-Seite von XP) ist ja schon mal ein Anfang.
Warum er nicht weiter bootet weiß ich noch nicht. Es macht auf alle Fälle keinen Unterschied ob ich die 2GB auf 4GB erweitere beim Kopieren oder einfach "nur" eine 2GB Partition auf die 4er schreibe......

Schönes Wochenende!


Didi
Bitte warten ..
Mitglied: BartSimpson
31.03.2006 um 16:02 Uhr
Und denn stürz er ab?
Bitte warten ..
Mitglied: Cassiopeia
31.03.2006 um 16:03 Uhr
Naja - BLUESCREEN kommt keiner - er bleibt dort einfach hängen und reagiert auf gar nix mehr ausser auf die Maus, mit der kannst Du spazierenfahren.......
Bitte warten ..
Mitglied: BartSimpson
31.03.2006 um 16:08 Uhr
haste mal den abgesicherten Modus versucht?
Bitte warten ..
Mitglied: Cassiopeia
31.03.2006 um 16:33 Uhr
Im abgesicherten lässt er mich noch den anzumeldenden Benutzer auswählen - in meinem Fall eben den Administrator, dann blendet er den anderen Benutzer aus und steht wiederum beim "Willkommen" auf hellblauem Hintergrund und "Administrator - Benutzereinstellungen werden geladen..."

Habs sogar schon mit einem Repair von CD versucht. Komischerweise bootet der Rechner zwar mit jeder XP CD aber leider lässt er sich nur bei einer bestimmten CD (die silberne XP CD - also NICHT SP2!) bedienen. Bei jeder anderen lädt er zwar alle möglichen Module, danach verweigert er sogar die Auswahl ob Du installieren, reparieren,.... willst. Er beendet den Vorgang sofort mit einem Bluescreen!

Ich habe nun zwar schon von der 2GB Platte alle Daten die nicht zum Betriebssystem gehören aufs Netz verschoben und die Laufwerkskomprimierung abgeschalten, neu gebootet, etc und erst dann auf die 4GB geschrieben, aber irgendwie mag er nicht mit der 4er komplett hochfahren. Vielleicht hat es ja doch was mit der Komprimiererei zu tun (welche ja nun ausgeschaltet ist bzw. sein sollte - ist ja M$).
Bitte warten ..
Mitglied: Cassiopeia
31.03.2006 um 17:33 Uhr
Wenn Du glaubst es geht nicht mehr.........
Ich hab jetzt schon (fast) aufgegeben und den Rechner einfach eingeschaltet gelassen - nach etwa einer halben Stunde ist er mit dem Starten fertig geworden!!!
In der Ereignisanzeige steht nur dass er etliche Dienste nicht starten hat können - na klar (war ja Abgesichert ohne Netzwerk,...), eine Datenträgerüberprüfung sowohl mit der Suche nach Fehlerhaften Sektoren und deren Wiederherstellung, als auch ohne dieser Einstellung brachte gar nix.
Eine Überprüfung mit "Dateisystemfehler automatisch korrigieren" (beim Neustart) brachte - so glaub ich zumindest auch nix - weil er ziemlich schnell fertig war und gleich danach wieder VON VORNE (POST,....) gebootet hat und nun schon wieder seit etwa 10 Minuten "normal" bootet.....
Mal sehen was die Ereignisanzeige, etc so zeigt und welche Dienste er nicht starten kann.......
Bitte warten ..
Mitglied: Cassiopeia
04.04.2006 um 11:30 Uhr
So, nun hab ich den Rechner über 12 Stunden "normal" booten lassen - er kam nicht weiter als bis zum "Willkommen"-Bildschirm.
Anhand der IDE-LED erkennt man zwar dass er hi und da (so etwa alle 5Minuten) mal auf die "Festplatte" zugreift, aber Fortschritt is da keiner zu sehen.
Ich hab zwar das Startprotokoll mitschreiben lassen, doch eine Analyse spar ich mir, da ich das Ding sicher neu aufsetzen muss.
Schade eigentlich, wir haben uns nicht gedacht dass es -nur weil es eine CF-Karte ist und keine HDD halt- solche Probleme bzw. Inkompatibilitäten gibt.

Trotzdem Danke für die Tipps!

Servus,


Didi
Bitte warten ..
Mitglied: Cassiopeia
18.04.2006 um 16:02 Uhr
Hallo nochmal,


wollte nur bescheid geben.
Nach einer Neuinstallation blieb das nigelnagelneue XP-SP2 auf der 4GB-CF-Karte auch beim Willkommenbildschirm hängen!!!!
Aus lauter Frust ist mein Kollege BEIM BOOTEN(!!!!) auf die <Strg>-<Alt>-<Entf> "angekommen" (mehr oder minder draufgedroschen) - was soll ich sagen - er hat daraufhin durchgestartet!!!! Man kann dies einwandfrei nachvollziehen! Einfach jedesmal beim Willkommenbildschirm diese Tastenkombination anwenden und er "fährt durch". Danach kommt die Meldung das -warum auch immer- die Auslagerungsdatei nicht angelegt werden konnte. Wenn man diese deaktiviert dann fährt er wieder normal hoch!!!!
Leider konnten wir bisher die Auslagerungsdatei nicht mehr anlegen - keine Ahnung warum - es sind übrigens noch über 2,8GB frei und die Auslagerungsdatei wäre 768MB.....
Eventuell hat ja die CF-Karte einen Fehler!?!?!?

Wir werden sehen ob wir eine andere Karte bekommen.....

Didi
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Robocopy Daten spiegeln
Frage von neotronBatch & Shell2 Kommentare

Hallo zusammen, mein Ziel ist es von einem Fileserver die "Altdaten" zu archivieren. Dazu möchte ich per Robocopy alle ...

Windows Tools
Desktop Spiegeln von Usern
Frage von Adnan88Windows Tools5 Kommentare

Hallo, ich wollte mal Fragen ob es folgendes Szenario / Möglichkeit geben tut: Ein Admin hat ein Client Win ...

Windows Server
Serverfestplatte spiegeln oder klonen
Frage von Autohaus-BollingerWindows Server7 Kommentare

hallo wir hatten bisher bei uns einen Server gemietet, dieser soll nun ausgetauscht werden, bzw ein Server wurde gekauft ...

Router & Routing
Dlink DFL-800 - CF Image gesucht
gelöst Frage von psannzRouter & Routing11 Kommentare

Hallo zusammen, Bei einer alten DFL-800 hat die CF Karte leider das Zeitliche gesegnet, einige der Daten sind korrupt. ...

Neue Wissensbeiträge
Entwicklung

Neu im TickX - Das neue Zusatzmodul Resourcen Syncronization

Tipp von TickXmedia-service vor 22 MinutenEntwicklung1 Kommentar

Mit der aktuellen TickX Version 3.2 haben wir wieder zahlreiche Verbesserungen und Anpassungen im TickX vorgenommen. Das neue TickX-Modul ...

MikroTik RouterOS

Dynamische VLAN Zuweisung für WLAN (u. LAN) Clients mit Mikrotik

Anleitung von aqui vor 3 TagenMikroTik RouterOS1 Kommentar

1. Allgemeine Einleitung: Das folgende Tutorial gibt einen Überblick über die dynamische VLAN Zuweisung von WLAN und LAN Clients ...

Humor (lol)
Würde man Frauen in IT-Klassen einteilen
Information von Henere vor 6 TagenHumor (lol)19 Kommentare

wollen, gäbe es folgende Varianten: Die Internet-Frau: Man muss bezahlen, um sich Zugang zu ihr zu verschaffen. Die Server-Frau: ...

Sicherheits-Tools

TrendMicro WorryFree Business Security 10.0 SP1 - neuer Patch 2179 (Korrekturupdate) verfügbar!

Tipp von VGem-e vor 7 TagenSicherheits-Tools

Servus, grad eben entdeckt, nachdem Patch 2178 zurückgezogen wurde: Gruß

Heiß diskutierte Inhalte
Ubuntu
Linux Ubuntu VNC IP
Frage von 141835Ubuntu60 Kommentare

Wie finde ich bei Linux Ubuntu die IP-Adresse vom VNC Server heraus???

Windows Server
Domaincontroller Windows Server 2003 durch 2016 ersetzen
Frage von MilordWindows Server20 Kommentare

Hallo zusammen, eventuell kann einer von euch weiterhelfen. Ich stecke aktuell etwas fest und komme nicht richtig weiter. Folgende ...

Hyper-V
Hyper-V-Host rebootet - einige wenige Gäste haben danach Ping-Zeiten von über 400ms!
Frage von DerWoWussteHyper-V18 Kommentare

Moin an alle Hyper-V Admins! Hat jemand außer mir schon einmal Folgendes erlebt? Hyper-V auf Server 2019. Server startet ...

Windows Installation
Netzwerkregistrierung mit regsvr32 über UNC Netzwerkpfad ohne Fehlermeldung gescheitert
Frage von RycoDePsycoWindows Installation17 Kommentare

Hallo, ich habe ein Problem und weiß nicht genau woran dies liegen kann. Es gibt ein Server (DomänenController) und ...