gelöst Cisco 897VA Router Probleme mit internetzugriff

Mitglied: theused

theused (Level 1) - Jetzt verbinden

20.11.2020 um 13:28 Uhr, 319 Aufrufe, 5 Kommentare

Hallo zusammen
Ich habe folgendes Problem mit einem Cisco 897VA Router.
Version: Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.5(3)M9, RELEASE SOFTWARE (fc1)
ROM: System Bootstrap, Version 15.2(3r)XC, RELEASE SOFTWARE (fc1)
Und zwar habe ich zum Testen 2 Vlans erstell (sollte im Nachhinein noch mehr werden) die Kommunikation untereinander funktioniert wunderbar.
Das Problem ist das der Interface (in dem fall gig 3) nicht ins Internet routet, zu erwähnen ist das der Cisco 897VA auf den Port eines bestehenden Router b-box 3 steckt, ich hätte ja gerne die Vlans auf der b-box 3 direkt konfigurier doch leider kann das Gerät keine Vlans und wir haben kein Zugriff drauf (er ist nicht von uns).
Die b-box 3 hat die Netzwerkadresse 192.168.1.0/24 mit dem Gateway 192.168.1.1
Vom Cisco 897VA kann ich alle Netzwerke anpingen auch das Gateway der b-box 3, von den Pc im z.b Vlan 10 komme ich auf dem Vlan 20 und auch auf die 192.168.1.2 aber nicht auf dem Gateway der b-box.
Ich habe sehr vieles probiert, komme aber irgendwie nicht weiter
Danke im voraus

Die Aktuelle Konfig

Router#show run
Building configuration...

Current configuration : 2583 bytes
!
! Last configuration change at 11:29:51 UTC Fri Nov 20 2020
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
ip dhcp excluded-address 192.168.10.1 192.168.10.99
ip dhcp excluded-address 192.168.10.200 192.168.10.254
ip dhcp excluded-address 192.168.20.1 192.168.20.99
ip dhcp excluded-address 192.168.20.200 192.168.20.254
!
ip dhcp pool Vlan10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.10.1
domain-name vlan10.home.arpa
!
ip dhcp pool Vlan20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 192.168.20.1
domain-name vlan20.home.arpa
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
license udi pid C897VA-K9 sn FCZ2124E14Y
!
controller VDSL 0
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface Ethernet0
no ip address
shutdown
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
switchport access vlan 20
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
switchport access vlan 99
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan99
ip address 192.168.1.2 255.255.255.0
ip nat outside
ip virtual-reassembly in
!
router rip
version 2
network 192.168.10.0
network 192.168.20.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
access-list 1 permit any
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!

line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
Mitglied: aqui
20.11.2020, aktualisiert um 14:09 Uhr
Das hiesige Tutorial zu dem Thema hast du gewissenhaft gelesen und umgesetzt ??
https://administrator.de/tutorial/cisco-880-890-isr-router-konfiguration ...

Ein paar kleine Tips weil heute Freitag ist:
2 mögliche Fehler ohne deine Routing oder NAT Intention zu kennen...:
  • Mit NAT ==> Du hast vergessen das NAT zu klassifizieren mit:
ip nat inside source list 101 interface vlan99 overload
!
access-list 101 permit ip 192.168.10.0 0.0.0.255 any
access-list 101 permit ip 192.168.20.0 0.0.0.255 any

Ohne dem Router zu sagen WELCHE IP Netze er auf das VLAN 99 Interface outbound NATen soll kann es logischerweise nicht klappen !
  • Ohne NAT ==> Auf dem Cisco NAT Konfigs entfernen und auf deiner "B-Box" eine statische Route: ip route 192.168.0.0 255.255.224.0 192.168.1.2 einrichten. (routet alle IP Netze von 192.168.0.0 bis .31.254 auf den 897)

Wie gesagt je nachdem ob du mit oder ohne NAT auf dem Cisco arbeiten willst oder musst ?!
Und noch ein Tip, da du ja sagst es kommen mehr VLANs dazu:
Statt alle VPN IP Netze einzeln einzutragen kannst du diese auch mit einem einzigen ACL 101 Kommando zusammenfassen:
access-list 101 permit ip 192.168.0.0 0.0.63.255 any
NATet dir dann alle lokalen VLANs von 192.168.0.0 bis 192.168.63.254. Oder
access-list 101 permit ip 192.168.0.0 0.0.127.255 any
alle lokalen VLANs von .0.0 bis .127.254. usw. usw.
Bitte warten ..
Mitglied: theused
20.11.2020 um 16:21 Uhr
* Ohne NAT ==> Auf dem Cisco NAT Konfigs entfernen und auf deiner "B-Box" eine statische Route: ip route 192.168.0.0 255.255.224.0 192.168.1.2 einrichten. (routet alle IP Netze von 192.168.0.0 bis .31.254 auf den 897)

Anscheinet kann man bei der B-Box 3 keine statische Route einrichten, dann werde ich wohl Nat einrichten müssen
Ich werde aber mal dein Tutorial akribisch durchlesen

danke schonmal
Bitte warten ..
Mitglied: aqui
21.11.2020, aktualisiert um 18:54 Uhr
Anscheinet kann man bei der B-Box 3 keine statische Route einrichten
Oha, das ist böse und dann ist das vermutlich genau so ein Schrottrouter wie ein Telekom Speedport, Vodafone Mist und Konsorten.
Dann hast du natürlich keine Chance und musst immer zwangsweise NAT machen. Das ist aber kein Nachteil.

Die Konfig deines Ciscos (relevanter Auszug) sieht dann dafür so aus:
!
interface Vlan10
description Lokales VLAN 10
ip address 192.168.10.1 255.255.255.0
ip nat inside
!
interface Vlan20
description Lokales VLAN 20
ip address 192.168.20.1 255.255.255.0
ip nat inside
!
interface Vlan99
description Internet via B-Box
ip address 192.168.1.2 255.255.255.0
ip nat outside
!
ip nat inside source list 101 interface vlan99 overload
!
access-list 101 permit ip 192.168.10.0 0.0.0.255 any
access-list 101 permit ip 192.168.20.0 0.0.0.255 any

!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!

Du hattest das schon alles richtig gemacht aber mit dem Overload Kommando einfach nur vergessen das NAT auf dem VLAN99 zu aktivieren. Kleiner Fehler...große Wirkung !
Damit sollte es dann sofort klappen.

Sollte es das gewesen sein bitte dann auch
https://administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Mitglied: theused
23.11.2020 um 17:36 Uhr
Ja hat geklappt danke
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerke
Sporadische Ausfälle im gesamten Heimnetz
gelöst bilbo-dvdFrageNetzwerke23 Kommentare

Guten Morgen, ich habe einen Kabelanschluss bei Vodafone und mein Tarif wurde im März auf CableMax 1000 umgestellt. Ich ...

Windows Server
Auslagerungsdatei wird nicht kleiner
GwaihirFrageWindows Server23 Kommentare

Hallo zusammen, gestern hat jemand auf einem unserer Terminalserver (Windows Server 2012 R2) eine Anwendung gestartet, die den RAM ...

Sicherheit
Sicherheit oder bessere Benutzbarkeit?
gelöst StefanKittelFrageSicherheit19 Kommentare

Hallo, ich habe eine Webanwendung programmiert und sehe mich nun mit einer Frage zur Benutzbarkeit konfrontiert. Bei der Anmeldung ...

LAN, WAN, Wireless
Externes Ziel nicht erreichbar vom internen Netzwerk
Stibe88FrageLAN, WAN, Wireless16 Kommentare

Hallo Community Ich habe bei mir Homematic IP installiert. Nun kann ich seit 4 Tagen mich nicht mehr in ...

Internet Domänen
Azure AD deactivate Identity Protection
Jannik2018FrageInternet Domänen15 Kommentare

kann mir einer sagen wie ich beim meiner MS Azure AD Domäne die Identity Protection deactiviere siehe Screenshot sollte ...

Debian
2 ungesyncte Mountpoints an einem Raid 1 ?!?
jrglndmnnFrageDebian13 Kommentare

Hallo die Damen und Herren, Liebe Menschen und Menschinnen! Ich habe folgende Ausgangssituation und bitte, verzeiht mir die kleine ...

Ähnliche Inhalte
Router & Routing
Cisco 897VA WAN
gelöst uncelsamFrageRouter & Routing25 Kommentare

Hallo Zusammen, ich versuche gerade verzweifelt den WAN Anschluss am CISCO 897VA zum laufen zu bekommen, leider klappt das ...

Router & Routing
Cisco 897VA keine IP im Gästenetz
gelöst uncelsamFrageRouter & Routing7 Kommentare

Hallo, leider bekommt mein Gastnetz keine IP vom DHCP zugewiesen Wenn ich allerdings das "ip access-group gastnetz in" im ...

Switche und Hubs
Cisco SG300 - Routing Problem
StandardpasswortFrageSwitche und Hubs15 Kommentare

Okay, wie erwartet bekomme ich die das Routen mit dem SG300 nicht hin. Hier nochmal die gewünschte Zielkonfiguration: VLAN10: ...

Router & Routing
Cisco 2951 VPN Problem
gelöst Serial90FrageRouter & Routing20 Kommentare

Moin Moin, ich habe folgendes Problem mit meinem Cisco: Wir haben einen VPN-Tunnel via SVTI Config zu einem anderen ...

Firewall
Cisco ASA5505 das letzte Problem.
gelöst YannoschFrageFirewall9 Kommentare

Hallo zusammen, ich hoffe ihr hattet ein schönes WE. Bei meiner ASA5505 klappt nun alles. Auch das VPN läuft ...

Windows Netzwerk

Kein Internetzugriff aber Netzwerkzugriff

Jan1986FrageWindows Netzwerk6 Kommentare

Hallo zusammen, ich habe ein komisches Phänomen. Wir haben 1 Nutzer hier im Unternehmen, welcher seit 2 Tagen am ...

Neue Fragen
Administrator Magazin
11 | 2020 Virtualisierung ist aus der IT nicht mehr wegzudenken. In der November-Ausgabe des IT-Administrator Magazins dreht sich der Schwerpunkt um das Thema "Server- und Storage-Virtualisierung". Darin erfahren Sie, wie sich die Virtualisierungstechnologie entwickelt hat, welche Varianten es im Bereich Server und Speicher gibt und wie ...
Neue Beiträge
Neue Jobangebote
Server- und Storage-VirtualisierungServer- und Storage-VirtualisierungBerechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid Cloud