Debian und Apache problem

nitramf
Goto Top
Hallo,

ich habe in einem Hotel einen Server laufen, auf dem Debian installiert ist. Auf diesem Server ist Apache installiert. Der Server ist für ein Hotspot Login Script gedacht. Dieses Script benutzt eine .htaccess, welche aber komischerweise nur im SSL Modus funktioniert. An was liegt das? Falsche Config?

Und der 2. Fehler:
Sobald im Browser (Internet Explorer 7) der SSL Modus anspringt, kommt ein Zertifikatsfehler. An was kann das liegen?

Ich hoffe ihr könnt mir helfen :) face-smile

Gruß,
nitramf

Content-Key: 66342

Url: https://administrator.de/contentid/66342

Ausgedruckt am: 16.05.2022 um 20:05 Uhr

Mitglied: baumpaul
baumpaul 16.08.2007 um 10:09:28 Uhr
Goto Top
1.
Sowas wie das da sollte im virtual host stehen, damit die abfrage mit .htaccess funktioniert.

<Directory /var/www>
AllowOverride Options FileInfo Authconfig
Order allow,deny
Allow from all
</Directory>

Das musst du also in die default site noch eintragen. (War bei mir auch nicht drin)

2.
Zertifkatsfehler mit ".... das Zertifikat gehöhrt ..... und nicht... " ?
Hier musst du beim erstellen der Server-Zertifikate unter common name nicht den
tatsächlichen, physikalischen Rechnernamen benutzen, sondern den Namen des Virtual Host,
also den, den du mit http://<rechner>.<domain>.<ext> rufst.

Greetz
:) face-smile
Mitglied: nitramf
nitramf 16.08.2007 um 10:16:54 Uhr
Goto Top
Hallo,

es gibt auf dem Server keinen Virtuellen Host.

Der .htaccess Quellcode ist schon vorhanden.

htaccess geht ja, aber NICHT im SSL!

Gruß,
Martin
Mitglied: baumpaul
baumpaul 16.08.2007 um 10:47:52 Uhr
Goto Top
.... Dieses Script benutzt eine .htaccess, welche aber komischerweise nur im SSL Modus funktioniert.

...htaccess geht ja, aber NICHT im SSL!

????? Ok ich bin heute noch nicht all zu lange wach, aber ist da nicht ein Widerspruch ?

Gut nun nochmal zur Geschichte mit den Virtual-Hosts.
Die Sites sind ja in Debian hier definiert, oder ?
/etc/apache2/sites-available/
In der default steht nicht sowas wie <VirtualHost _default_:*> ?
Leider habe ich die default Debian-files nicht mehr, weil ich meine Sites von
Debian zu Debian immer mit umziehe und entsprechend der Aufgaben erweitere.
Weiter habe ich die Virtual-Hosts getrennt in <VirtualHost _default_:80> und <VirtualHost _default_:443>

Ich habe letztens für eine Schulung Testseiten mit .htaccess für mit und ohne SSL auf einem Debian etch gemacht
und da funtzt es (visit https://baumpaul.homelinux.net:443)
Name netzwerker, PW netz!Werker
Wenn du willst kann ich dir ja meine configs schicken.