Defektes PoE Netzteil bringt Netzwerk zum wackeln?

easyrider
Goto Top
Hallo zusammen,

wir haben verschiedene physische und virtuelle Server bei uns im Netzwerk. Seit ein paar Wochen haben wir immer mal wieder Netzwerkprobleme und laut Protokollen sieht es so aus, als ob das Netzwerk einen kurzen Aussetzer im Bereich von weniger als eine Sekunde. Die meisten Applikationen verkraften das zum Glück recht gut, jedoch gibt es eine Datenbankanwendung, die damit überhaupt nicht zurecht kommt.

Die Fehlersuche ist hier echt schwierig. Ich habe mittlerweile zwei PoE Netzteile (nicht Switche) im Verdacht.
Haltet ihr das überhaupt für möglich, dass ein defektes PoE Gerät einen Switch / Netzwerk kurzzeitig so stören kann, dass der Verbindungen verliert.

Vorab vielen Dank!

Grüße
Easyrider

Content-Key: 2200300950

Url: https://administrator.de/contentid/2200300950

Ausgedruckt am: 28.06.2022 um 05:06 Uhr

Mitglied: LeReseau
LeReseau 17.03.2022 um 14:04:13 Uhr
Goto Top
Du redest etwas wirr... Einmal von einem PoE Netzteil, was ja wohl (vermutlich) das Netzteil des Switches selber sein soll. Ggf. (geraten...) ein hot swappable Netzteil ?
Und dann mit einmal von einem PoE Endgerät. Also 2 verschiedenen Komponenten.
Welches meinst du denn nun genau ?
Ersteres könnte möglich sein wenn das Netzteil des Switches an sich einen Defekt hat. Letzteres eher weniger, denn PoE bringt diverse Sicherungsoptionen mit die die PoE Stromversorgung schützen.
Zumindestens solange man PoE Standards nach 802.3af bzw. 802.3at nutzt und nicht passive und proprietäre nicht Standard konforme Verfahren einiger Billigheimer. Dazu ja leider auch keine Auskunft von dir. :-( face-sad
Mitglied: Mika909
Mika909 17.03.2022 um 14:05:42 Uhr
Goto Top
Moin,

kannst Du etwas präziser werden? Wie ist das Netzwerk aufgebaut? Die PoE-Netzteile sind wo verbaut? Hängen diese im kompletten Netzwerk und kannst Du Sie nicht entfrnen, um deine Vermutung auszuschließen?

gruß
Mitglied: Anton2812
Anton2812 17.03.2022 um 14:31:57 Uhr
Goto Top
Hallo Easyrider,

welche Hardwareswitche sind im Einsatz ?
Wieviele Switche sind im Einsatz ?
Wie sind die Switche zueinander verkabelt ?
Was sagen die Logfiles ? Gibt es überhaupt Logfiles ?

Und eine kleine Skizze würde ein gemeinsames Verständnis für Deine Installation herstellen.

Als es ist nicht schwierig an präzise Aussagen zu kommen wenn man ein paar kleine Details rausrückt.

Danke und Gruß

Anton
Mitglied: easyrider
easyrider 17.03.2022 um 17:04:14 Uhr
Goto Top
Im Netzwerk arbeiten "normale" (nicht PoE) HP 1820 Switche mit 48 ports.
2x WLAN Access Points, die Strom über ein externes PoE Netzteil erhalten. Diese beiden Netzteile habe ich im Verdacht defekt zu sein. Die Frage ist, haltet ihr es für möglich, dass solche Netzteile ein Netzwerk zum wackeln bringen.
Mitglied: altmetaller
altmetaller 17.03.2022 um 17:18:17 Uhr
Goto Top
Hallo,

dann hänge doch mal ein richtiges Netzteil an die APs, dann weißt Du es.

Gruß,
Jörg
Mitglied: easyrider
easyrider 17.03.2022 um 17:24:29 Uhr
Goto Top
Die APs können nur über PoE betrieben werden.
Mitglied: LeReseau
LeReseau 17.03.2022 aktualisiert um 18:24:00 Uhr
Goto Top
So so...du schreibst selber: "die Strom über ein externes PoE Netzteil erhalten."
Also betreibst du sie nur indirekt über PoE mit einem Injektor ! Korrekte Benennung der Technik würde schneller helfen...
Wenn das Billiginjectoren sind mit billigen China Stecker Schaltnetzteilen kann das gut sein. Leider dazu auch wie gehabt keinerlei Angaben. :-( face-sad
Besorg dir ein Ersatz Steckernetzteil oder Universal Steckernetzteil für kleines Geld und teste das aus. Versuch macht bekanntlich klug !
https://www.reichelt.de/festspannungsnetzteile-c4946.html?&nbc=1
https://www.reichelt.de/universalnetzteile-c4945.html?&nbc=1
Mitglied: altmetaller
altmetaller 17.03.2022 um 18:53:18 Uhr
Goto Top
Hallo,

man könnte testweise einen einfachen Switch davorklemmen.

Gruß,
Jörg
Mitglied: easyrider
easyrider 17.03.2022 um 23:04:26 Uhr
Goto Top
Zitat von @LeReseau:

So so...du schreibst selber: "die Strom über ein externes PoE Netzteil erhalten."
Also betreibst du sie nur indirekt über PoE mit einem Injektor ! Korrekte Benennung der Technik würde schneller helfen...
Wenn das Billiginjectoren sind mit billigen China Stecker Schaltnetzteilen kann das gut sein. Leider dazu auch wie gehabt keinerlei Angaben. :-( face-sad
Besorg dir ein Ersatz Steckernetzteil oder Universal Steckernetzteil für kleines Geld und teste das aus. Versuch macht bekanntlich klug !
https://www.reichelt.de/festspannungsnetzteile-c4946.html?&nbc=1
https://www.reichelt.de/universalnetzteile-c4945.html?&nbc=1

Abgesehen von dem richtigen Begriff PoE Injector verbuche ich Deine Beteiligung jetzt mal unter „er war stets bemüht“. Danke aber darfst dich ab jetzt gerne raushalten.
Mitglied: LordGurke
Lösung LordGurke 18.03.2022 aktualisiert um 01:34:03 Uhr
Goto Top
Das alles klingt aber nicht nach einem Problem, was irgendwie durch defekte PoE-Injectoren verursacht wird.
Also, vielleicht höchstens, wenn ausschließlich WLAN-Clients betroffen sind...

Wenn die Aussetzer im Netz, wie du sagst, wirklich nur 1-2 Sekunden andauern, sollte kein einziger Netzwerkdienst daran zerschellen. TCP, was ich einmal unterstelle, dass es für Datenbankverbindungen genutzt wird, ist darauf ausgelegt, Verbindungen stabil zu halten, die über abstürzende Satelliten bei Gewitter während einem Sonnensturm stattfinden. Während du im Keller sitzt. Da kannst du auch 10 Sekunden das Netzwerk unterbrechen, die Verbindung wird dann einfach fortgesetzt.

Wenn also TCP-Verbindungen in dieser Konstellation abbrechen, dann lässt das aus meiner Sicht nur die folgenden Schlüsse zu:
a) Die Verbindungsunterbrechungen dauern doch deutlich länger als 10 Sekunden - zumindest für die Datenbanken. Das könnte durch STP-Topologieänderungen ausgelöst werden.
b) Ihr habt doppelte IP- oder MAC-Adressen im Netzwerk, z.B. durch geklonte VMs. Oder weil jemand ein Gerät eingeschleppt hat.
c) Ihr habt ein Problem mit einer nicht erwähnten, aber nichtsdestotrotz eventuell trotzdem vorhandenen Firewall, eventuell sogar in Redundanz-Setup, die ein Problem hat.

Als gering wahrscheinlich könnte ein Hardware-Defekt des Switches die Ursache sein, an dem der Datenbank-Server angeschlossen ist. Falls der einen flappy Link hat, könnte auch das TCP-Verbindungen abrupt abbrechen lassen (denn PHY down unterbricht meist alle darauf laufenden TCP-Sitzungen).
Mitglied: jenni
jenni 18.03.2022 aktualisiert um 10:05:19 Uhr
Goto Top
Moin,

wo wohnt ihr?
wurde in letzter Zeit in der nahen Umgebung etwas gebaut, was groß ist?
wie sind deine switche angeschlossen?
USV vorhanden?
Last an der USV?
Zusatnd USV?

kein Witz...
Neue Putzfrau?

Bitte weitere Infos über Netzwerk und Switche
IP-Adressen, auch Leere Netzwerkdosen im Büro von Patchpanel auf Switch gepatched?

Gruß
der jenni
Mitglied: altmetaller
Lösung altmetaller 18.03.2022 um 10:38:30 Uhr
Goto Top
Hallo,

für mich klingt das auch eher wie ein Adresskonflikt.

Oder irgend etwas broadcastet fleißig rum und müllt das Netz zu.

Vielleicht hilft es schon, die „empfindlichen“ Datenbankserver in ein eigenes VLAN zu packen?

Gruß,
Jörg
Mitglied: easyrider
easyrider 18.03.2022 um 10:55:05 Uhr
Goto Top
Ok, Danke euch!
Ja, ich halte es auch für sehr unwahrscheinlich dass ein defekter PoE Injector solche Instabilitäten verursachen kann.
Adresskonflikt, Broadcast-Müll, doppelte MAC- Adressen,....das fühlt sich nach der richtigen Fährte an. Wobei mein alter Chef immer gesagt hat, ich soll ihn mit meinen Gefühlen in Ruhe lassen :D :D

USV ist vorhanden. Es wurden keine größeren Änderungen am Netzwerk oder auch baulich, z.B. neue Kabel gezogen, durchgeführt. Problem ist hier leider auch, dass der Fehler nur super sporadisch auftritt. Mal läuft es 6 Wochen. Mal passiert es 2x am Tag.

Vielleicht schließe ich die Datenbankserver wirklich mal an einen komplett eigenen Switch an oder auch per VLAN.

Nochmals vielen Dank für euren Input!
Mitglied: LeReseau
LeReseau 18.03.2022 um 11:23:42 Uhr
Goto Top
Bitte dann deinen Thread auch als erledigt markieren !
https://administrator.de/faq/32