DHCP Relay N2024

Wir möchten mit unsern Windows 2019 DHCP Server über unsern Dell Switch N2024 ein DHCP Relay aufbauen.

Eckdaten:

DHCP Server Port 3 / 192.168.100.10

VLAN 100 Port 14 / 192.168.100.x

VLAN 200 Port 13 / 192.168.200.x

Und VLAN 200 nimmt keine IP Adresse an.

Konfig lautet:

configure
vlan 100,200
exit
slot 1/0 1 ! Dell EMC Networking N2024
stack
member 1 1 ! N2024
exit
interface vlan 1
ip address 192.168.100.10 255.255.255.0
exit
interface vlan 100
ip address 192.168.100.1 255.255.255.0
exit
interface vlan 200
ip address 192.168.200.1 255.255.255.0
ip helper-address 192.168.100.10
exit
!
interface Gi1/0/13
switchport access vlan 200
dhcp relay - Klicke auf das Bild, um es zu vergrößern

Content-Key: 667452

Url: https://administrator.de/contentid/667452

Ausgedruckt am: 20.06.2021 um 00:06 Uhr

7 Kommentare
Mitglied: NixVerstehen
Servus,

ich hab zwar als Nicht-ITler einen eher laienhaften Blick, aber warum liegt dein DHCP-Server im VLAN1 mit 192.168.100.10
und dein VLAN 100 hat 192.168.100.0/24?

Gruß NV

Edit: Das ist doch dasselbe Netz mit zwei unterschiedlichen VLAN-ID's?
Mitglied: aqui
Das ist auch der grobe Konfig Fehler in diesem Switch Setup. Doppelte IP Netze in den beiden VLAN Segmenten sind ein absolutes NoGo ! Da wurde schon gegen die einfachsten Grundlagen einer simplen IP Adressierung verstoßen.
Folglich kann das so nicht funktionieren.
Das der Switch solch grob fehlerhafte Konfig überhaupt übernimmt spricht auch Bände über die Firmware bzw. Kommando Parser bei den gruseligen Switchgurken von Dell. Billiges OEM von Accton, was erwartet man also... :-( face-sad
Mitglied: NixVerstehen
Uff...ich hab es richtig erkannt. Hatte schon Angst, das es vom Meister wieder eine "Watsch'n" gibt :-) face-smile
@aqui Aber um als Laie auch etwas zu lernen: Warum erhalten die Clients im VLAN 100 dann eine Adresse per DHCP?
Mitglied: dellfreak
Vielen Dank für die Info. Dann werde ich das VLAN 100 erstmal rausnehmen.
Mitglied: NixVerstehen
Ich hab's zwar nicht so mit der CLI, aber wenn ich deine Konfig oben richtig deute, dann hast du dem Switch im VLAN 1 außerdem die Adresse 192.168.100.10 gegeben, die du auch deinem Server zugewiesen hast. Das kann natürlich in keiner Weise funktionieren.

Wenn du die IP des Servers so belassen willst, dann stell den Server ins VLAN 100, nimm die Clients aus dem VLAN 100 und setz die meinetwegen in ein VLAN 300.

Switch:

VLAN 1 - Netz 192.168.1.0/24 - Interface IP 192.168.1.1 (untagged / Management-VLAN)
VLAN 100 - Netz 192.168.100.0/24 - Interface IP 192.168.100.1
VLAN 200 - Netz 192.168.200.0/24 - Interface IP 192.168.200.1
VLAN 300 - Netz 192.168.300.0/24 - Interface IP 192.168.300.1

Dann im Switch noch das DHCP-Relay auf 192.168.100.10, auf dem Server die DHCP-Scopes anlegen, idealerweise dem DHCP das Schreiben in DNS gewähren (mit einem separaten Benutzerkonto) und dann läuft das ja. In ein Konfig-File kannst du es selbst packen, ich hab's nicht mehr so mit dem CLI.

Gruß NV
Mitglied: dellfreak
Es lag daran, die IP Pakete kamen zum DHCP Server an, der konnte Sie nicht verarbeiten. Da der DHCP Server nicht im IP Kreis der VLANs war.
Mitglied: aqui
Da der DHCP Server nicht im IP Kreis der VLANs war.
Ohh man...an solche Banalitäten denkt man schon gar nicht mehr in einem Adminitrator Forum. Ist ja so als ob man in den Urlaub will aber vergessen hat zu tanken !!
Trotzdem mutig das du dich hier mit sowas geoutet hast ! Respekt !

Dennoch ist auch dein IP Setup oben mit der doppelten IP Adressierung ein kapitaler Konfig Fehler der niemals so bleiben sollte !! Das verstößt gegen alle Standards.
Wie gesagt, das der Dell vom Kommando Parser so einen fatalen Unsinn überhaupt zulässt und nicht wie bei allen anderen üblich mit einer Konfig Error Meldung reagiert, spricht natürlich auch ne deutliche Sprache zu dieser Gruselhardware... :-( face-sad Das kann jeder Chinesen Switch vom Blödmarkt besser.
Case closed !
Heiß diskutierte Beiträge
Windows 10
Austritt Mitarbeiter - Windows- u. M365 Konto
gelöst NixVerstehenVor 1 TagFrageWindows 1011 Kommentare

Moin zusammen, ich habe hier im Kleinunternehmen tatsächlich zum ersten Mal die Situation, das eine Mitarbeiterin aus dem kaufmännischen Bereich ausscheiden wird. Die Kollegin ist ...

Netzwerke
Kassen freezen ohne ersichtlichen Grund
Ronic1Vor 18 StundenFrageNetzwerke12 Kommentare

Hallo Zusammen, ich schreibe heute zum ersten Mal in diesem Forum. Also weißt mich bitte auf etwaige Fehler meinerseits hin. Wie ich in anderen Beiträgen ...

Windows Server
Always-on-VPN mit einer Netzwerkkarte
bluelightVor 1 TagFrageWindows Server11 Kommentare

Hallo zusammen, ich bin tatsächlich einmal auf eure Hilfe angewiesen! Ich habe für unser Unternehmen ein Domänennetzwerk auf einem Rootserver von Netcup erstellt und weitestgehend ...

Microsoft
Wird die durch den DHCP zugewiesene IP-Adresse in der Ereignisanzeige gespeichert?
stephan.csVor 1 TagFrageMicrosoft6 Kommentare

Guten Morgen zusammen, leider bin ich mit meiner Recherche bis jetzt nicht weiter gekommen. Darum die Frage Wir haben folgende Situation: - Windows 10 Clients ...

Installation
Setup mit automatischen Klicks
akadawaVor 1 TagFrageInstallation9 Kommentare

Moin, ich habe eine Installation welche ich gerne über das Softwarecenter vom SCCM installieren lassen möchte. Leider lassen die Parameter der Setup.exe es nicht zu, ...

Windows Netzwerk
PRTG Probe erkennt Lancom Router nicht mehr
gelöst blackarchVor 1 TagFrageWindows Netzwerk6 Kommentare

Hallo zusammen, die o.g. Probe ist auf dem Server eines Standortes installiert und lief bis dato problemlos. Gestern fiel nun der Ping für den Router ...

Windows 10
PDF Datei wird falsch angezeigt
ben1300Vor 1 TagFrageWindows 107 Kommentare

Hallo zusammen, habe hier eine PDF Datei, welche auf einem Macbook (Big Sur) und einem Windows 10 Prof. x64 Client problemlos dargestellt wird. Nun kommt ...

TK-Netze & Geräte
Starface mit NGN verliert Gateway
FabezzVor 18 StundenFrageTK-Netze & Geräte9 Kommentare

Guten Morgen zusammen, ich hoffe dass ich das richtige Thema getroffen habe. In unserer Firma wurde beschlossen dass die in die Tage gekommene Openscape ausgetauscht ...