Druckerwarteschlange hängt sich beim drucken auf

Hallo Zusammen,

ich bitte um euer Schwarmwissen, da ich mittlerweile echt auf dem Schlauch stehe und nicht mehr weiß was ich noch umstellen soll/kann.

Folgende Konstellation:

Windows Server 2019 Standard im Active Directory - daran angeschlossen 19 Multifunktionsgeräte, welche über dem im Windows Server bereitgestellten Druck-Server Drucke empfangen und abarbeiten sollen.

Grundsätzlich funktioniert dies auch soweit, aber es gibt immer wieder Fehler, bei denen sich ein Druckauftrag "aufhängt" (wie im angehängten Foto zu sehen) und dadurch die Print-Queue des Druckers blockiert.

Es kommt mir so vor, als würde sich die Queue beim Spoolen des Dokumentes aufhängen.

Der Druckauftrag lässt sich dann auch nicht einfach löschen, sondern muss erst einmal gelöscht werden, dann wird der Druckspooler des gesamten Servers neu gestartet, dann wird der Druckauftrag nochmal gelöscht, der Spooler neu gestartet und dann ist der fehlerhafte Auftrag erst weg und die folgenden, noch in der Queue befindlichen Druckaufträge werden abgearbeitet.

Wir konnten mittlerweile relativ gut eingrenzen, was dieses Phänomen auslöst:

- Wenn eine Bilddatei (jpeg/png) oder ein PDF aus dem Internet im Webbrowser geöffnet und ausgedruckt wird. - Wobei es hier egal ist, welcher Web-Browser verwendet wurde.
- Wenn es ein angehängtes Bild (Jpeg/png)aus einer Mail im Outlook ist.
- Wenn das Bild mit der Windows-Foto-App oder Paint3D geöffnet wird.

Es tritt auch nicht bei jedem Foto/PDF und bei jedem Benutzer auf, aber wenn man genug Benutzer und Ausdrucke am Tag hat, die feststecken wird es leider echt nervig für alle Beteiligten.


Wir haben auf dem Server schon alle Konfigurations-Optionen für die Printqueue der Geräte gesetzt/rausgenommen:

- Bidirektionale Unterstütung ein/aus
- Über den Spooler drucken - in sämtlichen Variationen
- Druckaufträge im Spooler zuerst drucken ein/aus
- Erweiterte Druckfeatures aktiviert an/aus

Die Druckertreiber haben wir auch einmal neu gemacht, teilweise auch schon den Drucker komplett neu eingerichtet.

Das Phänomen tritt nicht auf, wenn wir den Drucker auf den Clients lokal installieren und als Anschluss dann auf die IP-Adresse drucken lassen.

Somit kann man die Geräte und den Treiber eigentlich ausschließen und es muss am Server irgendwas sein.

Ich würde mich über Hinweise freuen, was man noch versuchen könnte.

Viele Grüße
druckspooler_fehler

Content-Key: 1259177916

Url: https://administrator.de/contentid/1259177916

Ausgedruckt am: 25.09.2021 um 16:09 Uhr

Mitglied: Pjordorf
Pjordorf 14.09.2021 um 20:49:09 Uhr
Goto Top
Hallo,

Zitat von @Stormsoul:
Ich würde mich über Hinweise freuen, was man noch versuchen könnte.
Was ist mit den Papierformaten? Nicht überall in der Welt gilt als Standard das DIN A4, sodass mal ein Bild als Letter Size gedruckt werden will. Nicht jede Anwendung kann da problemlos mit umgehen und manche Drucker/MFP streiken da auch.

Gruß,
Peter
Mitglied: departure69
departure69 15.09.2021 um 08:42:10 Uhr
Goto Top
@Stormsoul:

Hallo.

Die Druckertreiber haben wir auch einmal neu gemacht, teilweise auch schon den Drucker komplett neu eingerichtet.


Immer wieder ein Thema, besonders bei Servern.

Ich habe in 20 Jahren Umgang mit Windows-Servern & Drucken die Erfahrung gemacht, daß bei Treibern genau aufgepasst werden muß.

- nicht immer ist der neueste Treiber der beste oder passendste Treiber

- fette Treiberpakete, die neben dem reinen Druckertreiber noch irgendwelche herstellerspezifischen, mitunter exotischen Extras mitbringen, würde ich allerhöchstens auf Clients installieren, doch niemals auf Servern

- auf Servern installiere ich deshalb immer nur den nackigen Treiber (der dann auch meist bloß wenige hundert KB groß ist, wenn überhaupt)

- ich gebe PCL (5 oder 6) - Treibern immer den Vorzug vor allen anderen Treibern, die der Hersteller so anbietet

- idealerweise haben die Hersteller ihre Treiber von/bei Microsoft zertifizieren lassen, erkennbar an den Kürzeln "HCL" oder "WHCL"

- auch die Bezeichnung "Classic" ist ein Hinweis auf hohe Kompatibilität

- oft genügt der Treiber, den das Server-OS mitbringt (falls passend vorhanden)

- in den letzten 10-15 Jahren gibt es vor allem bei den großen, bekannten Druckerherstellern (mir fallen da als Beispiele HP und Lexmark ein) sogenannte "Universaltreiber", auch diesen kann ich aus eigener Erfahrung eine hohe Kompatibilität (und dadurch wenig bis keine Probleme beim Drucken) bescheinigen


Prüf' den/die bei Euch eingesetzten Treiber mal auf diese Punkte.

Ansonsten hab' ich jetzt keinen Vorschlag, Deiner Beschreibung nach hast Du ja schon sehr viel ausprobiert.


Viele Grüße

von

departure69
Mitglied: Drohnald
Drohnald 15.09.2021 um 09:54:30 Uhr
Goto Top
- in den letzten 10-15 Jahren gibt es vor allem bei den großen, bekannten Druckerherstellern (mir fallen da als Beispiele HP und Lexmark ein) sogenannte "Universaltreiber", auch diesen kann ich aus eigener Erfahrung eine hohe Kompatibilität (und dadurch wenig bis keine Probleme beim Drucken) bescheinigen
Kann ich nur bestätigen.
Das hat auch den Vorteil, dass diese Universal ("HP Universal print driver" oder "Canon Generic Plus" oder wie sie alle heißen) schon auf den Clients sind. Kommt also ein neuer Drucker des gleichen Herstellers, müssen die Clients keine neuen Treiber installieren. Schöne Geschichte, vor allem mit der aktuellen PrintNightmare Thematik.
Mitglied: Stormsoul
Stormsoul 15.09.2021 um 10:41:48 Uhr
Goto Top
Guten Morgen :) face-smile

Vielen Dank für die Tips, das mit dem Papierformat sehe ich mir nochmal an.

Die Geräte sind Multifunktionsgerät von Ricoh, der Treiber den wir verwenden, ist der Ricoh eigene PCL6 - Universaltreiber.

Auch die nochmal neu eingerichteten Treiber basieren ebenfalls auf den gleichen Universaltreibern von Ricoh.
Wir haben lediglich die Queue des Druckers und das Treiberpaket einmal neu erzeugt.

Wir müssen halt da die Abrechnungscodes eingepflegt haben, das wird aber mit der Original-Konfigurationssoftware von Ricoh gemacht.

Ansonsten sind die Treiber nur mit Standard-Einstellungen versehen. Irgendwelche exotischen Einstellungen haben wir nicht vorgenommen. Wir haben keinerlei Sonderfeatures installiert. Es sind wirklich nur die reinen Treiber.


Liebe Grüße
Mitglied: departure69
departure69 15.09.2021 um 17:06:07 Uhr
Goto Top
@Stormsoul:

Alles O.K., sollte ja auch bloß ein weiterer möglicher Hinweis sein, wonach man noch schauen könnte. Vielleicht sammelt sich hier noch was.

Viele Grüße

von

departure69
Heiß diskutierte Beiträge
general
DSL-Modems am F-Buchse statt N-Buchse - warum?Windows10GegnerVor 22 StundenAllgemeinDSL, VDSL19 Kommentare

Hallo zusammen, es sind jetzt hier die Fernmeldetechniker gefragt. Normalerweise wird ja ein DSL-Modem mit der F-Buchse einer TAE-NFN-Dose verbunden. Was ist der genau Grund ...

general
Autodesk im Jahre 2021-2022dertowaVor 1 TagAllgemeinOff Topic4 Kommentare

Hallo zusammen, mal eine kleine Anekdote, u.a. da heute Freitag ist. Vor einigen Jahren hatte ich mit Autodesk AutoCAD LT zu tun, in der damaligen ...

general
Außergewöhnliche hohe Spamaktivitäten und Angriffe per E-Mail gelöst beidermachtvongreyscullVor 1 TagAllgemeinE-Mail5 Kommentare

Tach Kollegen, liegt das an den bevorstehenden Wahlen? Ich beobachte seit Tagen auf unserer Firewall, dass wir massiven Spamwellen ausgesetzt sind. Bisher kommt zum Glück ...

question
Einrichtung Unify Security Gateway gelöst markaurelVor 17 StundenFrageLAN, WAN, Wireless9 Kommentare

Hallo zusammen und bitte um eure Hilfe! Wie der Titel schon sagt Folgende Situation: Ich hab ein Netzwerk in folgenden IP-Bereich: 192.168.10.x. Als Gateway dient ...

question
Backup-Server, welcher sich selber sichertludakuVor 1 TagFrageBackup6 Kommentare

Moin Zusammen Stellen wir uns kurz folgendes Konstrukt vor: 1x Hypervisor mit 3 VMs: - DC & Fileserver - Webserver - Acronis Backup-Server Ist es ...

question
Sysprep nachträglich virtualisierenalf008Vor 1 TagFrageVmware6 Kommentare

Hallo, ich habe diverse physikalische Server virtualisiert und später sollten diese in eine neue Domäne aufgenommen werden. Leider habe ich beim Virtualisieren erst später (zu ...

question
Wlanprobleme nach Providerwechsel gelöst amsti70Vor 1 TagFrageRouter & Routing8 Kommentare

Hallo alle zusammen! Ich bin neu auf dieser Seite und komme gleich mit einem Problem. Habe jetzt von A1 auf Drei Festnetz gewechselt. Mein System ...

question
Exchange Autodiscover ExternredhorseVor 1 TagFrageExchange Server5 Kommentare

Guten Morgen, bei Heise wird aktuell über eine Problematik berichtet, bei der es bei einem nicht nach Microsoft-Vorgaben konfiguriertem Autodiscover zu einem Sicherheitsproblem kommt: Konkret ...