Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Eigener Server aus dem Firmennetz mit Firefox und IE nicht erreichbar. Fehlermeldung SSL ERROR RX RECORD TOO LONG

Mitglied: SKB-CGN

SKB-CGN (Level 1) - Jetzt verbinden

29.05.2020, aktualisiert 08:18 Uhr, 449 Aufrufe, 22 Kommentare

Hallo,
ich habe einen eigenen Server mit einer *.koeln Domain.
Diesen konnte ich bis vor 2 Tagen aus dem Firmennetz (VPN) noch erreichen. Jetzt auf einmal meldet Firefox diesen o.g. Fehler.

Seltsamerweise erreiche ich die www-Domain nicht, kann aber die Subdomain webmail.xxx.koeln erreichen.

Ich habe bei mir nichts verändert. Scheinbar wurden beim Firmennetz Einstellungen angepasst.
Kann mir jemand helfen, wie ich hier vorgehen kann, damit ich die Seite wieder erreiche?

Die Seite läuft auf einem Nginx Server und wird über einen Apache Reverse Proxy bereit gestellt.

Vielen Dank!
Mitglied: erikro
29.05.2020 um 08:48 Uhr
Moin,

Zitat von SKB-CGN:
ich habe einen eigenen Server mit einer *.koeln Domain.

Also Dein privater oder der der Firma?

Diesen konnte ich bis vor 2 Tagen aus dem Firmennetz (VPN) noch erreichen. Jetzt auf einmal meldet Firefox diesen o.g. Fehler.

Guckst Du hier: https://www.ssl247.de/kb/ssl-certificates/troubleshooting/apache/ssl-err ...

Ich habe bei mir nichts verändert. Scheinbar wurden beim Firmennetz Einstellungen angepasst.

Bricht da vielleicht die Firma https auf, um mitlesen zu können? Zwangsproxy?

Liebe Grüße

Erik
Bitte warten ..
Mitglied: SKB-CGN
29.05.2020 um 09:01 Uhr
Ja, ist mein privater Server, der auf einem FreeBSD läuft.

Wenn ich den Server bei ssllabs teste, bekomme ich ein A+.
Nur bei 2 Cipher zeigt es mir "weak" an.
Sollte ich diese vielleicht entfernen?

2020-05-29 08_58_41-ssl server test_ webmail.kreyenborg.koeln (powered by qualys ssl labs) - Klicke auf das Bild, um es zu vergrößern

Der Proxy wird als automatisches Skript in unseren Browsern eingefügt. Nun weiss ich nicht, was an meiner Seite "schlimm" sein soll.
Dort läuft ein Wordpress und man kann sich Informationen zu Smart-Home durchlesen.

Habe ich die Möglichkeit, herauszufinden, was genau den Proxy stört?
Bitte warten ..
Mitglied: erikro
29.05.2020 um 09:16 Uhr
Hast Du die Seite gelesen, die ich verlinkt habe? Die Meldung heißt: SSL/TLS wurde erwartet, unverschlüsselt kam an.

The web server is sending non-secure (HTTP) data where secure (HTTPS) data is expected by Firefox. This can be confirmed by going to http://server-name:443 instead of https://server-name.

Tritt der Fehler denn nur in der Firma auf? Oder auch bei anderen?
Bitte warten ..
Mitglied: SKB-CGN
29.05.2020 um 09:37 Uhr
Klar, habe die Seite gelesen und auch mit meiner *.conf verglichen.
Auch sollte ja die SSL Test Seite einen Fehler ausspucken, wenn SSL nicht richtig konfiguriert ist.

Das Problem habe ich an meinem Firmenrechner auch nicht, wenn ich außerhalb des VPN bin - dann wird der Firmen-Proxy nicht genutzt.

Kannst gerne die Seite mal anschauen, ob dort etwas "Fehlerhaftes" ist, was ich nicht sehe.

https://www.kreyenborg.koeln (geht nicht aus dem VPN)
https://webmail.kreyenborg.koeln (geht aus dem VPN)

beide Seiten liegen auf dem gleichen Jail und nutzen den gleichen Server
Bitte warten ..
Mitglied: erikro
LÖSUNG 29.05.2020 um 09:58 Uhr
Moin,

Zitat von SKB-CGN:

Klar, habe die Seite gelesen und auch mit meiner *.conf verglichen.
Auch sollte ja die SSL Test Seite einen Fehler ausspucken, wenn SSL nicht richtig konfiguriert ist.

Es gibt auf Deiner Seite keinen Fehler. Die Zertifikate scheinen in Ordnung. Es ist ja auch bei beiden dasselbe Wildcard-Zertifikat.

Das Problem habe ich an meinem Firmenrechner auch nicht, wenn ich außerhalb des VPN bin - dann wird der Firmen-Proxy nicht genutzt.

Frage mal Deine Admins, ob hier (teilweise) evtl. versucht wird SSL/TLS aufzubrechen, um mitlesen zu können. Das ist das, was ich vermute. Wenn es vom Prinzip geht und nur in der Firma nicht, dann würde ich Deine Konfiguration erst einmal als korrekt ansehen.

Liebe Grüße

Erik
Bitte warten ..
Mitglied: SKB-CGN
29.05.2020 um 10:52 Uhr
Danke, das beruhigt mich schonmal.
Man übersieht ja mal leicht etwas bei den ganzen Konfigurationen

Kannst Du vielleicht kurz erläutern, wie dieses SSL/TLS aufbrechen geht?
Wieso aber dann meine Seite nicht läuft, aber z.B. administrator.de schon
Bitte warten ..
Mitglied: erikro
29.05.2020 um 11:25 Uhr
Moin,

Zitat von SKB-CGN:
Kannst Du vielleicht kurz erläutern, wie dieses SSL/TLS aufbrechen geht?

Vom Prinzip so:
Die Clients werden so konfiguriert, dass sie zwangsweise auf einen Proxy zugreifen müssen. Es besteht also keine direkte Verbindung ins Internet. Dann stelle ich den Proxy so ein, dass er bei Anfragen per https diese nicht 1:1 an den Server weitergibt, sondern die Originalanfrage abfängt und selbst mit dem Zielserver eine https-Verbindung aufbaut. Der Zielserver benutzt nun zum Verschlüsseln die Sitzungskeys, die mit dem Proxy ausgehandelt werden. Der kann nun entschlüsseln und ich kann mitlesen. Wenn ich es ganz geschickt mache, dann installiere ich noch auf dem Client eine CA als vertrauenswürdig, mit deren Zertifikaten ich nun wiederum zwischen dem Proxy und dem Client eine https-Verbindung aufbaue. Dann merkt der User nur dann was, wenn er sich das Zertifikat ansieht.

Wieso aber dann meine Seite nicht läuft, aber z.B. administrator.de schon

Das musst Du Deine Admins fragen.

Liebe Grüße

Erik
Bitte warten ..
Mitglied: SKB-CGN
29.05.2020 um 11:29 Uhr
Danke für die Erläuterung.
Ich habe einen der Admins gefragt und er sagte mir, dass vor etwa 3 Tagen ein neues CA installiert wurde.
Ich denke, dies deckt sich sehr mit Deiner Aussage.

Kann ich dieses Zertifikat irgendwo sehen?
Bitte warten ..
Mitglied: erikro
29.05.2020 um 11:32 Uhr
Zitat von SKB-CGN:

Danke für die Erläuterung.
Ich habe einen der Admins gefragt und er sagte mir, dass vor etwa 3 Tagen ein neues CA installiert wurde.

AH!

Ich denke, dies deckt sich sehr mit Deiner Aussage.

Kann ich dieses Zertifikat irgendwo sehen?

Ja klar. Welcher Browser? Meist neben der URL in der Adresszeile ist ein kleines Schloss. Wenn Du da drauf klickst, kannst du feststellen, welches Zertifikat für die Verbindung genutzt wird. Sollte man aber wissen, wenn man eine Website betreibt.
Bitte warten ..
Mitglied: SKB-CGN
29.05.2020 um 11:47 Uhr
Das ist klar ;)

Ich meinte eher das "neue" CA Zertifikat. Mein eigenes Zertifikat kenne ich ja
Bitte warten ..
Mitglied: erikro
29.05.2020 um 12:52 Uhr
Zitat von SKB-CGN:

Das ist klar ;)

Ich meinte eher das "neue" CA Zertifikat. Mein eigenes Zertifikat kenne ich ja

Einmal kannst Du in der Zertifikatsverwaltung nachschauen, welche Stammzertifikate installiert sind. Ansonsten meinte ich das auch eher so, dass Du, wenn Du verbunden bist, mal schaust, ob da wirklich Dein Zertifikat benutzt wird oder irgend etwas anderes.
Bitte warten ..
Mitglied: SKB-CGN
29.05.2020 um 14:23 Uhr
Also, wenn ich verbunden bin und meine Seite z.B. webmail besuche, erscheint mein Zertiikat.
Wenn ich www.kreyenborg.koeln besuche, dann erscheint keine Seite, da er die SSL Settings anmeckert.

Mal weitersuchen, woran es noch liegen könnte.

Danke!
Bitte warten ..
Mitglied: Spirit-of-Eli
31.05.2020, aktualisiert um 19:51 Uhr
Zitat von SKB-CGN:

Also, wenn ich verbunden bin und meine Seite z.B. webmail besuche, erscheint mein Zertiikat.
Wenn ich www.kreyenborg.koeln besuche, dann erscheint keine Seite, da er die SSL Settings anmeckert.

Mal weitersuchen, woran es noch liegen könnte.

Danke!

Moin,

wenn du z.b. einen Chrome Browser nutzt, kannst du bei der Seite F12 drücken und unter Sicherheit sehen, was genau angemeckert wird.

Gruß
Spirit
Bitte warten ..
Mitglied: SKB-CGN
31.05.2020 um 20:04 Uhr
Danke!
Wir nutzen firmlich leider den Firefox.
Bitte warten ..
Mitglied: Spirit-of-Eli
31.05.2020 um 20:35 Uhr
Zitat von SKB-CGN:

Danke!
Wir nutzen firmlich leider den Firefox.

Der hat genauso "Entwickler Optionen". Die sind dort oben rechts in dem Menü zu finden.
Bitte warten ..
Mitglied: SKB-CGN
31.05.2020 um 21:45 Uhr
Da konnte ich leider nichts entdecken.
Daher suche ich noch, wo der Fehler liegen könnte...
Bitte warten ..
Mitglied: SKB-CGN
31.05.2020 um 23:18 Uhr
Danke für den Artikel.
Wo genau soll ich dort denn eine Hilfestellung für mein Problem finden?
Bitte warten ..
Mitglied: Spirit-of-Eli
31.05.2020 um 23:25 Uhr
Du sollst dir in den Entwickler Optionen den security Bereich anschauen. Dort steht auch wieso dein Zertifikat angemeckert wird.
Bitte warten ..
Mitglied: SKB-CGN
02.06.2020 um 07:58 Uhr
Ich soll .... aber wo?

2020-06-02 07_57_19-seiten-ladefehler - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Spirit-of-Eli
02.06.2020 um 17:01 Uhr
Schneller geht es nur oben in der Leiste, neben dem Link. Dort klickst du auf das Schild. Dann auf den Pfeil rechts neben dem Schloss.
Anschließend auf "Weitere Informationen".

Dann werden die nötigen Punkte aufgelistet.
Ich habe jetzt gerade extra deswegen Firefox installiert.
Bitte warten ..
Mitglied: SKB-CGN
02.06.2020 um 17:07 Uhr
Soweit komme ich ja erst gar nicht.
Die Seite wird direkt vom Firmen-Proxy blockiert und ich versuche ja herauszufinden, wo das Problem liegt.

2020-06-02 17_05_57-seiten-ladefehler - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Ähnliche Inhalte
DNS

Interne und Externe Domainname gleich - SSL ERROR RX RECORD TOO LONG

gelöst Frage von JuckieDNS3 Kommentare

Guten Morgen zusammen, wir haben eine interne Windows Domäne welche "meinefirma.de" heißt. Nun haben wir auch eine externe Domain ...

Apache Server

SSL received a record that exceeded the maximum permissible length. Error code: SSL ERROR RX RECORD TOO LONG

gelöst Frage von ukl1967Apache Server4 Kommentare

Hallo, ich hatte versucht ein GetSimpleCMS zu installieren und meine apache2.conf editiert. Nachdem die Installation nicht funktionierte entfernte ich ...

Drucker und Scanner

HP 2015n-Probleme, Page too complex Error

Frage von cardischDrucker und Scanner5 Kommentare

Hi@all zunächst der Zustand bis ca. Januar diesen Jahres: Arztpraxis: VM W2008R/2 (ESXi), dieser dient auch als Printserver. Da ...

Linux

Grub Error 17 Fehlermeldung

gelöst Frage von M.MarzLinux2 Kommentare

Hallo zusammen, wollte man das Androidx86 auf meinem VMplayer installieren. Nach der installation kommt die o. g. Meldung mit ...

Neue Wissensbeiträge
Off Topic

Im Tel Raum von Hamburg (040) sind mal wieder viele Indische Microsoft Anrufer unterwegs

Information von TomTomBon vor 20 StundenOff Topic3 Kommentare

Moin Moin, Die sind so schlecht das sogar meine Frau sofort die erkannt hat was die sind. Und Ihr ...

Router & Routing

FritzOS 7.20 kommt auch auf Deine Fritze (wahrscheinlich)

Information von Visucius vor 1 TagRouter & Routing10 Kommentare

Nachdem ich hier die Hassliebe zu den kleinen Kistchen kenne, sollten wir das nicht zu breit ausdehnen. Ein paar ...

Netzwerke

PfSense VPN mit L2TP (IPsec) Protokoll für mobile Nutzer

Anleitung von aqui vor 1 TagNetzwerke

Allgemeine Einleitung Das folgende VPN Tutorial ist eine Ergänzung zum bestehenden VPN_Client_Tutorial. Es beschreibt ebenfalls die VPN Anbindung von ...

Datenschutz

Berliner Datenschutzbeauftragten prüfen Videokonferenz-SW

Information von Visucius vor 4 TagenDatenschutz2 Kommentare

Eine grüne Ampel erhielten kommerziell bereitgestellte Instanzen der Open-Source-Software Jitsi, etwa von Netways oder sichere-videokonferenz.de. Eine positive Bewertung erhielten ...

Heiß diskutierte Inhalte
Windows Server
Domäne nach Ausfall eines DC komplett gestört
Frage von thaddaeus93Windows Server42 Kommentare

Hallo Zusammen, wir haben hier zwei DC's (einen 2011 SBS und einen 2016 Standard) - ursprünglich sollte die Migration ...

Windows Server
GPO Kennwortrichtlinie wird nicht angewandt
Frage von SabSchapWindows Server34 Kommentare

Hallo, ich habe per GPO Default Domain Policy unter "Computer" die Kennwortrichtlinie definiert. Das Kennwort soll nach 365 Tage ...

VB for Applications
VBS wird nach Anmeldung (Aufgabenplanung) nicht richtig ausgeführt
gelöst Frage von MrLabelVB for Applications30 Kommentare

Hallo, ich habe ein VB Script geschrieben, welches morgens mit der Aufgabenplanung gestartet wird. (Ich weiß die Lösung ist ...

Festplatten, SSD, Raid
Raid5 SAS HDD auf RAID10 SSD ML350 G8
gelöst Frage von DCFan01Festplatten, SSD, Raid25 Kommentare

Hallo Community, ich habe hier bei mir einen HPE ML350G8, mit P440 Raid-Controller und derzeit 4x SAS 10K HDD ...