Exchange 2013 Neuinstallation: kein Zugriff auf Exchange Administrative Center

bonnerjung
Hallo zusammen!

Vorgeschichte:

Dies ist mein zweiter neuer Server 2012 R2, den ich aufgesetzt habe.
Steht z.Zt. hier bei mir für die Grundinstallation.
Installierte Rollen: AD DS; AD-Zertifikatdienste; Anwendungsserver; Datei/Speicherdienste; DHCP; DNS; IIS; WSUS
Alles ohne Probleme wie bei Server 1, der mittlerweile seit ein paar Monaten ohne Probleme seinen Dienst versieht.

Dieser Server soll aber auch Exchange 2013 bekommen.
(Habe bisher einmal Exchange auf einem Server 2008 SMB konfiguriert. Danach nicht mehr.)

Als Erstes bin ich die Installationsvoraussetzungen und Vorbereitungen mehrfach durchgegangen.
Wird ja alles ausführlich z.B. auf
Technet

beschrieben. Zudem gibt es diverse gute YouTube Kanäle.
Youtube
Auch hier habe ich mich informiert.

ALSO:
Installiert wie auf technet beschrieben.
Das aktuelle Paket:
Exchange2013-x64-cu13

Die Installation läuft ohne Fehler.
Nur letztendlich scheitert der Zugriff auf das "Exchange Administrative Center".

Bevor ich jetzt die komplette Konfiguration des Servers hier aufliste, was ich aber gerne nachholen kann, hat vielleicht einer das gleiche Problem gehabt und sofort den Ansatz zur Lösung parat!

3 x habe ich die Installation nach Rücksetzen auf vorherigen Systemzustand wiederholt.

Starte ich das EAC:
https://localhost/ecp/?ExchClientVer=15
erhalte ich
zwischenablage01
Hierbei wird keine Eingabe akzeptiert.

Habe dann AD-Zertifikatdienste nach Anleitung installiert (obwohl ich davon überhaupt keine Ahnung habe)
Zertifikatdienste installieren
Hilft auch nicht weiter.

Aufruf von: https://192.168.5.55:444 (Server IP Adresse)
zwischenablage03

Füge ich die Ausnahme hinzu, bekomme ich:

Aufruf von: https://localhost:444
zwischenablage02



Beim Aufruf der Management Shell:


Gebe ich dann BBB.CCC ein, kommt noch mal die Meldung:


Was ist bloß schiefgelaufen?

Danke an alle Mitdenker.

Content-Key: 315010

Url: https://administrator.de/contentid/315010

Ausgedruckt am: 22.01.2022 um 21:01 Uhr

Mitglied: tomolpi
tomolpi 11.09.2016 um 17:52:38 Uhr
Goto Top
Zitat von @bonnerjung:
Was ist bloß schiefgelaufen?

Du hast Exchange auf einem Domänencontroller installiert... Das hat sich wahrscheinlich jetzt gerächt.

Oder warum hat dein Server die AD-Rolle? Exchangeserver sind NIE DCs, immer nur Memberserver (esseidenn sie sin ein SBS).

LG,

tomolpi
Mitglied: 129813
129813 11.09.2016 aktualisiert um 18:07:31 Uhr
Goto Top
AD DS; AD-Zertifikatdienste; Anwendungsserver; Datei/Speicherdienste; DHCP; DNS; IIS; WSUS
And on this fully overloaded machine you want to put an Exchange ?? WTF, are you kidding :-D face-big-smile? No wonder you get these problems.

Regards
Mitglied: wiesi200
wiesi200 11.09.2016 um 21:28:32 Uhr
Goto Top
Hallo,

so nebenbei. Warum Port 444?
Https ist normal 443 was in der Anleitung auch so beschrieben ist und man in der URL nicht angeben muss. Oder bist du absichtlich auf nen anderen Sport gegangen?
Mitglied: Chonta
Chonta 12.09.2016 um 10:38:54 Uhr
Goto Top
Hallo,

mit welchem Konto hast Du den Exchange installiert?
Mit dem Default Administrator der Domäne oder einem anderen Domainadministratorkonto?

Einen Exchange auf einer Windows CA zu betreiben halte ich für eine sehr schlechte Idee!
Sobald eine Windows CA auf einem Rechner installiert ist, hat dieser Rechner einige Besonderheiten und Einschrenkungen.
Davon abgesehen das ein DC wenn überhaupt maximal noch Fileserver seoin sollte aber am besten nur DC und nix anderes (viele Gründe)

Exchange will den IIS konfigurieren, aber die Zertifikatsdienste die schon installiert sind haben was dagegen.
Wenn es so und nicht anders geht musst Du mal googeln nach Exchange auf Windows CA installieren.
Evtl muss der Exchange zuerst laufen und dann die CA.

Gruß

Chonta
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 12:25:12 Uhr
Goto Top
Hallo tomolpi,

danke für Deinen Kommentar,
aber ich überlege die ganze Zeit, was ich darauf antworten soll.

So wirklich weiter bringt mich das nicht.

Aber:
Ich habe jetzt ein furchtbar schlechtes Gewissen.
Wahrscheinlich bin ich auch total unfähig.
Komme zudem in die Hölle.
Muss mich hier wieder rechtfertigen.

Leider war mir nicht bekannt, das Exchange nicht auf einem DC-Server läuft.
Hatte vorher noch hier nachgelesen: How to install ....
und wollte es mal probieren.

Es poppte auch während der Installation kein Fenster auf: Exchange lässt sich nicht auf DC installieren. Sorry.

Ich sehe eigentlich auch nicht, (so wie highload), dass der Rechner überladen ist.
Im Moment läuft hier eine CPU-Auslastung von 1-3%.

Vielleicht leben wir auch in verschiedenen Welten.
Ich versuche hier für einen kleinen Betrieb mit 5 (manchmal 8) Leuten nach 6 Jahren Server2008 einen neuen zu installieren.

Wenn es nach highload geht, würde ich jetzt 6 Maschinen hier hinstellen oder wie?

Beste Grüße
Mitglied: 129813
129813 12.09.2016 aktualisiert um 12:35:07 Uhr
Goto Top
Zitat von @bonnerjung:
Ich sehe eigentlich auch nicht, (so wie highload), dass der Rechner überladen ist.
Im Moment läuft hier eine CPU-Auslastung von 1-3%.
That was not was i meant. The combination of all these roles is the problem not the performance.
Wenn es nach highload geht, würde ich jetzt 6 Maschinen hier hinstellen oder wie?
No, only one physical machine as hypervisor (Hyper-V/VMware ESXi) and the machines and services distributed on VMs :-) face-smile. This is a common scenario, as well in small companies nowadays.
At least the following distribution:
VM1 : AD DS; AD-Zertifikatdienste; DHCP; DNS
VM2: Anwendungsserver; Datei/Speicherdienste ;IIS; WSUS
VM3: Exchange

Normally the DC should be redundant (min. 2), also in small companies, so installing this on a seperate hardware is recommended in most cases.
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 12:34:11 Uhr
Goto Top
Hallo Chonta,

installiert habe ich als administrator, der auch in der Gruppe Domänen-Admins ist.
Auch ohne Zertifikatdienste besteht das gleiche Problem.
Da ich einen Zusammenhang mit den Zertifikaten vermutete, habe ich diese Rolle mal nachinstalliert.

Beste Grüße
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 12:39:45 Uhr
Goto Top
Hallo,

während der Installation legt Exchange eine neue Seite an (Exchange Back End).
Da http und https mit den Standardports schon an "Default Web Site" gebunden sind, erfolgt hier die Bindung an die Ports 81 und 444.
Habe aber auch die Bindungen schon testweise geändert und komme nicht weiter.

Beste Grüße
Mitglied: 129813
129813 12.09.2016 aktualisiert um 12:46:36 Uhr
Goto Top
Da ich einen Zusammenhang mit den Zertifikaten vermutete, habe ich diese Rolle mal nachinstalliert.
:-D face-big-smile :-D face-big-smile You don't need a CA only to assign certificates to IIS and Exchange !! These ar typical results and errors of not reading the documentation, sorry.
Mitglied: Chonta
Chonta 12.09.2016 aktualisiert um 12:49:38 Uhr
Goto Top
Hallo,

installiert habe ich als administrator, der auch in der Gruppe Domänen-Admins ist.
die Domänen-admingruppe ist bei der Exchangeinstallation zweitrangig, wichtig ist das der Admin mit dem isntalliert wird auch Schemaadmin ist, sonst wird das nix.
Aber der Defaultadmin ist Schemaadmin, von daher passt das.

Auch ohne Zertifikatdienste besteht das gleiche Problem.
Da ich einen Zusammenhang mit den Zertifikaten vermutete, habe ich diese Rolle mal nachinstalliert.
Wenn die Zertifikatsdienste vorher nicht drauf waren und auch nicht im einsatz sind, runter mit denen vom Exchange :-) face-smile

Server 2012 R2 erlaubt es einen Hyper-V als Host zu haben und wenn der Host NUR die Hyper-V Rolle hat 2 VM zu betreiben.
Dann kannst Du DC und Exchange auch trennen.
Microsoft rät dringnd davon ab Exchange und DC auf dem selben System zu haben. Das es nicht geht sagt niemand.

Was waren vor der Installation des Exchange für Webdisynte auf dem Rechner installiert? War der IIS schon vorher drauf? Was hat der IIS für eine Rolle gehabt?
Auf nem normalen DC ist der IIS normalerweise nicht drauf.

Was passiert, wenn die Firewall deaktiviert wird?
Was bekommst Du wenn Du nicht übe rlocalhost versuchst den Exchange zueerreichen?
Normalerweise sollte der auf http://ip.vo.server reagieren und dann auf https://ip.vom.server/ecp umschalten.

Ist noch ein anderer Exchange in der domäne vorhanden?

Da http und https mit den Standardports schon an "Default Web Site"
Vor der Exchangeinstallation sollten auf der Kiste keine anderweitigen Webdienste laufen.

Gruß

Chonta
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 13:07:22 Uhr
Goto Top
Hallo,

also, wie oben schon beschrieben, läuft ein von mir konfigurierter anderer Server 2012 R2 mit all den Rollen (außer AD-Zertifikatdienste) einwandfrei.
serverstegh

Es gibt immer mehrere Dinge, die normal sind.

Die, wie von Microsoft beschrieben und erwünscht, und die, die sich in der Praxis mit den Kunden aufgrund von Bugets umsetzen lassen.

Warum muss ein DC unbedingt redundant sein? Fällt der Server aus und ich habe meine Datensicherungen parat, kann das Ganze wieder innerhalb von 12 Stunden oder früher laufen. Je nachdem, was passiert ist. Wenn der Kunde einverstanden ist, warum nicht?

Wenn die Aussage von tomolpi richtig ist, das ein Exchange NIE auf einem DC läuft, dann hab ich das halt übersehen.

Ich werde meinen Systemzustand wieder vor Exchange zurückstellen und mein unkompliziertes Communigate installieren.
Hab halt was dazugelernt.

Danke
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 13:41:55 Uhr
Goto Top
Hallo,

IIS hatte ich mitinstalliert. Keine besondere Rolle. Soll vielleicht später mal eine Intranetseite mit ein paar Infos hosten.
Ist aber nicht wichtig und kann ich erst mal weglassen.

Firewall auch testweise deaktiviert.

Alle Adressen durchgespielt:
http:/localhost/ecp, http:/localhost:81/ecp
https://192.168.5.55/ecp; https://192.168.5.55:444/ecp
https://server/ecp; https://server:444/ecp

Ich werde immer wieder darauf hingewiesen, das die Verbindung nicht sicher ist.
Füge ich Ausnahmen hinzu, erhalte ich letztendlich:

unbenannt1

Ein ander Exchange läuft nicht.

Ich werde noch mal den Systemzustand vor Exchange zurücksichern, AD-Zertifikatdienste und IIS entfernen und ein letztes Mal Exchange neu installieren.

Vielen Dank
Mitglied: tomolpi
tomolpi 12.09.2016 um 14:01:55 Uhr
Goto Top
Zitat von @bonnerjung:
Ich werde noch mal den Systemzustand vor Exchange zurücksichern, AD-Zertifikatdienste und IIS entfernen und ein letztes Mal Exchange neu installieren.
Ahh Moment! Wenn du einen DC zurücksicherst aus einem Image bitte aufpassen!

https://technet.microsoft.com/de-at/video/active-directory-tu-mir-das-ni ...

Bitte das Video anschauen da wird es erklärt was dann passiret. Lieber erst den Exchange runterwerfen, dann den Server wo der Exchange drauf war herunterstufen (dann ist er kein DC mehr und du hast nur noch einen) dann aus der Domäne nehmen. Erst dann installierst du bitte eine neue VM nur mit Exchange. Sonst gibt das schliumme Fehler im Eventlog.

tomolpi
Mitglied: 129813
129813 12.09.2016 aktualisiert um 14:09:06 Uhr
Goto Top
Ich werde immer wieder darauf hingewiesen, das die Verbindung nicht sicher ist.
Normal if you don't have a correct certificate with the entered common names in the URL. You should better use the FQDN of the server,
and check which certificate is used in the exchange backend site and the frontend site. The certs should match in your case.

Also execute an IISRESET in a console.
Mitglied: 129813
129813 12.09.2016 aktualisiert um 14:15:34 Uhr
Goto Top
Warum muss ein DC unbedingt redundant sein? Fällt der Server aus und ich habe meine Datensicherungen parat, kann das Ganze wieder innerhalb von 12 Stunden oder früher laufen. Je nachdem, was passiert ist. Wenn der Kunde einverstanden ist, warum nicht?
If the company does not loose money and reputation while they are not able to work react to mails etc., it's OK to have only one DC. Everyone has to decide himself.
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 16:25:30 Uhr
Goto Top
That's exactly what I say.

Da Exchange hier nur Mails via POP3-Connector holen soll, bleibt im Ernstfall immer noch der Umweg über den Mail-Provider.
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 16:38:17 Uhr
Goto Top
So, noch mal zurück. Geht ja schnell.

IIS entfernt und Zertifikatdienste entfernt.

dann

.\setup /prepareschema /IAcceptExchangeServerLicenseTerms
.\setup /PrepareAD /OrganizationName:3B /IAcceptExchangeServerLicenseTerms
.\setup /PrepareDomain /IAcceptExchangeServerLicenseTerms

Install-WindowsFeature AS-HTTP-Activation, Desktop-Experience, NET-Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, Web-Mgmt-Console, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation

Neustart

API Runtime: UcmaRuntimeSetup.exe
Office Filter Pack FilterPack64bit
Office Filter Pack SP1 filterpack2010sp1-kb2460041-x64-fullfile-de-de

WARNUNG:

Warnung:
Wenn Exchange Server auf einem Domänencontroller installiert wird, werden die Berechtigungen für die Exchange-Sicherheitsgruppe "Vertrauenswürdiges Subsystem" für Domänenadministratoren erhöht.
Weitere Informationen finden Sie unter: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness. ...


Warnung:
Setup kann nicht überprüfen, ob der Eintrag 'Host' (A) für diesen Computer in der DNS-Datenbank auf Server 192.168.5.55 vorhanden ist.
Weitere Informationen finden Sie unter: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness. ...

erster Aufruf:

zwischenablage01

Ausnahmeregel hinzugefügt:
zwischenablage02

im ie sieht es so aus:

zwischenablage03

übrigens installiert Exchange IIS wieder.
Eigentlich logisch, da das Back-End ja darüber läuft.

zwischenablage04

So, das ganze habe ich jetzt bis zum ... mehrmals durchgespielt.

Ob ich in der Adresszeile localhost, IP-NR oder Servername eingebe, ist egal.


Ich habe noch nie einen 2. Server in einer VM installiert.
Wäre ja dann die Option.
Wo finde ich dazu einen guten Workaround?
Kann ich meinen Key dafür einfach verwenden?

Beste Grüße
Mitglied: 129813
129813 12.09.2016 aktualisiert um 16:47:02 Uhr
Goto Top
On your picture your default website is not running, but this is necessary for the ecp to work properly!
Setup kann nicht überprüfen, ob der Eintrag 'Host' (A) für diesen Computer in der DNS-Datenbank auf Server 192.168.5.55 vorhanden ist.
You should resolve it => Reverse DNS-Zone.
So, das ganze habe ich jetzt bis zum ... mehrmals durchgespielt.
I did it one time, running and it works on a test install on a DC ... you are doing something wrong we can't see.

Regards
Mitglied: Chonta
Chonta 12.09.2016 um 16:53:22 Uhr
Goto Top
Ich habe noch nie einen 2. Server in einer VM installiert

Man installiert Server 2012R2 auf dem Blech und fügt die Hyper-V Rolle hinzu.
Auf diesem Wird dan NICHTS weiter installiert.

Man legt über den Hyper-V manager 2 VM an und installiert auf beiden Server2012R2
Die eine VM wird DC und die andere Exchange.

Saubere Trennung der Dienste.

Das ganze Prepare etx kannst du dir sparen, das wird automatisch gemacht.
Die Zertifikatswarnung kommt, da dem Zertifikat nicht vertraut wird, Exchange 2013 legt bei der Installation ein eigenes selbst erstelltes Zertifikat an, das genommen wird bis man ein eigenes hat.
Also zustimmen.

Als anmeldedaten die Logindaten vom Domänenadministrator verwenden mit : domäne\administrator Schreibweise.
https:\\exchangefqdn\ecp sollte dich dann in den Exchange rein bringen.
In den IIS Einstellungen kann man das "haatpassesspopup" bestimmt irgendiwe abstellen.

Laut screenshot ist die Defaultwebseite down (beendet)
Server schon neu gestartet?

Sind unter Defaultwebseite auch die nötigen Ordner angelegt?

Gruß

Chonta
Mitglied: bonnerjung
bonnerjung 12.09.2016 um 17:38:05 Uhr
Goto Top
On your picture your default website is not running, but this is necessary for the ecp to work properly!
Dieser Fehler kommt auch erst NACH der Installation von Exchange.
Vor der Installation ist hier alles OK.

You should resolve it => Reverse DNS-Zone.

Habe ich auch schon gelesen, doch fehlen mir dazu leider die Kenntnisse.
Im Moment weiß ich nicht, was ich im DNS-Manager eintragen muss.

... you are doing something wrong we can't see
Yes
Mitglied: Chonta
Chonta 13.09.2016 um 08:13:10 Uhr
Goto Top
Dieser Fehler kommt auch erst NACH der Installation von Exchange.
Vor der Installation ist hier alles OK.

Vor der Installation von Exchange sollte es ja eigentlich noch keinen IIS oder eine Defaultwebseite geben, das sollte erst alles mit der Installation von Exchange kommen.
Server neustart? Serverlogs warum die default Webseite nicht startet? Den IIS-Verwaltungsdienst neu gestartet?

Irgendwas ist am Grundsystem nicht sauber sonst würde es keine Probleme geben.
Wenn Du die Hyper-V darf keine weiteren Funktionen Regel beachtest, kannst Du aber 2 VM betreiben und in einer den Exchange getrennt vom DC.

Gruß

Chonta
Mitglied: bonnerjung
bonnerjung 13.09.2016 um 12:52:26 Uhr
Goto Top
Hallo, danke noch mal.

Also, wenn ich IIS vorher installiere, habe ich die Default Webseite ohne Fehler.
(Und auch die WSUS Seite)

Nach der Exchange Installation kommt halt noch die Exchange Backend Seite dazu. Dann mit Fehler.

Starte ich Exchange-Installation ohne vorher IIS installiert zu haben, wird IIS ja mitinstalliert. Mit den gleichen Fehlern.

Das irgendwas im Unreinen ist, ist mir klar. Bei allen andern funktioniert es ja.
Nur schade, das es keine Möglichkeit gibt, der Sache auf den Grund zu gehen.

Ich vermute auch ein DNS Problem, bin da aber leider überfordert.

Die Installation des Servers war eigentlich nicht aufregend. Keine weitere Fremdsoftware installiert.
DC konfiguriert, Benutzer und Gruppen angelegt.
DC mit 2 Arbeitsstationen getestet. Kann mich einwandfrei anmelden. Funktioniert alles.
Im Server-Manager alles grün.

Vielleicht folgendes:
Damit der Server hier bei mir Netz eine Internetverbindung hat, habe ich in meinem Router eine Route eingerichtet.
192.168.5.0 auf 192.168.10.254 (mein Router)

IP4 Serveradressen: 192.168.5.55
Soll auch im Netz 192.168.5.x laufen.
Standardgateway: 192.168.10.254
1. DNS 192.168.5.55
2. DNS 127.0.0.1

Damit läuft eigentlich alles.
Das Gateway ändere ich dann später im eigenlichen Netzt auf die Adresse des Routers 192.168.5.254

--

Ich weiß, dass Diagnosen ohne einmal draufzuschauen, sehr schwierig sind.
Ich würde den Server auch gerne fernwarten lassen, bevor ich die ganze Sache zur Konfiguration außer Haus gebe.


Hat jemand vielleicht eine seriöse Adresse?



Danke
Mitglied: 129813
129813 13.09.2016 aktualisiert um 13:08:02 Uhr
Goto Top
IP4 Serveradressen: 192.168.5.55
Standardgateway: 192.168.10.254
This cannot work if you have a 24bit mask, a gateway has to lie in the same subnet as the clients address!
Ich vermute auch ein DNS Problem, bin da aber leider überfordert.
Then you should give this to someone who knows what he is doing. Installing an Exchange without basic knowledge how a DNS-Server works ??? My dear ....
Ich weiß, dass Diagnosen ohne einmal draufzuschauen, sehr schwierig sind.
Right, too few information about your environment.
Mitglied: Chonta
Chonta 13.09.2016 um 13:07:44 Uhr
Goto Top
Und auch die WSUS Seite
WSUS ohne IIS ist nicht möglich, also warum ist da ein WSUS drauf?
WSUS nach dem Exchangeinstallationsversuch oder schon vorher?

Das Problem ist, das die Defaultwebseite nicht läuft und die muss laufen.
Ich hab den WSUS auch auf unserem Exchange, aber der WSUS wurde NACH dem Echange installiert.

Mach eine zweite VM und betreibe den Exchange darauf und alles wird gut.

Keine weitere Fremdsoftware installiert.
Für Exchange sind auch Microsoftdienste Fremdsoftware ;-) face-wink

Gruß

Chonta
Mitglied: bonnerjung
bonnerjung 13.09.2016 um 13:24:01 Uhr
Goto Top
Hallo,

die Netzmaske ist testweise 255.255.0.0 und alles funktioniert.

Trotzdem Danke noch mal für Deine Infos.

Beste Grüße
Mitglied: bonnerjung
bonnerjung 13.09.2016 um 13:31:03 Uhr
Goto Top
Hallo Chonta,

danke für die Infos.

Ursprünglich hatte ich WSUS und IIS installiert.
Danach die Exchange Installation gestartet. Ergebnis: IIS mit Fehlern.

Hier wurde mir geraten, den IIS erstmal nicht zu installieren.
WSUS wurde dann logischeweise auch entfernt.

IIS wurde ja dann mitinstalliert.
Das Ergebnis ist aber immer das gleiche. IIS mit Fehlern.

ALSO: Egal ob ich IIS vorher installiert habe oder IIS mit Exchange installiert wird: Fehler


Ich werden Deinem Rat folgen.
Danke
Mitglied: dg2dra
dg2dra 08.11.2016 um 09:30:01 Uhr
Goto Top
Was schief gelaufen ist, kann man aus der Ferne immer schlecht beantworten. Auch wenn ich hier nicht beabsichtige, Grundsatzdiskussionen vom Zaun zu brechen, man kann sehr wohl den Exchange auf einem DC betreiben - sonst müssten wir uns bei aller Virtualisierung auch darüber unterhalten, ob ein DC überhaupt virtualisiert werden _darf_ . Ich betreue aktiv ca. 100 Exchange-Installationen, kann also durchaus mir darüber eine Meinung bilden und habe nicht nur einen Exchange installiert. Nicht alle meine Installationen sind auf DCs, aber ca. die Hälfte schon (sind aber nie PDC). Für mich und meine Kunden auch eine Frage von Lizenzkosten, das wird immer gerne ausgeblendet. Macht man richtiges Sizing des Exchange (für eine Firma mittlerer Größe sage ich mal 32GB RAM und 8 Kerne für einen solchen Exchange), ist auch Zusatzfunktionalität wie AD kein Problem. Keiner meiner vielen Exchangeserver hat bis dato irgendwelche Probleme gehabt, die sich nicht lösen liessen, auch als DCs. Keiner musste irgendwann neu installiert werden, auch Migrationen auf neuere Versionen verliefen bis dato ohne nennenswerte Probleme ab. Das sind die Fakten. Grundsätzlich verfolge ich folgende Strategie bei der Installation: 1. Das Netzwerk samt DNS MUSS korrekt funktionieren und eingestellt sein, insbesondere der DNS, denn der ist bei AD die Basis und _lebenswichtig_. 80% aller AD-Probleme kommen von genau daher. Wer sich also an Exchange-Installationen wagt, MUSS vollumfängliche Netzwerkkenntnisse (heute beinhaltet das ebenfalls IPv6 und nicht nur IPv4) mitbringen, die auch Administration des DNS voraussetzt. DA, das hat sich immer wieder gezeigt, werden schon im Vorfeld die meisten Fehler generiert. 2. Ich installiere die Serverplattform grund, danach Windows-Updates. Alle sonstigen Rollen wie WSUS etc. erfolgen bei mir aus Prinzip immer NACH dem Exchange. 3. Abarbeitung der Exchange-Prequisities, diese findet man auf den entsprechenden Supportseiten von MS und sollte man einhalten ! 4. Dann der Exchange, _vorher_ auch die AD ausgiebig mit dcdiag nach möglichen Fehlern absuchen. Fertig. Muss danach eigentlich funktonieren. Nach Dutzenden von Installationen und Migrationen bei mir niemals Installationsprobleme aufgetreten, und das schon seit Exchange 2003 :) face-smile Hält man das alles so ein, wette ich, wird es auch kaum Probleme geben. Auch nutze ich nie self-sign-Certs für SSL, ich generiere statt dessen eine eigene CA samt CRL-Strukturen (nutze aber nicht die Windows-eigene CA der AD). Self-sign-certs haben einige Einschränkungen, die nicht immer gut sind, kann man aber für den Anfang durchaus machen.

Also zurück zu deinem Fall. Wenn alle Stricke reissen und es nicht geht, dann installiere einen zusätzlichen sauberen Server und gehe dann so wie ich das oben beschrieben habe vor. Dann sollte auch der Exchange korrekt laufen.

Gruss Heiko
Mitglied: wiesi200
wiesi200 08.11.2016 aktualisiert um 11:47:20 Uhr
Goto Top
Hallo,

du so nebenbei.
Nen PDC gibt es schon sehr lange nicht mehr. Auch schon zu Zeiten vom Exchange 2003.
Und Lizenztechnisch seit ist es seit neustem auch kein Problem mehr.

Mann kann pro Standard Server Lizenz zwei Virtuelle Hosts erstellen
Das währ dann einer für DC und einen für Exchange.

Und ja man kann und darf einen DC Virtualisieren. Hier gibt es nur ein paar kleine Rahmenbedingungen.

Und ein paar Zeilenumbrüche würden deinem Text gut tun.
Mitglied: dg2dra
dg2dra 10.11.2016 um 14:39:22 Uhr
Goto Top
Also eine der FSMO-Rollen ist sehr wohl noch PDC-Emulator...und das meinte ich damit.
Die aktuellen Lizenzbedingungen sind mir wohl bekannt - darum ging es aber auch nicht, zumal ja in der Praxis sowieso kaum nur ein einzelner Server alles macht - das wäre ja aus Redundanzgründen auch fatal und riskant.

Es ging aber um's Prinzip - möglich ist dieses Szenario EX auf DC sehr wohl, quasi als Single-Server-Lösung.

Ich habe nur meine Meinung zu der Aussage hinzugefügt, die da sinngemäß lautete "Exchange auf einem DC - das geht ja gar nicht". Ich teile diese Meinung nicht.
Es geht sehr wohl - sind aber einige Sachen zu beachten. Ist der Exchange bei der Installation auch GC, kann man das z.B. später nicht mehr ändern. Das darf ihm - wenn auch DC und GC - nicht mehr "weggenommen" werden, sonst nix Exchange mehr. Stimmt auch, habe ich schon getestet, ist so korrekt.

Selbstverständlich wird heute (fast) alles virtualisiert, mache ich ja auch so, da in diesen Fällen ja die Lizenznutzung und auch Hardwarenutzung effektiver wird, das ist unstrittig, allerdings auch mit den dazugehörigen Backupkonzepten und/oder Ausnutzung der Möglichkeiten durch Clustering, was ich meistens empfehle und auch umsetze. Hat aber auch seinen Preis :) face-smile

Ist aber letztlich alles eine Entscheidung des Kunden, was er finanziell in die Hand nehmen will. Und das ist eben nicht immer gleiches Niveau bei allen Kunden und Anwendern.

Kurzum, funktionieren tut es mit Exchange auf einem DC sehr wohl und auch von der Installation her hatte ich zumindest die ganzen Exchangeversionen seit 2003 bis heute 2016 kaum Probleme - zumindest keine die sich nicht schnell lösen liessen - unter Beachtung der vorbereitenden Massnahmen, denn die müssen korrekt umgesetzt sein. Dann klappts auch mit'm Exchange.
Mitglied: Chonta
Chonta 10.11.2016 um 15:08:44 Uhr
Goto Top
Kurzum, funktionieren tut es mit Exchange auf einem DC sehr wohl
Sagt auch keiner das es technisch nicht geht!
Wenn man eaber einen MS Call für diese Konstelleation brauchen würde, würden die aber nein sagen, weil diese Installation von denen nicht suportet wid und nur Umgebungen die deren Bedingungen entsprechen unterstützt werden.

Das es technisch machbar ist hat der SBS ja bewiesen und das war nix weiter als der Standardserver mit Exchange und erweterten Assistenten für leichteren Zugang.

Es geht sehr wohl - sind aber einige Sachen zu beachten.
Richtig.
Das mit dem GC und hinzu kommt der Server kann nicht demotet werden, bis der Exchange deinstalliert ist von diesem Server.
Im Problemfall hast Du zwei Kritische dienste auf dem selben System.
Wenn Du jetzt ein Image vom Server zurücksichern musst, weil das AD zerschossen ist, zack Mails sind auch weg.

Ist aber letztlich alles eine Entscheidung des Kunden, was er finanziell in die Hand nehmen will.
Richtig und der ders macht haftet und muss aufpassen und sich absichern und sich unterzeichenen lassen das der Kunde Mist will :-) face-smile

Gruß

Chonta
Mitglied: bonnerjung
bonnerjung 15.01.2017 um 10:56:53 Uhr
Goto Top
Als erstes vielen Dank an alle, die sich meinem Problem gewidmet und ihre Zeit geopfert haben.
Lieber spät als nie hier noch meine Rückmeldung.
Der Server läuft jetzt seit geraumer Zeit! Die Ursache für den Installationsfehler konnte ich leider trotz vielfacher Hilfe NICHT klären.
Ich habe letztendlich einige Ratschläge beherzigt und bin wie folgt vorgegangen:
Den Server minimal aufgesetzt. Danach Exchange installiert. Dieser richtete dann entsprechend die benötigten Rollen DNS-Server und Webserver mit ein. Jetzt konnte ich das erste Mal auf Exchange zugreifen. Danach installierte ich gegen jegliche Empfehlung auf dem gleichen Server noch die WSUS-Rolle. Läuft auch einwandfrei. Die DHCP-Rolle habe ich nicht installiert, da dies in dem kleinen Netzwerk der Router übernimmt. Den Exchange habe ich also nicht in einer VM eingerichtet. Mit meinem EaseUS Todo Backup kann ich zusätzlich sehr komfortabel Exchange und SQL-Datenbanken sichern. - Noch ein Wort unter Freunden. Ich habe geschrieben, dass ich hier bei mir für Testzwecke das Netzwerk wie folgt eingerichtet habe (ich wollte meinen Router hier bei mir nicht um konfigurieren und den Server gleich mit der richten IP-Adresse versehen):

Damit der Server hier bei mir Netz eine Internetverbindung hat, habe ich in meinem Router eine Route eingerichtet.
192.168.5.0 auf 192.168.10.254 (mein Router)
IP4 Serveradressen: 192.168.5.55
Soll auch im Netz 192.168.5.x laufen.
Standardgateway: 192.168.10.254
1. DNS 192.168.5.55
2. DNS 127.0.0.1
Damit läuft eigentlich alles.
Das Gateway ändere ich dann später im eigentlichen Netzt auf die Adresse des Routers 192.168.5.254

die Netzmaske ist testweise 255.255.0.0 und alles funktioniert.


129813 kommentierte das wie folgt und stellte mich ein wenig dümmlich dar:

129813 (Level 2)
13.09.2016, aktualisiert um 13:08 Uhr
IP4 Serveradressen: 192.168.5.55
Standardgateway: 192.168.10.254
This cannot work if you have a 24bit mask, a gateway has to lie in the same subnet as the clients address!
Ich vermute auch ein DNS Problem, bin da aber leider überfordert.
Then you should give this to someone who knows what he is doing. Installing an Exchange without basic knowledge how a DNS-Server works ??? > My dear ....
Ich weiß, dass Diagnosen ohne einmal draufzuschauen, sehr schwierig sind.
Right, too few information about your environment.

Lieber 129813, ich lade Dich gerne ein und zeige Dir, dass das Gateway so eingerichtet werden kann.
Vielleicht kann ich mich ja revangieren.

Grüße an alle.

P.S. Habe noch eine Frage zur Windows Server Sicherung auf einem Server2008SB.
Dazu aber ein neues Kapitel.
Heiß diskutierte Beiträge
general
Liste von URLs in wininet.dllFennek11Vor 1 TagAllgemeinInternet13 Kommentare

Hallo, die Frage ist zugleich enrsthaft und Satire: Windows enthält die Datei "c:\windows\system32\wininet.dll", die für viele Verbindungen ins Internet benötigt wird. Ein Blick in die ...

question
2 Faktor Authentifizierung generell abschaltenratzekahl1Vor 1 TagFrageGoogle Android9 Kommentare

Hallo zusammen, ich habe eine Frage: Kann ich in Google die 2 Faktor Authentifizierzung generell abschalten? Wenn ich ein Gerät als vertrauenswürdig hinzugefügt habe, ja, ...

question
Netzwerk Grafisch darstellen?FireWorldVor 1 TagFrageInternet8 Kommentare

Hallo, ich bin der Zeit auf der Suche nach einem Programm zur Grafischen Darstellung von inbound/outbound eines Servers in einem Rechenzentrum. Hat Jemand eine idee ...

info
Ruhe in Frieden, HackbratenVision2015Vor 1 TagInformationOff Topic5 Kommentare

Der US-Sänger Meat Loaf ist tot. Er starb laut seiner Facebook-Seite in der vergangenen Nacht im Alter von 74 Jahren. Meat Loaf, mit bürgerlichem Namen ...

question
Fritz Repeater 1750E "verloren"reksierpVor 1 TagFrageHardware9 Kommentare

Hallo, ich habe ein 150 Jahre altes Haus (ehemaliger Dorf-Bahnhof), sehr verwinkelt, viele Räume, mit Anbau, 2 Kriech-Dachböden. Vor mehreren Jahren hab ich einige Repeater ...

question
Tablet-Display defekt: wie Zugriff auf DatenMahstarDVor 1 TagFrageGoogle Android6 Kommentare

Guten Abend, ich habe ein Tablet überreicht bekommen mit der Bitte um den Versuch einer Datenrettung. Tablet: Samsung Galaxy Tab-A (2016, SM-T585) Das Display ist ...

info
SonicWall Bootloop seit letzter NachtSt-AndreasVor 1 TagInformationFirewall2 Kommentare

Sonicwall Gen 7 spielen Bootloop seit letzter Nacht. Hilfe dazu hier ...

question
Verständnisproblem SubnettingKarolaVor 18 StundenFrageNetzwerkgrundlagen6 Kommentare

Hallo, möchte mal nerven weil ich keine Antwort finde Ein Netzwerk 172.16.0.0 /16 besteht aus einem alten Router als 4 Port Switch und 4 Clients. ...