Falsche Testergebnisse mit iperf unter Windows Server 2016

Mitglied: g0drealm

g0drealm (Level 1) - Jetzt verbinden

19.01.2021 um 11:30 Uhr, 506 Aufrufe, 2 Kommentare

Hallo zusammen,

ich bin gerade dabei einen Starwind 2-Node Cluster einzurichten und wollte jetzt die Netzwerkkarten testen.

Bei den Servern handelt es sich um HP Proliant DL380p Gen8 und DL380 Gen9 Server mit HPE 530T Dual Port 10Gb Adaptern, eingesteckt in PCIe X16 Slots.
Die aktuellen Treiber sind installiert. Treiberdatum 21.06.19. Betriebssystem ist Windows Server 2016 Standard.

Die Server wurden früher für einen Proxmox Ceph Cluster verwendet und die Netzwerkkarten funktionierten damals einwandfrei.

Wenn ich jetzt unter Windows die Netzwerkkarten mittels iperf (bind auf 10Gb Port) messe, bekomme ich knapp 4Gbit/s angezeigt. Unter Linux waren es 9.8 Gbit/s.

Kurioserweise bekomme ich, wenn ich über das 10Gb-Netzwerk Daten auf eine Samba-Freigabe kopiere die maximale Schreibgeschwindigkeit der Platten von 1GB/s. Also deutlich mehr als die Messung mit iperf hergibt.

Was könnte hier das Problem sein?

Gruß,

g0drealm
Mitglied: aqui
19.01.2021, aktualisiert um 11:50 Uhr
Die aktuellen Treiber sind installiert. Treiberdatum 21.06.19
Direkt die vom Chipsatz Hersteller oder die beigepackten von Microsoft ?!
Wenn, sollte man wenn möglich immer die aktuellen des Chipsatz Herstellers verwenden !!
bekomme ich knapp 4Gbit/s angezeigt. Unter Linux waren es 9.8 Gbit/s.
Klar ein Treiberproblem und zu erwarten wenn du die MS Treiber verwendest.
Oft ist es auch fehlendes Jumbo Framing sowohl an Karten als auch Switch ! Hast du das auf beiden Komponenten aktiviert ? Bei 10G und höher sollte Jumbos Framing immer aktiviert sein.
auf eine Samba-Freigabe kopiere die maximale Schreibgeschwindigkeit der Platten von 1GB/s
SMB/CIFS ist generell durch die Verwenung von sehr kleinen Paketen immer sehr ineffizeint beim Kopieren. Das ist wenig aussagekräftig.
Wesser wäre es dann auch IPerf oder netIO auch auf dem Samba Server einmal laufen zu lassen und den Durchsatz zu den spzifischen Paketgrößen zu testen.
Billigswitches haben mit kleinen Frames wegen ihrer sehr oft schwachbrüstigen und überbuchten ASICS intern häufig schlechtere Durchsatzzahlen.
Sind das 10G Base T Kupferports oder arbeitest du mit SFP+ und DAC/Twinax Kabeln. Bei 10G Base T kommt noch dazu das das immer ein Negotiation Verfahren ist und massiv von der Kabelqualität abhängt. Volle Bandbreite erreicht man nur auf sehr kurzen Längen. Ein falscher Knick, Steckverbindung usw. und von den 10G kommen nur die Hälfte oder noch weniger an.
Bitte warten ..
Mitglied: g0drealm
19.01.2021, aktualisiert um 12:06 Uhr
Direkt die vom Chipsatz Hersteller oder die beigepackten von Microsoft ?!
Wenn, sollte man wenn möglich immer die aktuellen des Chipsatz Herstellers verwenden !!

Direkt von HP die aktuellsten Treiber.

Klar ein Treiberproblem und zu erwarten wenn du die MS Treiber verwendest.
Oft ist es auch fehlendes Jumbo Framing sowohl an Karten als auch Switch ! Hast du das auf beiden Komponenten aktiviert ? Bei 10G und höher sollte Jumbos Framing immer aktiviert sein.

Die Server sind direkt miteinander verbunden. Jumbo Frame war tatsächlich bei einer Karte ausgeschaltet. Hat am Ergebnis aber nicht geändert.
Der Ceph Cluster vorher lief über einen 10Gb Switch.
Bitte warten ..
Heiß diskutierte Inhalte
HTML
Ich brauche dringend Hilfe !
gelöst JulianpustVor 15 StundenFrageHTML16 Kommentare

Hallo erstmal, ich habe großen Mist gebaut in der Firma wo ich gerade mal 2 Tage arbeite. Was ist passiert: Ich sollte von Gmail ...

Exchange Server
0-day Exploit Chain für Exchange Server - Patches verfügbar
kgbornVor 1 TagInformationExchange Server6 Kommentare

Zur Info: Microsoft warnt vor einer Exploit-Chain, bei der vier 0-day-Schwachstellen für gezielte Angriffe auf Exchange per Outlook Web App kombiniert werden (eine chines. ...

Windows 10
Windows 10 schickt lokale Anfragen an das Gateway - was tun?
gelöst runthegaunzVor 1 TagFrageWindows 1015 Kommentare

Hallo! Ich bin vor ein paar Tagen wieder von Linux auf Windows umgestiegen. Ich hab die Windows 10 Version 20H2 installiert, wurde von Windows ...

Switche und Hubs
23 Cisco Switch einrichten - Wie am einfachsten?
gelöst Freak-On-SiliconVor 1 TagFrageSwitche und Hubs18 Kommentare

Hallo; Ich habe hier 4stk Cisco SX350X-24 9Stk Cisco SG350X-48P 10Stk Cisco SG350X-48 Diese werden aufgeteilt auf 9 Racks, und ersetzen alte HP Switches. ...

Exchange Server
Aktuelle Exchange Sicherheitslücke
jojo0411Vor 1 TagAllgemeinExchange Server11 Kommentare

Hallo Leute, Momentan gibt es da wieder einmal ein schönes neues Thema. Sehe ich das richtig das ich mit Exchange 2016 und CU 19 ...

Hardware
Fritzbox 7590 ändert selbständig die FTP-Adresse nach ca. 24h
Wicky1Vor 1 TagFrageHardware15 Kommentare

Hallöchen, ich habe da ein sehr kurioses Problemchen mit meiner Fritzbox. Doch erst mal eine kurze Beschreibung des Aufbaus: - Fritzbox 7590 (1&1 Edition) ...

Netzwerke
Smarthome Heimnetzwerk absichern
hell.wienVor 1 TagFrageNetzwerke12 Kommentare

Hallo. Ich mach mir gerade gedanken wie ich meine neue Wohnung sicher mache Überischthalber zur Hardware: Vorhanden: Modem APU4D4 Cisco SG250X-24P Mikrotik cAP ac ...

Windows Server
Windows Firewall: Alle öffentliche IPs sperren bis auf eine
SabSchapVor 1 TagFrageWindows Server7 Kommentare

Hallo, wir haben einen Windows 2019 Server. Wir nutzen diesen als Webserver. Nun haben wir die Webadresse www.test.de und möchten diese für alle öffentlichen ...