remotedesktopverbindung
Goto Top

Firmen-Website lädt sehr langsam, lokales DNS Problem

Servus,

habe ein kleines, aber nerviges Problem in einem Netzwerk:
Die Firmenwebsite ladet ca. 2-3 Minuten auf den Clients im Netz während sie auf dem Server innerhalb von 30 Sekunden geladen ist.
Andere Websiten laden mit normaler, angemessener Geschwindigkeit.
Da die Website den selben Namen wie die lokale Windows Domäne hat, hab ich eine Forward Lookup-Zone eingerichtet, die den passenden A-Eintrag mit IP-Adresse hat. Ohne den Eintrag kommt man ja auch gar nicht auf die Website. (Mir ist klar das dies nicht optimal ist, wurde aber so übernommen damals).
Wenn ich jetzt den primären DNS auf 8.8.8.8 auf den Clients stelle lädt die Seite sofort, jedoch will ich das vermeiden, da sonst Netzlaufwerke nicht funktionieren.
Zwischen Router und DNS-Server hängt noch eine Securepoint Firewall, aber ich bezweifel das es an ihr liegt. Im DNS bei Weiterleitungen bzw. Forwarder steht momentan die Firewall drinnen.

Meine Frage: Wie kann ich das Laden der Website jetzt auf den Clients beschleunigen? Ich denke das die Kommunikation zwischen den Geräten und dem DNS noch nicht optimal ist. Dies geschieht auch bei virtuellen Maschinen die direkt auf dem selben Server laufen.

Freu mich auf eure Antworten!

Content-Key: 2799368118

Url: https://administrator.de/contentid/2799368118

Printed on: April 22, 2024 at 11:04 o'clock

Member: NetzwerkDude
NetzwerkDude May 16, 2022 at 11:50:26 (UTC)
Goto Top
Das schöne ist das man Webseiten direkt mit dem Browser debuggen kann: Einfach die Entwicklertools mit F12 starten und dann in der Netzwerkanalyse schauen welche Elemente denn so elendig langsam laden.

unbenannt

Dort wirst du vermutlich die Domains finden für die die DNS abfrage sehr lange dauert, dann gilt er rauszufinden warum dein interner DNS langsamer ist als der externe.

PS: Auch 30 sekunden ist für eine Webseite eigentlich viiiiiel zu langsam, welcher User nimmt sowas hin ? face-smile
Member: Doskias
Doskias May 16, 2022 at 12:26:51 (UTC)
Goto Top
Moin,

Zitat von @NetzwerkDude:
PS: Auch 30 sekunden ist für eine Webseite eigentlich viiiiiel zu langsam,

Das würde ich nicht unbedingt pauschalisieren. Wir nutzen unsere Firewall zum Beispiel ausschließlich als White-List und selbst diese gelisteten Seiten werden bei jeder Öffnung komplett im Sandbox-Verfahren gescannt und das verhalten analysiert. Erst wenn alle geprüft wurde, wird die Website freigegeben. Im Regelfall dauert das ganze keine Sekunde, aber bei einigen wenigen Websites dauert es bei uns auch deutlich länger.

welcher User nimmt sowas hin ? face-smile
Jeder weil sie kein andere Wahl haben und sie gelernt haben, dass die Verzögerung nur der Sicherheit dient.

Das ganze liegt aber natürlich im bewusst konfiguriertem Verhalten der Firewall zu Grunde.

Gruß
Doskias
Member: Remotedesktopverbindung
Remotedesktopverbindung May 16, 2022 at 12:44:21 (UTC)
Goto Top
Gut, 30 Sekunden waren übertrieben, sind eher 5 sekunden. Auf einem Client dauert es jedoch 5 Minuten lang, ist ja auch nicht grade normal.

Bei der Netzwerkanalyse ist mir aufgefallen das viele Timeouts passieren, und die Adresse die dransteht ist meist die selbe wie der Domänenname.
Member: Dani
Dani May 16, 2022 at 12:50:23 (UTC)
Goto Top
Moin,
hört eure Website auf domain.de oder auf www.domain.de?
Für welche der genannten Varianten hast du einen A-Eintrag auf dem DNS-Server eingerichtet?


Gruß,
Dani
Member: Remotedesktopverbindung
Remotedesktopverbindung May 16, 2022 at 13:01:32 (UTC)
Goto Top
Servus Dani,
War zuerst website.de jetzt ist es www.website.de beim Hoster.
Der A-Eintrag hat www.website.de eingetragen (ist auch in einer eigenen Forward-Lookupzone)
Member: Dani
Dani May 16, 2022 at 13:06:10 (UTC)
Goto Top
Moin,
War zuerst website.de
Du hast dafür aber nicht bestehende DNS-Einträge auf deinem DNS-Server für den DC herum gebastelt? Falls dem so ist, schnellstmöglich wieder zurück bauen. Anderenfalls meine Befürchtung ignorieren.

jetzt ist es www.website.de beim Hoster.
Gut. Wird auch im Quelle überwall www.website.de genutzt? Nicht das dort noch ein Querverweis auf website.de ist und somit nicht vom Webhoster sondern von einem DC beantwortet wird. Das siehst du wie gesagt über die Entwicklungstools im Browser wie Kollege @NetzwerkDude oben beschrieben hat.


Gruß,
Dani
Member: Remotedesktopverbindung
Remotedesktopverbindung May 16, 2022 at 14:00:22 (UTC)
Goto Top
Zitat von @Dani:

Moin,
War zuerst website.de
Du hast dafür aber nicht bestehende DNS-Einträge auf deinem DNS-Server für den DC herum gebastelt? Falls dem so ist, schnellstmöglich wieder zurück bauen. Anderenfalls meine Befürchtung ignorieren.

Nein, natürlich nicht face-smile. Das war schon ein eigens erstellter Eintrag.

jetzt ist es www.website.de beim Hoster.
Gut. Wird auch im Quelle überwall www.website.de genutzt? Nicht das dort noch ein Querverweis auf website.de ist und somit nicht vom Webhoster sondern von einem DC beantwortet wird. Das siehst du wie gesagt über die Entwicklungstools im Browser wie Kollege @NetzwerkDude oben beschrieben hat.

Da sind wirklich noch ein paar Bilder und Schriftarten auf der alten Adresse ohne WWW. Meinst du das deswegen die Seite ewig auf dem Ladebildschirm hängt? Würde auch erklären warum ein paar Bilder fehlen wenn er die Seite auf dem DNS/DC-Server lädt. Ich besprech das mal mit dem Webmaster am besten nochmal.

Vielen Dank für die Hilfe so weit!
Member: Dani
Solution Dani May 16, 2022 at 14:02:50 (UTC)
Goto Top
Moin,
Meinst du das deswegen die Seite ewig auf dem Ladebildschirm hängt?
siehst du doch in den Entwicker Tools des Browsers, wie lange der Browser auf das Bild wartet.

Würde auch erklären warum ein paar Bilder fehlen wenn er die Seite auf dem DNS/DC-Server lädt.
Das müsste nicht nur auf den DC sondern auch auf den Clients so sein. Einfach dort nochmals testen.


Gruß,
Dani
Mitglied: 148523
148523 May 17, 2022 updated at 07:02:01 (UTC)
Goto Top
Die Firmenwebsite ladet ca. 2-3 Minuten
Autsch, das tut schon beim Lesen weh... face-wink https://www.duden.de/rechtschreibung/laden_packen_befrachten