mirmich
Goto Top

Fritzbox an ISP - OpenWrt als Client bekommt falsches Gateway

Hi,

ich habe eine Fritzbox 7590 mit ADSL und im 192.168.xx.0/24.
Per LAN da hinter einen OpenWrt mit 192.168.1.0/24.
Beide sind per Statischer Route miteinander verbunden und alle internen Adressen sind von beiden Seiten erreichbar.

Vom OpenWrt bekomme ich aber keine Verbindung ins Internet!
In den LAN (br-lan) Einstellungen ist als Gateway und erster DNS die Fritzbox eingetragen und als zweiter DNS 8.8.8.8.

Wenn ich mich in das WLAN des OpenWrt verbinde wird mir als Gateway die 192.168.1.1 geliefert. Das müsste ja eigentlich die Fritzbox mit der 192.168.xx.1 sein - oder?
OPKG liefert auch eine Fehlermeldung und ping auf Webseiten bzw. 8.8.8.8 liefert kein Ergebnis...

Irgendwie steh ich auf dem Schlauch... wo muss ich jetzt was noch einstellen damit der OpenWrt ins Internet kommt?

Wahrscheinlich nur eine Kleinlichkeit - aber manchmal sieht man eben den Wald vor lauter Bäumen nicht face-smile

Danke für Eure Hilfe face-smile

Content-Key: 3697459940

Url: https://administrator.de/contentid/3697459940

Ausgedruckt am: 25.09.2022 um 12:09 Uhr

Mitglied: SlainteMhath
SlainteMhath 19.08.2022 um 12:58:53 Uhr
Goto Top
Moin,

Wenn ich mich in das WLAN des OpenWrt verbinde wird mir als Gateway die 192.168.1.1 geliefert.
Das kann richtig sein. Welches IUP Subnetz verwendest du für dein WLAN?
Die FB als Gateway ist aber auf jeden Fall falsch. Das GW muss immer im gleich Subnetz sein, wie die Hosts.

lg,
Slainte
Mitglied: em-pie
em-pie 19.08.2022 aktualisiert um 13:14:21 Uhr
Goto Top
Moin,

also der Aufbau sollte ja wie folgt sein

DNS: FB 7490 hat die des ISP, OpenWrt verweist ggf. auf die Fritte, alles hinter dem OpenWrt hat als DNS-Server den OpenWRT-Router

in Ergänzung zu den statischen Routen sollte das eigentlich alles passen - sofern NAT auf dem OpenWrt eingeschaltet ist, denn die Fritte kann kein NAT für die Netze hinter dem OpenWrt, wenn ich das richtig in Erinnerung habe.

Gruß
em-pie
Mitglied: mirmich
mirmich 19.08.2022 um 14:57:34 Uhr
Goto Top
OK - Da könnte der Fehler sein...

Habe FB (192.168.xx0/24) LAN 4 <-> LAN1 OpenWrt (192.168.1.0/24)
Statische Route auf FB und auf OpenWrt eingetragen.

Muss das beides auf WAN? Möchte ja mit einigen Geräten, die per WLAN an der Fritz sind, auch auf Geräte zugreifen können die am OpenWrt sind. Das funktioniert ja aktuell auch - aber alle die an dem OpenWrt sind kommen eben nicht raus ins Internet.

Danke
Mitglied: em-pie
em-pie 19.08.2022 um 15:46:55 Uhr
Goto Top
Welche Aufgaben soll der OpenWrt wahrnehmen?

Dein Problem aktuell ist, dass die Fritte von LAN nach WAN NAT betreibt und keine Unsetzung für das 1.0/24er Netz kann.

Du kommst deshalb nicht raus
Mitglied: fredmy
fredmy 19.08.2022 um 17:01:54 Uhr
Goto Top
Hallo @mirmich

Soll openWRT nur WLAN im "eigenen" Netz liefen ?
oder: soll der openWRT "nur" als AP laufen ?

gibt Anleitungen zum Setup für solche Fälle.
und ... natürlich kann man (!) NAT ausschalten und nur routen so daß IPs aus beiden Netzen erreichbar sind
(läuft hier gerade zum Schrieben - hier Hintergrund: wahlweise DSL (2MBits) oder LTE( max. 10MBits , aber etwas "wackelig") für verschiedene Hosts bereitstellen. Wobei der LTE Router per WLAN-WAN-Schnittstelle angebunden ist. (werkeln FB7530 + Speedport2 LTE, sowie Alix2-Board-openWRT)

NAT ausschalten, Routen setzen ..feddich!
Tools wie traceroute (tracert) helfen dir ein wenig, die Stelle zu finden wo es klemmt.

Fred
Mitglied: mirmich
mirmich 19.08.2022 um 23:01:17 Uhr
Goto Top
OK - ich erkläre mal kurz die Situation:

An der Fritzbox hängt ein Homeoffice PC, die DECT Telefone + ein paar Thermostate die so wie bisher funktionieren müssen.
Da sich mein IoT + NAS + PROXMOX immer weiter ausweitet geht die Fritz (wegen der Broadcasts etc.) langsam in die Knie und ich möchte das voneinander trennen.
Daher habe ich mir einen X4S 7800 geholt und den mit OpenWrt geflasht um mit diesem ein Netzwerk zu schaffen, dass dediziert von der Fritz ist - aber einige Clients von der Fritz müssen auch in das Netz vom X4S.

Also habe ich die Fritz am ISP und die Handy + Notebooks sollen sich mit dem WLAN verbinden.
Auf dem X4S sollen alle Server per LAN und die IoTs per WLAN+LAN verbinden.
Es müssen aber einige der Clients von der Fritz auch rüber kommen ins Netz des X4S (damit ausgewählte Backups machen können und teilweise auch das IoT ansprechen können.

Also ISP -> Fritz mit "offenem Netz" <-> X4S mit Server und IoT

So der Gedanke...

Wenn Ihr mir da eine Lösung bieten könnt... bin ja bestimmt nicht der Erste mit so einer Konfiguration - aber ein entsprechendes TUT habe ich nicht gefunden.

Danke face-smile
Mitglied: fredmy
fredmy 20.08.2022 um 08:55:00 Uhr
Goto Top
Hallo @mirmich

die Suchmaschine liefert aber als Beispiel:

https://openwrt.org/docs/guide-user/network/switch_router_gateway_and_na ...

Läuft aber auf meinen letzten Beitrag hinaus: NAT ausschalten, Routen setzen ..feddich!
Zugegeben..es gibt keine "idiotensichere Anleitung" dazu, manches musst du dir "er-suchen" bzw. aus Beispielconfigs lesen (+ verstehen), in der openWRT-Doku sind alle Parameter erklärt - aber eben nur einmal !

man kann auch alles an den openWRT hängen und FRitz nur als "Modem" laufenlassen (wegen Telefonieren)
gern auch deine 70 Rechner in VLANS aufteilen. Bei 10..20..30 Maschinen sollte es noch keine Broadcastprobleme geben. Zumal Fritz beim broadcasten eh nur als stiller Zuhörer agiert...

Fred
Mitglied: mirmich
mirmich 20.08.2022 um 09:52:14 Uhr
Goto Top
Hallo Fred,

danke für Die Info face-smile

ja - leider ist auf der Fritz das original FritzOS drauf und muss auch drauf bleiben - daher kann ich NAT nicht ausschalten nur auf "exposed host" stellen und da gibt es wohl auch unschöne Nebeneffekte.
Außerdem ist an der Fritz am Gastnetz der Homeoffice PC dediziert unterwegs - das muss auch weiterhin so bleiben.

Also eine andere Überlegung:
Der X4S hat ja auch ein Modem drin - also den X4S direkt an den ISP und die Fritz da hinter als DHCP Server und der Rest mit Homeoffice und DECT (SIP über Telekom) läuft so weiter wie bisher (nur das das Modem eben lahm gelegt wird.)??.
Sollte auch gehen - aber da habe ich gelesen, dass Telefon Probleme macht wegen "keep alive" usw.
Muss dann wahrscheinlich auch auf LAN - WAN damit "Internetzugang über WAN" in der Fritz gewählt wird und SIP etc richtig läuft? Aber dann komm ich ja nicht mehr ohne Umwege auf die anderen VLAN - oder?

Danke face-smile
Mitglied: aqui
aqui 20.08.2022 um 16:02:58 Uhr
Goto Top
Vermutlich hast du die beiden statischen Routen
  • Default Route auf OpenWRT
  • .1.0er Subnetz Route auf der FritzBox
vergessen?!
Diese Tutorials erklären dir eine solche Router Kaskade und seine genauen Setups:
https://administrator.de/tutorial/routing-von-2-und-mehr-ip-netzen-mit-w ...
https://administrator.de/tutorial/kopplung-von-2-routern-am-dsl-port-487 ...
Die Kardinalsfrage hast du auch leider nicht beantwortet: Arbeitest du mit oder ohne NAT (IP Adress Translation) am OpenWRT ?