manuel-r
Goto Top

GPO wird nur teilweise im IE angewendet

Die Richtlinie greift insoweit, dass die entsprechenden Einstellungen am Zielsystem ausgeblendet werden; Site werden aber nicht übernommen.

Hallo alle zusammen,

ich hab hier ein kleines Problem mit Gruppenrichtlinien für den InternetExplorer unter Server 2008. Die Richtlinie sieht unter anderem vor, dass bestimmte URLs bzw. UNCs zu den Zonen vertrauenswürdige Sites bzw. lokales Intranet hinzugefügt werden. Die Richtline wird zumindest teilweise auch angewandt unter Server 2008. Das einzige Problem besteht darin, dass zwar die Einstellungen im IE des Zielsystems ausgegraut werden aber die entsprechenden Sites nicht eingetragen werden.

f47651101f3869df33b3ff3d2239eaf3-neu-1

GPResult sagt mir, dass die Richtlinie angewandt wird und auch das Eventlog ist der Meinung, dass die Richtlinie fehlerfrei übernommen wurde.
Und jetzt kommt's: Zielsysteme unter XP oder Windows 2003 setzen die Richtline auch wie gewünscht um. Dort werden mir die Sites so wie es sein soll angezeigt. Nur die 2008er sperren sich.
DC ist übrigens ein 2008er. Auf dem wurde die Richtline auch erstellt. Und der IE auf dem DC zeigt mir im Gegensatz zu allen anderen 2008ern als einziger die Sites in den entsprechenden Sicherheitsstufen auch an. Nur dort nützen sie mir recht wenig.

Für sachdienliche Hinweise die zur Klärung der Ursache beitragen kann ich leider keine Belohnung aussetzen face-wink

Manuel

Content-Key: 109364

Url: https://administrator.de/contentid/109364

Printed on: June 16, 2024 at 16:06 o'clock

Member: Sonnenscheinhasser
Sonnenscheinhasser Feb 18, 2009 at 11:47:01 (UTC)
Goto Top
Achte mal darauf, ob die "enhanced security configuration" für den IE ein- oder ausgeschaltet ist. Eine entsprechende Meldung dazu kommt, wenn du in der GPO die Sites einträgst. Ich bin da auch erst drüber gestolpert.
Member: manuel-r
manuel-r Feb 18, 2009 at 11:52:51 (UTC)
Goto Top
Beim Erstellen der Richtline kommt da kein Hinweis. Ist ja auch irgendwie logisch, denn woher soll der DC das wissen. Auf den Zielrechnern ist die "verstärkte Sicherheit" aktiv (s. Screenshot) und lässt sich - zumindest für die Intranetzone - auch nicht deaktivieren. Wenn ich bei den Optionen den Haken weg mache kommt keine Fehlermeldung und auch kein Hinweis, aber wenn ich erneut in die Optionen schaue ist der Haken wieder da. Bei den vertrauenswürdigen Sites ist der Haken im Übrigen zwar weg und trotzdem werden die Sites nicht übernommen face-sad

Manuel
Member: DerWoWusste
DerWoWusste Feb 18, 2009, updated at Oct 18, 2012 at 16:37:46 (UTC)
Goto Top
Was Du erfährst, ist evtl. ein Bug, hatte ich auch. Siehe GPO für Trusted Sites zieht nicht
Member: manuel-r
manuel-r Apr 16, 2009 at 12:34:18 (UTC)
Goto Top
Nachdem ich jetzt eine Weile mit anderen Sachen zu kämpfen hatte bin ich mal wieder da ran gegangen und habe wie es scheint eine Lösung gefunden. Im Registry-Pfad HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap muss der Eintrag IEHarden gelöscht werden. Danach noch fix ein gpupdate /force und schon klappt's auch mit dem IE7. Zumindest sieht es bisher so aus.
Nur doof, dass ich das jetzt von Hand auf allen Servern machen muss face-confused

Achso: Den RegWert gibt es übrigens auch im gleichen Pfad unter HKLM - dort bringt das Löschen aber gar nichts. Nach meinem Verständnis müsste es zwar umgekehrt sein, aber naja...

Manuel