Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Installation von ATK behauptet, glib wäre zu alt!

Mitglied: Flix3793

Flix3793 (Level 1) - Jetzt verbinden

24.10.2011 um 09:43 Uhr, 5297 Aufrufe, 6 Kommentare

Bei der Installation von atk 2.2.0 erhalte ich die Fehlermeldung, meine glib-Installation wäre zu alt (bzw. wäre nicht neuer als 2.0.0), obwohl glib 2.29.12 installiert ist.

Hallo administrator.de - Community!

Seit einiger Zeit habe ich als Windows-Mausschubser-Gewohnheitstier mich an Linux rangemacht, genauer gesagt an LinuxMint 11, weil man ja auch mal was anderes sehen will und sich vielseitig zeigt.

An und für sich hat die Installation in einer Oracle VirtualBox - VM geklappt, ist ja dank Gnome-Oberfläche auch nicht allzu schwer.

Als nächstes kam dann erstmal ein "Und jetzt?!", als ich auf dem Desktop war.


Dann: "Terminal!". Also machen wir das mal auf. Hm.


Der nächste Schritt war, mich darüber zu freuen, dass Mint mich über das Terminal mit Glückskekssprüchen und ähnlichem versorgt. =)


Soo... dann wollte ich mal sehen, wie man das Ding "benutzt". Erstmal Verzeichnisse lernen... root, home, etc, sys, usr, ~, /, wasweißich. Okay, das haut hin, schön ausgedruckt, was was ist, wie was heißt, und welches Verzeichnis im Groben was beinhaltet, damit ich ne Referenz zur Hand hab.

Als nächstes: Navigation. Mit cd und dir (-l) konnte ich mich recht schnell anfreunden.

"Juhu, Linux sieht gar nich so schwer aus, und Spaß macht es auch! Endlich mal keine Assistenten und Wizards mehr, sondern IT-Handarbeit!", schoss es mir durch den Kopf.

Aber wie installiert man da nun Software? Ich hab mal was von Paketen gehört... also Onkel Google gefragt.
Irgendwann hatte ich dann raus, dass ich mir die Pakete ziehen, entpacken und dann anscheinend (jetzt kommt der part, wo man mich wegen noobsein steinigen darf! :D) im entpackten Verzeichnis mit den Befehlen:

./configure
make
sudo make install

installieren kann.



(WICHTIG: Paketmanager u.Ä. is nich, habe in der VM keinen Internetzugriff. Und nein, der lässt sich auch nicht einrichten. Leider. -.-)



Gelesen, kurz überlegt, und getan. Als erstes wollte ich mir aus Jux und Dollerei mal ein Theme installieren: http://linuxmint-art.org/content/show.php?content=136291&forumpage= ...

Ganz einfach aus dem Grund, dass ich da mehr Motivation hab als z.B. bei einer öden Anwendungssoftware. Themes sind einfach tollerer.

Okay, dafür brauchen wir also dieses murrine und anscheinend ein sog. "RGBA-Modul". Hm. Weitergegoogelt. Rumprobiert, ruminstalliert...



Mittlerweile bin ich so weit, dass das RGBA-Modul drauf ist, ich aber noch mit murrine kämpfe, weil dieses einige Voraussetzungen hat, so alá murrine braucht als Voraussetzung Paket A und Paket B, Paket A braucht dann Paket C, Paket B braucht D und E, und für E brauch ich X, Y und Z.

Diese zu installieren hat bisher auch ganz gut geklappt. Eines der Pakete war eben auch glib, was ich in der mMn aktuellsten Version (2.29.12) erfolgreich installiert habe. Ein weiteres benötigtes Paket scheint atk 2.2.0 zu sein. Wenn ich dieses jedoch installieren möchte, bricht er mit folgendem Fehler ab:

checking for GLIB - version >= 2.0.0...
* 'pkg-config --modversion glib-2.0' returned 2.29.12, but GLIB (2.28.6)
* was found! If pkg-config was correct, then it is best
* to remove the old version of GLib. You may also be able to fix the error
* by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
* /etc/ld.so.conf. Make sure you have run ldconfig if that is
* required on your system.
* If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
* to point to the correct configuration files
no
configure: error:
* GLIB 2.0.0 or better is required. The latest version of
* GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
* but not in the same location as pkg-config add the location of the file
* glib-2.0.pc to the environment variable PKG_CONFIG_PATH.


Daraus schließe ich, dass die atk-configuration entweder zu doof ist, die Versionsnummer zu lesen (höhö...), oder schlicht und ergreifend das installierte glib - Paket nicht findet.


Liegt es an mir oder an dem System?
Hatte das schonmal jemand von euch?
Weiß einer, wie man das beheben kann?

Ich wäre euch wirklich verbunden, das interessiert mich echt und ich will das zum Laufen kriegen! :D


Lg, Felix!



(Achja, und btw: Ich als Windows-gewohnter muss zugeben, Linux sieht interessant aus und gefällt mir bisher wirklich gut. )
Mitglied: brammer
24.10.2011 um 11:39 Uhr
Hallo,

dein Rechner sagt dir doch was nciht stimmt...

* but not in the same location as pkg-config add the location of the file

Dein rehcner prüft die glib Veriosn nimmt dazu aber den alten oder ursprünglichen Pfad.
Nicht den Pfad in dem du installiert hast.

brammer
Bitte warten ..
Mitglied: Flix3793
24.10.2011 um 12:14 Uhr
Zitat von brammer:
Nicht den Pfad in dem du installiert hast.

Wenn ich das paket (glib 2.29.12) händisch per terminal folgendermaßen installiert habe:

./configure (im entpackten verzeichnis der heruntergeladenen glib-version, vorher mit cd dorthin navigiert natürlich)
make (ebenfalls im selben verzeichnis)
sudo make install (auch im gleichen verzeichnis)

Wohin wird es dann installiert? Was ist hier der standardmäßige Installationspfad?


(Und: Wie sage ich der atk-installation jetzt, wo sie glib findet?)


Danke für die Antwort, trotzdem!

Lg, Felix
Bitte warten ..
Mitglied: dog
24.10.2011 um 16:55 Uhr
Es gibt unter Linux zwei Wege um installierte Libraries zu finden:
  • Selber suchen
  • pkg-config benutzen

Dein Programm macht beides und kommt zu dem Ergebnis, dass das pkg-config und selber suchen zu zwei unterschiedlichen glibs kommen.
Du hast also mehrere Versionen nicht sauber getrennt installiert.

Die musst du jetzt erstmal finden.
01.
find / -name "libglib*.so"
Bitte warten ..
Mitglied: Flix3793
25.10.2011 um 07:36 Uhr
01.
felix@felix-VirtualBox ~ $ sudo find / -name "libglib*.so"
02.
[sudo] password for felix: 
03.
/usr/lib/cli/glib-sharp-2.0/libglibsharpglue-2.so
04.
/usr/local/lib/libglib-2.0.so
05.
/home/felix/glib-2.29.12/glib/.libs/libglib-2.0.so
(mit sudo, weil ich ohne ne ganze Latte von Permission Denied - Meldungen bekommen hab...)

Wenn ich das richtig lese, müsste ich dafür sorgen, dass die beiden oberen Ergebnisse verschwinden, oder?! o.O


Edit:
Wobei, nein! Das unterste Suchergebnis ist nur die entpackte .tar.gz... aber hä, was sind dann die beiden oberen?!
Bitte warten ..
Mitglied: Flix3793
28.10.2011 um 09:25 Uhr
Ich versteh's nich.... das ist irgendwie doof... o_O
Bitte warten ..
Mitglied: Flix3793
03.11.2011 um 10:34 Uhr
Soo, Probem solved...

Nachdem ich das ganze nochmal neu installiert hatte (diesmal virtuell auf unserem VMware ESXi - Testserver => weniger Stress, mehr Power! ), durfte ich feststellen, dass außer dem rgba-gtk alle nötigen Pakete (btw auch glib 2.0) in LinuxMint mitgeliefert werden. *facepalm*

Trotzdem danke! Sollte ich mal wieder was haben, schrei ich laut!


Lg, Flix
Bitte warten ..
Ähnliche Inhalte
Windows 7
Strg-Alt-Entf bei Anmeldung?
gelöst Frage von DirmhirnWindows 712 Kommentare

Hi, soweit ich das gehört habe soll die Kombination Strg-Alt-Ctrl bei der Windows Domain-Anmeldung gegen "überlagende" Malware helfen. Habt ...

Windows 7
Strg + Alt + Entf komplett blockieren
gelöst Frage von KaladialWindows 710 Kommentare

Hallo, ich hab eine eigentlich relativ simple Frage, auf die Mr.Google aber leider keine zufriedenstellende Antwort hatte. Folgendes Problem: ...

Windows 7

Win7 - Netzwerk- und Freigabecenter behauptet kein Internet zu haben

Frage von dremanWindows 724 Kommentare

Hallo zusammen, habe hier einen Windows 7 (Pro) PC, bei dem sowohl das Netzwerksymbol in der Taskleiste, als auch ...

Outlook & Mail

Outlook sucht von alt nach neu?

Frage von anteNopeOutlook & Mail4 Kommentare

Moin, ein Kunde hat mir berichtet, dass Outlook 2010 neuerdings bei der Suche nicht von neu nach alt, sondern ...

Neue Wissensbeiträge
Windows Server

Zähe Update-Installation auf Windows Server 2016

Information von kgborn vor 1 TagWindows Server4 Kommentare

Mir sind in der Vergangenheit immer wieder Beschwerden von Admins unter die Augen gekommen, die sich über die doch ...

Humor (lol)
Turnschuhe per Firmware lahmlegen
Information von Henere vor 1 TagHumor (lol)6 Kommentare

Und was kommt demnächst ? Bekomme ich kein Klopapier mehr, weil der Spender einem DDOS unterliegt ? :-) Ich ...

Sicherheit

Sicherheitsrisiko in WinRAR und Co. durch Schwachstelle in UNACEV2.DLL

Information von kgborn vor 1 TagSicherheit

In der seit 2005 nicht mehr aktualisierten Bibliothek UNACEV2.DLL gibt es eine Path-Traversal-Schwachstelle. Diese ermöglicht es, bei ACE-Archiven Dateien ...

Internet

CDU Propaganda: Urheberschutz im Internet - Ende des digitalen Wild-West

Information von Frank vor 2 TagenInternet6 Kommentare

Hallo Administratoren, aus einem Kommentar heraus habe ich folgenden Beiträge von Herr Sven Schulze und Axel Voss (beide CDU ...

Heiß diskutierte Inhalte
Hardware
Frage an Kenner von 5,25 Zoll Laufwerken
Frage von DerWoWussteHardware54 Kommentare

Moin Kollegen. Hier wird gerade im Archiv gewühlt und 5,25 Zoll Disketten ("2S/HD", 96TPI) sollen eingelesen werden. Ich habe ...

Windows Tools
Dateiname Automatisch auf PDF Klartext oder als Barcode abdrucken
Frage von spongebob24Windows Tools29 Kommentare

Hallo Zusammen, habe eine tolle Anforderung bekommen. Ich sollte auf mehrere PDF Dateien Automatisch einen Stempel anbringen lassen. Toll ...

Internet
SDSL oder ADSL - Preis-Leistungs-Verhältnis
Frage von ZeppelinInternet22 Kommentare

Wehrte Community, der Unterschied dieser beiden Techniken ist recht einfach erklärt. Das S, steht für Synchron (Gleich) und das ...

Microsoft Office
MicroSoft und seine Lizenzen
Frage von ZeppelinMicrosoft Office19 Kommentare

Wehrte Community, ich wende mich an die Community weil MicroSoft dazu keine Stellung nehmen möchte. Ich öffne mein Web-Browser ...