Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kopiervorgang langsam

Mitglied: Dani

Dani (Level 5) - Jetzt verbinden

15.08.2018 um 11:35 Uhr, 2560 Aufrufe, 8 Kommentare

Guten Morgen werte Kolleginnen und Kollegen,
nachdem ich mich entschlossen habe Privat auf Windows auf Linux umzusteigen, kommen nach und nach mehrere Baustellen auf.

Ich habe ein NAS (Synology DS418play) auf dem es mehrere CIFS/SMB Freigaben gibt. Um diese Freigaben nicht jedes Mal manuell einhängen zu müssen, habe ich die /etc/fstab um folgenden Eintrag erweitert:
01.
//192.168.52.6/anwendungen /media/dani/anwendungen cifs credentials=/home/dani/.smbcredentials,uid=1000,gid=1000 0 0
Nach einem Neustart und der Anmeldung wird die Freigabe Anwendungen problemlos eingehängt.

Mein Notebook und das NAS sind jeweils über einen Switch mit 1000MBit/s Full-Duplex verbunden.

Kopiere ich über den integrierten Dateimanager von Ubuntu (Version 3.26.3) von der eingehängten Freigabe eine ISO-Datei auf mein Notebook so beträgt die Übertragungsgeschwindigkeit im Schnitt 80-92MB/Sekunde. Wiederhole ich den selben Vorgang über das Terminal/die Shell so kommt der Befehl pvauf 80,8MB/Sekunde.
01.
pv /media/daniel/anwendungen/windows.iso > /home/dani/Downloads/windows.iso
Kopiere ich eine Datei vom Notebook auf die CIFS-Freigabe des NAS-Systems komme ich über den integrierten Dateimanager von Ubuntu auf knapp 11,2MB/Sekunde. Wiederhole ich auch diesen Vorgang über das Terminal/die Shell so komme ich mit dem Befehl pvca. 66MB/Sekunde.
01.
pv /home/dani/Downloads/windows.iso > /media/daniel/anwendungen/windows.iso
Alternativ zu /etc/fstab habe ich die SMB/CIFS-Freigabe als GVFS eingehängt.
01.
gio mount smb://192.168.52.6/anwendungen
Hier ist das Kopieren der Dateien sowohl vom als auch zum NAS blitz schnell. In beide Richtungen komme auf jeweils auf ca. 70-90MB/Sekunde. Das Problem bei dieser Variante ist, dass keine Zuordnung der Rechte wie bei mount möglich ist. Was dazu führt, dass vermeidlich gelöschte Ordner/Dateien auf der SMB/CIFS Freigabe immer wieder aufgelistet werden.

Notebook
Ubuntu 18.04.1 Desktop (LTS)
Dateimanager 3.26.3
Anbindung über 1GBit/s

NAS
Synology DS418play
DSM: 6.2-23739 Update 2
Anbindung über 1GBit/s
Dateidienste: SMB2, SMB3 aktiv

Kann jemand von euch das Verhalten nachstellen bzw. bestätigen? Gibt es evtl. einen Workaround für die Problematik?
Kopieren über die Shell wird mit der Zeit einfach mühsam.


Gruß,
Dani
Mitglied: NetzwerkDude
15.08.2018, aktualisiert um 13:25 Uhr
Häng mal das Share via fstab mit expliziter SMBv3 option ein, müsste folgender parameter sein:
01.
vers=3.0
also ingesamt so etwa:
01.
//192.168.52.6/anwendungen /media/dani/anwendungen cifs credentials=/home/dani/.smbcredentials,vers=3.0,uid=1000,gid=1000 0 0
Bitte warten ..
Mitglied: Dani
15.08.2018 um 14:19 Uhr
Hallo NetzwerkDude,
Häng mal das Share via fstab mit expliziter SMBv3 option ein, müsste folgender parameter sein:
hab ich bereits ausprobiert und keinerlei Verbesserung gebracht. Ebenfalls mit 2.0 bzw. 2.1 probiert - ohne Erfolg.


Gruß,
Dani
Bitte warten ..
Mitglied: Henere
15.08.2018 um 20:32 Uhr
Warum muss es SMB sein ?
Ich habe die beste Performance mit iSCSI auf den QNAP gemacht.
5 Platten als RAID5, 10GBe per SFP+ direkt zwischen Server und NAS ... bis zu 600MB/s habe ich schon gesehen.

Grüße, Henere
Bitte warten ..
Mitglied: Dani
15.08.2018, aktualisiert um 23:05 Uhr
Moin,
Warum muss es SMB sein ?
Geht vor allem um die Snapshot-/Versionierung Funktion.

Ich habe die beste Performance mit iSCSI auf den QNAP gemacht.
Die beste Performance unter Linux erreichst du mit NFS.

5 Platten als RAID5, 10GBe per SFP+ direkt zwischen Server und NAS ... bis zu 600MB/s habe ich schon gesehen.
Ich weiß nicht was du mir damit sagen möchtest. Die Performance an sich zwischen NAS und Notebook bzw. Rechner stimmt eigentlich. Mir geht es primär darum, warum die Performance beim Schreiben auf das NAS über den Ubuntu Dateimanager so miserabel ist.


Gruß,
Dani
Bitte warten ..
Mitglied: Henere
15.08.2018 um 23:32 Uhr
Nur über den Dateimanager oder auch per shell ?

Grüße, Henere
Bitte warten ..
Mitglied: Dani
16.08.2018 um 20:26 Uhr
Guten Abend Henere,
Nur über den Dateimanager oder auch per shell ?
steht oben in der Frage.


Gruß,
Dani
Bitte warten ..
Mitglied: Henere
17.08.2018 um 00:45 Uhr
Sorry. Ja. Ich muss aufmerksamer lesen.
Bitte warten ..
Mitglied: NetzwerkDude
16.10.2018 um 21:06 Uhr
Übrigens scheint es ein Bug in Nautilus zu sein, wird aktuell in deren Bugtracker diskutiert:
https://gitlab.gnome.org/GNOME/nautilus/issues/695
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk

Kopiervorgang von Share zu Client langsam

gelöst Frage von ahussainWindows Netzwerk4 Kommentare

Hallo, ich habe schon X Beiträge zu dieser Frage gelesen, aber nichts hat bisher geholfen. Problem: der Kopiervorgang von ...

Netzwerkgrundlagen

Kopiervorgang im Gigabit Heimnetzwerk mit 2 NICs langsam

gelöst Frage von John.DNetzwerkgrundlagen20 Kommentare

Hallo Administratoren ! Folgendes Szenario hat sich bei mir ergeben, welches ich nicht verstehe. Via Gb LAN ist mein ...

Windows 7

Kopiervorgang Logdatei

Frage von Riddler123Windows 71 Kommentar

Hi, hab ne NAS Festplatte und wollte wissen ob ich auf meinem Windows 7 Laptop nach dem Kopieren von ...

Windows Netzwerk

Kopiervorgang bricht ab !!!

gelöst Frage von alexlazaWindows Netzwerk6 Kommentare

Hallo Leute, im Einsatz ist ein HP ZBook 17 G4 mit WIN10 Pro. Seit neuestem bricht jeglicher kopiervorgang vom ...

Neue Wissensbeiträge
Internet

(NetzDG) .und Ihr heult über Limux in München, schon gehört, was die SPD vor hat?

Information von certifiedit.net vor 6 StundenInternet1 Kommentar

Na dann, Gute Nacht Bürgerrechte. Wofür dann eigentlich die DS-GVO? Ich bezeichne mich als Polizist und hol mir einfach ...

Sicherheit

Chrome 79 übermittelt eingegebene Kennwörter nach Hause

Information von DerWoWusste vor 2 TagenSicherheit15 Kommentare

Ab sofort warnt Chrome standardmäßig Nutzer davor, wenn aus Leaks bekannte Passwörter zum Einsatz kommen. Beim Besuch einer Website, ...

Viren und Trojaner
Trend Micro WFBS 10 SP1 Patch 2185
Tipp von Abramelin vor 3 TagenViren und Trojaner3 Kommentare

Hi, Hab gerade gesehen das Patch 2185 für TM WFBS 10 SP1 erschienen ist! Werde mal Morgen den Patch ...

Viren und Trojaner

Neuer Virus lässt Windows im abgesicherten Modus starten

Tipp von transocean vor 3 TagenViren und Trojaner7 Kommentare

Moin, lest selbst. Grüße Uwe

Heiß diskutierte Inhalte
Netzwerke
Netzwerkstruktur für Zuhause 1Anschluss 2 Netze
Frage von chrishaefNetzwerke27 Kommentare

Hallo liebes Forum, Ich hätte da mal eine Frage an die Profis. Bei uns liegt ein DSL Anschluss im ...

Windows 7
Windows 7 - Ein DSL Speedtest - Mehrere Browser - Unterschiedliche Ergebnisse
Frage von AusAltwirdNeuWindows 725 Kommentare

Hallo zusammen, mein PC hat zwei Rj45 Anschlüsse. Beide sind auf Gigabit Vollduplex eingestellt. An beiden Anschlüssen erreiche ich ...

Batch & Shell
Eingabeaufforderung macht Pause bei Datensicherung mit Robocopy auf DVD
Frage von anmelderBatch & Shell23 Kommentare

Hallo, ich sichere einige Daten per Robocopy auf DVD-RAM. Wenn ich nicht am Rechner sitze macht der Befehl nach ...

Server-Hardware
Server startet nach Debian Installation nicht mehr
Frage von RobertDServer-Hardware17 Kommentare

Hallo, ich habe heute zum ersten Mal auf meinen Server (selbst zusammengebaut) Linux installiert, ging auch alles ganz gut. ...