Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux debian Kernel Panic nach Erstinstallation

Mitglied: s7mahess

s7mahess (Level 1) - Jetzt verbinden

22.03.2010, aktualisiert 10:43 Uhr, 6043 Aufrufe, 10 Kommentare

Guten Morgen,

ich persönlich noch blutiger Linux anfänger wollte mich mal in das kalte Wasser werfen und meinen horizont erweitern, leider habe ich schon zu Anfang folgendes Problem:

Nach der Installation der Debian Distri vom 29.01 diesen Jahres.

http://www.debian.org/CD/netinst/ --> amd64

bekomme ich beim ersten start des Rechners gleich die Fehlermeldung:

[0.683427] Kernel Panic - not syncing: VFS: Unable to mount root on fs on unknown-block (0,0)

Festplattenaufteilung wie folgt:

hdd 0

part 0 - NTFS (Win XP 64)
part 1 - NTFS (Daten)
part 2 - ext3 (root)
part 3 - swap

Rechner:

AMD Athlon x64 3300+
8 GB DDR


Wie schon oben erwähnt habe ich gar keine Ahnung von Linux (außer Live CD).

MfG Martin
Mitglied: michi1983
22.03.2010 um 10:53 Uhr
Hallo Martin,

ich hoffe ich erscheine dir nicht zu dumm mit meiner Antwort

Ich bin mir nicht 100% sicher aber es scheint, als ob Linux versucht root auf der Partiton 0 (Auf der du ja Windows hast) zu mounten.

Abgesehen davon würde ich dir empfehlen, eine andere Distri zu empfehlen mit grafischem UI, ist auch einfacher zu installieren.
Ich kann dir nur Ubuntu empfehlen (Basiert übrigens ebenso auf Debian).

Gruß, Michael
Bitte warten ..
Mitglied: 85335
22.03.2010 um 10:54 Uhr
Leider hab ich keine Ahnung von der netinst-version.
Aber so wie es aussieht wird deine ext3 Partition nicht gefunden oder der bootmanager ist nicht richtig installiert.
Bootet Windows noch normal oder bekommst du ein Auswahlfenster mit Windows und Debian ?
Bitte warten ..
Mitglied: s7mahess
22.03.2010 um 11:00 Uhr
Zitat von michi1983:
Hallo Martin,

ich hoffe ich erscheine dir nicht zu dumm mit meiner Antwort

Ich bin mir nicht 100% sicher aber es scheint, als ob Linux versucht root auf der Partiton 0 (Auf der du ja Windows hast) zu
mounten.

Abgesehen davon würde ich dir empfehlen, eine andere Distri zu empfehlen mit grafischem UI, ist auch einfacher zu
installieren.
Ich kann dir nur Ubuntu empfehlen (Basiert übrigens ebenso auf Debian).

Gruß, Michael

Wie gesagt blutiger Anfänger, bei der Aktuellen Ubuntu Distri komme ich noch nciht mal soweit das ich installieren kann, der installtionsprozess bricht ab weil er keine partition findet.

Ich probier heute abend mal in Grub die entspächenden einstellungen zu ändern.

Zitat von 85335:
Leider hab ich keine Ahnung von der netinst-version.
Aber so wie es aussieht wird deine ext3 Partition nicht gefunden oder der bootmanager ist nicht richtig installiert.
Bootet Windows noch normal oder bekommst du ein Auswahlfenster mit Windows und Debian ?

ja windows bootet normal
Bitte warten ..
Mitglied: 85335
22.03.2010 um 11:05 Uhr
Dann ist auch noch kein bootloader installiert.

Probier doch mal die iso runterzuladen, vielleicht kommst du damit besser zurecht:
http://ftp.de.debian.org/debian-cd/5.0.4/amd64/iso-dvd/
Bitte warten ..
Mitglied: s7mahess
22.03.2010 um 11:16 Uhr
sorry, missverständnis

bootloader ist natürlich installiert, grub in der neusten version. windows startet nach der auswahl im bootlaoder normal
Bitte warten ..
Mitglied: 85335
22.03.2010 um 12:08 Uhr
Aha, dann ist es wohl die Einstellung. Wie Michi1983 schon sagte: (0,0) ist die erste Partition auf der ersten Platte, sollte aber (0,2) also 2. Partition auf der ersten Platte sein.
Bitte warten ..
Mitglied: alex-w
22.03.2010 um 12:23 Uhr
Richtig du musst die Reihenfolge der Platten im Grub umstellen (nicht von 0,0 sondern 1,0). Den Fehler hatte ich letztens auch auf einem Server.
Bitte warten ..
Mitglied: 85335
22.03.2010 um 12:56 Uhr
Wenn ich das richtig verstanden habe ist es nur eine Platte (hdd0) und diese Platte ist partitioniert (0-3).
Also (0,2)
Bitte warten ..
Mitglied: s7mahess
22.03.2010 um 17:52 Uhr
so hab mich oben in der reichenfolge etwas vertan

hdd 0

part 0 - NTFS (Win XP 64)
part 1 - ext3 (root)
part 2 - swap
part 3 - NTFS (Daten)

Grub einstellungen

1. linux

root (hd0,1)
kernel /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda2 ro quit
initrd /boot/initrd.img-2.6.26-2-amd64

2. linux single mode

root (hd0,1)
kernel /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda2 ro single
initrd /boot/initrd.img-2.6.26-2-amd64

3. windows

root (hd0,0)
savedefault
makeactive
chainloader +1
Bitte warten ..
Mitglied: orcape
30.03.2010 um 20:18 Uhr
Hi s7mahess,

ich gehe mal davon aus Du hast Lenny installiert.

Zitat von s7mahess:

bekomme ich beim ersten start des Rechners gleich die Fehlermeldung:

[0.683427] Kernel Panic - not syncing: VFS: Unable to mount root on fs on unknown-block (0,0)

......unknown-block (0,0) ?

Zitat von s7mahess:
root (hd0,1)
kernel /boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda2 ro quit
initrd /boot/initrd.img-2.6.26-2-amd64

.....root (hd0,1) irgendwas hast Du bei der Partitionierung falsch gemacht. Grub sucht mit Sicherheit in der falschen Partition nach den angegebenen Daten.

@michi1983
Selbstverständlich kannst Du auch Debian mit grafischem GUI installieren. Das es Ubuntu ehemaligen Win-Nutzern leichter macht bleibt unumstritten.

Gruss orcape
Bitte warten ..
Ähnliche Inhalte
Debian
Linux debian 9 Installation
gelöst Frage von 135624Debian16 Kommentare

Hallo zusammen, ich habe mich ein wenig mit Debian auseinandergesetzt und möchte mir eine Standard-Installation als Grundlage für andere ...

Debian
Linux (Debian) Schulung gesucht
Frage von smartinoDebian5 Kommentare

Hallo zusammen, ich bin schon seit vielen Jahren IT Systemadministrator und habe im Windows und IT Infrastrukturbereich tief gehende ...

Hyper-V
Linux Debian Maus nicht nutzbar!
gelöst Frage von TechProbsHyper-V5 Kommentare

Hi, wir haben einen 2 Host Cluster Hyper V Umgebung auf 2016er Windows Server. Wir haben versucht von Vsphere ...

Debian

Sauberes deinstallieren in linux (debian)

gelöst Frage von the-last-gentleman-jackDebian7 Kommentare

moin moin, ich bin vor kurzem erst auf linux(Debian Jessie) umgestiegen und nun stehe ich vor einem kleinen Verständnis ...

Neue Wissensbeiträge
Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 - Jetzt in Deutsch verfügbar! (Windows 10 1903 Support)

Tipp von TrinXx vor 1 TagSicherheits-Tools1 Kommentar

Moin! Nach wochenlangem Warten wird Trend Micro das SP1 für WFBS 10 voraussichtlich am 26.08.19 veröffentlichen. Ich habe das ...

Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 2 TagenHyper-V5 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 2 TagenServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 4 TagenHumor (lol)9 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Heiß diskutierte Inhalte
Server
Ein Server ins Haus stellen. Was brauche ich dafür?
Frage von JoschiTomServer13 Kommentare

Hallo Community, ich spiele mit dem Gedanken eine Server mir zu holen. Was brauche ich dafür? Und wie sind ...

Backup
Veeam Backup Endpoint Free sichert nicht alle Dateien in AppData
gelöst Frage von speedy26gonzalesBackup12 Kommentare

Hallo, ich sollte ein paar Dateien in C:\Users\xyc\AppData\Local\Microsoft\Outlook wieder herstellen. Auf dem Benutzerkonto ist in Outlook ein IMAP Konto ...

Windows Server
Ist es möglich, eine deutsche W2016 Installation mit einer UK-Lizenz zu aktivieren?
gelöst Frage von keine-ahnungWindows Server10 Kommentare

Moin at all, ist ja noch Freitag. Ich habe hier noch zwei UK OEM W2016 Standard Pakete rumfliegen Muss ...

Windows 10
Windows 10 Backup auf Netzwerk Storage
Frage von Futschel2608Windows 1010 Kommentare

Hallo geehrte Mitstreiter Innen, Wir wollen in unserer Windows 10 Domäne den Einzelnen Usern ermöglichen ihre Desktop PC's zusichern. ...