114380
Goto Top

Linux DomainMember - cifs - Computeraccount im AD

Hallo miteinander,

folgende Situation:
Linux-Rechner (ubuntu 18.04 LTS) wurde mittels sssd ein Domain-Member.
Funktioniert auch alles wie gewünscht...

Für ein Software (confluence) muß ein lokaler Pfad als Backup-Target angegeben werden, Freigaben müssen daher bereits gemountet sein.

Bei der Freigabe hat der Computeraccount r/w-Berechtigungen (QNAP).

Wenn ich ähnliche Konstrukte aus der Windows-Welt gefahren bin, mit einem DomainServer, konnte ich erfolgreich auf das Target zugreifen.

Irgendwie habe ich momentan eine Denkblockade, wie ich mount beibringen kann, den AD-Computeraccount zu verwenden.

Sicherlich kann ich als Alternative auch einen AD-User Account anlegen, was auch Plan B wird, wenn ich nicht weiterkomme, würde es aber nach Möglichkeit gern vermeiden.

Hat jemand eine Idee und kann mich in die richtige Richtung schubsen?

Viele Grüße Raboom

Content-Key: 468912

Url: https://administrator.de/contentid/468912

Printed on: February 23, 2024 at 07:02 o'clock

Member: GrueneSosseMitSpeck
GrueneSosseMitSpeck Jul 07, 2019 at 16:09:02 (UTC)
Goto Top
ähm ja, ich sach mal wenn ein Windows-Rechner einer Domäne beitritt, dann wird automatisch ein Computeraccount dort erstellt... bei Linux-Rechnern muß man das tlw händisch machen wenn das OS selbt keinen Domainjoin mitbringt. An der QNAP berechtigt man dann

domänenname\computernaccountname$ mit R/W Rechten

das entsprechende Mounten macht man über die FSTAB oder Mounttab Datei
Jedenfalls läuft das auf Windows-Rechnern, wenn ich z.B. einem Computeraccount Zugriff auf ein Zertifikat gewähre dann sieht das so aus als ob der accountname$ (das $ Zeichen sieht man an den meisten Windows GUIs nicht) Leserechte hat.
Mitglied: 114380
114380 Jul 08, 2019 at 13:28:05 (UTC)
Goto Top
Hi,

exakt so habe ich es, beim DomJoin wurde der AD-Account autom. mittels sssd angelegt.
Ich muß halt mount irgendwie beibringen, nicht nach User/PW zu fragen.
smbclient soll die Option "-P" kennen, jedoch auch nur einmalig aus einem anderen Beitrag in einem anderen Forum entdeckt.

Trotzdem vielen Dank

Raboom
Member: Dr0pLWD
Dr0pLWD Jul 22, 2019 at 15:02:25 (UTC)
Goto Top
Hey,

vielleicht hilft dir ja dieser Artikel? http://manpages.ubuntu.com/manpages/cosmic/de/man1/hostnamectl.1.html

Wenn du nach dem DomJoin den Hostname mit dem Domain-Suffix versiehst, erstellt sich für gewöhnlich auch ein AD-Computerkonto.

ich hoffe mal, ich hab's nicht falsch verstanden:D

Beste Grüße
Mitglied: 114380
114380 Sep 27, 2019 at 05:24:55 (UTC)
Goto Top
Hallo und sorry für die verspätete Rückmeldung,

DomJoin etc. ht ja alles wunderbar geklappt, das ist nicht das Problem.
AD-Account wurde autom.. erstellt, DNS-Eintrag ist, statisch und Suffix ist auch korrekt.

Mein Problem ist, wie gebe ich smbmount dazu, keinen AD-User sondern den AD-Computer-Account zu verwenden?

Viele Grüße Oli

P.S.: Ich habe es über einen User gelöst, ist für mich jedoch nicht schön. Daher würde ich es gern über den Computer-Account gelöst haben.