Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux VM nach umzug langsam

Mitglied: 136826

136826 (Level 1)

14.10.2019 um 14:43 Uhr, 1093 Aufrufe, 18 Kommentare

Hallo, ich habe meinen Server von 2012R2 auf 2019 neu installiert.

Also erst die VM´s exportiert und anschließend nach der Neuinstallation vom 2019 wieder importiert.
Bei keinen VM´s gibt es Probleme bis auf ein Debian8.3 VM!

Sie ist zwar per Ping vom host und anderen Clients erreichbar, von der VM aus sind pings zu anderen Clients möglich,
aber sie verhält sich extrem langsam..
das heisst: wenn ich mich per hyper v manager verbinde und ein ifconfig absende baut sich der Bildschirm extrem langsam auf, Zeile für Zeile..

Auf der VM läuft ein Webserver. Wenn ich die Seite per Browser aufrufe funktioniert sie zwar, aber jede Aktion (klick auf einen Reiter bspw)
benötigt mind. 50-60 Sekunden.

nun habe ich dr. Google befragt und verschiedenen Sachen ausprobiert.
-Zuvor stand die VM auf dynamische MAC. Das hab ich schnell geändert und die alte ursprüngliche MAC Adresse eingegeben.
keine Veränderung!

-hier und da habe ich gelesen das die /etc/udev/rules.d/70-persistent-net.rules angepasst werden muss. <- die existiert aber nicht auf meinem System!

- unter /etc/network/interfaces zeigt mit dir Schnittstelle eth0 an. diese ist auch mit der IP konfiguriert.

jemand zufällig eine Lösung parat?
Mitglied: NordicMike
14.10.2019 um 14:45 Uhr
Anzahl CPUs hast Du wieder hoch gesetzt?
Bitte warten ..
Mitglied: Lochkartenstanzer
14.10.2019 um 14:48 Uhr
Zitat von NordicMike:

Anzahl CPUs hast Du wieder hoch gesetzt?

Und auch geschaut, daß die richtigen Treiber verwendet werden, ggf. "Hardware" in der VM angepaßt?

lks
Bitte warten ..
Mitglied: 136826
14.10.2019 um 14:51 Uhr
vorher waren 4 CPU´s drin und so habe ich das auch gelassen. Die Konfiguration der VM wurde komplett übernommen.
Als ich die Microsoft VM´s zum erstenmal gestartet hatte, fragten diese nach Netzwerk - Ihr Adapter wird für ein anderes Netz
benutzt, sollen diese für das aktuelle Netz freigegeben werden? <- so ungefähr.

Die Linux VM hat keine GUI und fragte nicht nach sowas. kann es damit zusammen hängen?

eine Fehlermeldung erscheint nicht im Terminal.. Sie ist wie schon beschrieben per ping mit einem ttl von 63 <1ms erreichbar.
Bitte warten ..
Mitglied: 136826
14.10.2019, aktualisiert um 15:04 Uhr
zitat:Und auch geschaut, daß die richtigen Treiber verwendet werden, ggf. "Hardware" in der VM angepaßt?
wie kann ich das überprüfen?

probiert habe ich:
inxi
hwinfo
lshw
ohne erfolg. bash kennt das nicht.
nur lscpu wurde erkannt und zeigte mir daten zum cpu an..
Bitte warten ..
Mitglied: Spirit-of-Eli
14.10.2019 um 15:06 Uhr
Zitat von 136826:

zitat:Und auch geschaut, daß die richtigen Treiber verwendet werden, ggf. "Hardware" in der VM angepaßt?
wie kann ich das überprüfen?

probiert habe ich:
inxi
hwinfo
lshw
ohne erfolg. bash kennt das nicht.
nur lscpu wurde erkannt und zeigte mir daten zum cpu an..

Hast du schon aktualisiert? Sind über haupt die OpenVM Tools installiert?
Dann gibt es noch eine Anpassung am grub. Das könnte ich ggf. Noch raussuchen.
Bitte warten ..
Mitglied: StefanKittel
14.10.2019 um 15:42 Uhr
Moin,

eine Lösung habe ich nicht, aber wie wäre ein Update auf das aktuelle Ubuntu?
U8 ist von 2015 und seit 2018 gibt es keine Sicherheitsupdates. Für einen Webserver nicht zu empfehlen.

Was auch nicht hilft: Für Linux würde ich immer VMWare Hyper-V vorziehen.

Viele Grüße

Stefan
Bitte warten ..
Mitglied: 136826
14.10.2019 um 16:06 Uhr
Hallo, ein Umzug auf ein aktuelles Ubuntu ist nicht möglich da dieses installierte pogramm aktualisiert werden müsste was nicht funktioniert. Der Programmierer hatte mir davon abgeraten. Der Webserver ist nur intern im Netz betrieben. Von außen nicht erreichbar..
Bitte warten ..
Mitglied: Spirit-of-Eli
14.10.2019 um 16:09 Uhr
Zitat von 136826:

Hallo, ein Umzug auf ein aktuelles Ubuntu ist nicht möglich da dieses installierte pogramm aktualisiert werden müsste was nicht funktioniert. Der Programmierer hatte mir davon abgeraten. Der Webserver ist nur intern im Netz betrieben. Von außen nicht erreichbar..

Ohne Aktualisierung wird die VM schon unter HyperV 2016 nicht mehr sauber laufen. Ein Groß machen da die OpenVM Tools aus.
Sind diese aktuell wäre das schon ein Schritt.
Bitte warten ..
Mitglied: 136826
14.10.2019 um 16:10 Uhr
Die Anpassung im grub wären toll
Bitte warten ..
Mitglied: itisnapanto
14.10.2019 um 16:11 Uhr
Moin ,

sind die Integrationsdienste auch installiert und aktiviert ?
Würde aber auch auf die aktuelle LTS Version gehen . Ist beim Webserver ja schnell gemacht.

Hier noch ein netter Artikel. Speziell Punkt 6.3.

https://decatec.de/home-server/ubuntu-server-als-hyper-v-gastsystem-inst ...

Gruss
Bitte warten ..
Mitglied: Spirit-of-Eli
14.10.2019 um 16:15 Uhr
Zitat von 136826:

Die Anpassung im grub wären toll

LinuxVM Tools:

apt-get install --install-recommends linux-virtual
apt-get install linux-tools-virtual linux-cloud-tools-virtual
apt-get update
apt-get upgrade
reboot

Grub Anpassung:

nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="elevator=noop"

update-grub
reboot
Bitte warten ..
Mitglied: erikro
14.10.2019 um 16:17 Uhr
Moin,

Zitat von StefanKittel:
eine Lösung habe ich nicht, aber wie wäre ein Update auf das aktuelle Ubuntu?
U8 ist von 2015 und seit 2018 gibt es keine Sicherheitsupdates.

Das stimmt nicht. Der LTS für Jessie läuft noch bis Mitte 2020. Debian ist nicht Ubuntu.

Liebe Grüße

Erik
Bitte warten ..
Mitglied: certifiedit.net
14.10.2019 um 16:26 Uhr
Zitat von StefanKittel:

Moin,

eine Lösung habe ich nicht, aber wie wäre ein Update auf das aktuelle Ubuntu?
U8 ist von 2015 und seit 2018 gibt es keine Sicherheitsupdates. Für einen Webserver nicht zu empfehlen.

Was auch nicht hilft: Für Linux würde ich immer VMWare Hyper-V vorziehen.

Viele Grüße

Stefan

Einen Extra VIrtualisierer nur für das Debian ist aber weder sinnvoll, nur notwendig.

Wir betreiben seit 2008 (ja, würg, richtig, damals!) auch Linux unter Hyper-V und das läuft wunderbar.

VG
Bitte warten ..
Mitglied: StefanKittel
14.10.2019 um 18:03 Uhr
Zitat von erikro:
Zitat von StefanKittel:
eine Lösung habe ich nicht, aber wie wäre ein Update auf das aktuelle Ubuntu?
U8 ist von 2015 und seit 2018 gibt es keine Sicherheitsupdates.
Das stimmt nicht. Der LTS für Jessie läuft noch bis Mitte 2020. Debian ist nicht Ubuntu.

https://wiki.debian.org/DebianReleases
End of life date = 2018-06-17
Von LTS hat er nicht geschrieben also hat er das wohl auch nicht.
Bitte warten ..
Mitglied: certifiedit.net
14.10.2019 um 18:11 Uhr
Schon alleine die 8.3 würde ich nicht mehr einsetzen, die 8.9.x ok, weil auch Debian nicht immer so Reibungslos upzudaten ist. Aber auch hier scheint das Problem eher zu sein, dass man zwangsweise damit auseinandersetzt, ohne vertiefte Kenntnisse zu haben. Daher würde ich davon ausgehen dass a) jeder Stable Branch von Debian ein LTS ist, das heisst dennoch, dass von 8.0 bis 8.9.9.9xx jeweils durchgepatched gehört, aber b) die Nichtangabe eines LTS (im Falle von Ubuntu o.ä) nicht darauf schliessen lässt, dass er diese einsetzt - oder nicht.

Empfehlung: Einkauf von externem Support.
Bitte warten ..
Mitglied: erikro
15.10.2019 um 08:28 Uhr
Moin,

Zitat von certifiedit.net:
Daher würde ich davon ausgehen dass a) jeder Stable Branch von Debian ein LTS ist, das heisst dennoch, dass von 8.0 bis 8.9.9.9xx jeweils durchgepatched gehört, aber b) die Nichtangabe eines LTS (im Falle von Ubuntu o.ä) nicht darauf schliessen lässt, dass er diese einsetzt - oder nicht.

So ist es. Anders als bei MS, das sich LTS teuer bezahlen lässt, heißt LTS bei Debian lediglich, dass die Maintainer Group eine andere ist. Das kann man auch auf der Seite, die @StefanKittel angegeben hat, nachlesen, wenn man einfach mal auf den Link klickt:

Debian Long Term Support
Debian Long Term Support (LTS) is a project to extend the lifetime of all Debian stable releases to (at least) 5 years. Debian LTS will not be handled by the Debian security team, but by a separate group of volunteers and companies interested in making it a success.
Thus the Debian LTS team takes over security maintenance of the various releases once the Debian Security team stops its work.

Liebe Grüße

Erik
Bitte warten ..
Mitglied: 136826
15.10.2019 um 13:12 Uhr
Alles zurück! ich hab den Fehler beseitigen können!

aber wie ist das lächerliche!

Nach der migration der VM´s auf dem neuen host, habe ich übersehen zu schauen ob auf allen 3 DC´s der DNS ordentlich läuft.
ein DC hat es nicht überlebt. Ich musste die NW Schnitttstelle auf DHCP stellen und anschließend neu die ursprüngliche Konfiguration
eintippen. Und tataa es geht wieder!
aufgefallen ist es nur als ich versucht habe vom DC rauszupingen..


Wahnsinn!
Bitte warten ..
Mitglied: certifiedit.net
15.10.2019 um 13:39 Uhr
Das ist überhaupt nicht lächerlich, stümperhaft vielleicht. Ich meine, wofür hat man drei DCs, wenn man Sie nicht unter Kontrolle hat...gut, ein Ausfall sind dann nur 33%...

aber wie gesagt...liegt nicht am HV.
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Hyper-V VM Umzug
Frage von BytedreherHyper-V3 Kommentare

Hallo zusammen, ich möchte meinen virtuellen DC (Server2012) von aktuell Hyper-V Host (Server2012) auf meinen neuen Hyper-V Host (Server2012R2) ...

Microsoft Office
Excel langsam nach Umzug
Frage von Finchen961988Microsoft Office4 Kommentare

Hallo und einen wunderschönen guten Morgen liebes Forum, ich habe mal nee Frage, ich habe vor ein paar tagen ...

Vmware
VMWare Workstation VM langsam
Frage von TuberPlaysVmware11 Kommentare

Hallo zusammen, ich habe auf meinem neuen Notebook (HP Envy X360, weitere Details unten) eine Windows 10 VM, welche ...

Hyper-V
HyperV 2008 VM Umzug auf HyperV 2016
gelöst Frage von iceboxyzHyper-V1 Kommentar

Hallo zusammen, ich darf bei einem Kunden den Hyper V migrieren, bzw die VMs darauf. von Hyper-V 2008 auf ...

Neue Wissensbeiträge
Informationsdienste

Leistungsschutzrecht: Ein neuer Diskussionsentwurf liegt vor

Information von Frank vor 12 StundenInformationsdienste7 Kommentare

Anfang April (leider kein Scherz) hat das Bundesjustizministerium den nächsten ausformulierten Referentenentwurf für ein "erstes Gesetz zur Anpassung des ...

Instant Messaging

Videokonferenz oder Chatsystem für das Homeoffice

Information von Frank vor 19 StundenInstant Messaging5 Kommentare

Ich hatte es bereits in einem Kommentar gepostet, da ich aber viele Nachfragen dazu bekam, hier noch mal meine ...

Off Topic

Ein wenig Aufklärung über Corona von Bill Gates persönlich

Information von Frank vor 1 TagOff Topic24 Kommentare

Amerika hat ein Problem: Die Arroganz des sehr klugen Präsidenten führte zur aktuellen Corona-Krise in den USA. Was jetzt ...

Off Topic
3D-Drucker gegen Corona - helft mit!
Information von DerWoWusste vor 2 TagenOff Topic12 Kommentare

Unter vorigem Link sind Anleitungen, wie man sich mit seinem 3D-Drucker an der Produktion (Druck) von Bauteilen für Atemmasken ...

Heiß diskutierte Inhalte
Zusammenarbeit
Corona schlimmer als Ferien?
Frage von 114380Zusammenarbeit47 Kommentare

Hallo zusammen, sagt mal, kommt euch das auch so vor? Viele Eintagsfliegen stellen rudimentäre Fragen und reagieren dann gar ...

Batch & Shell
Alle Dateien eines Typs in Unterordnern in ein anderes Verzeichnis kopieren, aber so, dass sie in einem einzigen Unterverzeichnis liegen
gelöst Frage von Julia1989Batch & Shell26 Kommentare

Hallo, ich habe folgendes Problem: Ich habe viele *.php dateien, diese liegen in jeweils verschiedenen Unternordnern also C:\PfadZumOberverzeichnis\{A bis ...

Off Topic
Ein wenig Aufklärung über Corona von Bill Gates persönlich
Information von FrankOff Topic24 Kommentare

Amerika hat ein Problem: Die Arroganz des sehr klugen Präsidenten führte zur aktuellen Corona-Krise in den USA. Was jetzt ...

Windows 10
Über Remotedesktopverbindung erkennen, ob Monitor angeschaltet ist
Frage von Tomac84Windows 1013 Kommentare

Hallo Zusammen, Auf Grund der Krise arbeite ich vom Home Office aus. Ich melde mich per Remotedesktopverbindung an meinen ...