spirit-of-eli
Goto Top

MAC ändert sich nach 30s - Mikrotik WLan Bridge (P2P)

Moin zusammen,

ich habe hier zwei Mikrotiks als Wlan Bridge laufen. Diese haben jeweils eine IP in den entsprechenden Netzen.
Die Strecken über Wlan laufen Einwand frei. Möchte ich allerdings den Mikrotik selbst über die Wlan Strecke (es geht um die Station auf der anderen Seite.) erreichen (Winbox) kommt dieser andauernd mit einer anderen MAC Adresse seiner Interfaces raus. Somit bricht die Verbindung über Winbox dann verständlich ab. In der PfSense sehe ich auch ARP changes aller "moved to ...".

Ich komme nicht mehr auf den Kniff was gemacht werden muss.
Ich habe bereits versucht die MAC Adressen auf den Interfaces zurück zu setzen, allerdings löst es das Problem nicht.
Ebenfalls habe ich dem Wlan Interface schon die selbe MAC wie der Bridge gegeben, jedoch ohne erfolg.

Irgend so einen Trick gab es dabei, nur ich suche mir gerade einen Wolf. Wird Zeit das ich wieder häufiger mit der HW zu tun habe.
Bin gespannt ob ihr den Fehler seht und ich bloß blind bin.

Edit: Eine Sache habe ich vergessen. Der AP läuft als "bridge" und die Station als "Station - WDS". WDS ist auch aktiv und im AP ist die bridge Funktion aktiv.

Gruß
Spirit

Content-Key: 560778

Url: https://administrator.de/contentid/560778

Printed on: February 24, 2024 at 00:02 o'clock

Mitglied: 143127
Solution 143127 Mar 25, 2020 updated at 08:07:19 (UTC)
Goto Top
Die Verwaltung über die MAC Adresse in Winbox ist nur für die absolute Ersteinrichtung oder Fallback wenn man per Kabel am Gerät steckt und das Gerät noch keine IP hat. Danach sollte man die Verbindung über IP herstellen, nicht mehr über die MAC. Über WLAN kannst du die Verwaltung per MAC Adresse über Winbox knicken das läuft nicht sehr zuverlässig (zumindest nicht sehr lang) und wenn dann nur kurzzeitig so lange bis man dem Teil eine IP verpasst hat.
Die Änderung der MAC kommt vom Setting der Bridge auto-mac (Lösung admin-mac)
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...
Member: aqui
Solution aqui Mar 25, 2020 updated at 08:08:43 (UTC)
Goto Top
Auto Mac oder Admin Mac falsch oder vergessen zu setzen ?
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...
Admin Mac setzen sollte das Problem sofort fixen face-wink
Schalte das Auto Mac Feature ab und setze die Bridge fest mit Admin Mac auf die Adresse die sie sich zuvor per Auto Mac gegeben hat.
https://vswitchzero.com/2019/08/23/preventing-mikrotik-routeros-bridge-m ...

Nebenbei: Die gravierenden Nachteile einer Bridge in puncto Performance sind dir sicher bewusst, oder ? Wenn das eine LAN zu LAN Kopplung ist über WLAN solltest du wenn möglich immer routen und nicht bridgen !
Member: Spirit-of-Eli
Spirit-of-Eli Mar 25, 2020 at 08:08:16 (UTC)
Goto Top
Zitat von @aqui:

Auto Mac oder Admin Mac falsch oder vergessen zu setzen ?
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...
Admin Mac setzen sollte das Problem fixen face-wink
https://vswitchzero.com/2019/08/23/preventing-mikrotik-routeros-bridge-m ...

Nebenbei: Die gravierenden Nachteile einer Bridge in puncto Performance sind dir sicher bewusst, oder ? Wenn das eine LAN zu LAN Kopplung ist über WLAN solltest du wenn möglich immer routen und nicht bridgen !

Moin aqui,

den Punkt habe ich auch gerade gefunden. Ist es richtig das ich "auto-mac" dann deaktivieren muss, sobald ich die "admin-mac" setzte?
Mitglied: 143127
Solution 143127 Mar 25, 2020 at 08:08:57 (UTC)
Goto Top
Jepp
Member: aqui
Solution aqui Mar 25, 2020 at 08:09:15 (UTC)
Goto Top
Ist es richtig das ich "auto-mac" dann deaktivieren muss, sobald ich die "admin-mac" setzte?
Ja !
Member: Spirit-of-Eli
Spirit-of-Eli Mar 25, 2020 at 08:17:19 (UTC)
Goto Top
Ich habe mir die Interface Konfig angeschaut. Bei allen Bridges steht "auto-mac=no".
Ich schätze dafür ist ein Reboot nötig.
Member: aqui
Solution aqui Mar 25, 2020 at 08:18:56 (UTC)
Goto Top
Nur "auto-mac=no" ist nur die halbe Miete ! Du musst auch noch die Admin Mac setzen ! Das hast du auf dem Radar ?!
Member: Spirit-of-Eli
Spirit-of-Eli Mar 25, 2020 updated at 08:27:10 (UTC)
Goto Top
Zitat von @aqui:

Nur "auto-mac=no" ist nur die halbe Miete ! Du musst auch noch die Admin Mac setzen ! Das hast du auf dem Radar ?!
Die "admin-mac" ist gesetzt. Die Konfiguration ist i.o. Derzeit verursacht nur noch der AP die ARP moves in der Sense.

Kann ich irgendwie überprüfen ob der AP sowie die Station den MAC adress table für die WDS Konfig korrekt anlegen?
Member: aqui
Solution aqui Mar 25, 2020 at 08:28:50 (UTC)
Goto Top
show arp, show mac-address oder arp -a face-wink
Member: Spirit-of-Eli
Spirit-of-Eli Mar 25, 2020 updated at 08:55:49 (UTC)
Goto Top
Zitat von @aqui:

show arp, show mac-address oder arp -a face-wink

Auf dem Mikrotik sehe ich dort keine localen Einträge. Auf der Sense jedoch ist zu erkennen, das die Clients hinter der Station nun mit der jeweiligen Interface MAC ankommen. Ich habe mit der WDS Konfig jedoch erwartet, das deren eigene MAC genutzt wird.
Member: Spirit-of-Eli
Spirit-of-Eli Mar 25, 2020 updated at 09:59:07 (UTC)
Goto Top
Zitat von @aqui:
Nebenbei: Die gravierenden Nachteile einer Bridge in puncto Performance sind dir sicher bewusst, oder ? Wenn das eine LAN zu LAN Kopplung ist über WLAN solltest du wenn möglich immer routen und nicht bridgen !

Das ganze ist mehr eine Übergangslösung um zwei Rechner anzubinden. Wenn ich jetzt anfange zu routen, müsste ich dahinter weitere Netze anlegen und auf dem Main GW die Rückrouten pflegen. Die Performance ist ansonsten okay. Nur die MAC adress Thematik bereitet Probleme.
Dargestellt hat sich das ganze auch nur bei der Verbindung mit Winbox zur Station. Die Clients dahinter hatte nie Probleme. Diese kommen allerdings mit der Mikrotik MAC an der Firewall an.

Mittlerweile habe ich keine Ping drops mehr. Einzig die ARP changes auf der Sense sind noch vorhanden. Einen Reboot kann ich derzeit aber nicht durchführen.
Wie erwähnt hätte ich mir gewünscht, dass Clients hinter der Station nun auch mit ihrer eigenen MAC ins Netz kommen. Das funktioniert noch nicht.
Bei meinem Verständnis hätte sich das durch die Konfig AP=bridge mode und Station=Station-wds lösen lassen sollen da hier von den Wlan Teilnehmern ein eigener MAC table gepflegt werden sollte. Das passiert aber anscheint noch nicht.

Edit: Das Problem mit den MAC Adressen hinter der Station konnte ich lösen. Hätte ich am Anfang richtig gelesen, wäre ich drauf gekommen direkt den "station-bridge" mode zu nutzen. Dann ist meine geforderte Funktionalität gegeben.
Member: Spirit-of-Eli
Spirit-of-Eli Mar 25, 2020 at 08:55:33 (UTC)
Goto Top
Zitat von @143127:

Die Verwaltung über die MAC Adresse in Winbox ist nur für die absolute Ersteinrichtung oder Fallback wenn man per Kabel am Gerät steckt und das Gerät noch keine IP hat. Danach sollte man die Verbindung über IP herstellen, nicht mehr über die MAC. Über WLAN kannst du die Verwaltung per MAC Adresse über Winbox knicken das läuft nicht sehr zuverlässig (zumindest nicht sehr lang) und wenn dann nur kurzzeitig so lange bis man dem Teil eine IP verpasst hat.
Die Änderung der MAC kommt vom Setting der Bridge auto-mac (Lösung admin-mac)
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...

Moin,

das ist mir bewusst. Mein Problem bezieht sich aber darauf, das sich die MAC zu der IP ändert und darauf hin die Verbindung weg fliegt. Ich versuche mich ja über die IP zu verbinden.
Member: Spirit-of-Eli
Spirit-of-Eli Mar 25, 2020 updated at 10:45:43 (UTC)
Goto Top
Ich habe nun alle Probleme gelöst. Auf dem AP war nur noch ein Neustart nötig damit die admin-mac ebenfalls griff.
Auf der Station hat tatsächlich die Konfig als station-bridge alle weiteren Themen beseitig.

Euch vielen Dank für die Hilfe!
Nebenbei scheint auto-mac mittlerweile default auf einer Bridge deaktiviert zu sein oder es wird zumindest beim setzen der admin-mac deaktiviert. (Konfig über Winbox)

Edit: Die MAC vom Uplink Port muss bei der Bridge eingetragen sein. Möglicherweise ein Bug. Ansonsten kommen nach wie vor ARP moves.