Microsoft Server 2019 - RDP-Sitzung friert ein bei Nutzung von Google Maps

rastein
Goto Top
Hallo zusammen,

ich - und einige der User - habe(n) folgendes Problem bei der Benutzung von GoogleMaps in einer RDP-Sitzung an einem Terminalserver:

  • Login via RDP auf dem Server
  • Benutzung von GoogleMaps und Berechnung von Routen
  • mit Google Chrome und Mozilla Firefox

Systemdaten:
Es handelt sich um einen auf VMWare virtualisierten Microsoft Server 2019 der als Terminalserver dient.
Die Probleme treten erst seit dem Upgrade von Server 2016 auf Server 2019 auf.

Nun das eigentliche Problem.

Nach einigen Routenberechnungen auf GoogleMaps friert die gesamte RDP-Sitzung ein
  • das Bild wird noch dargestellt
  • ein Wechsel auf andere Programme ist nicht mehr möglich
  • weder per Maus noch per [Umschalt]+[Tabulator]

Um weiter arbeiten zu können ist es allerdings nicht nötig, die Sitzung als Administrator abzumelden. Es genügt für den betreffenden User, dass RDP-Fenster per X zu schließen und sich anschließend wieder via RDP einzuloggen. Im Anschluss lässt sich die RDP-Sitzung und die zuvor gestarteten Programme wie gewohnt bedienen.

Ich bin etwas ratlos und würde mich über hilfreiche Beträge freuen.

Content-Key: 2938764358

Url: https://administrator.de/contentid/2938764358

Ausgedruckt am: 10.08.2022 um 16:08 Uhr

Mitglied: KowaKowalski
Lösung KowaKowalski 30.05.2022 um 16:40:40 Uhr
Goto Top
Hi,


prüfe ob Deine RDP Sitzung unnötigerweise lokale Ressourcen durchschleift.
Drucker, plug & play Geräte die nicht nötig sind weglassen.

Und dann stell Dein RDP mal testweise auf TCP um.


mfg
kowa
Mitglied: DerWoWusste
DerWoWusste 30.05.2022 um 17:36:17 Uhr
Goto Top
Du hast zum Client noch keine Angaben gemacht.
Haben hier mit einem 2019er TS und sämtlichen internetanwendungen (auch Maps) keine Probleme seit Jahren. Clients sind bei uns aktuelle Win10 (stets letzter Build).
Mitglied: erikro
erikro 30.05.2022 um 19:05:35 Uhr
Goto Top
Moin,

Zitat von @rastein:
Nach einigen Routenberechnungen auf GoogleMaps friert die gesamte RDP-Sitzung ein

Nein, tut sie nicht.

Um weiter arbeiten zu können ist es allerdings nicht nötig, die Sitzung als Administrator abzumelden. Es genügt für den betreffenden User, dass RDP-Fenster per X zu schließen und sich anschließend wieder via RDP einzuloggen. Im Anschluss lässt sich die RDP-Sitzung und die zuvor gestarteten Programme wie gewohnt bedienen.

Es friert also der Client ein. Wäre es die Sitzung, warum sollte sie dann nur das Trennen vom Client wieder auftauen? Lässt sich der Fehler reproduzieren auf einem Rechner, an dem ein anderer User sich problemlos verbinden kann? Logfiles? Welcher Client? Welches clientseitiges OS?

Liebe Grüße

Erik
Mitglied: MysticFoxDE
Lösung MysticFoxDE 30.05.2022 um 19:47:56 Uhr
Goto Top
Und dann stell Dein RDP mal testweise auf TCP um.

dasselbe wollte ich gerade auch vorschlagen. 🙃
Mitglied: rastein
rastein 01.06.2022 um 10:56:05 Uhr
Goto Top
Zitat von @KowaKowalski:

Hi,


prüfe ob Deine RDP Sitzung unnötigerweise lokale Ressourcen durchschleift.
Drucker, plug & play Geräte die nicht nötig sind weglassen.

Und dann stell Dein RDP mal testweise auf TCP um.


mfg
kowa

Hallo kowa,

vielen Dank zunächst für deinen Lösungsansatz.
Das durschleifen der lokalen Ressourcen ist bereits auf das Notwendige reduziert. RDP über TCP lasse ich derzeit von einigen Usern testen.
Ich melde mich erneut sobald ich ein paar Daten sammeln konnte.

mfg
rastein
Mitglied: rastein
rastein 01.06.2022 um 10:58:38 Uhr
Goto Top
Zitat von @DerWoWusste:

Du hast zum Client noch keine Angaben gemacht.
Haben hier mit einem 2019er TS und sämtlichen internetanwendungen (auch Maps) keine Probleme seit Jahren. Clients sind bei uns aktuelle Win10 (stets letzter Build).

Hallo derwowusste,

auf Clientseite sind ebenfalls Windows 10 im aktuellen Build + aktuelle Patches im Einsatz. Bis zum Wechsel Server 2016 auf Server 2019 traten diese Probleme tatsächlich nicht auf.

mfg
rastein
Mitglied: MysticFoxDE
MysticFoxDE 01.06.2022 um 11:02:35 Uhr
Goto Top
Moin rastein,

auf Clientseite sind ebenfalls Windows 10 im aktuellen Build + aktuelle Patches im Einsatz. Bis zum Wechsel Server 2016 auf Server 2019 traten diese Probleme tatsächlich nicht auf.

laufen diese rein zufällig auf einem Hyper-V 2019, denn du jüngst auch von 2016 angehoben hast?

Beste Grüsse aus BaWü

Alex
Mitglied: DerWoWusste
DerWoWusste 01.06.2022 um 11:03:34 Uhr
Goto Top
Prüfe bitte, ob die Hardwarebeschleunigung im Browser an oder aus ist - es ist hier besser, sie auszuschalten.
Mitglied: rastein
rastein 01.06.2022 um 11:05:36 Uhr
Goto Top
Zitat von @erikro:

Moin,

Zitat von @rastein:
Nach einigen Routenberechnungen auf GoogleMaps friert die gesamte RDP-Sitzung ein

Nein, tut sie nicht.

Um weiter arbeiten zu können ist es allerdings nicht nötig, die Sitzung als Administrator abzumelden. Es genügt für den betreffenden User, dass RDP-Fenster per X zu schließen und sich anschließend wieder via RDP einzuloggen. Im Anschluss lässt sich die RDP-Sitzung und die zuvor gestarteten Programme wie gewohnt bedienen.

Es friert also der Client ein. Wäre es die Sitzung, warum sollte sie dann nur das Trennen vom Client wieder auftauen? Lässt sich der Fehler reproduzieren auf einem Rechner, an dem ein anderer User sich problemlos verbinden kann? Logfiles? Welcher Client? Welches clientseitiges OS?

Liebe Grüße

Erik

Hallo Erik,

  • der Client friert nicht vollständig ein
  • der Fehler lässt sich mit verschiedenen Usern an verschiedenen Clients reproduzieren
  • Logfiles? -> Welche?
  • Welcher Client? -> verschiedene
  • Welches clientseitiges OS? -> Windows 10

mfg
rastein
Mitglied: rastein
rastein 01.06.2022 um 11:09:56 Uhr
Goto Top
Moin Alex,

laufen diese rein zufällig auf einem Hyper-V 2019, denn du jüngst auch von 2016 angehoben hast?
Nein, VMWare als Virtualisierungsplattform.

mfg
rastein
Mitglied: rastein
rastein 01.06.2022 um 11:14:18 Uhr
Goto Top
Zitat von @DerWoWusste:

Prüfe bitte, ob die Hardwarebeschleunigung im Browser an oder aus ist - es ist hier besser, sie auszuschalten.

Das hatte ich in den Flags für Chrome tatsächlich schon für Hardware-accelerated video decode getan
Mitglied: rastein
rastein 01.06.2022 um 11:17:03 Uhr
Goto Top
Zitat von @MysticFoxDE:

Und dann stell Dein RDP mal testweise auf TCP um.

dasselbe wollte ich gerade auch vorschlagen. 🙃

Hallo Alex,

auch dir besten Dank für den Vorschlag. Test läuft derzeit wie gesagt.

Wie kommt ihr - du und kowa - auf diesen Ansatz? Ist das eine Best Practice?

mfg
rastein
Mitglied: DerWoWusste
DerWoWusste 01.06.2022 um 11:18:57 Uhr
Goto Top
Das hatte ich in den Flags für Chrome tatsächlich schon für Hardware-accelerated video decode getan
Nein, das ist etwas anderes. Ich spreche von https://www.howtogeek.com/412738/how-to-turn-hardware-acceleration-on-an ....
Mitglied: rastein
rastein 01.06.2022 um 11:28:23 Uhr
Goto Top
Zitat von @DerWoWusste:

Das hatte ich in den Flags für Chrome tatsächlich schon für Hardware-accelerated video decode getan
Nein, das ist etwas anderes. Ich spreche von https://www.howtogeek.com/412738/how-to-turn-hardware-acceleration-on-an ....

Achso, auch diesen Schalter hatte ich tatsächlich schon durchgetestet, allerdings ohne Erfolg
Mitglied: DerWoWusste
DerWoWusste 01.06.2022 um 11:39:34 Uhr
Goto Top
Ok, dann ist der wohl einzige erkennbare Unterschied zu uns, dass unser TS2019 keine VM ist.
Mitglied: MysticFoxDE
MysticFoxDE 01.06.2022 um 12:00:00 Uhr
Goto Top
Moin rastein,

Wie kommt ihr - du und kowa - auf diesen Ansatz? Ist das eine Best Practice?

weil es bei z.B. Bei VoIP und UDP relativ egal ist, ob das UDP Packet vollständig und auch korrekt ausgeliefert wird
oder etwas verkürzt und oder verhunzt, dann knistert es eben etwas beim telefonieren und oder die Qalität ist nicht berauschend.

Bei RDP ist das schon etwas anderes, der RDP ist bei weitem viel zickiger, wenn seine UDP Pakete unterwegs verändert oder gekürzt werden werden. Und das ist spätestes beim RDP Betrieb über VPN der Fall, weil dort die UDP Pakete, aufgrund des VPN-Headers am VPN-Gateway entweder zerstückelt oder gekürzt werden und das sorgt dann dafür, das der RDP Client zu spuckeln anfängt. Und da per UDP keine Übertragungsquittierung wie bei TCP stattfindet, bekommt der RDP-Server nicht von dem Murks am VPN-Gateway mit und sendet weiterhin die UDP-Pakete mit voller LAN-MTU. 🤢🤮

So, ich hoffe dieser Entwirrungsversuch ist jetzt nicht zu verwirrend geworden. 🤪

Beste Grüsse aus BaWü
Alex
Mitglied: MysticFoxDE
MysticFoxDE 01.06.2022 um 12:02:23 Uhr
Goto Top
Moin Rastein,

laufen diese rein zufällig auf einem Hyper-V 2019, denn du jüngst auch von 2016 angehoben hast?
Nein, VMWare als Virtualisierungsplattform.

OK, aber dass du die RDS auf 2019 gezogen hast, ist hier viel entscheidender.
Schalte mal testweise auf der vNIC (innerhalb der VM) RSS und wenn vorhanden RSC aus.

Beste Grüsse aus BaWü

Alex
Mitglied: KowaKowalski
KowaKowalski 01.06.2022 um 14:57:03 Uhr
Goto Top
Zitat von @rastein:
Wie kommt ihr - du und kowa - auf diesen Ansatz? Ist das eine Best Practice?


Hi rastein,

dieser Workaround hilft gelegentlich wenn User über mangelnde RDP-Performance meckern.
Aber eben leider nur gelegentlich. Und da der Aufwand überschaubar ist wäre es einen Versuch wert.



grüße
kowa
Mitglied: Tharrol
Tharrol 03.06.2022 um 10:22:44 Uhr
Goto Top
Hallo,

Hast du mal probiert bei dem RDP-Client die Einstellungen auf „Leistung“ umzustellen Ich gehe davon aus, das du eine RDP-Sitzung gespeichert hast und die User die Verknüpfung anklicken und sich somit auf den TS verbinden. Wenn du diese mit Rechtsklick bearbeiten öffnest kannst du ja diverse Einstellungen auswählen meistens steht die Verbindung auf Automatisch. Hier würde ich Probeweise auf „Leistung“ gehen. Da es durch Schwankungen der Verbindung durchaus sein kann das Datenpakete verloren gehen. Sei es durch den ISP oder den VPN - Tunnel oder gar Rechenanforderungen auf dem TS.

Mit besten Grüßen
Mitglied: Phoenixza
Phoenixza 06.07.2022 aktualisiert um 13:04:40 Uhr
Goto Top
Hallo,
das sollte helfen -> UDP deaktivieren:
https://christierney.com/2019/09/17/windows-10-rdp-freezing/

am client

Run gpedit.msc.
Navigate to Computer Configuration > Administration Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client.
Set the “Turn Off UDP On Client” setting to Enabled.

GL HF
LG ~Phoenixza