rumburack
Goto Top

Mikrotik CRS354-48P Port defekt? Bekannter Bug?

Hallo zusammen,

in meinem Heimnetz arbeiten ein Mikrotik CRS326 (28 Port) an einer Pfsense direkt an einem Anschluss der Deutschen Glasfaser.

Kurze Einführung
Aufgrund der guten Erfahrungen mit dem CRS326 sollen die unifi WLAN AP (schlechte Erfahrung) rausfliegen und durch Mikrotik CAP AC ersetzt werden. Da perspektivisch auch noch ein paar POE-Cams dazukommen und auch die CAP AC via POE betrieben werden sollen, die Ports am CRS326 mit irgendwelchem andern Gedöns (2 NAS, Haussteuerung usw.) belegt sind, habe ich mich für einen Tausch der Switch HW entschieden. CRS326 raus und CRS354 als 48 Port mit POE rein.

Der CRS geht gerade in Betrieb und ich nutze den Parallelbetrieb zum Spielen und ein paar Dinge besser zu verstehen. Damit ich nach einem notwendigen Reset alles schnell wieder zusammenbekommen, arbeite ich über Winbox und nutze da das Terminalfenster. Das alles aber nur kurz zur Einführung.

Wie gehe ich vor
Mein Notebook hing über Kabel an ether46. Die Terminalbefehle liefen immer gut durch. Da sich die Konfig dem Ziel nähert, habe ich ether48 als zukünftigen Managementport eingeplant. Also Kabel von ether46 auf ether48 umgestöpselt. Für einen Clean Install via Script den Router resetet.

Meine Frage/Problem
Ich kann reproduzierbar über folgende Anweisungen den CRS354 "platt" machen.

Winbox via MAC verbinden
/system reset-configuration skip-backup=yes no-default=yes

Sicherheitsabfragebestätigen

Winbox bricht kurz ab, ist nach dem reboot aber dann wieder da.
/interface ethernet
set [ find default-name=ether1 ] comment="Uplink pfsense 1"  
set [ find default-name=ether2 ] comment="Uplink pfsense 2"  

Der Schnippsel hat immer funktioniert.

Seit ich auch
set [ find default-name=ether48 ] comment="Local management Port"  
ausführe, verliert WINBOX nach ein paar Connections die Verbindung und verbindet sich nicht wieder.

Firmware ist aktuell auf 6.48.6 LTS

Wireshark sieht auf der ether-Schnittstelle auch vom CRS was kommen.
Hier mal das Paket als YAML. Die MAC-Adresse passt. Aber wie oben schon geschrieben, Winbox kann sich nicht verbinden.

- 18:fd:74:86:9a:b1
- CDP/VTP/DTP/PAgP/UDLD
- CDP
- 91
- Device ID: RouterOS  Port ID: ether48  

Das einzige was hilft, ist ein reset.

Ich bin bei meiner Recherche auch über diesen Thread gestolpert: forum.mikrotik.com/viewtopic.php?t=160561.

Kennt jemand mein Problem? Hängt es mit dem 1-8 Port Problem zusammen?

Freue mich über Eure Erfahrungen mit dem CRS354. Wenn Ihr weitere Infos benötigt, bitte fragen. Ach so, weil immer danach gefragt, das ganze wird bisher und soll zukünftig auch als Layer-2 Setup am Switch betrieben werden. Routing macht als die pfsense. Aber das dürfte hier alles keine Rolle spielen.

Beste Grüße
Rumburack

Content-Key: 4848581992

Url: https://administrator.de/contentid/4848581992

Printed on: March 1, 2024 at 18:03 o'clock

Mitglied: 4400667902
4400667902 Dec 04, 2022 updated at 06:26:39 (UTC)
Goto Top
Erst einmal, verbinden via MAC ist nur ein Notbehelf für die erste Minute bis man eine Management IP (IP > address) eingerichtet hat, denn die Verbindung via Layer-2 ist oft instabil. Danach sollte man so schnell es geht auf die Verbindung via IP oder RoMon wechseln.
Zweitens, für Winbox via MAC muss der MAC-Server (Tool > Mac-Server) auch auf den jeweiligen Interfaces laufen, des weiteren auch das Mikrotik Neighbor Discovery (IP > Neighbors >Discovery settings) auf den jeweiligen Interfaces aktiviert sein damit Winbox via MAC läuft, bzw. der Switch/Router dort erkannt werden kann.

Uk.
Member: Visucius
Visucius Dec 04, 2022 updated at 06:46:16 (UTC)
Goto Top
Mein Gott, nen 48 Porter fürs Heimsetup ­čśé

Willste Dich in so nem Umfeld wirklich noch an dem 6er Image abarbeiten? Nur weil da LTS dran steht? Ein späteres upgraden auf 7ff ist nicht unbedingt fehlerfrei möglich, weil sich im Unterbau einiges verändert hat.

PS: Wie ist denn die Performance vom CRS354? Ich habe ja selber nen 326 in Betrieb und der 354 scheint von den Daten her ja noch schwächer?
Member: Rumburack
Rumburack Dec 04, 2022 at 07:12:22 (UTC)
Goto Top
Zitat von @4400667902:

Erst einmal, verbinden via MAC ist nur ein Notbehelf für die erste Minute bis man eine Management IP (IP > ..... Interfaces aktiviert sein damit Winbox via MAC läuft, bzw. der Switch/Router dort erkannt werden kann.

Uk.


Hallo Uk,

danke für die rasche Antwort. Mir ist nur nicht klar, wie mir die Aussagen helfen sollen. Winbox via Mac funktioniert beim CRS354 zuverlässig.

Erst mit der Anweisung
set [ find default-name=ether48 ] comment="Local management Port"  
ist der Port nicht mehr zu nutzen. Das sollte aber die für Winbox notwendigen Konfigurationen nicht beeinflussen und auch Layer-2-mäßig 0 Auswirkungen haben.

In dem verlinkten Thread im mikrotik Forum wird von merkwürdigen Port Aussetzern beim CRS 354 gesprochen. Nachvollziehbar gelöst wurden sie bisher noch nicht. Daher meine Frage, ob es hier mglw. ein Zusammenhang besteht. Oder eben, ob jemand aus Erfahrung weiß, dass Port 48 beim CRS354 irgendwie besonders ist.

Ich bin heute ganztägig privat unterwegs, und kann daher leider erst heute Abend, wenn überhaupt, weitere Testsanstellen. Vielleicht funktionieren ja andere Ports usw.

Aber nochmal Danke für die schnelle Antwort.

VG
R.
Member: Rumburack
Rumburack Dec 04, 2022 at 07:21:12 (UTC)
Goto Top
Zitat von @Visucius:

Mein Gott, nen 48 Porter fürs Heimsetup ­čśé
Ja, ich weiß. Irgendein Hobby ja jeder. Und mit verschiedenen NAS, VLANs, Konsolen, VU+-Boxen usw. sammelt sich halt so ein Zoo an.

Willste Dich in so nem Umfeld wirklich noch an dem 6er Image abarbeiten? Nur weil da LTS dran steht? Ein späteres upgraden auf 7ff ist nicht unbedingt fehlerfrei möglich, weil sich im Unterbau einiges verändert hat.

Wie ob schon an Uk geschrieben. Komme ich heute nicht zum testen. Ich ziehe als nächstes die CAPS AC ab. Packe die 7 stable drauf und teste es nochmal neu. Vielleicht auch erst Anfang kommender Woche.
PS: Wie ist denn die Performance vom CRS354? Ich habe ja selber nen 326 in Betrieb und der 354 scheint von den Daten her ja noch schwächer?
Dazu kann ich aktuell nicht so viel sagen. face-sad Das Ding fliegt ja noch nicht.

Mein Vertrauen in den CRS354 bröckelt gerade. Die Anforderungen sind folgende
- 48 Ports
- Mehr als 8 POE Ports, dann habe ich Luft nach oben (WLAN AP und Kameras)
- Gerne Mikrotik (finde die Kombi aus Winbox, CAPsMAN usw. gut und habe bisher eben auch sehr gute Erfahrungen damit gemacht)
- gerne baulich bedingt ein Gerät. Aber kein Muss. Wenn es mit dem CRS354 nicht besser wird, dann geht der zurück und es kommt ein 2. 28 Port von Mikrotik dazu. Der hängt der neue 28er eben am jetzigen CRS326. Dann sind die Patch-Kabel halt nicht so schön gesteckt face-smile

Danke.

VG
R.
Mitglied: 4400667902
Solution 4400667902 Dec 04, 2022 updated at 07:52:39 (UTC)
Goto Top
Erst mit der Anweisung
set [ find default-name=ether48 ] comment="Local management Port"
ist der Port nicht mehr zu nutzen. Das sollte aber die für Winbox notwendigen Konfigurationen nicht beeinflussen und auch Layer-2-mäßig 0 Auswirkungen haben.
Du sägst damit am Ast auf dem du sitzt auch wenn du nur den comment änderst, probier's mit IP und du wirst sehen das es besser klappt.
Aber ne aktuelle Firmware würde ich hier auf jeden Fall drauf machen.
Member: Visucius
Solution Visucius Dec 04, 2022 updated at 08:28:07 (UTC)
Goto Top
Das Problem der CRS ist halt am Ende RouterOS. Mit SwitchOS laufen die supi aber mit dem ROS und den Möglichkeiten darin muss man schon ganz genau hinsehen, was dann noch performt und wo evtl. noch hw-offload möglich ist. Und dann fehlt immer noch RAM und Speicher.

Fürn Tausi hätte ich wohl eher einige RB5009 mit und ohne PoE zusammengehängt. Alleine schon wegen der Lautstärke!

Will den Thread aber nicht weiter zerfasern. Hoffe das fliegt mit ROS7.6 umd Dir viel Erfolg!

VG

PS: Den 326 gibts auch mit PoE als 328