Mikrotik mit Ubiquiti Access Point und VLAN

westerwaelder
Goto Top
Moin zusammen,

ich bin momentan mein privates Heimnetz etwas am umstellen. Bis vor kurzem hat das Netzwerk noch mit einer OPNSense Firewall funktioniert.

Da die OPNSense Hardware so langsam allerdings den Geist aufgibt habe ich mich nun für einen Mikrotik Router RB3011 entschieden. (mein erster MT) Da der Mikrotik über 10 LAN Schnittstellen verfügt möchte ich nun auch den HP 1810 Switch ausrangieren. Die 10 LAN Ports reichen für meine Geräte aus.

lan

Den Mikrotik habe ich mit Hilfe des sehr guten Tutorials von aqui bereits eingerichtet (Großes Lob für das Tutorial!!). Mein PC und Drucker sind im VLAN5 (per LAN Kabel). Die beiden Ubiquiti AP´s senden 4 SSID´s die jeweils den VLAN´s 5,10,20,30 zugeordnet sind. Momentan läuft auch alles!

Entferne ich nun den HP 1810-24G und stecke den einen Ubiquiti AP direkt an den Mikrotik Router funktioniert es nicht mehr. Dieser AP funktioniert dann nicht. Der Port am MT ist untagged in VLAN5 und hat tagged die anderen VLAN´s. Verschiedene Frametypes habe ich auch schon probiert. Müsste ja eigentlich "admit all" sein.

Ich hoffe ihr habt eine Idee woran es liegen kann.


LG

Content-Key: 2848072832

Url: https://administrator.de/contentid/2848072832

Ausgedruckt am: 27.06.2022 um 09:06 Uhr

Mitglied: aqui
aqui 20.05.2022 aktualisiert um 08:41:56 Uhr
Goto Top
direkt an den Mikrotik Router funktioniert es nicht mehr.
Im Grunde muss der AP Port vollkommen identisch zum Uplink Port des HPs konfiguriert sein. Was da fehlerfrei funktioniert muss dann logischerweise auch für den AP Port funktionieren. ;-) face-wink
Am MT AP Port hast du vermutlich mit der Einrichtung der PVID und des Taggings in der VLAN Bridge einen Konfig Fehler begangen?!
Müsste ja eigentlich "admit all" sein.
Das ist richtig!
Ideen woran es liegen kann hat man viele aber wie sollte, ohne deine MT Konfig (und deine möglichen Felhler) genau zu kennen, denn eine zielführende Hilfe aussehen?
Da bleibt uns dann auch nur kristallkugeln. :-( face-sad
Ein paar Screenshots und/oder ein export Auszug würden hier massiv helfen.
Mitglied: westerwaelder
westerwaelder 20.05.2022 um 08:55:10 Uhr
Goto Top
hier mal ein Auszug aus der Konfig:

Es geht um ether9. Momentan hängt da der HP Switch dran und es funktioniert
Mitglied: aqui
aqui 20.05.2022 aktualisiert um 09:12:26 Uhr
Goto Top
  • Und WO hängt der AP dran? Oder ziehst du den HP ab und ersetzt ihn am gleichen Port mit dem AP?
  • Welchem Interface ist das Netz 172.22.0.1/24 zugeordnet? Oder ist das eine "Konfig Leiche"?
  • "add address=192.168.5.0/24 dns-server=192.168.5.210 gateway=192.168.5.1" ist doppelt gemoppelt. Die Angabe des Gateways dort ist überflüssig wenn es der MT in diesem Segment ist!
  • Der Mikrotik ist hier Spanning Tree Root Switch! Achte im Spanning Tree der Bridge darauf das du dort 0x4000 als Priority einstellst und die HPs auf RSTP Spanning Tree gesetzt sind.
Der Rest ist soweit OK. Welche RouterOS Version hast du im Einsatz?

Teste den AP Port wasserdicht aus indem du dort einfach erstmal einen PC anschliesst und checkst ob du aus VLAN 5 eine DHCP IP bekommst und alle anderen MT VLAN IP Interfaces pingen kannst.
Dann testweise an den Port den Switch anklemmen und in den AP MSSID VLANs checken ob du dort auch per DHCP immer die entsprechenden IPs bekommst. (PC immer auf die entsprechenden Access Ports in den MSSID VLANs umstecken)
So kannst du absolut sicherstellen das der AP Port dann exakt die gleiche und funktionsfähige Konfig hat wie der Switchport und sauber funktioniert.
Alternativ kann man das auch mit einem PC testen dessen Netzwerkkarte VLAN Tagging supportet:
https://administrator.de/tutorial/vlans-ueber-802-1q-trunk-auf-windows-u ...
Der Aufwand ist aber ungleich größer und mit dem Switch ist es einfacher zu testen. ;-) face-wink
Mitglied: westerwaelder
westerwaelder 20.05.2022 um 09:22:06 Uhr
Goto Top
Zitat von @aqui:

  • Und WO hängt der AP dran? Oder ziehst du den HP ab und ersetzt ihn am gleichen Port mit dem AP?
Ja. Den HP zieh ich ab und da kommt der AP dran.


* Welchem Interface ist das Netz 172.22.0.1/24 zugeordnet? Oder ist das eine "Konfig Leiche"?
Das ist ne Konfig-Leiche. Wird gelöscht...

Ich werde nachher mal mit einem PC am Port testen und gebe Rückmeldung..
Mitglied: colinardo
Lösung colinardo 20.05.2022 aktualisiert um 11:01:10 Uhr
Goto Top
Servus.
Es geht um ether9.

/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether10,ether9,ether7 vlan-ids=5
Wenn an ether9 jetzt der AP untagged in vLAN 5 hängen soll musst du ihn auch tagged aus der Bridge vLAN config raus nehmen, jetzt steht der Port ja noch tagged darin.

Grüße Uwe
Mitglied: westerwaelder
westerwaelder 21.05.2022 um 11:37:53 Uhr
Goto Top
Zitat von @colinardo:

Servus.
Es geht um ether9.

/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether10,ether9,ether7 vlan-ids=5
Wenn an ether9 jetzt der AP untagged in vLAN 5 hängen soll musst du ihn auch tagged aus der Bridge vLAN config raus nehmen, jetzt steht der Port ja noch tagged darin.

Grüße Uwe

Hi Uwe,

vielen Dank!!! Das war die Lösung.