Mit SSH auf Android - Fehler mit "mount"

Hallo

Ich bin über SSH auf einem Android Device (Nvidia Shield).
Das Device funktioniert im LAN. D.h. der Zugriff auf Dateien auf dem NAS über Kodi oder Tool FX ist kein Problem.

Heute mit SSH darauf verbunden. Ziel: Datei aus dem Device auf das NAS kopieren.
Jetzt habe ich ein Blackout und verstehe nicht wie ich vorgehen muss, um ein Verzeichnis auf dem NAS zu mounten.

Ich gebe ein:

Fehler:

Das ist verfügbar (ping) und wenn ich mount angebe, wird das NAS auch angezeigt
mount

Wir haben strahlen schönes Wetter und die lieben Kollegen zehren mich vom Computer weg zu einer Wanderung 😍😎

Für sachdienliche Hinweise, andere Vorgehensweisen, Links / Buch Hinweise danke ich im Voraus 😉

Beste Grüsse
Peter

Content-Key: 1426162646

Url: https://administrator.de/contentid/1426162646

Ausgedruckt am: 27.11.2021 um 15:11 Uhr

Mitglied: cykes
cykes 24.10.2021 um 15:11:41 Uhr
Goto Top
Moin,

vielleicht kommt Dir ja die zündende Idee an der frischen Luft...? ;-) face-wink

Falls nicht, vielleicht mal den mount anstatt mit nfs mit smb/cifs versuchen?

Gruß

cykes
Mitglied: PeterGyger
PeterGyger 24.10.2021 um 15:17:31 Uhr
Goto Top
Hallo cykes

Beides negativ. Habe ich vorhin vergessen zu schreiben

Thx / Gruss
Mitglied: godlie
godlie 24.10.2021 um 15:22:02 Uhr
Goto Top
Hallo

du hast vergessen anzugeben wohin du den share mounten willst, daher schaut Mount in der fstab nach ob dort etwas zu finden ist.


Mitglied: PeterGyger
PeterGyger 24.10.2021 aktualisiert um 17:19:26 Uhr
Goto Top
Hallo godlie

Negativ
mount2

Auch mit Zielverzeichnis erhalte ich dieselbe Fehlermeldung.

Beste Grüsse
Peter
Mitglied: PeterGyger
PeterGyger 24.10.2021 um 17:38:16 Uhr
Goto Top
Nachtrag:
"dev_mount" geht auch nicht. Ich habe über 40 Min recherchiert und keine Lösung gefunden.
android.stackexchange.com/questions/14530/whats-the-android-equivalent-of-etc-fstab

Mein Ansatz mit SSH / Mount ist nicht zwingend. Auf dem Android Device kann ich mit der App Kodi als auch FX auf Dateien im NAS als auch Android Device zugreifen.

Wenn meine Idee mit SSL auf den Device zu zugreifen und Dateien zwischen NAS und Android auszutauschen "nicht geht" so ist das OK.

Besten Dank
Mitglied: gammelobst
gammelobst 24.10.2021 aktualisiert um 23:07:38 Uhr
Goto Top
Hallo,

und was ist mit:

und Public ungleich public!

cya
Mitglied: PeterGyger
PeterGyger 24.10.2021 um 23:16:20 Uhr
Goto Top
Guten Abend gammelobst

Es geht doch nichts über die nachaktiven Informatiker :-) face-smile

"Case sensitive" ist mir klar. Shield gibt Dir dennoch einen Korb:
mount3

Beste Grüsse
Peter
Mitglied: gammelobst
gammelobst 24.10.2021 um 23:41:28 Uhr
Goto Top
Hallo,

Nvidia Staff sagt:


SHIELD does not have native support for NFS, only samba.

könnte ja auch daran liegen, also mal:

cya
Mitglied: PeterGyger
PeterGyger 24.10.2021 um 23:54:50 Uhr
Goto Top
Hallo gammelobst

Nvidia hat in Shield auch keinen SSL Server integriert.
Ich verwende SSHelper

Anyway - der Test ergab folgendes negative Resultat:
mount4

Grüsse in die Nacht
Peter
Mitglied: gammelobst
gammelobst 25.10.2021 um 00:00:48 Uhr
Goto Top
Hallo,

dann bitte:

Mitglied: PeterGyger
PeterGyger 25.10.2021 um 07:01:02 Uhr
Goto Top
Guten Morgen Gemmelobst

Negativ
mount6

Oben habe ich einen Link plaziert, der besagt das Android kein Linux ist. Sogar der Kernel wurde angepasst.
D.h. mit den Linux Manpages kommt man hier nicht weiter.

Aber wie bereits geschrieben, ich übernehme gerne andere Vorgehensweisen. Der SSHelper unterstützt auch Rsync.
Oder ich installiere einen FTP Server auf dem Nvidia Shield. So tausche ich auch Files zwischen den mobilen Geräten und dem NAS aus.

Btw. steht auf in der FAQ von arachnoid-SSHelper dieser interessante Abschnitt:


D.h. jedes Android Device ist eine Wundertüte, wo man nicht weiss welche Logik / Abhängikeiten implementiert wurden.

Beste Grüsse und eine schöne Woche
Peter
Mitglied: hacktor
hacktor 25.10.2021 aktualisiert um 08:34:51 Uhr
Goto Top
Zitat von @gammelobst:

Hallo,

dann bitte:

Das ist falsch, Optionen dürfen nicht nach den Pfad- bzw. Device-Angaben folgen!



mount [-fnrsvw] [-t vfstype] [-o options] device dir

Mitglied: PeterGyger
PeterGyger 25.10.2021 um 08:34:09 Uhr
Goto Top
Guten Morgen hacktor

Die Macht ist nicht mit Dir 😉
mount7

Der Nächste bitte.

Beste Grüsse
Peter
Mitglied: hacktor
hacktor 25.10.2021 aktualisiert um 08:43:43 Uhr
Goto Top
Du musst das Mount-Verzeichnis natürlich vorher erst erstellen! Und wenn da schon Inhalt drin ist (was bei /mnt meist der Fall ist dann erstelle ein leeres Unterververzeichnis wie bspw. mkdir -p /mnt/test und mounte dorthin!)

Der Nächste bitte.
Depp. Lies doch bitte zu aller erst einfach das Handbuch, dann lüppt das auf Anhieb. Wenn wir dir hier erst die Shell Grundlagen beibringen müssen dann bist du hier ehrlich gesagt fehl am Platze.
Mitglied: PeterGyger
PeterGyger 25.10.2021 um 08:53:09 Uhr
Goto Top
Guten Morgen hacktor

Entschuldige den Humor.

Was mache ich hier falsch?
mount8

Gestern Abend habe ich zum einschlafen das EBook "Bash" von Cameron Newham aus dem O'Reilly Media gelesen.
Heute Abend steht das EBook vom Rheinwerk Verlag auf dem Tablet bereit.

Danke / Grüsse
Peter
Mitglied: hacktor
hacktor 25.10.2021 aktualisiert um 09:45:30 Uhr
Goto Top
Zitat von @PeterGyger:
Was mache ich hier falsch?

"test" hast du ja nicht im Root angelegt also ist die Pfadangabe im Mount-Befehl schon wieder falsch deswegen findet er den Pfad nicht, lass dir mittels "pwd" dein aktuelles Verzeichnis anzeigen und dann gibt das Verzeichnis richtig an.

Ich seh schon, wir haben es hier mit einem blutigen Anfänger zu tun, normalerweise ist der Freitag für die reserviert 🐟. Sorry für meinen Humor.
Mitglied: PeterGyger
PeterGyger 25.10.2021 um 12:45:57 Uhr
Goto Top
Hallo hacktor

Humor ist gut - kein Problem damit :-) face-smile

Das Verzeichnis für "Mount" kann irgend ein Verzeichnis sein. Es muss nicht im Root bzw. "mnt" sein. Natürlich ist es dann beim nächsten Reboot weg. Das besagten die Manpages.

Du schreibst, dass der Mount Befehl nur absolute Pfadangaben für das Verzeichnis zulässt? "test" ist ja das Unterzeichnis im aktuellen Verzeichnis, wo der Befehl ausgeführt wird. Daher sollte - IMO - die relative Angabe "/test". Zumindest habe ich keine solche Vorgabe gefunden.

Wenn es ein absoluter Pfad sein muss, dann sollten diese Version funktionieren.
bash2

Wie eingangs beschrieben, ist das ein nicht gerootetes Android Device (Nvidia Shield). Und keine Linux Disti.

Mit Freude warte ich auf Freitag, um Deine Lösung umzusetzen.

Beste Grüsse
Peter
Mitglied: hacktor
hacktor 25.10.2021 aktualisiert um 13:21:07 Uhr
Goto Top
Zitat von @PeterGyger:
Das Verzeichnis für "Mount" kann irgend ein Verzeichnis sein. Es muss nicht im Root bzw. "mnt" sein.
Richtig ich habe auch nicht geschrieben das im Root liegen muss aber du gibst den Pfad mit "/test" an also muss dieser wenn du diesen Pfad nutzt auch im Root erstellt werden und nicht in irgendeinem Unterordner!
Natürlich ist es dann beim nächsten Reboot weg. Das besagten die Manpages.
Nein, das Mount-Verzeichnis selbst ist dann nicht weg, nur der Mount selbst.


Du schreibst, dass der Mount Befehl nur absolute Pfadangaben für das Verzeichnis zulässt?
Nein schrieb ich nicht, es kann auch eine relative Angabe sein, aber deine Angaben starten nunmal mit "/" also ist es eine absolute Pfadangabe.
"test" ist ja das Unterzeichnis im aktuellen Verzeichnis, wo der Befehl ausgeführt wird.
Tja aber das aktuelle Verzeichnis ist bei dir nicht "/"

Daher sollte - IMO - die relative Angabe "/test". Zumindest habe ich keine solche Vorgabe gefunden.
Hier liegt dein Denkfehler !! Pfade die mit einem Slash beginnen sind keine relativen Pfadangabe sondern beschreiben immer den kompletten Pfad vom Root (/) aus!
Ein relativer Pfad wäre ./test oder einfach nur test

Ächz, bei dir muss man wirklich bei 0 anfangen ....
Mitglied: PeterGyger
PeterGyger 25.10.2021 um 14:15:19 Uhr
Goto Top
Hallo hacktor

Danke für die detailierte Erklärung.

Hier funktioniert weder die relative Pfadangabe (Kommando 1) noch die absolute (Kommando 2)
bash3

Hast Du auch eine Erklärung?
Danke im Voraus

Beste Grüsse
Peter
Mitglied: aqui
aqui 25.10.2021 aktualisiert um 14:29:16 Uhr
Goto Top
Dein Kommando ist etwas wirr. Etwas geraffter ist:
Das sollte dann fehlerfrei klappen. Entsprechende Rechte und korrekte User/Passwd Credentials vorausgesetzt. Ansonsten ein "sudo" vor das mount.cifs Kommando setzen.
Mitglied: PeterGyger
PeterGyger 25.10.2021 um 14:54:51 Uhr
Goto Top
Hallo aqui

Rechte für das Verzeichnis "test" sind OK.

Dennoch negativ.
bash4

Ich denke, dass an der Android Version des Nvidia Shield liegt.

Beste Grüsse
Mitglied: aqui
aqui 25.10.2021 aktualisiert um 16:12:39 Uhr
Goto Top
ch denke, dass an der Android Version des Nvidia Shield liegt.
Ja, definitiv ! Das o.a. Kommando rennt hier
  • auf RasPi
  • Debian
  • Latest Ubuntu
  • Linux Mint
auf ein Windows Share und QNAP fehlerlos.
Testweise könntest du ggf. nochmal
Dort darf dann keinesfalls die fstab Meldung kommen.
Mitglied: PeterGyger
PeterGyger 25.10.2021 um 17:27:50 Uhr
Goto Top
Hallo Aqui

Auch bei mir war der Test mit Debian und Pi OK
Nur der Android Device spielt nicht mit...

B.t.w. auch dieser Version des Befehles erhalte ich denselben Error.

Allen Foristen vielen Dank für die Unterstützung.

Nächstes WE versuche ich es mit RSync und / oder FTP

Einen schönen Abend
Peter
Mitglied: aqui
aqui 25.10.2021 um 21:35:04 Uhr
Goto Top
Allen Foristen vielen Dank für die Unterstützung.
Bitte dann den Thread auch als "erledigt" markieren !
https://administrator.de/faq/32
Mitglied: PeterGyger
PeterGyger 25.10.2021 um 21:47:56 Uhr
Goto Top
Done
Heiß diskutierte Beiträge
question
Windows Server 2019 AD MigrationjamesbrownVor 1 TagFrageWindows Server9 Kommentare

Hallo zusammen Langsam habe ich Panik, die komplette Domäne zerschossen zu haben. Bevor ich weiter vergehe, wollte ich darum hier um Rat bitten. Was ist ...

question
Mobilfunk-Internet ins Heimnetzwerk integrieren? gelöst AvarianVor 1 TagFrageNetzwerkmanagement8 Kommentare

Hallo, Ich bin neu hier. Wir sind vorletztes Jahr umgezogen. Die Gelegenheit habe ich damals direkt genutzt, um künftig auf wackelige WLAN-Lösungen (Repeater, Mesh-Repeater, Powerlines ...

general
Sicherheit beim Online-BankingWeyershausenVor 13 StundenAllgemeinSicherheitsgrundlagen18 Kommentare

Hallo, in unserer Firma verwenden wir SFirm als Online-Banking-Software. In dieser Woche hatten wir einen IT-Berater bei uns, der uns dringend folgendes Vorgehen empfahl: Wir ...

question
Maximale Empfänger bei Office365 gelöst mmpmmpVor 1 TagFrageMicrosoft Office11 Kommentare

Hallo, ich verwende nun Office365 (Exchange Online) für Emails und würde gerne die Weihnachtsgrüße per Mail versenden. Wo liegen die Beschränkungen der maximalen Empfänger? ...

report
Mailversand durch Sophos XG gestört (25.11.2021)kgbornVor 1 TagErfahrungsberichtFirewall2 Kommentare

Kurze Information - vielleicht hat jemand eine ähnliche Beobachtung gemacht. Ein IT-Admin hat mich darauf hingewiesen, dass es wohl gestern (25.11.2021) ein Update des Antivirus-Pattern ...

question
Treuhand für ebay-Verkäufer, die nicht direkt nach D. liefernDerWoWussteVor 1 TagFrageHardware4 Kommentare

Moin Kollegen, es gibt ja Fälle, wo man alte Hardware benötigt, aber nur noch über ebay bekommt. Wenn der Verkäufer dann aber nicht nach Deutschland ...

question
Reinigung der Apple Watch gelöst honeybeeVor 1 TagFrageApple6 Kommentare

Hallo, mit welchem Reinigungsmittel kann ich das Armband meiner Apple Watch schonend reinigen? Auf dem Bild seht ihr, dass es in einem guten Zustand ist. ...

question
Über das Notebook per Simkarte von unterwegs aus ins Internet?isarc01Vor 1 TagFrage5G, 4G, LTE, UMTS, EDGE & GPRS8 Kommentare

Hallo, folgende Frage: Wenn ich über mein Notebook über eine angemeldete SIM Karte mit einer Datenflatrate ins Internet gehen möchte, benötige ich hier einen bestimmten ...