Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzlaufwerk per Skript beim Start sicher verbinden

Mitglied: DerM1cha

DerM1cha (Level 1) - Jetzt verbinden

18.06.2019 um 09:06 Uhr, 746 Aufrufe, 17 Kommentare

Hallo,

ich hab das Problem das drei unserer Firmenpcs die Maschinen steuern nach einen Neustart oft das eine ihnen zugehörige Netzlaufwerk nicht zu 100% verbinden.
Dies sieht man daran das dann das rote X am Netzlaufwerk ist.

Da die Mitarbeiter dort oft nur im Notfall diese Maschinen und PCs neu starten bzw. bei Wartungen, vergessen diese dann die Verbindung zum Netzlaufwerk zu prüfen.
Im Normallfall reicht ein einfaches öffnen des Netzlaufwerkes damit es wieder funktioniert.

Hier ist aber der Knackpunkt.

Wenn das Netzlaufwerk nicht richtig verbunden ist schreibt der Pc die Fehler die in einer Log Datei festgehalten werden nicht weg.
Diese gehen dann einfach verloren.

Daher ist es nun mein Plan ein Skript in den Autostart zulegen was entweder 1. die Verbindung prüft und ggf. erneuert
oder
2. die Verbindung erst trennt und dann neu herstellt.

Ich denke 2. ist einfacher zu realisieren.

Ich habe dazu folgende Zeilen schon zusammen getragen, leider funktionieren die nicht richtig.
Da ich vorher noch nie Skripte selber bauen musste hab ich auch keine Ahnung warum....


@echo off
cls
echo Verbinde Netzlaufwerk
echo
net use X: /DELETE
net use X: \\serverip-adresse\ordner\unterordner\unterordner\zielordner\ /user:[Domäne.local]\benutzerkonto benutzerkennwort
echo
echo Verbindung erfolgreich
exit


Vlt hab ich auch nen Knoten im Kopf oder sowas, ich hoffe jedenfalls nicht ganz falsch zu liegen und würde mich über eure Hilfe sehr freuen.
Mitglied: TomTomBon
18.06.2019 um 09:25 Uhr
Moin Moin,

Ich habe nach Problemen dieser Art folgende cmd bei mir erstellt:

Bitte warten ..
Mitglied: emeriks
18.06.2019 um 09:26 Uhr
Hi,
kann diese Software bloß auf Laufwerke schreiben oder auch direkt auf UNC-Pfade?
Hast Du schon mal versucht, diese Software mit Symbolic Links auszutricksen?

CMD "als Administrator" ausführen:
Bsp.
Das Passwort zuvor mit CMDKEY hinterlegen.

Dann kann man über C:\LW_X auf die Freigabe zugreifen.

E.
Bitte warten ..
Mitglied: TomTomBon
18.06.2019 um 09:33 Uhr
net use /? ist übrigens sehr informativ:


Kleiner Hinweis:
wenn man das obige script mit dem schalter /savecred vor dem Benutzer anlegt, muss das PW nie wieder (..) eingegeben werden für diesen Benutzer.
Nur.
Wenn Ich den Benutzer dann mit einem anderen Skript verwende, werden dessen Rechte auch benutzt!!
-->
Dazu gibt es einen schönen kleinen Artikel:
runas /savecred… don't accept cmdkey /add (credentials)

Einfache Lösung:
Skript schreiben für die Verbindung.
Und dieses Skript in der AUFGABENPLANUNG als Benutzer X mit Password Y bei JEDEM Anmelden starten!
An diese Anmeldedaten kommt keiner ran
Bitte warten ..
Mitglied: emeriks
18.06.2019 um 09:53 Uhr
Zitat von TomTomBon:
Kleiner Hinweis:
wenn man das obige script mit dem schalter /savecred vor dem Benutzer anlegt, muss das PW nie wieder (..) eingegeben werden für diesen Benutzer.
Da passiert auch nicht anderes als bei CMDKEY. Das landet im selben Speicher.

Nur.
Wenn Ich den Benutzer dann mit einem anderen Skript verwende, werden dessen Rechte auch benutzt!!
Wessen Rechte?
Die Anmeldedaten werden verwendet. Ja. Hat man dann ja auch so angegeben ....

An diese Anmeldedaten kommt keiner ran
*hüstel*
Bitte warten ..
Mitglied: TomTomBon
18.06.2019 um 13:47 Uhr
Naja,

Kein User.

Wenn ich die reg entsprechend auslese geht das, Ich weiß.
Dafür gibt es Verschlüsselung.

Aber wenn der User irgendwie mitbekommt das er nur die Bla.cmd gegen eine andere bla.cmd tauschen muss ist das eine viel geringere Hürde.
Echter Schutz...
Selbst bei Kiosk Systemen nicht wirklich
Bitte warten ..
Mitglied: emeriks
18.06.2019 um 13:55 Uhr
Zitat von TomTomBon:
Kein User.
???

Wenn ich die reg entsprechend auslese geht das, Ich weiß.
Dafür gibt es Verschlüsselung.
???

Aber wenn der User irgendwie mitbekommt das er nur die Bla.cmd gegen eine andere bla.cmd tauschen muss ist das eine viel geringere Hürde.
Echter Schutz...
Selbst bei Kiosk Systemen nicht wirklich
Damit hast Du dann Deinen eigenen Vorschlag ad absurdum geführt.
Bitte warten ..
Mitglied: erikro
18.06.2019 um 15:42 Uhr
Moin,

Zitat von DerM1cha:
ich hab das Problem das drei unserer Firmenpcs die Maschinen steuern nach einen Neustart oft das eine ihnen zugehörige Netzlaufwerk nicht zu 100% verbinden.
Dies sieht man daran das dann das rote X am Netzlaufwerk ist.

Die Gruppenrichtlinie "Computerkonfiguration -> Richtlinien -> administrative Vorlagen -> System -> Anmelden -> Beim neustart des Computers und bei der Anmeldung immer auf das Netzwerk warten" ist aktiviert?

hth

Erik
Bitte warten ..
Mitglied: DerM1cha
19.06.2019 um 09:18 Uhr
Jaein,

sie war nicht aktiv, als ich vor Ort war und probiert habe alle wichtigen Informationen mit den Mitarbeitern zu erfassen um darauf hin dann eine Lösung zu finden, habe ich diese ausprobiert, ohne Erfolg.

Ich dachte auch das wäre die einfachste Lösung aber da sie nicht funktioniert ...
Bitte warten ..
Mitglied: DerM1cha
19.06.2019 um 09:34 Uhr
Hallo,

ich hab dein Skript mal kopiert und die Zeile 26 angepasst auf mein Ziel und den dafür gedachten benutzer

nur leider sagt er trz das ich nicht mit den Netzwerk verbunden bin, rufe ich das Ziel über den Explorer auf funktioniert es
Was passiert denn hier ?
Bitte warten ..
Mitglied: erikro
19.06.2019 um 09:39 Uhr
Sicher, dass die GPO auch angewendet wurde? Normalerweise funktioniert das dann, wenn man auf das Netz warten lässt.
Bitte warten ..
Mitglied: DerM1cha
19.06.2019 um 11:06 Uhr
Ich hatte die Einstellung aktiviert, gespeichert und dann neu gestartet, das sollte doch als Test reichen oder ?
Dort hat es dann jedenfalls nicht geklappt.
Bitte warten ..
Mitglied: erikro
19.06.2019 um 11:11 Uhr
Ein gepresult nach dem Test ist immer eine gute Idee, wenn es nicht klappt. Außerdem solltest Du das mit

einmal anstoßen. Es kann nämlich passieren, dass die GPO nicht wirkt, weil das Netz noch nicht da ist.
Bitte warten ..
Mitglied: emeriks
19.06.2019 um 11:16 Uhr
Zitat von DerM1cha:
Ich hatte die Einstellung aktiviert, gespeichert
In einer Domänen-GPO?

Falls ja
und dann neu gestartet, das sollte doch als Test reichen oder ?
Nein, nicht unbedingt. Nur wenn man vor dem Neustart wartet, bis diese GPO angewendet wurde oder man manuell GPUPDATE ausgelöst hat.
Ansonsten muss man 2x neu starten.
Bitte warten ..
Mitglied: TomTomBon
19.06.2019 um 15:11 Uhr
Moin,

Es müssen hier folgende Zeilen geändert werden:
Zeile 16 und 17:
16.
ping MAINSERVER -n 1 >NUL
17.
(ping MAINSERVER >NUL)|| goto :nostart


Mainserver ist am besten der Proxy/AD/Router mit Namensauflösung oder IP.


Zeile 20. muss mit net use angepasst werden!!
Hinter net use muss erst das Laufwerk stehen und dann das Ziel.

20.
net use g: \\192.168.178.50\Freigabe /Persistent:No /user:Heim\Anwender



Bitte warten ..
Mitglied: DerM1cha
20.06.2019 um 12:16 Uhr
Nein nicht in der Domänen GPO sondern auf dem Client und wie gesagt dort nur einmal neu gestartet, ... wahrscheinlich wird das aber nicht greifen wenn es in der GPO der Domäne anders eingestellt ist ?
Bitte warten ..
Mitglied: DerM1cha
20.06.2019 um 12:31 Uhr
Hallo,

ich habe deine Antwort bzgl den zu anpassenden Bereichen gelesen und aufgenommen und werde das angepasste Skript in der nächsten Umbauphase der Maschinen testen und mich danach melden

Ich hoffe damit endlich des Problems Herr zu werden

An der Stelle erstmal vielen Dank @all die mir hier helfen =)
Bitte warten ..
Mitglied: erikro
20.06.2019 um 15:47 Uhr
Moin,

Zitat von DerM1cha:

Nein nicht in der Domänen GPO sondern auf dem Client und wie gesagt dort nur einmal neu gestartet, ... wahrscheinlich wird das aber nicht greifen wenn es in der GPO der Domäne anders eingestellt ist ?

Doch, das wird greifen, wenn Du es richtig machst:

1. Eine GPO erstellen, die auf die Computer wirkt und in der Du einstellst, dass auf das Netzwerk gewartet wird.
2. Entweder 90 Minuten warten oder zum Testen

auf der Kommandozeile eingeben.

Danach wirkt die GPO beim Neustart und alles ist gut. Zumindest bei uns und auch bei allen von mir zuvor betreuten Netzen funktioniert das wie Schmitz' Katze.

Liebe Grüße

Erik
Bitte warten ..
Ähnliche Inhalte
Windows 7

Bluescreen nach .exe Start von Netzlaufwerk

gelöst Frage von felixf.Windows 717 Kommentare

Hallo zusammen, wir haben seit Freitagmorgen auf 3 von 50 Win 7 64 Bit Rechner in der Domäne folgenden ...

Batch & Shell

PowerShell GUI Skript ausführen durch "Start" Knopf

gelöst Frage von 135531Batch & Shell2 Kommentare

Hi all, ich bin absoluter Neuling im Thema PowerShell. Ich versuche derzeit eine GUI für DDA (Discrete Device Assignment) ...

Windows Server

GPO Netzlaufwerk aktualisiert sich nicht

gelöst Frage von newit1Windows Server2 Kommentare

Hallo ! Folgendes Problem: Ein Benutzer1 ist im AD in der Organizational Unit1. Eine entsprechende Gruppenrichtlinie mit Scope auf ...

Windows Netzwerk

Netzlaufwerk lässt sich nicht verbinden

gelöst Frage von MarkowitschWindows Netzwerk7 Kommentare

Hallo zusammen, ich habe einen Windows 10 Pro. Rechner welcher per VPN auf eine Synology NAS zugreift. Dies funktioniert ...

Neue Wissensbeiträge
Viren und Trojaner
Emotet: IT-Totalschaden beim Kammergericht Berlin
Information von StefanKittel vor 12 StundenViren und Trojaner4 Kommentare

Interne Daten wurden geklaut und "ein kompletter Neuaufbau der IT-Infrastruktur wird angeraten", heißt es im forensischen Bericht zum ...

Viren und Trojaner
Avast verkauft anscheinend browserdaten
Tipp von magicteddy vor 15 StundenViren und Trojaner14 Kommentare

Moin, da es immer wieder Anfragen zu Virenscannern gibt denke ich das der Artikel von Heise Avast verkauft Bowserdaten ...

Router & Routing

Statische Route dauerhaft einrichten unter Ubuntu 18.04 LTS

Erfahrungsbericht von the-buccaneer vor 3 TagenRouter & Routing2 Kommentare

"Kann ja nicht so schwer sein, unter Ubuntu 18.04 LTS ne statische Route einzurichten", denkt der Windows-Admin und gelegentliche ...

Microsoft

Effect on customer websites and Microsoft services and products in Chrome version 80 or later

Information von Dani vor 3 TagenMicrosoft

Guten Abend zusammen, The Stable release of the Google Chrome web browser (build 80, scheduled for release on February ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Installation USG
Frage von jo23487LAN, WAN, Wireless45 Kommentare

Hallo zusammen, nach den beiden anderen Fragen habe ich mir den Cloud Key und auch ein USG gekauft - ...

Ausbildung
In den Beruf IT-Systemadministrator gerutscht
Frage von TorwolfAusbildung25 Kommentare

Hallo zusammen, kurz zu meiner Person, ich bin 25 Jahre alt, habe die Fachhochschulreife und eine abgeschlossene Ausbildung als ...

Outlook & Mail
Mehrere Domänen User, selber PC, großer IMAP Account, Vorgehen?
Frage von heifumaOutlook & Mail21 Kommentare

Moin, Szenario: - Windows Server 2019 AD - Ein und derselbe PC im Netzwerk soll im Laufe der Arbeitswoche ...

Microsoft
All-Cloud für KMU (Management, Backup, etc.)
Frage von NRGNRGMicrosoft20 Kommentare

Hallo zusammen, kurze Interessensfrage an Euch in die Runde, da ich hierzu gerade interessante Diskussionen mit Kollegen habe: Szenario: ...