stefanbruhn
Goto Top

PCs werden immer langsamer und frieren dann ein

Hallo,

ich habe ein Problem, wo ich nicht mehr weiterkomme. Wir haben einen Kunden der hat folgendes Problem.
Es fing vor etwa 2 Jahren an. Der Kunde ist in ein neues Büro gezogen. Zu dem Zeitpunkt hat er neue Server bekommen.

Er hat ein DC/Fileserver mit SQL Datenbank und Email Server Tobit (Server 2019). Einen Remoteserver (Server 2022), erst vor kurzen getauscht und ein DMS Server mit Server 2022. Vor Ort arbeiten 7 Leute lokal, der Rest über VPN Leitung auf dem RDP. Soweit funktioniert alles. Der Kunde nutzt eine DISPO Software die auf den SQL Server zugreift. Wir haben die Software in Verdacht, aber können es nicht beweisen. SQL Server ist ein Standard 2014, mit aktuellem Patchstand. SQL Server und Software hat die Herstellerfirma installiert.

Jetzt aber das Problem. Damals konnte er etwa 5h ohne Probleme arbeiten und dann wurde alles extrem verlangsamt. Das Problem trat auf allen lokalen PC's auf. Der RDP war nicht ganz so schlimm betroffen. Analyse von CPU oder Netzwerk am Server und an den Clients hat nichts gebracht. CPU auf dem Server bei 10% und weniger, Datenübertragung im Minimumbereich. Die PC's zeigen das selbe Bild. Die PC's werden so langsam, das ein normales arbeiten nicht mehr möglich ist. Es half nur ein Neustart und es ging etwa wieder 5h. Dann das gleiche. Heute ist es so, das sie nur noch 1h arbeiten können und dann schon neu starten müssen. Das betrifft auch PC's die neu ins Netzwerk integriert werden. Ich habe mal zum Test mein NB (keine Verbindung mit der Firma, keine Drucker, keine Domäne) über Wlan ins Netzwerk gebracht und versucht die DISPO Software zu starten. Ich war nur 5min im Netzwerk und hatte die selben Probleme. Die Datenübertragung zum Server ist in der Zeit in Ordnung. Liegt bei 1GBit. Wir haben schon den Hersteller der Firma mit ins Boot geholt. Der hat am SQL Server mit SQLTrace Analysen gemacht und nichts gefunden. Wir tippen auf ein Zusammenspiel von der DISPO Software mit den Druckern oder dem Emailprogramm. Auch bei den Druckern (Laser- Ricoh, Nadel- Epson) habe ich schon die Treiber getauscht. Hat auch nichts gebracht. Mittlerweile ist es so, das der Druckauftrag bis zu 5min braucht, bis das Fenster zum drucken erscheint. Das Problem bezieht sich aber dann auch auf alle Programme, die auf dem PC auf sind. Schließt er das DISPO Programm geht es nach einer weile wieder. Aber normal arbeiten geht erst nach Neustart.

Den Switch habe ich auch schon mal getauscht. (einfacher Netgear Smartswitch)

Habt ihr noch eine Idee wo man da ansetzen kann? Das Problem ist ja, das ALLE PC's das gleiche Problem zur gleichen Zeit haben. Auf dem Server ist aber nichts sichtbar. Keine Belastung nichts. Auch keine Meldungen. Für mich sieht es so aus, als wenn die Verbindung von der DISPO Software zum Server diese Problem verursacht, aber wo durch? Wir haben anderen Firmen, die die selbe Software nutzen, gefragt, aber keiner hat so ein Problem. Vor dem Umzug hatten wir auch kein Problem.

Falls ihr noch mehr Daten braucht, bitte Bescheid sagen.

Gruß
Stefan

Content-Key: 6121088401

Url: https://administrator.de/contentid/6121088401

Printed on: April 13, 2024 at 01:04 o'clock

Member: radiogugu
radiogugu Feb 24, 2024 at 10:45:02 (UTC)
Goto Top
Mahlzeit.

Zitat von @StefanBruhn:
Er hat ein DC/Fileserver mit SQL Datenbank und Email Server Tobit (Server 2019)

Nicht wirklich ein guter Plan. Ein Domain Controller sollte außer das AD, DNS und DHCP keine anderen Dienste und Rollen installiert haben.

Die Verkabelung des Netzwerks ist in Ordnung? Also keine Loops oder so eventuell auf dem Switch gesteckt?

Welcher Router kommt zum Einsatz?

Gibt es konfigurierte VLANs?

Wer macht DHCP?

Haben die Server und Clients statische oder dynamische IP-Adressen?

Die Server sind Hardware oder virtualisiert?

Wenn du dein Notebook in das Netzwerk hängst ohne die Software zu starten, tritt dann dasselbe Verhalten auf?

Gruß
Marc
Member: em-pie
em-pie Feb 24, 2024 at 11:00:36 (UTC)
Goto Top
Moin,

Neben den Fragen des Kollegen @radiogugu wäre es auch mal spannend zu wissen, wie die Software tickt:
Greifen die User (Die Client-Anwendung) direkt auf die DB zu oder ruft der Client (Web)Services auf, die wiederum dann die Daten mit dem DB-Server austauschen.

Schließt er das DISPO Programm geht es nach einer weile wieder. Aber normal arbeiten geht erst nach Neustart.
Ist dann ein eigens programmierter Client oder läuft der im Browser?


Erzähle auch mal etwas mehr zum Server. Welche CPUs, wieviel RAM, welche HDDs/ SSDs? Welcher RAID-Controller? Welches RAID-Level? Mit/ ohne Cache? …
Member: StefanBruhn
StefanBruhn Feb 24, 2024 at 11:08:32 (UTC)
Goto Top
Hallo Marc,
- DC und File auf ein System ist nicht gut, das ist richtig.
- Die komplette Verkabelung ist das einzige, was wir noch nicht ausgetauscht haben.
- Router ist eine Fritzbox, die das Inet an die Firewall weitergibt. Die Firewall (Securepoint) macht VPN
- VLans gibt es nicht
- DHCP macht der DC/File
- PC's haben dynamische Adressen
- Von der Virtualisierung bin ich wieder weg gegangen. Alles kleine Mini Server eines großen lila Unternehmens aus DE
- Nein, wenn du die Software nicht aufrufst, dann kannst du normal arbeiten.

Das ist ja das komische. Der Außendienst, der die Software nicht so häufig braucht, hat kaum Probleme. Nur die, die den ganzen Tag damit arbeiten. Die Software ist zum Teil 3 oder 4 Mal auf.

Gruß
Stefan
Member: StefanBruhn
StefanBruhn Feb 24, 2024 at 11:18:54 (UTC)
Goto Top
Zitat von @em-pie:

Moin,

Neben den Fragen des Kollegen @radiogugu wäre es auch mal spannend zu wissen, wie die Software tickt:
Greifen die User (Die Client-Anwendung) direkt auf die DB zu oder ruft der Client (Web)Services auf, die wiederum dann die Daten mit dem DB-Server austauschen.

Schließt er das DISPO Programm geht es nach einer weile wieder. Aber normal arbeiten geht erst nach Neustart.
Ist dann ein eigens programmierter Client oder läuft der im Browser?


Erzähle auch mal etwas mehr zum Server. Welche CPUs, wieviel RAM, welche HDDs/ SSDs? Welcher RAID-Controller? Welches RAID-Level? Mit/ ohne Cache? …

Hallo em-pie,
Die Software ist vollständig auf dem Server installiert.
Es gibt nur eine Verknüpfung zur Exe auf dem Desktop. Das Programm ist in Delphi programmiert.
Wir haben schon folgendes ausprobiert. UNC über Name, IP und Aufruf über Laufwerk/Freigabe. Alles das gleiche.

Die Server sind Standard MiniServer mit Adaptec Raid Controller und SSDs (Raid 10). Ram liegt bei 32GB.
Serversystem ist 2019

Raid:
raid
Member: em-pie
em-pie Feb 24, 2024 updated at 11:25:11 (UTC)
Goto Top
- Router ist eine Fritzbox, die das Inet an die Firewall weitergibt. Die Firewall (Securepoint) macht VPN
- VLans gibt es nicht
- DHCP macht der DC/File
- PC's haben dynamische Adressen

Kannst du mal was zum Netzdesign (IP-Adressen) sagen?

Welche IPs sind im Netz zwischen Fritte und SecurePoint?
Welches IP-Netz habt ihr hinter der SecurePoint?
Sind alle Clients/ Server hinter der SecurePoint untergebracht?
Poste hier mal ein ipconfig / all vom Server sowie von einem der Clients.


Edit:
Die Software ist vollständig auf dem Server installiert.
Es gibt nur eine Verknüpfung zur Exe auf dem Desktop.
Sagt leider nichts darüber aus, wie die Daten in die DB kommen: schreibt der Server die Daten in den SQL oder macht das die gestartete EXE direkt?
Member: MirkoKR
MirkoKR Feb 24, 2024 at 11:46:58 (UTC)
Goto Top
Hi.

Also, da di schreibst, das die Auslastung nicht sonderlich auffällt, wäre mein Kommentar eher überflüssig...

... tatsächlich mussten wir zu meiner aktiven Zeit Anno 2006 bei einer SQL-gestützten Dispo/Flotten-Software dennoch feststellen, das eine extrem hochfrequente GPS-Syncronisierung trotz geringer Ressourcen-Werte genau dieses Verhalten erzeugte ...

Viel Erfolg bei der Fehlerfindung!
Member: MysticFoxDE
MysticFoxDE Feb 24, 2024 updated at 12:17:07 (UTC)
Goto Top
Moin @StefanBruhn,

Das ist ja das komische. Der Außendienst, der die Software nicht so häufig braucht, hat kaum Probleme. Nur die, die den ganzen Tag damit arbeiten. Die Software ist zum Teil 3 oder 4 Mal auf.

Die Server sind Standard MiniServer mit Adaptec Raid Controller und SSDs (Raid 10). Ram liegt bei 32GB.
Serversystem ist 2019

ich sehe für dein Problem die folgenden möglichen Ursachen.

Entweder bricht dir das bescheuerte RSC der NIC's das Genick oder der RAM läuft auf den Clients oder den Servern über, respektive, wird von dem bescheuerten Software-Caching von Windows nach und nach aufgefressen.

Das Problem mit dem RSC kannst du recht einfach beheben, indem du den folgenden Befehl auf sowohl den Servern als auch den Clients mal durchklopfst.
(CMD als Administrator ausführen)
netsh int tcp set global rsc=disabled

Und was das Problem mit dem RAM angeht, so musst du auf den Servern und Clients deren RAM Auslastung mal genauer im Auge behalten.
Hierbei aber bitte auf das folgende Insbesondere achten.

taskmanager-standby

Auf dem oberen Screenshot sieht es auf den ersten Blick so aus, als ob das entsprechende System noch 80,6GB RAM verfügbar hätte, doch das ist genaugenommen gelogen, da der RAM nicht wirklich frei ist sondern bereits zum Grossteil vom dem bescheuerten Software-Caching (Standby Memory) belegt wurde. ­čĄó­čĄ«
Wenn das der Fall ist, also wenn der freie RAM komplett vom Software-Caching (Standby Memory) gefressen wurde, dann läuft so gut wie nichts mehr wirklich flüssig, da das Windows einer Anwendung oder einem Treiber bei Bedarf nicht sofort weiteren RAM zuordnen kann, weil es diesen zuerst vom Standby Memory wieder freikratzen muss.

So sieht übrigens wirklich freier Speicher aus.
taskmanager-frei

Den "Standby Memory" kannst du übrigens mit RamMap ...
https://learn.microsoft.com/de-de/sysinternals/downloads/rammap
(als Administrator ausführen)
ram map
... jederzeit im laufenden Betrieb leeren. ­čśë

Gruss Alex

P.S. Und führe mal auf allen Servern die SMB-Freigaben bereitstellen mal den folgenden Befehl aus.

(PowerShell als Administrator ausführen)
Set-SmbServerConfiguration -TreatHostAsStableStorage $true -AsynchronousCredits 2048
Member: StefanBruhn
StefanBruhn Feb 27, 2024 at 18:14:09 (UTC)
Goto Top
Hallo, danke erstmal für die Vorschläge

- Netzwerk Topologie:
-> Fritzbox 192.168.114.1 -> Firewall 192.168.118.201( Exposed Host in Fritzbox)
An der Fritzbox ist noch ein Videorecorder dran, der an einer 2. Fritzbox angeschlossen ist. (nicht von uns)
-> Firewall stellt Internet als Gateway zur Verfügung. Netzwerk ist 192.168.118.0/24. Alle PC's, Server und Drucker
sind in diesem Netzwerk. DHCP macht der Server. Es gibt noch eine alte Fritzbox im Netzwerk, die nur als Wlan
AP fungiert.

- Software
-> Die Software (EXE Datei) kommuniziert über den Native SQL Client direkt mit dem SQL Server

@MysticFoxDE
-> Deine beiden Befehle habe ich umgesetzt. Beim RAM meinte ich, das der Server 32GB hat und nicht 32GB belegt
sind (hatte das Problem aber mal bei einem anderen Kunden. Habe dort auch einen Ram Cleaner eingesetzt). Die
Auslastung liegt im normalen Bereich. 13GB für den SQL Server und dann der Rest. Ist noch genug frei.
Aber deine Befehle scheinen etwas bewirkt zu haben. Im Moment müssen sie sich nur noch einmal abmelden.
Wir sind noch am testen.

Gruß
Stefan