pasu69
Goto Top

PfSense Performance mit Gigabit WAN

Einen schönen Montag euch allen,

ich habe mich am Wochenende mal wieder mit meiner neuen pfSense beschäftigt.
Diese läuft auf einer APU4.D4 im Dual-WAN Betrieb (Failover) und funktioniert absolut einwandfrei
- bis auf das Problem, dass ich nicht mehr als rund 45MB/s im Download schaffe.

WAN1 - Vodafone Business Kabel 1000/50 an Fritzbox 6591 im Bridgemode
WAN2 - Telekom VDSL 200/50 als Backup und IP TV Quelle

Getestet habe ich folgende Dinge:
PC direkt an die FB6591 als einziger Client - DL >100MB/s
Draytek 2927 Router, WAN1 an FB6591 DHCP - DL >100MB/s
Draytek 2927 Router, WAN1 an FB6591 Bridgemode - DL >100MB/s
pfSense (APU4D4), WAN1 an FB6591 DHCP - DL rund 40MB/s
pfSense (APU4D4), WAN1 an FB6591 Bridgemode - DL rund 40MB/s

Eine testweise installiere OPNsense (APU4D4) bringt genau den selben Speed,
wie die pfSense. Zusätzlich habe ich die pfSense auch noch auf einem Intel NUC installiert
(mit einem USB-C LAN Adapter), auch hier liegt die DL-Rate nur bei rund 40%.
Als "Overkill" habe ich dann nochmal eine pfSense VM auf einem Hyper-V aufgesetzt,
ihr 16GB RAM und 16 CPU Kerne verpasst - hier liegt die Performance immerhin bei 60MB/s.

Die CPU Auslastung auf der APU4D4 liegt nie über 35% während des Downloads, auf dem NUC
liegt sie bei 3%, auf der VM bleiben die 16 Kerne fast im Idle Mode.
Mein bisheriger Draytek schafft, wie gesagt, locker die 100MB/s und hat dabei nicht mehr als 5% CPU-Last.

Ich habe einiges Dinge im Netz gefunden, aber die Tuning-Tipps haben alle nichts gebracht.
Hat jemand von euch dieses Phänomen auch schon einmal gehabt und wenn ja, konntet ihr das Problem
lösen? Ich würde mit über Tipps sehr freuen.

Euch eine schöne Woche

pasu

Content-Key: 665648

Url: https://administrator.de/contentid/665648

Printed on: May 21, 2024 at 21:05 o'clock