ivirusyx
Goto Top

Powershell-Script - Warnung ausblenden

Ich versuche mich gerade an Powershell da wir gerade erst vor kurzem auf Exchange 2010 gewechselt sind und ich meine Kenntnisse etwas verfeinern will.
Jetzt brauche ich eure hilfe um meinen PS-Einzeiler zu ergänzen, ich komme einfach nicht weiter...

Hallo Leute,

ich versuche mich gerade an Powershell da wir gerade erst vor kurzem auf Exchange 2010 gewechselt sind und ich meine Kenntnisse etwas verfeinern will.

Es geht um folgendes: ich erstelle eine Liste aller "Distribution Group" Objekte die den Wert "Require Sender Authenication" angekreuzt haben. Das mache ich mit folgender Zeile:

Get-DistributionGroup | where {$_.RequireSenderAuthenticationEnabled -eq $True}

Nun wenn ich diese Zeile ausführe kriege ich Tonnen gelber Warnungen da das System noch sämtliche alter "Distribution Group" Objekte mit ungültigem ALIAS beherbergt...

"WARNING: Property expression..."

Gibt es eine Möglichkeit diese Warnung zu unterdrücken, ergo nicht anzuzeigen?

Ich habe schon mit "-WarningActions SilentlyContinue" versucht, das klappt aber irgendwie nicht...


Vielen Danke für eure Hilfe!

MFG
iVirus

Content-Key: 203995

Url: https://administrator.de/contentid/203995

Printed on: December 9, 2022 at 00:12 o'clock

Member: filippg
filippg Mar 26, 2013 at 20:15:27 (UTC)
Goto Top
Hallo,

ich bin mir nicht _ganz_ sicher, aber m.E.:
der "WarningActions"-Parameter müsste von jedem cmdlet einzeln implementiert werden - und manche tun das einfach nicht. Verwendet man stattdessen $WarningPreference='silentlycontinue' muss sich das cmdlet nicht darum kümmern, sondern die PS übernimmt das.
Siehe auch https://connect.microsoft.com/PowerShell/feedback/details/541500/warning ...

Gruß

Filipp
Member: iVirusYx
iVirusYx Mar 27, 2013 at 14:55:12 (UTC)
Goto Top
Danke das hat mir geholfen! Das mit dem WarningPreferences Parameter hatte ich versucht aber es hat nicht geklappt. Es hat sich herausgestellt das dies daran lag dass ich sofort die "Exchange Management Shell" benutzt habe.

Ich muss zuerst eine normale PowerShell öffnen, die $WarningPreferences und $ErrorActionsPreferences Variablen dann auf "SilentlyContinue" ändern und dann erst mit "Add-PSSNapin -Name Microsoft.Exchange.Management.PowerShell.E2010" die eigentliche Exchange-Shell laden.

Nun wird mir keine Meldung mehr angezeigt wenn ich den Befehl ausführe face-smile

MFG
iVirus