killtec
Goto Top

Probleme Win7 Netzwerkerkennung

Hallo zusammen,

wir haben hier ein Domänennetzwerk mit XP Pro und Win7 Pro Clients und Win 2k8 R2 Servern.
Auf den Servern am Hauptstandort (wo der Fehler auftrifft) sind 2 DC's aktiv. Beide DC's teilen sich auch das DHCP.
Nun ist das Problem, dass einige Clients das Netzwerk nicht richtig erkennen.

Das ganze sieht dann so aus:
86513196307ed1411524dbd8f0d11b7a

Sollte aber so aussehen:
e30671c0791b782628b4e8c6b22981bb


Das Problem tritt an unterschiedlichen Rechnern im Netzwerk auf.

Startet man den PC Neu kann es sein, dass alles ok ist. Was auch schon mal geholfen hat war, den DNS-Server manuell einzutragen und danach konnte man ihn wieder raus nehmen. Das ist jedoch keine zufriedenstellende Lösung.

Habt ihr da was, was mir helfen kann?

Danke.

Killtec

Content-Key: 193448

Url: https://administrator.de/contentid/193448

Printed on: April 18, 2024 at 04:04 o'clock

Member: DerWoWusste
DerWoWusste Oct 29, 2012 updated at 08:56:41 (UTC)
Goto Top
Moin.

Zur Info: Windows wertet alle Netzwerkkarten aus. Hat man mehrere, kommt es evtl. zu ungewollten Effekten - dies tritt auch bei virtuellen Karten (von VMWare/VirtualBox o.Ä.) auf. Prüf das mal.
Member: killtec
killtec Oct 29, 2012 at 08:59:25 (UTC)
Goto Top
Hi,
an den Rechnern wo das auftritt gibt es nur eine Netzwerkkarte. Da gibt es auch keine vmware oder firewire-Karten. Das sind normale Office PC'S mit einer 1GBit Netzwerkkarte die onBoard ist.
Das ganze ist auch unabhängig davon, ob es ein x86 oder x64 System ist.
Member: DerWoWusste
DerWoWusste Oct 29, 2012 updated at 09:07:46 (UTC)
Goto Top
Prüf bitte mal, ob der Dienst Network Location Awareness läuft und falls er (wie zu erwarten ist) läuft, starte ihn mal neu und beobachte Deine abgebildete Ansicht.
Member: Deepsys
Deepsys Oct 29, 2012 at 09:09:10 (UTC)
Goto Top
Moin,

Zitat von @killtec:

Beide DC's teilen sich auch das DHCP.

Das verstehe ich nicht, wie können sich denn zwei DHCP-Server ein Subnetz teilen?

VG
Deepsys
Member: d4shoerncheN
d4shoerncheN Oct 29, 2012 at 09:13:06 (UTC)
Goto Top
Hallo,

kannst du mir erklären - wieso ihr auf Screenshot 1 "Öffentliches Netzwerk" als Profil gewählt habt?

Das solltet ihr wie in Screenshot 2 mal auf "Domänennetzwerk" ändern face-wink

Gruß
Member: killtec
killtec Oct 29, 2012 updated at 09:23:23 (UTC)
Goto Top
@ DerWoWusste: Das werde ich tun, sobald der Fehler beim nächsten PC auftritt.

@ Deepsys: Man nimmt zwei DHCP-Server und erstellt den gleichen DHCP-Bereich. Bei DHCP-Server 1 sagt man dass die Adressen von x-y ausgeschlossen sind und bei DHCP-Server 2 von a-b.

Bsp: DHCP-Server Bereich: 1-254
DHCP-Server 1: 1-154
DHCP-Server 2: 155-254

Das macht man deshalb, falls ein DHCP-Server ausfällt, kann der andere DHCP-Server das Lease erneuern, sonst hast du plötzlich keine IP-Adresse mehr. Er kann zwar nicht die gleiche IP-Adresse wie vorher vergeben wenn beim Booten der DHCP1 nicht da ist, aber die PC's funktioinieren, das ie eine andere Adresse von DHCP2 bekommen.
Was auch funktioniert ist wenn Reservierungen außerhalb des DHCP-Bereiches liegen.
Member: Deepsys
Deepsys Oct 29, 2012 at 10:27:15 (UTC)
Goto Top
Hi,

Zitat von @killtec:
@ Deepsys: Man nimmt zwei DHCP-Server und erstellt den gleichen DHCP-Bereich. Bei DHCP-Server 1 sagt man dass die Adressen von x-y
ausgeschlossen sind und bei DHCP-Server 2 von a-b.
Und das soll sauber funktionieren?
Der Client schickt ja einen Broadcast und welcher Server antwortet dann?
Ich denke, mal der, mal der, oder?

Das macht man deshalb, falls ein DHCP-Server ausfällt, kann der andere DHCP-Server das Lease erneuern, sonst hast du
plötzlich keine IP-Adresse mehr.
Naja, wenn der Lease nicht auf 2 Stunden steht, brauchen die Clients erstmal keinen DHCP-Server.

Aber egal, ich will nicht mit dir streiten ob das Sinn macht oder nicht (ich finde nicht), aber ich könnte es mir als Fehlerursache denken.
Gerade weil es ab und zu passiert.
Ich würde mal einen DHCP-Server deaktivieren und mal sehen was passiert.

VG
Deepsys
Member: aqui
aqui Oct 29, 2012 at 12:23:40 (UTC)
Goto Top
<OT>...da es ja nicht um DHCP geht aber ein paar Anmerkungen...
Nein, das kann so nicht sauber funktionieren, denn so kommt es zu einer sog. Race Condition zwischen diesen beiden DHCP Servern. Das DHCP auf Broadcasts basiert bekommen beide Server Client Anfragen und schicken auch beide Leases raus an den Client. Der nimmt den ersten und ignoriert dann den anderen. Für den Server suboptimal da nun Timeouts zuschlagen. Zudem gibt es keinerlei Synchronisation der Lease database was zu erheblichen Problemen beim DNS führen kann.
Sauber ist da keineswegs, sondern eher eine quick and dirty Implementation von redundantem DHCP oder wie Laien denken wie man es redundant machen könnte, was es keinesfalls ist und natürlich eine permanente Fehlerquelle darstellt.
So abwegig ist deine Vermutung also nicht das das der Quell des Übels ist...?
Wenn dann clustert man 2 Server mit einer gemeinsamen DHCP Lease Database. Wie man das sauber anhand von ISC DHCP Servern machen kann auf 2 Systemen zeigt dieser_Link. Winblows hat diese Funktion nur in einem NLB Cluster m.E.
</OT>
Member: killtec
killtec Oct 29, 2012 at 13:47:14 (UTC)
Goto Top
Hi DerWoWusste,
an dem Dienst Network Location Awareness liegt es nicht.
@ squi: schaue ich mir gern mal an. Bei der Technikerweiterbildung hatten wir das genau so gelernt, aber ich lasse mich da eines besseren belehren.

Gruß
Killtec
Member: Deepsys
Deepsys Oct 29, 2012 at 15:08:18 (UTC)
Goto Top
Zitat von @killtec:
@ squi: schaue ich mir gern mal an. Bei der Technikerweiterbildung hatten wir das genau so gelernt, aber ich lasse mich da eines
besseren belehren.
Mit dem was ich in meiner Technikerausbildung gelernt habe, liefe hier nichts sauber face-wink
Das Beste waren 3 Wochen suchen warum der NT-Server nicht zu installieren war ..... wenn man zum Lizenzakzeptieren F8 drücken soll, sollte man das auch tun und nicht Enter .... War der Lehrer .... face-smile


VG
Deepsys
Member: HappyHippo
HappyHippo Oct 29, 2012 at 17:08:01 (UTC)
Goto Top
Wenn man auf den beiden DHCP Servern zwei unterschiedliche Adressbereiche nutzt die sich nicht überlappen - dann funktioniert das auch in der Non-Cluster Version face-smile
Member: killtec
killtec Oct 30, 2012 at 07:26:51 (UTC)
Goto Top
Also am DHCP-Server liegt es schon mal nicht. Da habe ich eben einen deaktiviert.
Member: d4shoerncheN
d4shoerncheN Oct 30, 2012 at 07:35:17 (UTC)
Goto Top
Hallo,

kriege ich auch noch eine Antwort? face-smile

ZITAT ANFANG
kannst du mir erklären - wieso ihr auf Screenshot 1 "Öffentliches Netzwerk" als Profil gewählt habt? Das solltet ihr wie in Screenshot 2 mal auf "Domänennetzwerk" ändern.
ZITAT ENDE

Gruß
d4shoerncheN
Member: killtec
killtec Oct 30, 2012 at 08:08:20 (UTC)
Goto Top
Sorry d4shoerncheN,
das haben wir nicht gewählt, dass ist der Fehler... Erkennt er das Netz, ist es richtig, erkennt er es nicht, ist es öffenltich und nicht authentifiziert.

Gruß
Member: d4shoerncheN
d4shoerncheN Oct 30, 2012 at 09:01:30 (UTC)
Goto Top
Hallo,

und wenn du auf das "Öffentliche Netzwerk" klickst und es auf "Domänennetzwerk" änderst?

Gruß
Member: killtec
killtec Oct 30, 2012 at 09:10:03 (UTC)
Goto Top
Das Wäre eine Idee,
wird nur leider nicht ganz klappen, weil wenn er nicht Authentifiziert ist, klappen auch die Netzlaufwerke nicht, da er dann eine Meldung mit Anmeldung Fehlgeschlagen: Der Zielkontoname ist ungültig.

Gruß
Member: killtec
killtec Nov 01, 2012 updated at 07:20:20 (UTC)
Goto Top
Also meine Vermutung geht in Richtung DNS...
Habe heute morgen bei einem Client einen anderen DNS eingetragen und schon ging die Netzwerkerkennung. Weiß aber nicht genau, wo ich da ansetzen soll zum suchen. Habt irh da eine Idee?

Was mir aufgefallen ist:
An den beiden DC's am Standrt hier sind die Seriennummern gleich.
An den DC's an den aussenstandorten weichen diese ab.

Gruß
Member: killtec
killtec Nov 21, 2012 at 12:59:53 (UTC)
Goto Top
Das Problem ist gelöst. Es lag an einem DC der sich nicht korrekt repliziert hat (Remote Standort).

Gruß