ProLiant bootet nicht nach Nicht-Boot-Drive Veränderung

Mitglied: fldlwgr

fldlwgr (Level 1) - Jetzt verbinden

11.03.2021 um 15:18 Uhr, 505 Aufrufe, 5 Kommentare

Guten Tag allerseits!

Das Herzstück meines Homelab (und eigentlich der gesamten Netzwerkinfrastrukur) ist ein HP ProLiant DL360p Gen8. In ihm verbaut ist ein HP Smart Array P420i Controller. (Dieser Controller kann vieles, aber das meiste nur, wenn der SuperCap funktioniert.)
Nun hatte ich ursprünglich zwei original HP HDDs im Raid 1 mit je 300 GB verbaut und Windows Server darauf laufen. Natürlich wird in einem gut genutzen Homelab der Platz von 300 GB (nutzbar bekanntlich etwas weniger) schnell voll und HDDs... naja. Im vergangenen Sommer hatte ich mir dann eine 120 GB SSD (vorzugsweise als Boot-Platte und die wichtigste VHDX drauf) und eine 1 TB HDD gekauft (beiden von WD, somit nicht original HP). Dann fiel erst auf, dass der SuperCap defekt war. Ohne SuperCap lässt sich die Konfiguration des Controllers nicht bzw. nur eingeschränkt verändern. Also: Einen neuen (= gebrauchten, Homelab halt) gekauft. Schnell die Ernüchterung: Auch kaputt... Dann mal tiefer in die Tasche gegriffe,n um einen anderen zu kaufen, der neu sein sollte - schien mir nicht, denn klappte auch nicht. Mag auch am Controller selbst liegen, aber da würden die Kosten ja explodieren.
Laut Datenblatt kann der P420i ohne SuperCap zwei logical Drives bereitstellen. Reicht mir, passt schon. Ich entschied mich dafür, die SSD als Boot Drive zu nutzen und das Raid 1 (das sind ja die original HDDs mit der aktuellen Bootpartition) als Datenpartition zu nutzen. Die 1 TB HDD habe ich als so-da-Platte eingebunden (also gar nicht, die liegt da nur...).
Jetzt ist mein Original-HDD-RAID (knapp 300 GB) wieder voll. Alle virtuellen Platten auch schon aufs Minimum verkleinert, komprimiert, ... das Modell der 1 TB HDD war aber im Angebot, da habe ich eine von besorgt und hatte mir überlegt, ich entferne die logical Drive der Originalplatten und weise stattdessen die zweite mögliche logical Drive ohne Nutzung des SuperCaps den zwei 1 TB HDDs zu.
Was ich also heute gemacht habe ist folgendes: Die beiden WD 1 TB HDDs in zwei freie Festplatten-Bays verbunden. Anschließend im Smart Storage Administration Tool die logical Drive sprich das Array der HP-Platten entfernt. Dann ein neues Array created, RAID 1 und beide 1 TB HDDs ausgewählt. (Notiz: Die SSD oder die zugehörige Konfiguration habe ich nicht angerührt.)
Dann Booten...
Er bootet nicht von Hard Drive, merkwürdig.
Boot order trotz Erstversuch Hard Drive überprüft: Hard Drive steht oben. Das ist korrekt. Bootcontroller ist ebenfalls der P420i, nicht der Intel-Controller. Auch korrekt. Vielleicht eine Einstellung im P420i-Array-Controller? Tatsächlich war die primary und secondary Boot Partition beide auf none stellt. Mag sein, dass es durch das entfernen des ursprünglichen RAIDs war. Es war sicher logical drive 1 und die SSD dann logical drive 2, wenn logical drive 1 entfernt wird, hat sich die Nummerierung evtl geändert und deswegen auf none gestellt? Keine Ahnung. Beide habe ich auf die SSD gestellt und war erleichtert, das Problem gelöst zu haben. Pustekuchen: Gleiches Problem. Habe dann mal alle HDDs abgezogen und nochmal gebootet. Ebenfalls wieder
Klar, das eine RAID hat keine Platten. Aber er müsste doch zumindest von der SSD booten???

Hat jemand noch einen Ratschlag für mich? Hauptsache ich bekomme zumindest die Boot-SSD mit der daraufliegenden VM wieder ans Laufen. Langsam verzweifle ich...
Es gab doch irgendwie eine Möglichkeit, die Platten so ohne Controller durchzuschleifen, oder? Weiß jemand wie das war, habe dazu keine Informationen gefunden. Das wäre mein Plan B.
Im Endeffekt geht es mir nicht darum ein RAID 1 zu haben. Ob ich die Platten so durchschleife, ein JBOD oder RAID 0/1/5 nutze ist mir gänzlich egal. Ich sichere wöchentlich alles und wenn mal eine HDD eines Nicht-RAID 1/5 ausfällt, sind halt höchstens Daten (zB Messwerte des Home Assistants, Einstellungen an AD/DNS/DHCP, ... oder anderer Test-VMs) einer Woche weg oder einige VMs gerade nicht verfügbar, aber es ist ein Homelab, das ist nichts weltbewegendes. Hauptsache ich hab Platz um zu testen und mein Wissen (und Erfahrung/Können) zu erweitern.

Ich freue mich auf eure Ideen und Ratschläge. Und danke schonmal.
Gruß
fldlwgr
Mitglied: erikro
LÖSUNG 11.03.2021 um 15:50 Uhr
Moin,

Zitat von @fldlwgr:
Nun hatte ich ursprünglich zwei original HP HDDs im Raid 1 mit je 300 GB verbaut und Windows Server darauf laufen.

Ursprünglich wurde also von dem RAID1 gebootet. Zu dem Zeitpunkt war auch keine andere Platte im System. Also liegt der Boot Loader auf diesem System. Der fehlt jetzt, da Du die Platten ja ausgebaut hast. Du musst also einen neuen Boot Loader installieren. Wie man das macht, findest Du bei Tante Google. ;-) face-wink

hth

Erik
Bitte warten ..
Mitglied: fldlwgr
11.03.2021 um 17:15 Uhr
Mega, danke! Das war das Problem. Da hab ich gar nicht dran gedacht. Aber cool, so lernt man immer weiter dazu. Herzlichen Dank.
Bitte warten ..
Mitglied: erikro
11.03.2021 um 17:55 Uhr
Zitat von @fldlwgr:

Mega, danke! Das war das Problem. Da hab ich gar nicht dran gedacht. Aber cool, so lernt man immer weiter dazu. Herzlichen Dank.

Das heißt er läuft wieder? Schön, dass ich helfen konnte.
Bitte warten ..
Mitglied: fldlwgr
11.03.2021 um 18:13 Uhr
Ja, er läuft wieder. Ich finde es umso schöner, dass mir geholfen wurde. Und so schnell...

Für spätere Leser mit ähnlichem Problem:
Hatte von Tante Google mehrere Möglichkeiten über die cmd gelesen, den Bootloader bzw. die Boot File wiederherzustellen / neu zu erstellen. Klappte alles nicht. Aber erstaunlicherweise konnte ich über den Punkt "Problembehandlung" in der Computerreparatur (über eine Server 2016 installer iso) einfach reparieren lassen. Ich betone: Reparieren lassen. Hatte Problembehandlung geklickt und mich gewundert, dass der Server plötzlich korrekt bootete.
Bitte warten ..
Mitglied: erikro
11.03.2021 um 18:25 Uhr
Zitat von @fldlwgr:

Ja, er läuft wieder.

Das ist schön.

Ich finde es umso schöner, dass mir geholfen wurde. Und so schnell...

Gerne.

Für spätere Leser mit ähnlichem Problem:
Hatte von Tante Google mehrere Möglichkeiten über die cmd gelesen, den Bootloader bzw. die Boot File wiederherzustellen / neu zu erstellen. Klappte alles nicht.

Die meisten dieser Anleitungen gehen davon aus, dass man einen zerschossenen Bootloader reparieren will, die ursprüngliche Platte also noch vorhanden ist.

Aber erstaunlicherweise konnte ich über den Punkt "Problembehandlung" in der Computerreparatur (über eine Server 2016 installer iso) einfach reparieren lassen. Ich betone: Reparieren lassen. Hatte Problembehandlung geklickt und mich gewundert, dass der Server plötzlich korrekt bootete.

Die Problembehandlung wird immer besser. Ist ja auch vernünftig, dass man für immer wiederkehrende Probleme Skripte zu deren Behebung bereit stellt. Schön wäre, wenn man da reingucken und sie anpassen könnte. Ein paar Rückmeldungen, was passiert, wären auch nett. Aber das ist halt Windows. Da gibt es ein buntes Bild mit einem hin- und herjuckelnden Balken. ;-) face-wink
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Unterschiedliche IP-Adressbereiche im Netzwerk
achkleinVor 1 TagFrageLAN, WAN, Wireless17 Kommentare

Hallo, ich stehe vor einem Problem mit der WLAN-Verbindung zum Router (Fritzbox Cable 6490). Das verbundene Notebook hat die Adresse 192.168.0.164, Gateway ist 192.168.0.149: ...

Off Topic
Microsoft und der (leidige) Datenschutz
Franz-Josef-IIVor 1 TagAllgemeinOff Topic18 Kommentare

Hello Ich möchte vorausschicken, daß ich rein prinzipiell nichts gegen Microsoft habe, eher gegen die US-amerikanische Politik 😊 Microsoft bietet die Datenverarbeitung in der ...

Off Topic
32 bit Problem
brammerVor 1 TagAllgemeinOff Topic9 Kommentare

Hallo, also das ist mal ein Problem das ich auch haben möchte eine Aktie ist mehr Wert als das die Börsensoftware darstellen kann. brammer

Hardware
Thin- oder Zero-Client für RDP und Dual-Monitor im LAN gesucht
FestplattenaufzieherVor 1 TagFrageHardware9 Kommentare

Hallo, Kurzfassung meiner Frage: Ich suche Thin/Zero-Clients (4 Stück) mit Dual-Monitor-Unterstützung für den RDP-Zugriff auf PCs in einem LAN - idealerweise lautlos und relativ ...

Windows Server
Lizenzen für Virtualisierungshost
TakworianVor 10 StundenFrageWindows Server15 Kommentare

Hallo, ich werde demnächst einen HA-Cluster aus 3 x HP DL580 in Betrieb nehmen. Der Cluster wird unter Proxmox betrieben und es sollen diverse ...

Windows 10
Windows 10 2021-04 end of life?
gelöst Paedi12Vor 1 TagFrageWindows 103 Kommentare

Hi Leute! Ich bin gerade auf der Suche, wie lange die Windows Version 2021-04 unterstützt wird. Kann aber nichts finden. Hat jemand eine Ahnung, ...

Switche und Hubs
Netgear Switch Problem bei VLAN Konfiguration
gelöst meltersVor 1 TagFrageSwitche und Hubs15 Kommentare

Hallo, ich habe einen Netgear XS716T Switch zum Testen in Betrieb genommen, komme aber mit der VLAN Konfiguration nicht so ganz klar. Bislang habe ...

Router & Routing
Suche Tipps für Selfmade-Load-Balancing-Router auf HP MicroServer Gen10+
gelöst MagicChris86Vor 1 TagFrageRouter & Routing7 Kommentare

Hi Leute, ich habe einen HP MicroServer Gen10+ Performance übrig, der bei einer Kundin rausgeflogen ist, weil sie mehr Power brauchte für Desktopvirtualisierung für ...