survial555
Goto Top

RDP Programm Autostart

Hallo,
ich scheitere gerade an einer eigentlich so einfachen Sache.
Ich habe einen RDP Server MS Server 2019.
Domänencontroller ist auch Server 2019 (mit Functionallevel 2016).
Der Benutzer "benutzer1" ist in der AD angelegt und berechtigt sich am RDP Server anzumelden.
Der benutzer1 hat die Zugriffsrechte auf \\192.168.0.2\freigabe\programm.exe und kann diese sowohl per Pfadeingabe als auch als Verknüpfung auf dem Desktop starten.
Jetzt möchte ich aber gerne, dass dieses Programm automatisch startet, wenn der benutzer1 sich am RDP Server anmeldet.
Also habe ich in der AD im Benutzerprofil unter "Umgebung" das Programm mit absolutem Pfad und "starten in" Ordner angegeben (wahlweise sowohl als \\192.168.0.2\ als auch über Namensauflösung \\server\....
Wenn ich mich dann per RDP am Server als benutzer1 anmeldet wird nichts gestartet.
Teste ich das dagegen auf einem noch alten Server 2003, da wird das Programm problemlos gestartet.

Also müssen ja meine Einstellungen in der Benutzerkarte korrekt sein. Nur warum wird es auf dem RDP Server 2019 nicht gestartet?
Ich kann leider auch keinerlei Logs oder Fehlermeldungen finden, damit ich einen Ansatz habe wo ich suchen kann ...

Hat jemand einen Rat für mich?

Content-Key: 1874670938

Url: https://administrator.de/contentid/1874670938

Printed on: June 15, 2024 at 15:06 o'clock

Member: em-pie
em-pie Feb 09, 2022 at 19:43:06 (UTC)
Goto Top
Moin,

leg doch einfach eine Verknüpfung in den Autostart...

Gruß
em-pie
Member: DerWoWusste
DerWoWusste Feb 09, 2022 updated at 19:45:48 (UTC)
Goto Top
Hi.

Pack es in den Autostartordner (%appdata%\Microsoft\Windows\Start Menu\Programs\Startup) des Nutzers am Termserv., das ist simpel und läuft.
Member: computerdarkman
Solution computerdarkman Feb 09, 2022 at 19:53:56 (UTC)
Goto Top
Ab Windows Server 2016 werden die Attribute zur RDP-Umgebung per Default nicht mehr aus dem AD ausgelesen/berücksichtigt.

Um Dein Problem zu lösen, musst Du in den RDP-Legacy-Mode wechseln.

Setze folgende Einträge in der Registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
Name: fQueryUserConfigFromDC
Type: Reg_DWORD
Value: 1

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-tcp
Name: fQueryUserConfigFromDC
Type: Reg_DWORD

Dann einmal Reboot.

Wir hatten seinerzeit dasselbe Problem...
Member: survial555
survial555 Feb 09, 2022 at 20:40:28 (UTC)
Goto Top
Danke für die Hinweise!
Es hat schon Gründe, warum ich genau diese Funktion nutzen will. Weil dann nämlich der Benutzer auch automatisch abgemeldet wird, wenn man das Programm wieder schließt.

@computerdarkman: DANKE ! DAS war die Lösung des Problems !!!
Member: em-pie
em-pie Feb 10, 2022 updated at 08:16:46 (UTC)
Goto Top
Moin,

als Alternative via GPO folgende Einstellung setzen/ verteilen:
Benutzerkonfiguration -> Richtlinien -> Administrative Vorlagen -> System -> Benutzerdefinierte Benutzeroberfläche -> dort deine \\192.168.0.2\freigabe\programm.exe hinterlegen.

Effekt: meldet sich der Nutzer an, wird statt der explorer.exe dein Programm.exe ausgeführt. Alles andere ist weg. Schließt man das Programm, wird der User wieder abgemeldet.

Nutze wir für einige "Kiosk"-Rechner so...