sendmail spamassassin setzt spam flag auf interne mail vom externen client

greenlinus
Goto Top
guten morgen,

vieleiecht hat einer einen tipp für mich?
ich bin gerade etwas verwirrt.

ich betreibe derzeit in einer testphase einen scalix mailserver. dieser verwendet als mta sendmail. um mich vor spams zu schützen verwende ich spamassassin. was an sich auch alles einwandfrei klappt. derzeitige trefferqoute liegt rum umd bei 500 spams kommen 10 durch.
was aber mein problem ist, wenn ich mich von außerhalb mich mit einem mail client via imap pop3, auf dem mail server connecte und dann via smtp über dieses eine spam versenden (smtp auth) möchte, markiert spamassassin diese als spam. was nicht gerade praktisch ist. weiß da jemand rat? hab nicht wirklich was gefunden.

gruß

Content-Key: 79299

Url: https://administrator.de/contentid/79299

Ausgedruckt am: 29.06.2022 um 12:06 Uhr

Mitglied: theton
theton 28.01.2008 um 14:01:06 Uhr
Goto Top
Welcher X-Spam-Status wird denn gesetzt? Daran sollte man ja erkennen können warum er die Mails als Spam markiert.
Mitglied: greenlinus
greenlinus 28.01.2008 um 14:25:11 Uhr
Goto Top
hi, warum die mail als spam geflagt wird ist mir klar. weil der score über den max liegt. dies wird ausgelöst weil der imap client (laptop irgendwo unterwegs) an ner leitung hängt mit einer dynamischen ip und diese auf ner blacklist ist. "[dyn. wan-ip] listed in dnsbl.sorbs.net". mir ging es viel mehr darum wie man das im allgmeinen verhindern kann, dass die ausgehenden mails gefiltert werden? ich kenn zwar den paramert -i im spamass-milter jedoch muss ich bei dem ein ip oder netz angeben. bin mir nicht sicher ob man nen kompletten range angeben kann.
Mitglied: theton
theton 28.01.2008 um 15:26:20 Uhr
Goto Top
Na da wird der Fehler doch schon klarer... "weil der imap client (laptop irgendwo unterwegs) an ner leitung hängt mit einer dynamischen ip und diese auf ner blacklist ist".

Im Normalfall wird dieses Flag nicht gesetzt, wenn mit der Authentifizierung alles korrekt läuft. Der SMTP-Server würde den Client schon vor dem Weiterreichen der Mail an den Spamassassin "maskieren", was bei dir offenbar nicht der Fall ist. Du solltest also deine Fehler-Analyse dort beginnen.
Mitglied: greenlinus
greenlinus 28.01.2008 um 15:52:17 Uhr
Goto Top
stimmt, jetzt wo du es sagst. ich glaub auch schon zu wissen was lost ist. ich muss gleich mal ran.
ich probier mal in der smtpd.cfg über die relay angaben AUTH_SUCCESS accept ALL anzugeben. da sollte auf jedenfall eine authentifizering vorher gehen am sosnten wird ja gleich verweigert.

----- nachtrag:

hat nicht wirklich was gebracht :( face-sad

_____________________________________________________________________________

so hab es jetzt anders gelöst.

hab gewisse regeln für den header und den body im spamassassin abgeändert.
ist zwar nicht die idealste lösung, aber ich hab einfach nicht gefunden, wie ich dem dingen sagen kann das solche mails die von einem authentifizierten kommen nicht filtern soll.

danke für die tipps, die haben mich auf den weg gebracht.
Mitglied: Liberation
Liberation 18.02.2009 um 19:00:34 Uhr
Goto Top
Hallo,
ich habe genau das selbe Problem.
Interner Mailverkehr wird auch durch Spamassassin geprüft. Das soll aber so nicht sein! Habe schon versucht im procmail regeln zu definieren die das weiterleiten interner mails vom Spamassassin ausschliessen das hat aber leider nicht geklappt.

Wie stelle ich es an das serverinterner Mailverkehr nicht geprüft wird?
Mitglied: theton
theton 18.02.2009 um 21:06:36 Uhr
Goto Top
Trage 127.0.0.1 in die 'trusted_networks' in der local.cf ein. Dann sollte er sie eigentlich ungeprüft durchlassen.
Mitglied: Liberation
Liberation 19.02.2009 um 10:52:29 Uhr
Goto Top
Hi,
leider wollte das auch nciht so recht funktionieren.

Ich habe es nun so gelöst das procmail die mails erst garnicht an spamassassin weitergibt:

  • !^Received:.from.MeineDomain.de
  • !^Received:.by.MeineDomain.de
  • !^Delivered-To:.*MeineDomain.de
  • < 256000
| /usr/bin/spamc -f