Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Squid einrichten

Mitglied: Franzmann

Franzmann (Level 1) - Jetzt verbinden

04.09.2007, aktualisiert 15.10.2007, 6005 Aufrufe, 4 Kommentare

Hallo,
ich will einen Squid auf einem SLES 10.2 ans laufen bekommen.
Meine Konfig sieht im Wesentlichen so aus:
--- schnipp ---

http_port SERVERIP:8080

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 81 8003
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl FTP_ports port 21 # ftp

acl Safe_ports port 90 5000 81 8801 8003 53900 # verschiedene Ports

acl CONNECT method CONNECT

acl meinegruppe src 10.222.200.0/21-10.222.207.254/21
http_access allow meinegruppe

cache_peer GATEWAYIP parent 8080

http_access deny all

--- schnapp ---

Lokal auf ner virtuellen Maschine funktioniert das auch.
Wenn ich das jetzt bei uns ins Firmennetz implementiere, geht er nicht.
Meine Frage, ist dieser Parameter so richtig ?
--> cache_peer GATEWAYIP parent 8080
Wo gebe ich die IP oder den DNS der Internetverbindung an ?
Und was ist für den Squid die Internetverbindung ? Das Gateway oder die Firewall ?

Danke !!!
Mitglied: Dani
07.09.2007 um 19:30 Uhr
Hi Franzmann,
Lokal auf ner virtuellen Maschine funktioniert das auch.
Wenn ich das jetzt bei uns ins Firmennetz implementiere, geht er nicht.
Hmm...sind die beiden Maschinen identisch. Sprich die Lokale und der Server / Client auf dem nachher Squid laufen soll??

Wo gebe ich die IP oder den DNS der Internetverbindung an ?
Hää.....? Die Clients haben doch die IP (GW, DNS, WINS) statisch oder per DHCP bekommen. Der Server hat auch 1 (2) IP-Adresse(n) und bei einer Karte ist ein Default DNS und Backup DNS hinterlegt.


Grüße
Dani
Bitte warten ..
Mitglied: Franzmann
11.09.2007 um 11:18 Uhr
Ja beide Maschinen sind identisch!

Ah ok, das wusste ich nicht, ich dachte da gibts im Squid noch Parameter die diesbezüglich angepasst werden müssen.

Also ich glaube mittlerweile das es daran liegt das ich net ricchtig rauskomme.
Ping funktioniert, traceroute und wget nicht...

IP-Config der Linux Maschine
eth0
...
inet addr:IP_des_Servers Bcast:BD__des_Servers Mask:SBN_des_Servers
...
IP-Config des Squid auf der Linux Maschine
eth0:0
...
inet addr:IP_des_Servers Bcast:BD__des_Servers Mask:SBN_des_Servers
...

Hmm wo kanns denn noch hängen ?!
Bitte warten ..
Mitglied: Franzmann
11.09.2007 um 12:08 Uhr
Wenn ich mit dem squidclient intern teste, bekommen ich folgende Meldung:
1189502450.154 179899 MEINE_SQUID_IP TCP_MISS/504 1376 GET http://www.gmx.de - DIRECT/217.72.204.254 text/html

Lässt das auf was schließen ?
Bitte warten ..
Mitglied: Franzmann
15.10.2007 um 15:16 Uhr
Wenn ich mit dem squidclient intern teste,
bekommen ich folgende Meldung:
> 1189502450.154 179899 MEINE_SQUID_IP
TCP_MISS/504 1376 GET http://www.gmx.de -
DIRECT/217.72.204.254 text/html

Lässt das auf was schließen ?

Es lag an den Ports, waren falsch freigeschaltet.
Thx@all
Bitte warten ..
Ähnliche Inhalte
Linux Netzwerk
Squid Fehlermeldung
gelöst Frage von AKillerInHellLinux Netzwerk5 Kommentare

Naben liebe Admins Habe folgendes Problem auf meiner CentOS VM mit Squid und Webmin. Es ist erstmal nur eine ...

Linux
Squid Problematik
gelöst Frage von eazy-isiLinux4 Kommentare

Hallo zusammen, bei der Konfigurationen eines SQUID-ProxyServers habe ich Probleme mit der User-Authentifizierung. Bei der Anmeldung am Squid wird ...

Monitoring
Squid Monitoring
gelöst Frage von akadawaMonitoring2 Kommentare

Hallo liebe Community, seit ein paar Tagen nutzt eine oder mehrere Windows-Maschine/n den kompletten Traffic aus. Leider ist die ...

Firewall
PfSense + Squid + ClamAV
Frage von mrserious73Firewall5 Kommentare

Hallo zusammen, auch ich habe Probleme, Squid mit ClamAV auf pfSense zum Laufen zu bekommen. Bei Google finden sich ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 1 TagiOS3 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 1 TagiOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 3 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 4 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
gelöst Frage von frosch2Windows Netzwerk27 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

Hosting & Housing
VMware VM mit über 1TB RAM für S4HANA
Frage von Leo-leHosting & Housing22 Kommentare

Hallo zusammen, wer hat Erfahrng und kann mir einen Tipp zum sizing von S4HANA Systemen geben? Wir möchten, zunächst ...

LAN, WAN, Wireless
WLAN und Ausmessung - Eine Glaubensfrage?
Frage von ptr2brainLAN, WAN, Wireless20 Kommentare

Liebe Experten, als Sys-Admin habe ich mir schon öfter die Frage gestellt, ob es sich beim Thema WLAN und ...

Virtualisierung
Gebrauchte Server Hardware als Virtualisierungs-"Spielwiese"?
Frage von NixVerstehenVirtualisierung19 Kommentare

Einen wunderschönen guten Morgen zusammen, ich möchte mich gerne etwas tiefer mit dem Thema Virtualisierung beschäftigen und dazu ein ...