Suche Excel Formel

Mitglied: klooon

klooon (Level 1) - Jetzt verbinden

21.08.2011 um 18:13 Uhr, 3681 Aufrufe, 11 Kommentare

Hallo,

ich habe 2 Excel Tabellen mit der selben Spalte Namens Artikelnummer, also wie ein Primätschlüssel.

Jetzt ist es so das Tabelle 1 unter anderem eine Spalte Geschmack hat welche Tabelle 2 nicht hat.

Nun würde ich gerne diese Spalte in Tabelle 2 hinzufügen indem geschaut wird ob Artikelnummer aus Tabelle 1 mit der Artikelnummer aus Tablle 2 übereinstimmt und wenn ja dann soll die dazugehörige Zelle Geschmack in Tabelle 2 hinzugefügt werden.

Ich hoffe mal ich konnte mich verständlich ausdrücken.

Wäre super wenn ihr mir helfen könntet.

Danke
Mitglied: Xboxer
21.08.2011 um 18:21 Uhr
Hi,

schau dir mal SVERWEIS an.

Gruß
Christoph
Bitte warten ..
Mitglied: dog
21.08.2011 um 18:21 Uhr
SVERWEIS
Bitte warten ..
Mitglied: winf-hst
21.08.2011 um 18:21 Uhr
Hallo Klooon,

du brauchst doch lediglich eine Wenn-Formel benutzen.
Also in etwa so: wenn(a2=a1;b1)
Sprich wenn Artikelnummer in a2 gleich der in a1 ist dann nimm für diese Zelle den Wert von b1.
Wobei a2 die Artikel Nummer in Tabelle 2 und a1 die in Tabelle 1 ist und b1 dann der Geschmack.

Ich hoffe es hilft dir.

gruß
Bitte warten ..
Mitglied: Solarius
21.08.2011 um 18:22 Uhr
Auch Hallo,

teste mal die Funktion "Sverweis" damit sollte das gelöst werden können.

Schönen Sonntag noch.

Solarius

da waren wieder alle schneller ;-) face-wink
Bitte warten ..
Mitglied: Niklas434
21.08.2011 um 18:53 Uhr
Primätschlüssel meinst Primärschlüssel naja Excel ist keine Datenbank aber ich Versteh was du meinst Nimm den Sverweis schau dir zur not videos bei youtube an :) face-smile
Bitte warten ..
Mitglied: Zollwurf
21.08.2011 um 21:31 Uhr
=SVERWEIS([Suchwert];[Suchmatrix];[RückgabeSpalte])

Liest sich komplex, ist aber recht "easy":
  • In Suchwert gehört deine Artikelnummer aus Tabelle2
  • In Suchmatrix gehört der Bereich aus Tabelle1 mit Artikelnummer und Geschmack, beginnend mit der Spalte der Artikelnummer
  • RückgabeSpalte ist die Nummer der Spalte rechts der Spalte mit der Artikelnummer (aus Tabelle1)

Angenommen, in Tabelle1 stünde (in Spalten)
A |B|C
1234| Kaviar | salzig
3421|Honig | süss

und in Tabelle2
A|B
ArtNr.|Geschmack
3421|=SVERWEIS(A1;Tabelle1!$a:$c;3)

Wenn das ganze unsortiert ist, benötigst du eventuell es letzten (optionalen) Parameters der SVERWEIS-Funktion.
Bitte warten ..
Mitglied: bastla
21.08.2011 um 21:47 Uhr
@Zollwurf
Wenn das ganze unsortiert ist, benötigst du eventuell es letzten (optionalen) Parameters der SVERWEIS-Funktion.
Auch wenn's sortiert ist, würde ich lieber eine Fehlermeldung erhalten (oder, besser, mit "WENN(ISTNV(..." abfangen), als dass stillschweigend der Wert aus der nächst(best)en Zeile genommen wird - daher in solchen Fällen immer noch ein ",0" (für "0 Toleranz beim Suchen" ;-) face-wink) hinten dran ...

Grüße
bastla

[Edit] Etwas verzögert Vorschlag mit "ISTNV()" hinzugefügt - hat sich daher mit Zollwurfs Hinweis überschnitten [/Edit]
Bitte warten ..
Mitglied: bastla
21.08.2011 um 21:50 Uhr
[OT]
@Solarius
da waren wieder alle schneller ;-) face-wink
Nicht alle ... ;-) face-wink

Grüße
bastla
[/OT]
Bitte warten ..
Mitglied: Zollwurf
21.08.2011 um 21:53 Uhr
Auch kein Problem. Frage den #NV-Error ab. In der Wenn-Funktion kannst du dir dann das ausgeben lassen, was beliegt. Oder Userdef-Function schreiben ;-) face-wink

Gruß
Bitte warten ..
Mitglied: bastla
21.08.2011 um 21:59 Uhr
@Zollwurf
In der Wenn-Funktion kannst du dir dann das ausgeben lassen, was beliebt.
Das wäre der Plan ... ;-) face-wink

... und für einen (wie es scheint) einmaligen Vorgang sicher ausreichend.

Grüße
bastla
Bitte warten ..
Mitglied: klooon
05.09.2011 um 10:57 Uhr
Super ich danke euch allen für die schnelle Hilfe, -> Problem gelöst!
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
Windows 7 pro Lizenz nutzen für Windows 10
lukas0209Vor 1 TagFrageWindows 1015 Kommentare

Hallo Community, ich versuche seit einigen Wochen unser Netzwerk von Windows Server 2008 R2 Standard auf Windows Server 2016 Essentials um, welches eine städtische ...

Windows Netzwerk
Telefone im Netzwerk bekannt machen
jannik0205Vor 1 TagFrageWindows Netzwerk13 Kommentare

Hallo Zusammen, In unserem Unternehmen gibt es eine Telefonanlage mit eigenem Telefonienetz (192.168.5.X). Schließe ich ein Telefon an eine Netzwerkdose, bekommt es vom DHCP- ...

Windows Netzwerk
WTS-Anmeldung per RDP am Wochenende verbieten?
MuM2810Vor 1 TagFrageWindows Netzwerk9 Kommentare

Hallo zusammen, wir haben bei uns Windows Server 2016 mit 2 Terminal Servern im Einsatz. Wie aus dem Titel schon ersichtlich ist, ist bei ...

Netzwerkgrundlagen
Frage zu LWL Kabel
gelöst NominisVor 1 TagFrageNetzwerkgrundlagen6 Kommentare

Hallo, ich habe nur mal eine kurze Verständnisfrage. Es geht um die Verbindung bzw. Anbindung von Switches (Cisco 48Port 10/100/1000 MBit mit 2 SFP+ ...

Microsoft
Microsoft Teams - "bitte wenden Sie sich an (. . .) um Teams für "domäne" zu aktivieren" nur bei einem Benutzer
eastfrisianVor 1 TagFrageMicrosoft6 Kommentare

Hallo zusammen! Wir haben bei uns Teams als Hybridversion eingeführt (Exchange on premise, AD-Sync in die Cloud) und nutzen Teams über das basic-Abonnement. Während ...

Microsoft
Staatsanwaltschaften verschicken Vorladungen in Sachen Windows 10 Lizenzkeys
kgbornVor 11 StundenInformationMicrosoft3 Kommentare

Nur zu Info für die Käufer der eBay-Schnäppchen - neuer Fall Staatsanwaltschaften verschicken Vorladungen in Sachen Windows 10 Lizenzkeys

Netzwerke
Keine Versand von Mails von der Firmen zur Privaten E-Mailadresse möglich
blaub33r3Vor 1 TagFrageNetzwerke6 Kommentare

Hallo zusammen, wieso kommt der User keine Mails mehr? Der Sender wird als Spamer betrachtet? 1. Mailing an andere Privaten Adressen / Firmen Adressen ...

Netzwerke
Netzwerklaufwerk - Nur Lesen (Streamen)
CryexXVor 1 TagFrageNetzwerke8 Kommentare

Hallo, ich hab mal ne Frage und hoffe auf Lösung. Mir schießt aktuell keine in den Kopf :( Ich möchte ein Netzlaufwerk freigeben. Auf ...