TCP Retransmission VNC the Server closed connection - server is running as application

bl0cks1z3
Goto Top
Hallo Admins,

ich habe einen Client im Netzwerk - ein nagelneues HP Elitebook für fast 2000 € - welches Probleme mit der Netzwerkverbinung hat.

Auf dem Gerät sind Windows 10 1803 x64, Virtual Box, einige VPN-Clients (Sophos, Lancom, Openvpn) und einge Programmiertools von Siemens und Phoenix installiert.


Das Notebook hat irgendwie ein Netzwerkproblem. Wenn ich UltraVNC auf einen Server verbinde, wird nach kurzer Zeit der Verbinung geschlossen.
Der VNC-Client meldet "the Server closed connection - server is running as application ".

Dabei ist es komischerweise völlig Egal, welchen Netzwerkadapter oder Anschluß ich verwende (Ethernet, W-LAN). Verbinde ich mein eigenes Notebook gleichzeitig mit dem gleichen Server, gibt es das Problem nicht. Wir verwenden Cisco SG500X Switche als Backbone und Sophos AP 10 und 15 Accesspoints für das W-LAN.

Deshalb habe ich auf dem Problemcomputer Wireshark mitlaufen lassen.

Bevor die Verbinung getrennt wird, werden hier viele TCP-Retransmissions und Dup-Acks geloggt.

Ich habe bereits die Winsock und den IP Stack zurückgesetzt. Alle Treiber und Windows sind auf dem neuesten Stand.

Ich weiß nicht mehr wie ich das Problem noch eingrenzen kann, oder den Fehler finden soll.

Ich hoffe, das Ihr mir helfen könnt.

Content-Key: 388193

Url: https://administrator.de/contentid/388193

Ausgedruckt am: 25.05.2022 um 16:05 Uhr

Mitglied: aqui
aqui 01.10.2018 aktualisiert um 10:10:44 Uhr
Goto Top
welches Probleme mit der Netzwerkverbinung hat.
Welches Betriebssystem ??
Bei Windows solltest du NICHT die mitgelieferten bzw. embeddeten Treiber nehmen sondern immer die jeweils aktuellsten Treiber des Netzwewrk Chipsatzes (Intel, Broadcomm, etc.) installieren und die von der Website des Chipsatz Herstellers laden.
Ist das geschehen ?
Mitglied: Bl0ckS1z3
Bl0ckS1z3 01.10.2018 um 10:29:46 Uhr
Goto Top
Zitat von @aqui:

welches Probleme mit der Netzwerkverbinung hat.
Welches Betriebssystem ??
Bei Windows solltest du NICHT die mitgelieferten bzw. embeddeten Treiber nehmen sondern immer die jeweils aktuellsten Treiber des Netzwewrk Chipsatzes (Intel, Broadcomm, etc.) installieren und die von der Website des Chipsatz Herstellers laden.
Ist das geschehen ?

Ich habe alle Treiber über den HP Support-Assistent aktualisert. Das sind die vom Hersteller empfohlenen Treiber.
Mitglied: Bl0ckS1z3
Bl0ckS1z3 01.10.2018 aktualisiert um 11:42:07 Uhr
Goto Top
Musste gerade feststellen, dass der HP Support-Assistant wohl nicht richtig arbeitet.

Ich habe jede Menge Updates und Firmware auf der Download-Seite des Notebooks von HP gefunden, die mir der Support-Assistant nicht vorgeschlagen bzw. angezeigt hat.

Werde erstmal alles herunterladen und dann updaten....
Mitglied: Vision2015
Vision2015 01.10.2018 um 14:28:12 Uhr
Goto Top
Moin...

einige VPN-Clients (Sophos, Lancom, Openvpn)
einer würde reichen!

Frank
Mitglied: Bl0ckS1z3
Bl0ckS1z3 01.10.2018 aktualisiert um 14:39:19 Uhr
Goto Top
Nachdem ich alle Updates per Hand heruntergeladen und installiert hatte, war das Problem leider immer noch da.

Nun habe ich mir mal die Protokolle und Dienste vom aktiven Netzwerkadapter angesehen und mit meinem Notebook verglichen.

Es fiel mir auf, dass bei dem Elitebook ein zusätzlicher Netzwerkdienst an den NIC gebunden war und zwar der "LiveQos NDIS6 Filter Driver".

Ich habe den Dienst bei dem Netzweradapter deaktiviert und die Problem scheinen beseitigt zu sein.

Der Dienst wird vom HP Velocity Tool installiert und scheint ne Macke zu haben, bzw nicht richtig konfiguriert zu sein.
Ich weiß im Moment nicht mal was das Tool genau macht, muss mich erst einlesen.

Also für alle die ein ähnliches Problem mit HP-Hardware haben, konnte das die Lösung sein.