supertux
Goto Top

Typo3: Website mit Fehlermeldung im Frontend bzw. kein Backend möglich

Hallo,

für einen Bekannten habe ich ein Umzug zu einem anderen Anbieter (Hetzner) vorgenommen.
Vom Webdesigner habe ich nun die Dateien und Ordner erhalten, aber ohne CMS-System.
Die Seite wurde laut Quellcode mit Version 4.5 erstellt und über die Jahre nur Texte und Bilder verändert.
Nun, habe ich mir das alte 4.5 mit den Ordner und Dateien auf das Webspace geladen und die
localconfig.php zur neuen Datenbank eingerichtet.
Klar, es gibt neure Versionen, aber ich habe mit typo3 noch nie gearbeitet und wollte erst die
Webseite sehen ob sie funktioniert. Die neuen Versionen haben keine localconfig.php mehr.
Nach ein paar Infos aus Google habe ich in der Localconfig.php die Errormeldung auf 1 gesetzt.
Den Installationshash habe ich ebenfalls geändert.

Die Seite ist nun Online, es gibt zwei Problem.

Strict Standards: Accessing static property t3lib_PageRenderer::$cssFiles as non static in /usr/www/users/xxxx/xxx/t3lib/class.t3lib_pagerenderer.php on line 1385
Strict Standards: Accessing static property t3lib_PageRenderer::$jsLibs as non static in /usr/www/users/xxxx/xxx/t3lib/class.t3lib_pagerenderer.php on line 1415
Strict Standards: Accessing static property t3lib_PageRenderer::$jsFiles as non static in /usr/www/users/xxxx/xxx/t3lib/class.t3lib_pagerenderer.php on line 1439
Strict Standards: Non-static method t3lib_div::getClassName() should not be called statically in /usr/www/users/xxxx/xxx/t3lib/class.t3lib_div.php on line 5253

Und ins Backend erhalte ich eine weise Seite oder Error 500.
Der Aufruf in die Installation funktioniert.

Ist die Seite doch auf einer neueren Version?
Das hochladen eines neuen CMS hat kein Erfolg gezeigt, hier funktioniert die Seite nicht..
Bei PHP wurden die verschiedenen PHP 7.x durch getestet.
Die Seite mit 4.5 läuft unter 5.6.

Wenn die Fehler weg sind, wie kann ich die Seite auf eine neuer Version aktualisieren?

Danke für eure Unterstüzung

supertux

Content-Key: 619731

Url: https://administrator.de/contentid/619731

Printed on: February 29, 2024 at 23:02 o'clock

Member: wiesi200
wiesi200 Nov 06, 2020 at 07:04:47 (UTC)
Goto Top
Hallo,

Schau doch mal ob du in's install tool kommst. Wie das genau bei 5.4 geht kann ich dir nicht auswendig sagen, da müsstest du suchen.
Member: StefanKittel
StefanKittel Nov 06, 2020 at 07:16:41 (UTC)
Goto Top
Hallo,

die Seite läuft doch aktuell irgendwo.
Also einen Datenbankdump erstellen (z.B. PHPMyAdmin) und per FTP alle Dateien runterladen.
Auf dem neuen Server Dateien hochladen, Datenbank einspielen, ggf. neue Datenbankzugangsdaten einspielen und fertig.
Was Dir einen Strich durch die Rechnung machen könnte wäre wenn die Seite so alt ist, dass sie die aktuellen PHP-Versionen nicht kann.

In einem CMS befindet sich 90% des Inhaltes in der Datenbank.
Nur die Dateien bringen Dir gar nichts.

Stefan
Member: supertux
supertux Nov 06, 2020 at 08:47:44 (UTC)
Goto Top
Hallo,

die Seite wo Online ist, ist die wo ich selbst zum laufen bekommen habe.
Er hat mir in einer Zip-Datei die Daten für den FTP-Upload und SQL-Datenbank gesendet.

inhalt

Hier fehlt das eigentliche CMS-Verzeichnis (typo3, t3lib).
In seiner index.php steht typo3_src/index.php und ist somit keine Originaldatei.
Die .htaccess entspricht nicht ganz der Originaldatei.
Damit die Seite funktioniert verwende ich die Originaldateien aus typo3 4.5.
Wenn ich auf der funktionieren Seite das PHP auf 7.1 stelle geht sie nicht mehr.

Somit denke ist, ist die Struktur der Seite wirklich auf dem Stand von 4.5.

Ich habe auch nicht herausgefunden wie ich die Seite auf was aktuelles aktualisieren kann.
In der Installroutine kommt ein Punkt mit Upgrade < 4.4 auswählen kann.

installroutine

installroutineupdate
Member: sabines
sabines Nov 06, 2020 at 09:18:54 (UTC)
Goto Top
Zitat von @supertux:

Wenn die Fehler weg sind, wie kann ich die Seite auf eine neuer Version aktualisieren?


Moin,

ja das geht, es ist allerdings unter Typo3 nicht immer trivial auf neue Versionen zu gehen, es hängt davon ab von welcher Version zu welcher gegangen werden soll und ob Extensions eingesetzt werden, die nicht mehr unterstützt werden oder gar eigene Anpassungen vorhanden sind.

Als erstes solltest Du die "alte" Seite auf dem neuen Server erstmal zum laufen bringen. Deine Aussagen sind hier etwas ungenau.
Gibt es den alten Server noch oder nicht?

Gruss
Member: supertux
supertux Nov 06, 2020 updated at 09:35:16 (UTC)
Goto Top
Hallo,

ich habe die Seite ja bereits am neuen Server zum laufen bekommen.
Unter typo 4.5 mit PHP 5.6.

Nein, die Seite lag bei einem Webdesigner auf seinem Server.
Die Seite ist dort nicht mehr verfügbar, er hat alles ins Zip gepackt nur eben ohne typo3 CMS.
Member: wiesi200
wiesi200 Nov 06, 2020 at 10:33:41 (UTC)
Goto Top
Der Upgrade Wizard bringt dir erst was wenn du eine aktuellere Version einspielst als vorhanden bzw. wenn du das schon gemacht hast.

Und hier sind die Plugins oft ein Fallstricke. Aber du kannst dort das System bis zu einem bestimmten Punkt Prüfen lassen.
Member: supertux
supertux Nov 06, 2020 at 15:12:08 (UTC)
Goto Top
Hallo,

ich habe nun verschiedene CMS-Version von Typo3 auf das Webspace geladen und die Updates durchgeführt.
Nun bin ich bei 6.1.10 angekommen und das Frontend und Backend funktioniert ohne Fehler.

Danke für eure Unterstützung

supertux